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Enterprise Analyzer

Installation Guide

Overview

This manual describes how to install and configure Micro Focus Enterprise Analyzer (EA), a suite of
software products for analyzing and modernizing legacy applications.

Enterprise Analyzer provides insight into the technical reality of complex application portfolios, including

» Tools for application and program level understanding, utilizing extensive metrics, reports, diagrammatic
views and querying tools to support myriad of business initiatives.

« Quality Assessment with standard code quality queries to serve as a guidance to a code quality practice
in both development and maintenance phases.

« Portability Assessment to help you generate various HTML reports to identify points of interest for
migrations.

« In depth analysis tools to promote efficiency in the performance of daily tasks such as field changes,
understanding of data propagation through a program, and dead code removal.

Business Rule Manager mines business logic from program code and encapsulates the logic in business
rules.

While all products are installed with Enterprise Analyzer, each product is licensed separately.

EA is deployed in a multi-user environment with access to a common repository of application objects.
Repository setup is the responsibility of a master user, leaving team members free to focus on their tasks.
The database for the repository is assumed to be the customer's own.

EA installations consist of the following components:
* The EA Server which hosts EA workspace files and related support files.
« EA Clients which host the link files used to connect to workspaces on the server.

Installation Tasks

The table below describes the tasks involved in installing Enterprise Analyzer and the order in which the
tasks must be performed.

Task Order Notes

Install Database Client 1 The EA package installs SQL Server Express. This is
enough for a small sized repository (up to 10 GB).

Beyond that, an Oracle or DB2 database client must be
installed wherever the EA client or EA server is installed.
Install only if the database client is not already installed.

Install EA on Server 2

Install EA on Clients 3

Each task is described and explained in the chapters of the Installation Guide.
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Deployment

The figure below shows the standard EA deployment scenario. The role each machine performs and its key
relationships are described in the following sections.

I —

Enterprise Analyzer —
. E—

cents Network FTP/
Share sFTP

Enterprise Analyzer
Server

Network FTP

Mainframe with Server

FTRSFTE Server

Application Source code
origingies here

Mainframe and Network Server

The mainframe typically hosts the application to be modeled in EA. Application source files are
downloaded from the mainframe (and, if necessary, a network server) to the EA server via FTP or SFTP.

Repository Server

The Repository Server hosts the database for one or more multiuser repositories, one repository per EA
workspace. This server provides centralized, network-accessible storage for parsed data and analysis
output.

EA Server

The EA Server hosts workspaces, workspace support files (including the copies of application source files
EA creates at workspace loading), and workspace output. This server leverages multiple processes to
enhance parsing performance in online or batch mode.

Parsed data is sent via ODBC to the repository server. Some analysis output is stored on the EA server as

well.
Note: In a multi-user environment, the EA Server cannot reside on the same machine as the EA
Repository. The installation program is the same for the EA client and EA server.

EA Client

EA Clients host the link files that let team members connect to workspaces on the EA server. These clients
access repository data stored in the repository server via ODBC.

y Note: The installation program is the same for the EA client and EA server.

Single User Installation

You can configure Enterprise Analyzer to build a workspace on one machine for a single user. You can use
Microsoft SQL Server Express - installed by default - to create a workspace on your local machine. EA
creates a database for the workspace "on the fly," with no intervention on your part. If you do use SQL
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Server Express, bear in mind that the Windows user who creates the workspace must have been
configured with appropriate permissions in SQL Server Express. The user who installed SQL Server
Express will always have the appropriate permissions. See the SQL Server Express documentation for
configuration instructions.

i Restriction: The database size limit when using the SQL Server Express option is 10 GB.

Database Setup

If you use Oracle or DB2, your DBA must set up a schema for each repository you plan to create. Each EA
user who accesses the repository must supply credentials for a database user with appropriate access
privileges to the repository.

If you use Microsoft SQL Server, the DBA must set up a SQL Server database for each workspace
repository you plan to create. EA users typically supply Windows credentials to access the repository.

DB2 User Privileges

If your site uses a DB2 database, your DBA must set up a database schema for each repository you plan
to create. Use the scripts provided with EA to create the DB2 database and tablespace, and the required
schemas. The scripts are located in the [Enterprise Analyzer_Installation _Directory]\DB2
Scripts folder.

Creating a Database and Tablespace

Run the following scripts provided with EA to create the DB2 database and tablespace. Open
the[Enterprise Analyzer_Installation_Directory]\DB2 Scripts folder:

1. Double-click [Enterprise Analyzer_Installation Directory]\DB2 Scripts
\crtmwdb.cmd to create the database.

2. Open [Enterprise Analyzer_Installation_Directory]\DB2 Scripts\crttblspace.cmd
in an editor. Replace [ADMINISTRATOR_USER_ NAME] and [PASSWORD] with the user name and
password of a user with administrative privileges for the database. Save and close the file.

3. Double-click [Enterprise Analyzer_Installation_Directory]\DB2 Scripts
\crttblspace.bat to create the tablespace.

Modify the database (mwdb), buffer pool (mwbp), and tablespace (mwtblsp) names (optional). Modify the
names in any scripts that reference them.

Note: The tablespace page size must be 32K. To improve the performance (optional) specify a
second tablespace for use in storing database indexes. Users specify both tablespaces when they
create an EA workspace. For instructions on how to create a workspace, see Getting Started in the
EA documentation set.

Creating a Schema

Set up a DB2 schema for each repository you plan to create. Run the following scripts provided with EA to
create a schema. In the [Enterprise Analyzer_Installation_Directory]\DB2 Scripts
folder:

1. Open crtschema.cmd in an editor. Replace [ADMINISTRATOR_USER_ NAME] and [PASSWORD]
with the user name and password of a user with administrative privileges for the database. Replace
each instance of [SCHEMA_NAME] with the name of the schema and [USER_NAME] with the database
user name. Save and close the file.

2. Double-click crtschema.bat to create the schema.

Repeat these steps for each schema you need to create.
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Each EA user who accesses a repository must supply credentials for a database user with appropriate
access privileges to the schema. These credentials are typically those for the Windows domain user. The
table below shows the required privileges.

Type Privilege

Database Privileges BINDADD
CREATETAB
CONNECT

IMPLICIT_SCHEMA

Schema Privileges CREATEIN

DROPIN
ALTERIN

Tablespace Privileges USE OF

Oracle User Privileges

If your site uses an Oracle database, your DBA must set up a database schema for each repository you
plan to create. Each EA user who accesses the repository must supply the name and password of a
database user with appropriate access privileges to the schema. The table below shows the required

privileges.
Type Privilege
Roles GATHER_SYSTEM_STATISTICS (required only for Compute Database Statistics

method. See Getting Started in the EA documentation set.)

System Privileges ALTER SESSION

CREATE SESSION
CREATE PROCEDURE
CREATE SEQUENCE
ALTER ANY SEQUENCE
CREATE SYNONYM
CREATE TRIGGER
CREATE ANY TABLE
DROP ANY TABLE
ALTER ANY INDEX
CREATE ANY INDEX
DROP ANY INDEX
[UNLIMITED TABLESPACE]1

Object Privileges SELECT on SYS.V_$INSTANCE

SELECT on SYS.V_$SESSION
SELECT on SYS.V_$PARAMETER

SQL Server Database Setup

If you use Microsoft SQL Server, you must set up a SQL Server database for each workspace repository
you plan to create. If EA users connect to the repository through an SQL Server login account, ensure the
server authentication property is set to SQL Server and Windows Authentication mode, as described
below.

The following instructions assume you are using the SQL Server Management Studio tool for SQL Server
2008. The procedure for the SQL Server Management Studio Express tool for SQL Server 2005 is similar.

10 | Enterprise Analyzer



Note: For Windows XP installations using the Italian locale, you must set the Time format in the
Control Panel Regional Language Options to "HH:mm:ss" before attempting to verify an EA
workspace with a SQL Server repository. Click Settings > Control Panel > Regional and Language
Options > Customize > Time and choose "HH:mm:ss" from the Time format list.

1. Click Start > Programs > Microsoft SQL Server 2008 > SQL Server Management Studio.
2. In the Connect to Server screen, select:

+ Database engine in the Server type list.
* The server on which you want to create the repository database in the Server name list.
* Windows Authentication in the Authentication list.

3. Click Connect. The Microsoft SQL Server Management Studio window opens. In the Object Explorer
pane, expand the folder for the server. Click Databases and choose New Database from the right-click
menu. The New Database window opens.

4. Select the General page. In the Database name field, enter the name of the database for the
repository. Modify the logical name and initial sizes of the database and log files if needed, then click
OK. The new database is displayed in the Object Explorer pane.

Note: The database collation should be case insensitive. Additionally, check the SQL Server
Management Studio documentation for details on other database settings.

5. If you connect to the workspace repository through a Windows user account, skip the remaining steps.
If you connect to the workspace repository through an SQL Server login account, click the server name
in the Object Explorer pane and choose Properties from the right-click menu. The Server Properties
window opens.

6. Select the Security page. In the Server authentication area, select SQL Server and Windows
Authentication mode, then click OK.

7. In the Object Explorer pane, click Security > Logins and choose New Login from the right-click
menu. The Login - New window opens.

8. Select the General page. In the Login name field, enter the database login name, then choose SQL
Server authentication. Enter the password for the database login in the Password and Confirm
password fields, then click OK. The new login is displayed in the Object Explorer pane.

9. In the Object Explorer pane, expand the database you created for the workspace repository. Click
Security > Users and choose New User from the right-click menu. The Database User - New window
opens.

10.Select the General page. Define the database user:

* Inthe User name field, type the database user name.

* Inthe Login name field, type the database login name. Use the Browse button to browse for the
login name.

Note: You specify the login name, not the database user name, when you create or connect to
a workspace, so it is usually best to make the user name and login name the same.
* In the Database role membership pane, check db_owner, then click OK. The new user is displayed
in the Object Explorer pane.

) Tip: You can use the same login and database user for multiple databases or workspaces.
i

You can configure Enterprise Analyzer to build a workspace on one machine for a single user. You can use
Microsoft SQL Server Express - installed by default - to create a workspace on your local machine. EA
creates a database for the workspace "on the fly," with no intervention on your part. If you do use SQL
Server Express, bear in mind that the Windows user who creates the workspace must have been
configured with appropriate permissions in SQL Server Express. The user who installed SQL Server
Express will always have the appropriate permissions. See the SQL Server Express documentation for
configuration instructions.
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i Restriction: The database size limit when using the SQL Server Express option is 10 GB.

Note: SQL Server database transaction logs can become full, resulting in errors. To avoid this, Micro
Focus recommends that you turn off transaction logging or implement automatic log recycling so that
normal EA processing is not interrupted. EA does not use the SQL recovery processes so the
transaction logging is not required, but it is recommended that the database is regularly backed up.

collation

Hardware and Software Requirements

The following sections describe the hardware, disk space, operating system, and software requirements for
EA installations.

Repository Server Hardware Requirements

The table below lists the hard drive storage requirements for the Repository Server. For other hardware
recommendations, check with support services.

Type Requirement Notes

Hard Drive Storage Variable Minimum of 20 GB disk space needed for the
software installation of the RDBMS and the
EA template database. Plus approximately
60x the size in bytes of the application source
code modeled in EA (e.g., 100 MB source =
6 GB).

Repository Server Software Requirements

The table below lists the software requirements for the Repository Server:

Type Requirement

SQL Server MS SQL Server 2012, 2014, 2016, 2017 or 2019
PostgreSQL PostgreSQL 13, 14

Oracle Oracle 10g, 119

f Note: If you run the Batch Refresh Process (BRP) on
the repository server, Oracle must be .NET-enabled.
Oracle requirements for local BRP execution are as
follows:

e For Windows 7, Oracle 11g

DB2 DB2 10.5 or higher

EA Server Hardware Requirements

The table below lists the hardware requirements for EA Server installations. Hardware requirements may
vary depending on the size of the application you are analyzing.

Type Requirement Notes
Processor 2.6 GHz Dual Core or 2x 3.0+ GHz Dual processing capability with multiple cores
Processors in a processor or separate physical
processors.
Physical Memory 3 GB RAM
Virtual Memory 1GBto3GB
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Type Requirement Notes

Hard Drive Storage Variable For EA workspaces, approximately 40x size
in bytes of the application source code
modeled in EA (for example, 100 MB source
=4 GB).

For EA software, minimum 200 MB.

For database client, minimum 200 MB.

EA Server Software Requirements

The table below lists the software requirements for EA Server installations:

Type Requirement

Operating System Microsoft Windows Server 2016, 64-bit
Microsoft Windows Server 2019, 64-bit
Microsoft Windows 10, 32-bit and 64-bit
Microsoft Windows Server 2022, 64-bit
Microsoft Windows 11, 64-bit

Database Client Oracle database client requirement is Oracle 11g.
For PostgreSQL the 32-bit ODBC drivers are required.

Pre-Requisite Software Note: The pre-requisite software is automatically
installed by the installer.

¢ Sentinel RMS License Manager

* .NET Framework 4.0

e .NET Framework 4.6.1

« .NET6.0.3

¢ Visual C++ 2012 Redistributable 11.0.61030

¢ Visual C++ 2017 Redistributable 14.11.25325.0
e SQL Server 2014 Express (optional install)

* Apache Tomcat 9.0.33 (optional). Needed for EA Web
deployment.

Web browser Required to view HTML report outputs or to access the Web
client.

* Internet Explorer 6.0 or higher (optional)
¢ Mozilla Firefox 3.6 or higher
e Chrome 6 or higher

Microsoft Office (optional) Required by EA tools with reporting capabilities to save to
Microsoft Office file formats. Excel is required for standard
deviation charts in the Executive Report.

Microsoft Visio (optional) Required to generate output as Microsoft Visio files.

Note: When the Visio version is 2013 or higher,
the .VSDX format is used instead of .VSD.

OpenJDK JRE 8.0 or higher (optional) Required for Java parsing.
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EA Client Hardware Requirements

The table below lists the hardware requirements for EA Client installations. Hardware requirements may
vary depending on the size of the application you are analyzing.

Type Requirement Notes

Processor 3.0 GHz Processor Single processor (single or dual core).
Physical Memory 1GB RAM

Virtual Memory 1GB to 3GB

Hard Drive Storage Variable For EA software, minimum 200MB.

For database client, minimum 200MB.

EA Client Software Requirements

The table below lists the software requirements for EA Client installations:

Type Requirement

Operating System Microsoft Windows Server 2016, 64-bit
Microsoft Windows Server 2019, 64-bit
Microsoft Windows 10, 32-bit and 64-bit
Microsoft Windows Server 2022, 64-bit
Microsoft Windows 11, 64-bit

Database Client Oracle database client requirement is Oracle 11g.

For PostgreSQL the 32-bit ODBC drivers are required.

Pre-Requisite Software Note: The pre-requisite software is automatically
installed by the installer.

» Sentinel RMS License Manager

* .NET Framework 4.0

e .NET Framework 4.6.1

e .NET6.0.3

* Visual C++ 2012 Redistributable 11.0.61030

* Visual C++ 2017 Redistributable 14.11.25325.0
* SQL Server 2014 Express (optional install)

Web browser Required to view HTML report outputs or to access the Web
client.

» Internet Explorer 6.0 or higher (optional)
* Mozilla Firefox 3.6 or higher
» Chrome 6 or higher

Microsoft Office (optional) Required by EA tools with reporting capabilities to save to
Microsoft Office file formats. Excel is required for standard
deviation charts in the Executive Report.

Microsoft Visio (optional) Required to generate output as Microsoft Visio files.

Note: When the Visio version is 2013 or higher,
the .VSDX format is used instead of . VSD.

OpenJDK JRE 8.0 or higher (optional) Required for Java parsing.
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EA Performance Optimization Guidelines

This section describes the optimal performance environments in which to run Enterprise Analyzer,
including selecting the right hardware configuration for specific types of usage, and optimizing the EA
configuration for the selected configuration. The suggestions for performance improvements are focused
on the repository build phase of the workspace.

The most time-consuming and hardware-intensive aspects of running Enterprise Analyzer are the source
verification and database loading during the workspace build phase. The guidelines include suggestions for
improving performance by using multiple Queue Processors and taking advantage of multiple CPU cores,
using the parallel verification option which determines the number of used Queue Processors, and
guidelines for defining the number of Queue Processors needed for a given configuration of available
machines and database server power.

There are two deployment scenarios for Enterprise Analyzer:

« Single User - this is typically a mobile user, such as a consultant on a laptop, who uses the repository
for demonstration or assessment purposes.

< Enterprise Installations - several computers are used (one for a database server, one for workspace and
multiple user machines).

Choosing Hardware Configuration

Single User (One Machine)

Minimum Hardware Requirements

Type Requirement Notes

Processor 1.8 GHz, minimum dual core

Physical Memory 2 GB RAM

Hard Drive Storage HDD with at least 20 GB free space For EA workspaces, approximately

60x size in bytes of the application
source code modeled in EA (for
example, 100 MB source = 6 GB).

With this minimum hardware configuration you can run Enterprise Analyzer and analyze sources.

Suggested Upgrades

The analysis time increases when the number of analyzed sources rises. To reduce the analysis time we
recommend you use one of the suggested upgrades:

1. A high speed Solid State Drive (SSD) for storing database tables. This can be added as an external
drive; however USB 3.0 or eSATA must be used. This will improve the verification performance by 25%
over the minimum configuration.

2. Use a quad core processor such as Intel Core i7 2670QM or any other quad core QE/QM processor.
This improves the verification performance by 50% over the minimum system configuration.

Note: You must run additional Queue Processors to benefit from the additional cores. See the
Choosing the Optimal Amount Of Queue Processors section for details.

Note: Improved verification performance means that if the project verification takes 100 minutes, and
you get 33% performance improvement, the verification time is reduced to 67 minutes.
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Recommended Configuration 1

This configuration gives 33% improved verification performance. The changes from the minimum

configuration are marked in bold.

Type

Requirement

Notes

Processor
Physical Memory
Hard Disk Drive

2.0 GHz, 2 cores
4GB
SSD with at least 20 GB free space

For EA workspaces, approximately
60x size in bytes of the application
source code modeled in EA (for

example, 100 MB source = 6 GB).

Recommended Configuration 2

Recommended Configuration 2 gives 50% improved performance of verification. The changes from the
minimum configuration are marked in bold.

Type

Requirement

Notes

Processor
Physical Memory
Hard Disk Drive

2.0 GHz, 4 cores
4 GB

Any type with at least 20 GB free
space

For EA workspaces, approximately
60x size in bytes of the application
source code modeled in EA (for

example, 100 MB source = 6 GB).

Performance Configuration

The Performance Configuration is a combination of all upgrades. It gives 66% improved verification
performance. The changes from the minimum configuration are marked in bold.

Type

Requirement

Notes

Processor
Physical Memory
Hard Disk Drive

2.0 GHz, 4 cores
4GB
SSD with at least 20 GB free space

For EA workspaces, approximately
60x size in bytes of the application
source code modeled in EA (for
example, 100 MB source = 6 GB).

Enterprise Installation (Multiple Users Using Separate Database Server)

A typical environment where large projects will be verified on a regular basis usually consists of 3 types of

components:

1. Database server (Oracle, DB2, MS SQL Server).
2. EA server with the workspace files. This is the machine where EA is installed and where the EA

workspace folder is located.

y Note: There can be more than one workspace.

3. Processing node(s). This is one or more computers running Queue Processors, or hosting the users of

the tool.
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Database Server

Minimum hardware requirements

Type

Requirement

Notes

Processor

Physical Memory

Hard Disk Drive

2.6 GHz Dual Core or 2x 3.0+ GHz
Processors

3 GB RAM

Dual processing capability with
multiple cores in a processor or
separate physical processors.

For EA workspaces, approximately
60x size in bytes of the application
source code modeled in EA (for
example, 100 MB source = 6 GB).

The minimum configuration can be up to four concurrent Queue Processors while providing reasonable
response time. To improve performance, one of the following upgrades should be used:

1. Use faster storage, for example use SSD or storage arrays in RAIDO. SSD improves the performance of
verification by 33%. 2x SCSI 15000 rpm gives a similar performance improvement.

2. Use 8 GB of RAM. Increasing the amount of RAM improves the performance of verification by 15%
when using more Queue Processors.

3. Network latency between database server and repository server and users should be less than 1ms.

Recommended hardware configuration

This is the recommended hardware configuration. The changes from the minimum configuration are

marked in bold.

Type

Requirement

Note

Processor

Physical Memory
Hard Disk Drive

2.6 GHz Dual Core or 2x 3.0+ GHz
Processors

8 GB RAM
SSD or SCSI 15000 rpm in RAIDO

Dual processing capability with
multiple cores in a processor or
separate physical processors.

For EA workspaces, approximately
60x size in bytes of the application
source code modeled in EA (for
example, 100 MB source = 6 GB).

Performance Configuration

You get 33% improved performance of verification.

Type

Requirement

Note

Processor
Physical Memory
Hard Disk Drive

Xeon CPU E5310 or Core i7 3770
8 GB

2x SCSI 15000 rpm RAIDO or 240GB

SSD

Note: Performance configuration can support up to 16 concurrent Queue Processors. Note that user
activity through the online tool should be counted as an active Queue Processor.
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EA and Workspace Server

The repository server stores the Enterprise Analyzer workspace folder and files. It is shared on the network
so that other users can access it.

/1. Warning: Micro Focus does not recommend combining the EA server and database server (and even
processing node) for machines with limited resources.

Minimum hardware requirements for Repository Server are:

Type Requirement Note

Hard Disk Drive Minimum of 20 GB disk space For EA workspaces, approximately
needed for the software installation of 60x size in bytes of the application
the database software. source code modeled in EA (for

example, 100 MB source = 6 GB).

Storing your workspace on an SSD
drive improves verification
performance by 5%-15%, depending
on your project.

Processing Node/Nodes

This is the machine that runs the Queue Processors and the processes that they kick off. The minimum
configuration lets you run a single Queue Processor.

Minimum System Requirements

Type Requirement

Processor 3.0 GHz single core or 2 GHz dual core
Physical Memory 2GB

Virtual Memory 1GBto3GB

Hard Disk Drive 1GB

The minimum system lets you analyze small volumes of sources and use the basic functionality of the tool.
To determine the optimal amount of Queue Processors for your Processing node see Choosing the
Optimal Amount of Queue Processors. To improve the performance, some of the following upgrades can
be used:

1. Use more CPUs or CPU cores. Enterprise Analyzer scales very well so the performance improvement
matches the CPU cores added - verification performance is improved by 90% when CPU cores are
doubled. The limit is eight physical cores that exclude hyper threading, with 16 queue processors. Each
concurrent Queue Processor instance needs up to an additional 2GB of RAM. Make sure your database
server can support the additional Queue Processors, see Database Server.

2. Use more computers as processing nodes.

Recommended Configuration (66% improved performance of verification)

Type Requirement
Processor 3 GHz quad core CPU
Physical Memory 4GB

Hard Disk Drive 4GB

As these processing nodes communicate extensively with the database server, a low-latency network is
required between processing node(s) and database server.
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Note: For best results, the computers must be on the same local network. You can use a repository
server or a database server (or both) as processing nodes, provided that MS Windows is installed.

Software Configuration

Verification Information

Verification is the process of analyzing the code loaded into EA. The verification process demands a lot of
CPU power. Enterprise Analyzer is designed to use a single CPU core for the main application, but each
Queue Processor can run on a separate CPU core. The Queue Processors can even run on multiple
computers to help with the verification database loading. There are two ways of initiating the verification
process. The first is the online tool (Enterprise Analyzer) and the second is through the Batch Refresh
Process (BRP).

Parallel Verification

By default Enterprise Analyzer uses serial verification both for the online tool and for BRP. If you have a
multicore CPU, it is better to use parallel verification.

To enable it in Enterprise Analyzer:

1. Click Options > Workspace Options.
2. Click Verification > Parallel Verification tab.
3. Select either

¢ Run Parallel Verification in the online tool
¢ Run Parallel Verification in BRP

4. Adjust the Minimum Queue Processors to improve performance when using an optimized number of
CPU cores.

Note: On a quad core CPU you get up to 4 times better performance provided that you use the
optimal number of Queue Processors.

Choosing the Optimal Number of Queue Processors
The optimal number of Queue Processors is related to the number of physical CPU cores available.

If you have X physical CPU cores you should use at least X Queue Processors. Using more Queue
Processors than physical CPU cores slightly increases performance but depending on your system setup it
could also slow down the verification because of the large number of concurrent 10 operations.

f Note: Micro Focus recommends using <number-of-physical-CPU-cores> multiplied by two.

Using More Computers
You can start a new Queue Processor on another computer to help the current verification.

f Note: EA must be installed on the computer that launches a Queue Processor.

1. Open Micro Focus Enterprise Analyzer Administration and click Administer > Build New Connection.
This creates a local - rwp file to connect to the workspace that needs help during the verification and
database loading.

2. Click Administer > Launch Queue Processor. The Launch Queue Processor window opens.

3. Specify the local . rwp file for the workspace and enter the number of Queue Processors that you want
to start.
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Installing and Uninstalling Enterprise Analyzer

Before running an installation program described in this section, make sure you have administrative
permissions for the machine on which you are performing the installation. If you do not have administrative
permissions, the installation program will not let you continue.

Note: You can run the Windows Installer (.msi) installation programs "silently." That is particularly
useful when you are installing clients on a network. Check with support services for the appropriate
sequence of commands.

Installing the Database Client

If you use Oracle or DB2, a database client must be installed wherever the EA client or EA server is
installed. If the RDBMS client software is not already installed on your machine, follow the instructions in
this section to install it.

Installing the Oracle Client
You will need the following information from your DBA to install and configure Oracle client software:

* The TNS Service Name for the database in which your workspace repositories will be stored.
« The host name for the computer on which the database resides.

e The port number for communications with the host, if it is not the standard port number.

e A database user ID and password.

1. Double-click the setup.exe program for the Oracle client installation. The Welcome screen opens.
2. Click Next. The Select Installation Type screen opens. Select Custom.

3. Click Next. The Specify Home Details screen opens. Enter an alternate name and path for the
installation, if desired. Otherwise, accept the defaults.

4. Click Next. The Available Product Components screen opens. Select the following components:
e SQL *Plus
e Oracle JDBC/THIN Interfaces

» Oracle Windows Interfaces. Deselect every choice under Oracle Windows Interfaces except Oracle
ODBC Diriver.

e Oracle Call Interface (OCI)
e Oracle Net

5. Click Next. The installer checks for prerequisites to ensure your environment meets the minimum
requirements for installation. Resolve any flagged items, if necessary.

6. Click Next. Review the Summary screen to confirm your selections. Use the Back button to correct any
errors. When you are satisfied that all the information is correct, click Install.

7. When installation completes, the Oracle Net Configuration Assistant is launched.

8. Click Next. The Naming Methods Configuration screen opens. Verify that Local Naming is shown in the
Selected Naming Methods field.

9. Click Next. The Net Service Name Configuration screen opens. In the Service Name field, enter the
TNS Service Name for the database your workspace repositories will be stored in. This name is
provided by your DBA.

10.Click Next. The Select Protocols screen opens. Select TCP.

11.Click Next. The TCP/IP Protocol screen opens. Enter the host name for the computer on which the
Oracle database resides. This name is provided by your DBA. Use the standard port number of 1521
unless otherwise instructed by your DBA.

12.Click Next. The Test screen opens. Select Yes, perform a test.
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13.Click Next. You should receive a message that the test did not succeed. This is because the default
login used for the test is the Oracle SYSTEM login. You must change the user name and password to
those provided by your DBA.

14.Click Change Login. In the Change Login dialog, enter the user ID and password provided by your
DBA.

15.Click OK. You should now receive a message that the connection test was successful. If the test
remains unsuccessful, click Change Login and confirm that you entered the correct credentials as
provided by your DBA. If problems persist, contact your DBA for assistance.

16.Click Next. The Net Service Name screen opens.

17.The Net Service Name field is prefilled with the TNS Service Name you specified in Net Service Name
Configuration screen. Click Next. The Additional Net Service Names screen opens.

18.In the Additional Net Service Names screen, configure additional TNS Service Names, one per
database instance you need to connect with. This step is optional. Select Yes to configure additional
TNS Service Names. Select No to complete the configuration.

Note: If you need to connect to additional database instances at a later date, you can add TNS
Service Names by manually editing the thsnames.ora file in Repository Client HOME. See
your DBA for details.

19.Click Next. Then click Next on the following two screens to complete the Oracle Net Configuration.
20.0n the Oracle Net Configuration completion screen, click Finish to exit the Net Configuration Assistant.

21.The Oracle Installer window opens Click Exit. You are prompted to confirm that you want to exit. Click
Yes.

Installing the DB2 Client
Follow the instructions in this section to install the DB2 client.

Note: The DB2 client must be .NET-enabled. Choosing the Typical DB2 client installation ensures
that .NET support is available.

1. Double-click the setup.exe program for the DB2 client installation. The Welcome screen opens. Click
Install a Product.

2. A screen prompts you to select the product you want to install. Under IBM Data Server Client, click
Install New.

3. The DB2 Setup Wizard opens. Click Next.

4. The Software License Agreement screen opens. Read the License Agreement carefully. Click | accept
the terms in the license agreement to accept its terms, then click Next.

5. A screen prompts you to select the installation type. Select Typical, then click Next.

6. A screen prompts you to install the IBM Data Server Client. Select Install IBM Data Server Client on
this computer, then click Next.

7. A screen prompts you to select an installation folder. To accept the prefilled value, click Next. To specify
a different folder, click Change and follow the substeps below.
a) Navigate the folder structure to find a suitable location. If the destination folder does not exist, the

installation creates it.

b) Click OK to exit the screen and return to the installation folder screen.
¢) Click Next in the installation folder screen.

8. A screen prompts you to enable operating system security for DB2 objects. Unless otherwise instructed
by your system or database administrator, deselect Enable operating system security, then click
Next.

9. A screen prompts you to start copying installation files to your computer. Click Install to begin
transferring files to your machine. A progress meter indicates the progress of the transfer.

10.When the transfer is complete, a screen informs you that setup is complete. Click Next.
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11.A screen prompts you to install additional products. Click Finish.

Installing EA on the Server or Client

The EA Server hosts EA workspace files and related support files. EA Clients host the link files used to
connect to workspaces on the server. Follow the instructions in this section to install EA on the client or
server. The Micro Focus License Manager is packaged with the installation.

Note: Having the EA server and the database on separate machines could improve performance. The
installation program is the same for the EA client and EA server.

1. Double-click EnterpriseAnalyzer.exe. Note that there might be a version number in the name of
the .exe file.

2. Change the installation directory if not installing to the default location.
3. Select which optional installs you want to include:

« Microsoft SQL Server - Express Edition

¢ Web Client

e Micro Focus MFA

e Micro Focus Enterprise Analyzer Administration Tool (needed for server, not really needed for client).
4. Read the End User License Agreement and check | agree to the End User License Agreement.
5. Click Install.

Uninstalling Enterprise Analyzer

Follow the instructions below to uninstall an Enterprise Analyzer product. Make sure you close any open
EA programs before running the uninstall program.

1. Click Start > Control Panel > Programs > Programs and Features > Uninstall a program

2. In the Uninstall or change a program window, right-click the product you want to uninstall, then click
Uninstall. You are prompted to confirm that you want to uninstall the product. Click Uninstall.

Post-Installation Administrative Tasks

Before you can work in Enterprise Analyzer, you must complete the basic administrative tasks described in
this section. You are prompted to perform the first of these tasks, configuring the EA, when you complete
the installation.

Configuring Enterprise Analyzer

Use the Configuration Manager in the Enterprise Analyzer Administration tool to configure EA options and
displays for the programming languages, dialects, character sets, and products in use at your site.

If you configure your EA for COBOL, for example, you will see only the EA options and displays appropriate
for COBOL modernization. You need to configure your EA for PL/I as well, you can come back to the
Configuration Manager later and select PL/I in addition to COBOL.

Note: The Enterprise Analyzer Administration tool will prompt to be run with elevated privileges. This
is required because some features of the tool require write access to the Program Files directory.

1. Open the Configuration Manager window.

« If you are installing EA, the Configuration Manager window opens after you finish the installation.

* If you have previously installed EA and want to reconfigure it, choose Start > Programs > Micro
Focus > Enterprise Analyzer > Enterprise Analyzer Administration. The Enterprise Analyzer
Administration window opens. In the Administer menu, choose Configure Micro Focus Enterprise
Analyzer. The Configuration Manager window opens.
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i Note: If EA is open, you are prompted to exit. Click OK, then close EA.

2. Select each programming language, dialect, and character set in use at your site. Select each EA
product you want to use at your site. The core Application Analyzer product is always selected. Select
Additional Tools to enable tools not used in typical EA configurations. When you are satisfied with your
choices, click OK.

Note: If you modify your EA configuration, make sure you upgrade workspaces created under the
previous configuration.

f Note: The Enterprise Analyzer Administration tool will prompt to
be run with elevated privileges. This is required because some
features of the tool require write access to the Program Files
directory.

Licensing

Although Enterprise Analyzer and Business Rule Manager) are both installed by the Enterprise Analyzer
installer, each product is licensed separately. Follow the instructions in the topics listed below to manage
your licenses.

Upgrading Customers

A customer upgrading from Modernization Workbench version 3.1 or later may use the existing license key
to enable Enterprise Analyzer for the same number of users.

Concurrent Use

You can license Enterprise Analyzer and Business Rule Manager for concurrent use. In this mode, one
license key for the purchased number of end users will be registered to a license server and each user
instance will contact it for authorization.

Enterprise Analyzer Licensing
A Sentinel RMS license server is installed with Enterprise Analyzer.

Depending on the licensing model in use at your site, you can manage your license:

» Locally, using the installed Sentinel RMS license server.
« Remotely, using a Sentinel RMS license server that has been configured to manage licenses centrally.

Note: The remote license server uses the same software as the local license server that is
installed with Enterprise Analyzer.

You will need to apply a license in the Micro Focus License Administration to use Enterprise Analyzer. To
start the Micro Focus License Administration, choose Start > All Programs > Micro Focus License
Manager > License Administration.

e If you use a local license server, you can apply a license using an authorization code or a licensing file
in the Install tab of the License Administration.

« Authorization code: Enter the 16-character license authorization code for Enterprise Analyzer, then
click Authorize.

* Licensing file: Enter your downloaded license file (.mflic) by browsing or dropping the file, then click
Install Licenses.

« If you use a remote license server, click Options > Advanced Configuration, then click Change in the
License server field. Enter the IP address or server name of the license server, then click Save.
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Your License System Administrator can tell you which licensing model your site uses and provide you with
the name of the remote license server if needed. For complete information, including how to configure a
remote license server, refer to the help provided with the License Administration tool.

Business Rule Manager Licensing

Trial licenses are not provided for Business Rule Manager. Before you can work with it, you must enter the
16-character license authorization code:

* Choose Start > Programs > Micro Focus License Manager > License Management System. In the
Licensing System Administration tool, click the Authorize tab, then enter the authorization code in the
Enter authorization code field and click Authorize.

Micro Focus End User License Agreement

IMPORTANT: LICENSOR PROVIDES LICENSED SOFTWARE TO LICENSEE UNDER THIS END USER
LICENSE AGREEMENT (THE "AGREEMENT"). THIS AGREEMENT GOVERNS LICENSEE’S
INSTALLATION AND USE OF THE VERSION OF THE LICENSED SOFTWARE IDENTIFIED IN THE
APPLICABLE PRODUCT ORDER, OR IF NOT ACQUIRED VIA A PRODUCT ORDER, LICENSEE’S
INSTALLATION OR USE OF THE LICENSED SOFTWARE CONSTITUTES ACCEPTANCE OF THIS
AGREEMENT. THE TERMS AND CONDITIONS OF THIS AGREEMENT MAY BE DIFFERENT FROM
THE AGREEMENT(S) THAT ACCOMPANIED EARLIER RELEASES OF THE LICENSED SOFTWARE.
PLEASE READ THIS AGREEMENT CAREFULLY BEFORE PROCEEDING, AS IT MAY CONTAIN
ADDITIONAL RESTRICTIONS ON YOUR USE OF THE SOFTWARE. THIS AGREEMENT
SUPERSEDES AND CONTROLS OVER ANY OTHER TERMS PROVIDED TO LICENSEE REGARDING
LICENSEE’S USE OF THE LICENSED SOFTWARE, WHETHER WRITTEN OR ORAL, AS PART OF A
SIGNED AGREEMENT (INCLUDING, BUT NOT LIMITED TO, MASTER AGREEMENTS AND
PORTFOLIO TERMS, UNLESS A DIFFERENT AGREEMENT IS EXPRESSLY REFERENCED IN A
PRODUCT ORDER OR EXECUTED BY LICENSOR AND LICENSEE SPECIFYING THAT IT APPLIES
TO THE VERSION OF THE LICENSED SOFTWARE TO WHICH THIS AGREEMENT RELATES), A
CLICK-WRAP AGREEMENT PROVIDED WITH THE LICENSED SOFTWARE OR OTHERWISE (SUCH
TERMS REFERRED TO AS THE "OTHER AGREEMENT"), EVEN IF SUCH OTHER AGREEMENT WAS
EMBEDDED WITHIN PREVIOUSLY LICENSED SOFTWARE. LICENSOR RESERVES THE RIGHT TO
UPDATE, AMEND, AND/OR MODIFY THIS AGREEMENT FROM TIME TO TIME, AND MAY INCLUDE
SUCH UPDATED AGREEMENT WITH OR EMBEDDED IN FUTURE VERSIONS OF THE LICENSED
SOFTWARE. PLEASE DIRECT ANY QUESTIONS TO THE MICRO FOCUS LEGAL DEPARTMENT AT
LEGALDEPT@MICROFOCUS.COM.

ENTERING INTO THIS AGREEMENT DOES NOT CONSTITUTE A SALES TRANSACTION. THE SALE
OF A LICENSE TO SOFTWARE PRODUCTS TAKES PLACE UNDER PRODUCT ORDERS WHICH
(UNLESS OTHERWISE STATED IN THE PRODUCT ORDER) INCORPORATE THE TERMS OF THIS
AGREEMENT.

Capitalized terms in this Agreement are defined as follows:

"Additional License Authorization"” or "ALA" means the additional specific software license terms that
govern the authorized use of a given software product of Licensor, including requirements for any non-
production use rights described in the Non-Production Licensing Guide, and License Options available for
that software product, along with additional terms or conditions applicable to a given License Option, all of
which are made a part of this Agreement. The applicable Additional License Authorization for the Licensed
Software is either attached hereto or can be found here: https://software.microfocus.com/en-us/about/
software-licensing by product name and version; all references in this Agreement to "Additional License
Authorization" or "ALA" shall refer to the ALA that corresponds to the version of the Licensed Software.

"Documentation” means the user documentation that Licensor makes available for the Licensed Software
in electronic form or paper form.

"Licensee" means the legal entity or individual that is identified in the applicable Product Order or who has
rightfully received a license to the Licensed Product.
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"License Option" means the type of license available for a given software product (such as a named user
license, concurrent user license or server license). In addition to the ALA, a License Option may be set
forth in a Product Order or an agreement executed in writing by Licensee and Licensor.

"Licensor" means the applicable Micro Focus entity and its affiliates who own the intellectual property
rights in Licensed Product.

"Licensed Product" means the Licensed Software and Documentation.

"Licensed Software" means the executable version of Licensor’s software listed in the Product Order or
otherwise provided to or rightfully acquired by Licensee. This Agreement shall govern the use of any
update to the Licensed Software that Licensee receives pursuant to a separate support and maintenance
agreement as described in Section 4 below, unless such update contains, comes with, or is otherwise
specifically governed by a different end user license agreement.

"Product Order" means an agreement between Licensor and Licensee that consists of a document that
has been (i) submitted by Licensee describing the License Option(s) to be purchased for the Licensed
Software, and (ii) accepted by Licensor (a) in writing or (b) by delivering the Licensed Software to Licensee,
whichever occurs first. A Product Order may also consist of a written quote, or other written document
issued by Licensor (the "Quote"), (i) describing the License Options for the Licensed Software to be
purchased, and (ii) that is accepted by Licensee before the Quote expires either by (a) returning the Quote
signed by an authorized representative of Licensee, (b) issuing a purchase order that references the Quote
(if the Quote expressly allows acceptance in this manner), or (c) paying Licensor the fees listed in the
Quote. Unless otherwise expressly set forth in the relevant Product Order, each Product Order incorporates
the terms and conditions of this Agreement, and in no event will any different or additional terms of a
purchase order or similar document issued by Licensee in connection with this Agreement or a Product
Order apply, and any such additional or different terms are hereby rejected by the Licensor. For purposes
of this paragraph, "Licensor" shall also include the relevant Micro Focus entity as defined above and its
authorized distributors and resellers. Any conflicting or additional terms in a Product Order accepted by an
authorized distributor or reseller of Licensor shall have no effect unless such terms have been agreed to by
the applicable Micro Focus entity in writing.

"Third Party Component" means any run time or other elements owned or licensed to Licensor by a third
party (other than open source code or elements) which may be embedded in the Licensed Software.

"Third Party Software" means additional or accompanying software owned or licensed by a third party
(such as Adobe Acrobat or Microsoft Internet Explorer, but not any open source code or elements) that
may be specified in the Documentation or in a file accompanying such Licensed Software.

"Warranty Period" means the ninety (90) day time frame beginning on date of delivery of the Licensed
Software to Licensee (Licensed Software delivery is deemed to occur when the Licensed Software is
physically delivered to Licensee EXWORKS or made available for download to Licensee).

1. GRANT OF LICENSE; LICENSE CONDITIONS.

a. License Grant. Subject to Licensee’s compliance with the terms and conditions of this Agreement
(including but not limited to payment of applicable fees), Licensor grants to Licensee a personal,
non-transferable, non-sublicensable and non-exclusive license to use the Licensed Software as
authorized by the License Option(s) specified in the ALA solely for Licensee’s internal business
operations, functions and benefit, and not for commercialization of the Licensed Software or to
provide services or benefit to any affiliates or subsidiaries of Licensee or any other third party.
Throughout the license term, Licensee agrees to: (i) implement internal safeguards to prevent any
unauthorized copying, distribution, installation, use of, or access to, the Licensed Products and
associated support and maintenance, or any other breach of this Agreement; and (ii) take all
necessary steps to destroy or erase all Licensed Software codes, programs, Documentation, and
other proprietary information of Licensor before disposing of any media or hardware. Licensor will
provide any license key necessary for activation and use of the Licensed Software. Licensor is not
liable or responsible for lost or broken license keys and is not obligated to replace license keys or
issue new license keys unless (1) Licensee has purchased a support and maintenance plan for the
applicable Licensed Software that specifically covers the issuance of new or replacement keys and
(2) the applicable version of the Licensed Software is then generally available for distribution by
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Licensor. If Licensee has not paid for such a support and maintenance plan, replacement or new
license keys may be available for purchase at Licensor’s then-current list price for applicable new
licenses.

Evaluation Licenses. With respect to any Licensed Software provided to Licensee solely for
evaluation purposes (an "Evaluation License"), in the event of conflict this Section 1.b shall prevail
over any other provisions set forth in this Agreement. An Evaluation License may be used for a
period of no more than thirty (30) days from the date the Licensed Software is provided to Licensee
("Evaluation Term"), unless a different period is specified in writing by Licensor. An Evaluation
License may be used solely for Licensee’s internal evaluation and testing purposes on a single
computer system and not for development, commercial, or production purposes. For Licensed
Software subject to an Evaluation License, (i) Licensee may not reproduce or distribute the Licensed
Products; and (ii) Licensee’s results of benchmark or other performance tests run on or using the
Licensed Software may not be disclosed to any third party without Licensor’s prior written consent.
At any time during the Evaluation Term or upon completion thereof, Licensee may, upon written
notification to Licensor and payment of the applicable license fee, replace the Evaluation License
with a license to use the Licensed Software that is not restricted to evaluation purposes. In the
absence of such notification by Licensee, the Evaluation License shall automatically terminate at the
end of the Evaluation Term, and Licensee shall return, or, if Licensor so directs, delete and destroy
all such Licensed Software and provide Licensor with written confirmation of its compliance with this
provision. Upon written request from Licensee, Licensor may, in its sole discretion, grant Licensee an
extension in writing prior to the expiration of the Evaluation Term. Other than updates to Licensed
Software provided as part of support and maintenance, Licensed Software provided by Licensor free
of license fee charge shall be deemed to be provided for evaluation purposes only. Licensed
Software furnished under an Evaluation License is provided without any contractual obligation of
maintenance and support by Licensor and is provided "as is" without warranties, implied or express,
of any kind.

Bundles/Suites. If the Licensed Software is licensed in a bundle or suite of multiple products, and the
applicable Product Order specifies the License Option and license count for the bundle or suite (but
not the individual product components of the bundle or suite), then each product in the bundle or
suite shall share such license type and count. For example, individual products in the bundle or suite
cannot be used by multiple users if only one user license is purchased (for user-based licenses) and
cannot be installed on multiple devices or servers if only one device or server license is purchased
(for device or server-based licenses).

2. USE RESTRICTIONS. Except as may be otherwise specifically permitted in the applicable ALA,
Licensee agrees not to, directly or indirectly:

a.

b.
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Copy, distribute or use the Licensed Software, in whole or in part (such as any portion, feature,
function, or user interface) without paying Licensor the applicable fees;

Use the Licensed Software as a service, or for timesharing, facilities management, outsourcing,
hosting, service bureau use, or for providing other application service (ASP) or data processing
services to third parties or for like purposes, or permit the use of the Licensed Software by a third
party or permit access by or use for the benefit of any third party without executing a separate
distribution agreement for the Licensed Software and paying Licensor the applicable required
additional fees;

Modify or create derivative works of the Licensed Software, or decrypt, translate, disassemble,
recompile, decompile or reverse engineer the Licensed Software or attempt to do so (except to the
extent applicable law specifically permits such activity, in which case Licensee must provide Licensor
with detailed information regarding such activities);

Alter, destroy, or otherwise remove any proprietary notices or labels on or embedded within the
Licensed Software;

Use the Licensed Software in a manner other than as specifically permitted in this Agreement or an
ALA;

Assign, sell, resell, license, rent, lease, lend, sublicense, outsource or otherwise transfer the
Licensed Software to any third party, without first paying Licensor the applicable required license
fees and obtaining Licensor’s prior written consent;



g. Authorize, allow or appoint any third party to do any of the foregoing. For the avoidance of doubt,
third parties include, without limitation, contractors and consultants (including contractors and
consultants retained to provide services solely for the benefit of Licensee), outsourcers, Licensee’s
affiliates and subsidiaries, parent companies, customers, and the public; or

h. Publish or disclose to third parties any evaluation or benchmarking of the Licensed Software without
Licensor's prior written consent.

Notwithstanding the foregoing, Licensee may: (i) make a reasonable number of archival back-up
copies of the Licensed Software and (ii) make a reasonable number of copies of the Documentation.
Licensee shall reproduce all copyright and other proprietary rights notices appearing in or on the
Licensed Products, including notices of all third party suppliers.

. TERM OF LICENSE. This Agreement and the license term for the Licensed Software granted herein is
perpetual, unless a subscription/term license has been purchased by Licensee (in which case the
license term shall be set forth in the Product Order or ALA), and is subject to earlier termination as
provided in this Section 3. If Licensee has purchased a subscription/term license, such license shall
automatically terminate upon expiry of such subscription/term, unless earlier terminated under this
Section 3. Licensor may terminate this Agreement, along with any or all licenses then in effect with
Licensee, immediately by giving Licensee written notice of termination in the event that (i) Licensee
breaches any term or condition of this Agreement and fails to remedy such breach within ten (10) days
of receipt of Licensor’s notice detailing such breach; (ii) Licensee becomes insolvent, has a receiver
appointed, or files for or has filed against it, liquidation, bankruptcy or analogous proceedings; or (iii)
Licensee infringes or misappropriates the intellectual property rights of Licensor. Termination shall be
without prejudice to any other rights or remedies Licensor may have. In the event of any termination,
Licensee’s license(s) to install, access or use the Licensed Software will immediately terminate, and
Licensee shall destroy and erase all copies of such Licensed Software in its possession or control and
provide written certification to Licensor that it has complied with this provision. Early termination of this
Agreement shall not entitle Licensee to any refund or reimbursement of any previously paid fees. The
rights and obligations of the parties contained in Sections 3 (Term of License), 6 (Disclaimer of
Warranty), 7 (Limitation of Liability), 8 (High Risk Uses), 9 (Ownership), 10 (Third Party Software and
Components), 11 (Notice to U.S. Government End Users), 12 (License Fees and Payment Terms), 13
(Audits), 15 (Privacy and Use of Licensee Information),16 (Licensee Trademark and Feedback) and 17
(Miscellaneous) will survive the termination or expiration of this Agreement.

. SUPPORT AND MAINTENANCE. Licensee is not entitled to any updates to the Licensed Software,
unless Licensee purchases maintenance and support services pursuant to Licensor’s then-current
applicable standard maintenance and support agreement, which can be found at https://
www.microfocus.com/support-and-services/maintenance-and-support-agreements/ or can be provided
by Licensor at Licensee’s request. Maintenance and support services (including, but not limited to, any
new versions, bug fixes, and patches) provided by Licensor will be subject to such agreement. Where
Licensee purchases maintenance and support for any Licensed Software, Licensee hereby agrees to
purchase or keep current on such maintenance and support services for all of Licensee’s licensed units
of such Licensed Software product, regardless of License Option.

. LIMITED WARRANTY. Licensor warrants for the Warranty Period that: (i) if the Licensed Software is
supplied via media, the media will be free from defects in materials or workmanship under normal use,
and (ii) the copy of the Licensed Software delivered to Licensee substantially conforms in all material
respects to the Documentation. Licensee’s sole and exclusive remedy for any defective media supplied
by Licensor shall be Licensor’s repair or replacement of such defective media free of charge, provided
that the defective media is returned to Licensor during the Warranty Period. During the Warranty Period,
Licensee’s sole and exclusive remedy for not meeting part (ii) of the above warranty shall be the repair
or replacement of the Licensed Software by Licensor free of charge so that it substantially conforms to
the Documentation or, if Licensor reasonably determines that such remedy is not economically or
technically feasible, Licensee shall be entitled to a full refund of the license fee and any maintenance
fee paid for such Licensed Software. Upon such refund, Licensee’s license to use such Licensed
Software will immediately terminate. The warranties set forth in this Section 5 shall not apply if the
defects in the Licensed Software or media result from: (a) failure to use the Licensed Software in
accordance with the Documentation, this Agreement or ALAs; (b) the malfunctioning of Licensee’s
equipment or network; (c) accident, neglect, or abuse; (d) service by any unauthorized person; (e) other
software used by Licensee and not provided by Licensor, or for which the Licensed Software is not
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designed or licensed for such use; (f) Third Party Software that is not a Third Party Component; (g) any
other cause occurring after initial delivery of the Licensed Software or media to Licensee, unless
caused directly by Licensor. Licensor has no responsibility for any claims made outside of the Warranty
Period. The foregoing warranty shall not apply to any free-of-charge Licensed Software or updates
provided under support and maintenance. THE FOREGOING WARRANTIES DO NOT APPLY, AND
LICENSOR DISCLAIMS ALL WARRANTIES, WITH RESPECT TO ANY THIRD PARTY SOFTWARE
THAT IS NOT A THIRD PARTY COMPONENT. The warranties set forth in this Section 5 will not apply
and will become null and void if Licensee materially breaches any provision of this Agreement.

6. DISCLAIMER OF WARRANTY. EXCEPT FOR THE LIMITED WARRANTY SET FORTH IN SECTION
5, THE LICENSED PRODUCTS ARE PROVIDED TO LICENSEE "AS-I1S" WITHOUT WARRANTY OF
ANY KIND. LICENSOR DOES NOT WARRANT THAT THE FUNCTIONS CONTAINED IN THE
LICENSED SOFTWARE WILL MEET LICENSEE’'S REQUIREMENTS, THAT OPERATION WILL BE
UNINTERRUPTED, ACHIEVE ANY INTENDED RESULT, BE COMPATIBLE, OR WORK IN
COMBINATION WITH ANY OTHER SOFTWARE, APPLICATIONS, OR SYSTEMS, MEET ANY
PERFORMANCE OR RELIABILITY STANDARDS, OR BE ERROR FREE, OR THAT ANY ERRORS
OR DEFECTS CAN OR WILL BE CORRECTED. EXCEPT AS SET FORTH HEREIN AND TO THE
EXTENT PERMITTED BY LAW, ALL OTHER WARRANTIES WITH RESPECT TO THE LICENSED
PRODUCTS, WHETHER EXPRESS OR IMPLIED, STATUTORY OR OTHERWISE, INCLUDING, BUT
NOT LIMITED TO, IMPLIED WARRANTIES OF MERCHANTABILITY, QUALITY, FITNESS FOR A
PARTICULAR PURPOSE, TITLE, NON-INFRINGEMENT, AND WARRANTIES THAT MAY ARISE OUT
OF COURSE OF DEALING, COURSE OF PERFORMANCE, USAGE, OR TRADE PRACTICE ARE
EXPRESSLY DISCLAIMED BY LICENSOR AND ITS THIRD-PARTY SUPPLIERS AND AFFILIATES.
LICENSEE ACKNOWLEDGES THAT LICENSEE IS RESPONSIBLE FOR THE SELECTION OF THE
LICENSED SOFTWARE TO ACHIEVE LICENSEE'’S INTENDED RESULTS AND FOR THE
INSTALLATION AND/OR USE OF, AND RESULTS OBTAINED FROM, THE LICENSED SOFTWARE.

7. LIMITATION OF LIABILITY.

a. Aggregate Cap. IN NO EVENT SHALL ANY LIABILITY OF LICENSOR OR ITS AFFILIATES OR
ANY OF ITS OR THEIR RESPECTIVE LICENSORS OR SERVICE PROVIDERS UNDER OR IN
CONNECTION WITH THIS AGREEMENT EXCEED, IN THE AGGREGATE, THE AMOUNTS PAID
BY LICENSEE FOR THE LICENSED SOFTWARE AND THE INITIAL PERIOD OF MAINTENANCE
AND SUPPORT GIVING RISE TO THE APPLICABLE CLAIM.

b. Waiver of Liability. IN NO EVENT SHALL LICENSOR OR ITS AFFILIATES OR ANY OF ITS OR
THEIR RESPECTIVE LICENSORS OR SERVICE PROVIDERS BE LIABLE FOR ANY INDIRECT,
SPECIAL, INCIDENTAL, CONSEQUENTIAL, PUNITIVE OR SIMILAR DAMAGES, LOSS OF
PROFITS, BUSINESS, DATA, OR PROGRAMS (INCLUDING, BUT NOT LIMITED TO, THE COST
OF RECOVERING OR REPLACING SUCH DATA OR PROGRAMS), LOSS, DAMAGE OR ANY
COSTS DUE TO INTERRUPTION, DELAY, OR INABILITY TO USE THE LICENSED SOFTWARE,
WHETHER ARISING OUT OF OR IN CONNECTION WITH THIS AGREEMENT, EVEN IF
INFORMED OF THE POSSIBILITY OF SUCH DAMAGES IN ADVANCE.

c. Scope. THE LIMITATIONS AND EXCLUSIONS OF THIS SECTION 7 APPLY TO ALL CAUSES OF
ACTION, INCLUDING, WITHOUT LIMITATION, BREACH OF CONTRACT, BREACH OF
WARRANTY, NEGLIGENCE, STRICT LIABILITY, MISREPRESENTATION AND OTHER TORTS.
THESE LIMITATIONS AND EXCLUSIONS APPLY COLLECTIVELY TO LICENSOR, ITS PARENTS,
AFFILIATES, AND SUBSIDIARIES AND EACH OF THEIR RESPECTIVE EMPLOYEES,
CONTRACTORS, AND SUPPLIERS. NOTWITHSTANDING THE FOREGOING, NOTHING IN THIS
SECTION 7 EXCLUDES LIABILITY FOR WILLFUL MISCONDUCT OR FRAUDULENT
MISREPRESENTATION.

d. Exclusive Remedy. LICENSEE’S REMEDIES IN THIS AGREEMENT ARE LICENSEE'S
EXCLUSIVE REMEDIES. LICENSEE AGREES THAT, IN ENTERING INTO THIS AGREEMENT, IT
DID NOT RELY ON ANY REPRESENTATIONS (WHETHER WRITTEN OR ORAL) OF ANY KIND
OTHER THAN THOSE EXPRESSLY SET OUT IN THIS AGREEMENT.

e. Essential Purpose. LICENSEE FURTHER ACKNOWLEDGES THAT THE LIMITATIONS AND
EXCLUSIONS OF LIABILITY IN THIS SECTION 7 APPLY TO THE FULLEST EXTENT
PERMITTED BY LAW AND ARE AN ESSENTIAL ELEMENT OF THIS AGREEMENT AND THAT, IN
THE ABSENCE OF SUCH LIMITATIONS AND EXCLUSIONS, THE PRICING AND OTHER TERMS
AND CONDITIONS SET FORTH HEREIN WOULD BE SUBSTANTIALLY DIFFERENT. THE
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LIMITATIONS AND EXCLUSIONS SET FORTH IN THIS SECTION 7 SHALL APPLY EVEN IF THE
LICENSEE’'S REMEDIES UNDER THIS AGREEMENT FAIL OF THEIR ESSENTIAL PURPOSE.

f. Free Software. IF LICENSOR PROVIDES LICENSEE WITH ANY LICENSED SOFTWARE FREE-
OF-CHARGE OR UNDER AN EVALUATION LICENSE, TO THE EXTENT PERMITTED BY LAW,
LICENSOR SHALL NOT BE RESPONSIBLE FOR ANY LOSS OR DAMAGE TO LICENSEE, ITS
CUSTOMERS, OR ANY THIRD PARTIES CAUSED BY THE LICENSED SOFTWARE THAT IT
MAKES AVAILABLE TO LICENSEE.

8. HIGH RISK USES. The Licensed Software is not fault tolerant, nor designed, manufactured, or intended
for use in hazardous environments requiring fail-safe performance (including, without limitation, the
operation of nuclear facilities, aircraft navigation or communication systems, air traffic control, direct life
support machines, or weapons systems) in which failure of the Licensed Software could lead directly or
indirectly to death, personal injury, or severe physical or environmental damage. Licensor and its
suppliers shall have no liability for any use of the Licensed Software in any high-risk situations.

9. OWNERSHIP. The Licensed Products are provided under license, and not sold, to Licensee. The only
rights in the Licensed Products are the licenses expressly stated in this Agreement and no other rights
are implied or granted by estoppel. Licensor (and its affiliates) and its and their licensors and third party
suppliers retain ownership of, and reserve all rights in and to, the Licensed Products, including all
copies thereof, and all intellectual property rights arising out of or relating to the Licensed Products.
Licensee shall use reasonable efforts to safeguard the Licensed Products (including all copies thereof)
from infringement, misappropriation, theft, misuse, or unauthorized access. Licensee shall promptly
notify Licensor if it becomes aware of any infringement or misappropriation of the Licensed Products
and shall fully cooperate with Licensor, at Licensor’s expense, in any legal action taken by Licensor to
enforce its intellectual property rights.

10.THIRD PARTY SOFTWARE AND COMPONENTS. The Licensed Software may come with or require
Third Party Software that Licensee shall license directly from the third party licensor pursuant to such
third party’s terms and conditions and not this Agreement. Additionally, some Licensed Software may
include certain Third Party Components and open source software. Such open source software and
Third Party Components may also be loaded on the Licensed Software media. Third Party Components
are licensed to Licensee under this Agreement; open source software is licensed pursuant to the
applicable open source license. To the extent applicable, information about the open source software
may be found (i) in a file accompanying the applicable Licensed Software or (ii) in the Documentation or
ALA. Licensee shall not directly access any Third Party Components other than with or as part of the
Licensed Software. Licensee agrees that to the extent required by a third party licensor or supplier of a
Third Party Component, that third party licensor or supplier is an intended third party beneficiary of this
Agreement as necessary to protect intellectual property rights in the Licensed Software and limit certain
uses thereof.

11.NOTICE TO U.S. GOVERNMENT END USERS. The Licensed Products are deemed to be "Commercial
Items," as defined at 48 C.F.R. 82.101, consisting of "Commercial Computer Software" and
"Commercial Computer Software Documentation," as such terms are used in 48 C.F.R. §12.212 or 48
C.FR. 8§227.7202, as applicable. Consistent with such sections, the Licensed Products are licensed to
U.S. Government end users (i) only as Commercial Items, and (ii) with only those rights as are granted
pursuant to this Agreement.

12.LICENSE FEES AND PAYMENT TERMS. Licensee agrees to pay the applicable license fees for the
Licensed Products within thirty (30) days of the date of invoice or such other date as agreed in writing
by the parties. Software license fees are non-refundable, except as provided in Section 5 above, and
shall be paid without any deduction or tax withholding. Software License fees are exclusive of any
applicable transportation charges, sales, use, value added tax, and other applicable taxes and duties,
and all such amounts shall be paid or reimbursed by Licensee. Licensee shall be liable for all
outstanding past due amounts, which shall accrue interest at the rate of 1.5% per month compounded
or, if lower, the maximum rate allowed by applicable law, and any collection costs associated with the
collection of any past due amounts.

13.AUDITS. Licensor or an Auditor (as defined below) has the right to verify Licensee’s compliance with
the licenses issued under Product Orders, the applicable ALAs and this Agreement (please see Micro
Focus License Compliance Charter at http://supportline.microfocus.com/licensing/licVerification.aspx,
which can also be provided by Licensor at Licensee’s request). Licensee agrees to:
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a. Recordkeeping. Keep, and upon Licensor’s request, provide records, sufficient to certify Licensee’s

compliance with this Agreement based on the applicable License Option(s) (including applicable
license metric and other terms and conditions) for the Licensed Software, which may include but are
not limited to, serial numbers, license keys, logs, the location, model (including quantity and type of
processor) and serial number of all machines on which the Licensed Software is installed or
accessed or from which the Licensed Software can be accessed, the names (including corporate
entity) and number of users accessing or otherwise able to access the Licensed Software, metrics,
reports, copies of the Licensed Software (by product and version), and network architecture
diagrams as they may relate to Licensee’s licensing and deployment of the Licensed Products and
associated support and maintenance;

b. Questionnaire. Within seven (7) days of Licensor’s request, Licensee shall furnish to Licensor or its

designated independent auditor ("Auditor") a completed questionnaire provided by Licensor or
Auditor, accompanied with a written statement signed by a director of Licensee certifying the
accuracy of the information provided; and

c. Access. Provide representatives of Licensor or Auditor any necessary assistance and access to

records and computers to allow an inspection and audit of Licensee’s computers and records, during
Licensee’s normal business hours, for compliance with licenses, the applicable ALAs, and this
Agreement, and fully cooperate with such audit.

. Non-Compliance. In the event that Licensee has, or at any time has had, unlicensed installation, use

of, or access to the Licensed Software or has otherwise breached this Agreement or an ALA (a
"Non-Compliance"), without prejudice to any other rights or remedies Licensor may have, including,
without limitation, injunctive relief, Licensee shall, within thirty (30) days’ notice of such Non-
Compliance to Licensee, purchase sufficient licenses and/or subscriptions and associated support
and maintenance to cure the Non-Compliance, by paying Licensor’s current (as of the date of such
additional purchase) list license fees and 12-month support and maintenance fees to Licensor for
such additional licenses, plus Licensor’s current (as of the date of such additional purchase) list term
license and support and maintenance fees and interest (compounded at 1.5% monthly or the
maximum rate permitted by applicable law if lower) for such additional licenses for the time period
from the commencement of the Non-Compliance until payment of the aforementioned fees, with
interest payable even if an invoice was not issued at the time the Non-Compliance occurred. For
purposes of the foregoing, "list" shall mean Licensor’s full list price as set forth in Licensor’s standard
price list that is current as of the commencement of the audit without any volume or other discount. If
Licensee’s Non-Compliance results in an underpayment of license fees of 5% or greater, Licensee
shall also reimburse Licensor for the reasonable cost of such audit in addition to other amounts due.
In the event of a dispute related to a Non-Compliance, Licensor shall have the right to collect from
Licensee its reasonable costs and attorneys' fees incurred in enforcing this Agreement.

14.RELATED SERVICES. Licensee shall be responsible for obtaining and installing all proper hardware
and other third party support software (including operating systems) for the proper installation and
implementation of the Licensed Software. In the event that Licensee retains Licensor to perform any
services with respect to the Licensed Software (for example: installation, implementation, maintenance,
consulting, or training services), Licensee and Licensor agree that such services shall be provided at
Licensor’s then- current standard terms, conditions, and rates for such services unless otherwise
agreed in writing by Licensor.

15.PRIVACY AND USE OF LICENSEE INFORMATION.

a. Responsibility and Compliance with Laws. Licensee is solely responsible for and assumes all liability
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with respect to its own collection, processing, storage, and transfer of any user data, including, but
not limited to, personally identifiable information and personal health and financial information
(collectively, "Personal Information"). Licensee shall be solely responsible for notifying its users of
proper use of such data. Each party is responsible for complying with its respective obligations under
all applicable laws, regulations, and industry standards regarding data collection and data privacy
applicable for the use of the Licensed Software by the relevant party.

Licensee shall not provide any Personal Information to Licensor for processing by Licensor on behalf
of Licensee, unless otherwise agreed by the parties in writing in an applicable transaction document
with applicable privacy terms. If the parties agree that processing Personal Information is necessary
for the performance of this specific transaction, and when such Personal Information processing falls



within the scope of the General Data Protection Regulation (EU) 2016/679 ("GDPR"), before any
Personal Information is made available to Licensor, the parties agree that Licensee will be the data
controller and Licensor will be the data processor, and when Licensor is processing Personal
Information on behalf of Licensee, such processing shall be governed by terms that comply with
Article 28 of the GDPR including standard contractual clauses to be included in such transaction
document.

Licensor will not have access to protected health information unless the parties have an executed
business associate agreement in place for this transaction. Licensee is solely responsible for
assessing the Licensed Product or any related product or service for compliance with any industry
requirements applicable to Licensee.

b. Consent to Use of Licensee Information. To the extent required or permitted by law, Licensee hereby
expressly consents to (i) receiving information from Licensor from time to time advertising Licensor’s
products; (ii) the use of Licensee’s name in Licensor customer lists, promotional materials, and press
releases; and (iii) the collection and use of information about the computer system on which the
Licensed Software is installed (e.g. product version, serial number) for internal security and licensing
purposes. Further information about Licensor’s processing of personally identifiable data is available
at https://www.microfocus.com/about/legal/#privacy (click "Privacy Notice" tab) or can be provided by
Licensor at Licensee’s request.

c. Other Use of Licensee Information. To the extent required or permitted by law, and notwithstanding
the terms in Section 15.a, Licensor may also process personally identifiable information of Licensee
and Licensee’s users (i) in order to comply with a legal obligation to which Licensor is subject; (ii) as
is necessary for the performance of this Agreement; and (iii) where necessary for the purposes of
Licensor’s legitimate interests, except where such interests are overridden by the interests or
fundamental rights and freedoms of the Licensee or Licensee’s users which require protection of
personally identifiable information.

16.LICENSEE TRADEMARK AND FEEDBACK. Licensor may use Licensee’s name and logo for business
development and marketing purposes, including, but not limited to, online and printed sales and
marketing materials. Any other use of Licensee’s name or logo, or a description of Licensee’s use of the

Licensed Software, shall be subject to Licensee’s prior consent. Any suggestions, ideas for

modifications, enhancements, and other feedback from Licensee regarding the Licensed Software

provided at any time (collectively, the "Feedback"), including (but not limited to) all intellectual property
rights in and to such Feedback, shall be owned exclusively by Licensor. Licensee hereby assigns all
right, title and interest in and to such Feedback and all the intellectual property rights therein to

Licensor, without the necessity of any further consideration. To the extent any Feedback cannot be

assigned to Licensor, Licensee hereby grants to Licensor a perpetual, irrevocable, exclusive, worldwide,

royalty-free, fully paid up license, with the right to sublicense through multiple tiers to use, make, sell,
distribute, execute, adapt, translate, reproduce, display, perform, modify, create derivative works of and
otherwise exploit the Feedback in any manner.

17.MISCELLANEOUS.

a. Assignment. Licensor may assign this Agreement, including any rights or obligations under the
Agreement (in whole or in part) to a parent or an affiliate. Licensee may not assign or transfer this
Agreement or any of its rights or duties hereunder, including (but not limited to) by merger,
acquisition by any entity of all or substantially all of Licensee’s stock or assets, change of control,
operation of law, or otherwise, without the prior written consent of Licensor and payment by Licensee
of the applicable assignment fee. Any attempted assignment not in accordance with this Section
shall be null and void.

b. Governing Law. If Licensee is located in North America, the laws of the State of California govern
this Agreement and the licenses granted hereunder, and the parties hereto consent to the exclusive
jurisdiction of the State and Federal courts of the State of California in any action based on this
Agreement or the Licensed Software hereunder or any License Option under an ALA. Each party
waives any right it may have to object to such venue, including objections based on personal
jurisdiction or forum non conveniens (inconvenient forum). The parties agree that the Uniform
Computer Information Transaction Act or any version thereof, adopted by any state, in any form
("UCITA"), shall not apply to this Agreement. To the extent that UCITA is applicable, the parties
hereby opt out of the applicability of UCITA pursuant to the opt-out provision(s) contained therein. If
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Licensee is located in France, Germany or Japan, this Agreement is governed by the laws of the
country in which Licensee is located. In the rest of the world the laws of England govern this
Agreement. In each case, the applicable law shall apply without regard to conflict of laws provisions
thereof, and without regard to the United Nations Convention on the International Sale of Goods.
Other than for North American transactions, this Agreement, the licenses granted hereunder, and the
parties hereto, shall be subject to the exclusive jurisdiction of the courts of the country determining
the applicable law as aforesaid.

c. Export Control. This Agreement may be subject to export control laws, regulations, and other
restrictions of the United States (including, but not limited to, the U.S. Export Administration
Regulations (the "EAR")), United Kingdom, or the European Union regarding export or re-export of
computer software and technology. Licensee agrees to comply with all applicable export control
laws, regulations, and restrictions, including the EAR, where applicable.

d. Entire Agreement. The applicable Product Order and this Agreement including the applicable ALA,
constitutes the complete and exclusive statement of agreement between the parties relating to the
license for the Licensed Products and supersedes all prior proposals, communications, purchase
orders, and agreements (including, without limitation, Other Agreements), without need for a
mutually executed amendment to any such Other Agreement. Any conflicting terms and conditions
shall be resolved according to the following order of precedence: the applicable Product Order, the
applicable ALA, and then this Agreement in all other respects.

e. Amendment. No representation, supplement, modification, or amendment of this Agreement will be
binding on either party unless executed in writing by duly authorized representatives of both parties
(excluding any distributor or reseller of Micro Focus) to this Agreement.

f. Waiver. No waiver of any right under this Agreement will be effective unless in writing and signed by
authorized representatives of both parties (excluding any distributor or reseller of Licensor). No
waiver of any past or present right arising from any breach or failure to perform will be deemed to be
a waiver of any future right arising under this Agreement.

g. Severability. If any provision in this Agreement is invalid or unenforceable, that provision will be
construed, limited, modified or, if necessary, severed, to the extent necessary, to eliminate its
invalidity or unenforceability, and the other provisions of this Agreement will remain unaffected.

h. No Reliance. Each party acknowledges that in entering into this Agreement it has not relied on any
representations, agreements, warranties or other assurances (other than those repeated in this
Agreement) and waives all rights and remedies which but for this Section 17 would be available to it.

Micro Focus EULA (1 November 2019)

Additional License Authorizations for Visual COBOL & Enterprise software products

This Additional License Authorizations document (“ALA”) set forth the applicable License Options and
additional specific software license terms that govern the authorized use of the software products specified
below, and are part of the applicable agreement (i.e., Micro Focus End User License Agreement; and/or
any separate agreement that grants Licensee a license to such products (e.g., Customer Portfolio Terms or
other Master Agreement); and/or Quotation) (the “Applicable Agreement”). Capitalized terms used but not
defined herein shall have the meanings set forth in the Applicable Agreement.

Products and Suites covered

Products E-LTU or E-Media Non-production software Term License Non-
available * class ™ production software class
(if available)

Business Rule Manager Yes Class 2 Class 2

COBOL Analyzer Yes Class 2 Class 2

COBOL Server Yes Class 2 Class 2

COBOL Server for Stored  Yes Class 2 Class 2

Procedures
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Products E-LTU or E-Media Non-production software Term License Non-

available * class ™ production software class
(if available)

COBOL 2010 Runtime Yes Class 2 Class 2

COBOL 2010 Runtime Test Yes Class 2 Class 2

Server

Database Connectors (all Yes Class 2 Class 2

variants)

Enterprise Analyzer (all Yes Class 2 Class 2

variants)

Enterprise Analyzer Server Yes Class 2 Class 2

(all variants)

Enterprise Developer (all Yes Class 2 Class 2

variants)

Enterprise Server (all Yes Class 2 Class 2

variants)

Enterprise Server for Yes Class 2 Class 2

Stored Procedures (all

variants)

Enterprise Test Server Yes Class 2 Class 2

Enterprise Test Server Yes Class 2 Class 2

Premium

Enterprise View Yes Class 2 Class 2

Relativity Designer Suite for Yes Class 2 Class 2

MF COBOL

Relativity for Windows Yes Class 2 Class 2

Workstations for MF

COBOL

Relativity Server for MF Yes Class 2 Class 2

COBOL

Visual COBOL (all variants) Yes Class 2 Class 2

Visual COBOL Database Yes Class 2 Class 2

File Handler

Suites E-LTU or E-Media Non-production software Term License Non-
available * class ™ production software class

(if available)

Visual COBOL for Eclipse  Yes Class 2 Class 2

Distributed Edition

Visual COBOL for ISVs Yes Class 2 Class 2

Visual COBOL Studio Yes Class 2 Class 2

Distributed Edition for ISVs

* Any product sold as E-LTU or E-Media shall be delivered electronically regardless of any contrary

designation in a purchase order.

Enterprise Analyzer | 33



™ Additional licenses solely for non-production use may be available as specified in the Non-Production
Licensing Guide found at software.microfocus.com/legal/software-licensing depending on the non-
production software class specified above. Any such non-production licenses will be subject to the Non-
Production Licensing Guide and the applicable License Option terms and conditions set forth in this
ALA.

Definitions

Term Definition

Authorized User Means a single user that has been authorized by
Licensee to use the Licensed Software or any device or
other software program that may access the Licensed
Software, either directly or indirectly through any other
software program, regardless of how such access occurs
or if such individual uses any hardware or software that
reduces the apparent number of users who are using the
Licensed Software, such as by using a terminal service.

Batch Processing Means the execution of one or more tasks, transactions
or programs by a computer system without the
continuous interaction of the end user with the Licensed
Software for the entire period during which each such
task, transaction or program is being executed by the
system. Batch processing includes situations where a
queue of jobs is processed as resources become
available and is in contrast to transaction or interactive
processing.

Concurrent Users Means individuals who, at the same point in time, have
accessed or used the Licensed Software via any device
or other software program, directly or indirectly,
regardless of how such access occurs or whether such
user uses any hardware or software that reduces the
apparent number of users who are using the Licensed
Software, such as by using a terminal service.

Container Means an isolated user-space instance created using
operating-system-level virtualization, also known as
containerization. A program running inside a Container
whether standalone or using an orchestration technology,
can only see the resources and devices assigned to the
Container. Examples of such container technologies
include Docker and podman and examples of
orchestrators include Kubernetes and Open Shift.

Core Means a physical (not virtual) subunit within a CPU on a
single chip that handles the main computational activities
of a computer. A CPU may have one or more Cores and
therefore be a "Multicore CPU" if it has more than one
Core.

CPU or Central Processing Unit Means a data processing unit, normally identified with a
single microchip mounted on a single circuit board and
can comprise several Cores.

E-LTU and E-Media Means products which are electronically delivered only,
and as such any reference to FOB Destination or delivery
methods that are stated on your purchase order other
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Term Definition

than electronic shall be null and void with respect to these
E-LTU or E-Media products.

Hard Partitioning Means using hard physical partitioning to physically
segment a single larger server or machine into separate
and distinct smaller systems where each separate system
acts as a physically independent, self-contained server or
machine with its own CPUs, operating system, separate
boot area, memory, input/output subsystem and network
resources (each known as a "Hard Partition"). Examples
of Hard Partitioning methods include: Dynamic System
Domains (DSD) -- enabled by Dynamic Reconfiguration
(DR), Solaris Zones (also known as Solaris Containers,
capped Zones/Containers only), IBM LPAR (adds DLPAR
with AIX 5.2), IBM Micro-Partitions (capped partitions
only), vPar, nPar, Integrity Virtual Machine (capped
partitions only), Secure Resource Partitions (capped
partitions only), and Fujitsu's PPAR. All approved hard
partitioning technologies must have a capped or a
maximum number of Cores/processors for the given
partition.

Named User Means a single user that has been authorized by
Licensee to use the Licensed Software.

Platform Means a hardware chipset (e.g., PA-RISC, Itanium, x86,
or SPARC) and operating system (e.g., Windows, Linux,
Solaris, AlX, or HP-UX) combination. Each unique Linux
distribution is considered a different operating system
from other Linux distributions and a different Platform
even with the same hardware chipset.

Soft Partitioning Means using an operating system resource manager to
segment and limit the number of Cores, CPUs, or other
processing devices utilized by the Licensed Software by
creating areas where processor resources are allocated
and limited within the same operating system (each such
area known as a "Soft Partition"). Examples of such Soft
Partitioning include: Solaris 9 Resource Containers, AlIX
Workload Manager, HP Process Resource Manager,
Affinity Management, Oracle VM, and VMware.

vCPU Means a virtual central processing unit that represents a
portion or share of the underlying, physical CPU that is
assigned to a particular Virtual Machine.

Virtual Machine Means a software implementation that can run its own
operating system and execute programs like a physical
machine where the software running inside the virtual
machine is limited to the resources and abstractions
provided by the virtual machine.

License Options

The following License Options are the types of licenses available for a given software product as further
specified in this ALA. The applicable License Option for a license shall be as set forth in the Applicable
Agreement or Product Order. Those products with only one License Option available shall be governed by
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such License Option whether or not stated in the Applicable Agreement or Product Order unless otherwise
agreed in writing between Licensee and Licensor.

Named User License

Licensed Software provided under this License Option gives Licensee the right to install the Licensed
Software on a single physical or Virtual Machine or server, or one or more Containers on such single
physical or Virtual Machine or server, for use solely by the number of Named Users expressly authorized
by Licensor in the Product Order for such license for whom Licensee has paid the applicable license fee.
Each such Named User has the right to unlimited access to the Licensed Software on such single machine
or server. A Named User License is required for each Named User that uses an installation of the Licensed
Software. For example, if Named User A and Named User B both use the same two separate installations
of the Licensed Software, a total of four Named User Licenses would be required for such use. Licensor
reserves the right at any time to require Licensee to provide a list of the Named Users. Licensee may
change a Named User provided that the change is made either (i) permanently, or (ii) temporarily to
accommodate the use of the Licensed Software by a temporary worker while the Named User is absent,
but in each case no more than once every 30 days. Licensee may not use the Licensed Software for user
acceptance testing, system/load testing, production or deployment. For purposes of this ALA, a Named
User License is considered to be a Development License.

Concurrent User License

Licensed Software provided under this License Option gives Licensee the right to install the Licensed
Software on multiple physical or Virtual Machine host machines or servers, or one or more Containers on
such physical or Virtual Machine host machines or servers, for use solely by the maximum number of
Concurrent Users expressly authorized by Licensor in the Product Order for such license for whom
Licensee has paid the applicable license fee. Licensee may not use the Licensed Software for user
acceptance testing, system/load testing, production or deployment. For purposes of this ALA, a Concurrent
User License is considered to be a Development License.

User License (Authorized Users)

Licensed Software provided under this License Option gives Licensee the right to install the Licensed
Software on an unlimited number of physical or Virtual Machine servers or Containers for use by up to the
total number of Authorized Users expressly authorized by Licensor in the Product Order for such license for
whom Licensee has paid the applicable license fee. The Licensed Software may not be used or accessed
by (i) individuals who are not Authorized Users; or (ii) any other software or hardware device that does not
require an individual to use or access it, including, without limitation, Batch Processing. Licensor reserves
the right at any time to require Licensee to provide a list of the Authorized Users. Licensee may change an
Authorized User provided that the change is made either (i) permanently, or (ii) temporarily to
accommodate the use of the Licensed Software by a temporary worker while the Authorized User is
absent, but in no event more than once every 30 days. This License Option may be further subject to the
Additional License Options set forth below in this ALA. For purposes of this ALA, a User License
(Authorized Users) is considered to be a Deployment License.

Server License (Concurrent Users)

Licensed Software provided under this License Option gives Licensee the right to install the Licensed
Software on a single physical machine or server or Virtual Machine, or one or more Containers on such
physical single machine or server or Virtual Machine, for use by the maximum number of Concurrent Users
expressly authorized by Licensor in the Product Order for such license for whom Licensee has paid the
applicable license fee. The Licensed Software may not be used or accessed by any other software or
hardware device that does not require an individual to use or access it including, without limitation,
Batch Processing. A Server License (Concurrent Users) cannot be split into multiple licenses of lesser
quantity (e.g., a license for 10 Concurrent Users cannot be split into two licenses of five Concurrent Users
each) without Licensor’s prior written consent and possible provision of different license keys. This License
Option may be further subject to the Additional License Options set forth below in this ALA. For purposes
of this ALA, a Server License (Concurrent Users) is considered to be a Deployment License.

Server License (per core) or Server License (per IFL)
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Licensed Software provided under this License Option gives Licensee the right to install the Licensed
Software on a single physical machine or server (“Host Server”), or one or more Containers on the Host
Server (provided such Containers are not running in a Soft Partition or Virtual Machine unless Licensee
has purchased the Virtualization License Extension or otherwise been granted such rights separately from
Micro Focus), and have the Licensed Software executed by up to the total number of (i) Cores in the case
of a Server License (per core), or (iii) Integrated Facility for Linux processors (“IFLs”) in the case of a
Server License (per IFL), specified for the license in the applicable Product Order (“License Specification”).
If the number of Cores is not specified for a CPU in the event a CPU is specified in the License
Specification, such CPU shall be considered to be single-Core. A license covering all physical Cores or
IFLs, as applicable, that are contained in and/or can be accessed by the Host Server (“Total Processors”) is
required with all applicable license fees paid, even if one or more of such Cores or IFLs are not accessing
or running the Licensed Software for any reason, including, for example, installation of the Licensed
Software in a Container that has fewer than the Total Processors allocated to it. For example, if 32 Cores
are the Total Processors on the Host Server, but only 16 Cores are utilized to execute the Licensed
Software, a 32-Core license is required notwithstanding the fact that 16 of the 32 Cores may not actually be
accessing the Licensed Software. Each Core on a multi-core CPU requires a license covering each such
Core. For example a Host Server with Total Processors consisting of a single quad-core CPU will require a
4-Core license.

Licensed Software provided under this License Option is for use by an unlimited number of Licensee’s
internal users, other software devices and hardware devices. Server License (per core) and Server
License (per IFL) are the only license types authorized for any Batch Processing. Licensor reserves
the right at any time to require Licensee to provide a specification of the Host Server. Licensee is required
to purchase a license for the Total Processors on each Host Server that accesses or uses the Licensed
Software either directly or indirectly through any other software program, regardless of how such access
occurs, or if the Host Server, CPU or operator uses any hardware or software that reduces the apparent
number of Cores, IFLs, or other processing devices that are using the Licensed Software, such as by using
a terminal service. This License Option may be further subject to the Additional License Options set forth
below in this ALA. For purposes of this ALA, a Server License (per core) and Server License (per IFL) are
considered to be Deployment Licenses.

Server License (per vCPU)

Licensed Software provided under this License Option gives Licensee the right to install and use the
Licensed Software in a virtualized environment that uses vCPUs as the metric for assigned processing
resources, on any number of instances, provided that the collective amount of vCPUs accessible by those
instances does not exceed the applicable license quantity. An instance may be within a single Virtual
Machine or Container that is not necessarily tied to just one physical machine. Licensee may make one (1)
failover or disaster recovery copy of the Virtual Machine or Container in which the Licensed Software is
installed and instantiate such Virtual Machine or Container in the event and for as long as the primary
installation is unavailable. For purposes of this ALA, a Server License (per vCPU) is considered to be
Deployment License.

Additional License Options

The following additional License Options may also apply to one of the License Options above if set forth in
the applicable Product Order notwithstanding anything else to the contrary in this ALA:

Test License

Licensed Software provided under this License Option gives Licensee a limited license to use the Licensed
Software solely for Licensee's internal testing purposes on a single computer subject to this section and
the restrictions applicable to the type of license specified in the applicable Product Order (e.g., Server
License (per core)) as set forth elsewhere in this ALA. In the event of a conflict, the terms and conditions in
this section shall prevail. At no time may Licensee use the Licensed Software for development, commercial,
or production purposes, nor may Licensee reproduce or distribute the Licensed Software or any software
application programs created with it. Licensee's results of benchmark or other performance tests run on or
using the Licensed Software may not be disclosed to any third party without Licensor's prior written
consent.
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Disaster Recovery License

Licensed Software provided under this License Option gives Licensee a limited license to use the Licensed
Software solely on a Disaster Recovery System subject to this section and the restrictions applicable to the
type of license specified in the applicable Product Order (e.g., Server License (per core)) as set forth
elsewhere in this ALA. In the event of a conflict, the terms and conditions in this section shall prevail. A
Disaster Recovery System is a single machine on which the Licensed Software is installed but is not
instantiated, running, or otherwise in use except: (i) if a disaster arises and the single machine for which
the Disaster Recovery System is configured to recover or replace (known as the "Primary Machine" in this
clause) is unavailable, (ii) for the purposes of periodic disaster recovery testing, and/or (iii) for periodic
system diagnostics or maintenance of the Disaster Recovery System itself. A Disaster Recovery License
cannot be used: (a) concurrently with any other license for the Licensed Software or in any production, test,
or development environments except while the Primary Machine is being recovered or replaced in a
disaster recovery situation, or (b) for load-balancing, failover, testing (other than disaster recovery testing),
clustering, or training purposes. Additional copies for use in production, test, and/or development
environments, or for load-balancing, failover, clustering, or training purposes, must be purchased
separately. The license quantity and metric of any Disaster Recovery License installed may not be less
than the license quantity and metric of the standard license for the Licensed Software on the Primary
Machine.

Failover License

Licensed Software provided under this License Option gives Licensee a limited license to use the Licensed
Software solely on a Failover System subject to this section and the restrictions applicable to the type of
license specified in the applicable Product Order (e.g., Server License (per core)) as set forth elsewhere in
this ALA. A Failover System is a single machine on which the Licensed Software is installed and running,
but only used to prepare for the recovery or replacement of the single machine for which the Failover
System is configured to recover or replace (known as the “Primary Machine” in this clause), up to and
including real-time data backups, mirroring, or any other activity to allow a synchronized switch-over from
the Primary Machine. Licensee may not use the Failover License for any other purpose such as production,
testing (other than failover testing), development, or training except during a disaster where the Primary
Machine is unavailable. Licensee may not use the Licensed Software for load-balancing or clustering; a
separate license for each of those use cases is required to be purchased by Licensee. The license quantity
and metric of any Failover License installed may not be less than the license quantity and metric of the
standard license for the Licensed Software on the Primary Machine.

Batch License

Where any Licensed Software is designated as a Batch License or “Batch-Only” in the applicable Product

Order using such description or similar terminology, such Licensed Software may only be used to perform

batch processing on a single computer subject to the restrictions applicable to the type of license specified
in the applicable Product Order (e.g., Server License (per core)) as set forth elsewhere in this ALA. In the

event of a conflict, the terms and conditions in this section shall prevail.

Virtualization License Extension

For a license for which a Virtualization License Extension has been purchased, the restrictions applicable
to the type of license specified in the applicable Product Order (e.g., Server License (per core)) as set forth
elsewhere in this ALA for such license shall apply subject to the terms in this clause. For as long as such
license is current on support and maintenance with Licensor, such license can be installed, used, or
accessed on, in, or from a Virtual Machine. Such license may not be installed or used in a public cloud
service. With respect to licenses based on processing devices such as Cores, the Licensed Software may
be installed and used on any number of instances provided that the collective amount of licensed
processing devices accessible by those instances does not exceed the applicable license quantity. For
example, for Core-based licenses, the license can be used on any number of instances provided that the
collective amount of Cores accessible by those instances does not exceed the applicable license quantity.
An instance may be within a single Virtual Machine or Container that is not necessarily tied to just one
physical machine. Licensee may make one (1) failover or disaster recovery copy of the Virtual Machine or
Container in which the Licensed Software is installed and instantiate such Virtual Machine or Container in
the event and for as long as the primary installation is unavailable.
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Third Party Usage License Extension

For a license for which a Third Party Usage License Extension has been purchased, such license can be
used by third party contractors of Licensee, notwithstanding any restriction to the contrary in the Applicable
Agreement, provided that (1) each such third party is under a written obligation of confidentiality and
restrictions of use which provide for protections and limitations of use of the license no less restrictive than
the Applicable Agreement, (2) the license will only be used on behalf of Licensee, (3) such use is subject to
the terms and conditions of the Applicable Agreement, and (4) Licensee remains liable for any breach by
any such third party of the terms of the Applicable Agreement.

Off Continent License Extension

For a license for which an Off Continent License Extension has been purchased, such license can be used
worldwide, except where prohibited by applicable law, notwithstanding any restriction to the contrary in the
Applicable Agreement.

Software Specific Terms

Business Rule Manager

The following License Options apply: Named User License, Concurrent User License.
COBOL Server, COBOL 2010 Runtime

The following License Options apply: User License (Authorized Users), Server License (Concurrent Users),
Server License (per core), Server License (per IFL), Server License (per vCPU) (COBOL Server only).

With any valid and properly granted license to this Licensed Software, Licensee may reproduce and
distribute internally, in whole or in part, subject to the applicable License Option as set forth in this ALA and
the applicable Product Order, any software application program created by Licensee using Visual COBOL
(if separately licensed to Licensee by Licensor) ("Licensee Application Software"). In such event Licensee
shall (a) include Licensor's copyright notice for the Licensed Software on any product label and as a part of
any sign-on message for such Licensee Application Software product; and (b) indemnify, hold harmless
and defend Licensor and its third-party suppliers from and against any claims or lawsuits, including
attorneys' fees, legal fees and court costs that arise out of, or result from, the use or distribution of such
Licensee Application Software.

Licensee can only reproduce and distribute Licensee Application Software to third parties after entering
into a separate distribution agreement with Licensor. Usage and distribution of the Licensee Application
Software arises both by the explicit distribution of any Licensee Application Software and by the implicit
distribution and usage of any of the Licensee Application Software's functionality when linked into another
software application program. Access and/or use of data, results and/or output obtained and/or generated,
either directly or indirectly, and in any format whatsoever, through the use of any Licensed Software (such
as when a user accesses an application that calls or uses output from another application running the
Licensed Software, whether or not on the same machine or server) are deemed to be access and/or use of
such Licensed Software. Licensor offers specific production licensing options for distribution to third parties
which vary depending upon the license fees paid by Licensee and Licensee should contact its Licensor
sales representative for more details.

COBOL Server for Stored Procedures
The following License Options apply: Server License (per core), Server License (per IFL).

The terms applicable to COBOL Server above apply to COBOL Server for Stored Procedures, except that
COBOL Server for Stored Procedures may only be used to enable deployment of COBOL stored
procedures on a single database server per license.

Database Connectors (all variants)
The following License Options apply: Server License (Concurrent Users), Server License (per core).

Enterprise Analyzer (all variants), Enterprise Analyzer Server (all variants), COBOL Analyzer,
Enterprise View
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The following License Options apply: Named User License, Concurrent User License, Server License
(Enterprise View only).

Named User Licenses for this Licensed Software may be installed on multiple machines for use solely by
the licensed Named Users. In the event the applicable Product Order specifies an amount of lines of code
for a license, then the application portfolio size (aggregate number of lines of code in all repositories
created) for such license is limited to the maximum lines of code (LOC) set forth for such license in the
applicable Product Order. LOC includes all lines of code from all programs (including each version of the
same program), all Java files, and all job control and database definition files in the repository. Copybook
and other included code is counted separately for each program in which it appears. Each Server License
of Enterprise View may only be installed on one server and may only access one repository at a time.

With respect to Enterprise Analyzer, the Licensed Software may require certain third party database
software beyond the limited database software that may be included with such Licensed Software, and in
such event Licensee must separately purchase or otherwise obtain such database software from the
applicable third party.

Enterprise Developer (all variants)
The following License Options apply: Named User License, Concurrent User License.

Licensee shall not use the Licensed Software, nor reproduce or distribute any files supplied as part of the
Licensed Software, in order to create a compiler, interpreter, runtime support product or any other product
that is generally competitive with or a substitute for the Licensed Software or any other Licensor product.

This Licensed Software may include or generate limited licenses for Enterprise Server or other application
deployment product If such licenses are included or generated, these limited licenses are provided solely
for use by the licensed user(s) of the Licensed Software in order to unit test an application developed with
the Licensed Software on the same machine or server used to develop the application and may not be
used for system testing, production or deployment. Any use of this limited license outside of the
development and unit testing of such applications is not permitted.

Enterprise Developer for Stored Procedure Debug. This Licensed Software may only be used to debug
stored procedures on a single database server per license.

Enterprise Developer Connect. Licensee may install certain Enterprise Developer components and models
in another Eclipse or IBM Developer for z environment in accordance with the applicable Documentation
solely for use with a valid license for Enterprise Developer Connect.

Enterprise Developer Models. This Licensed Software may only be used with a valid license for Enterprise
Developer and shall be governed by the same terms and conditions as such license. No support or
maintenance is provided or available for this Licensed Software.

Enterprise Server (all variants)

The following License Options apply: User License (Authorized Users), Server License (Concurrent Users),
Server License (per core), Server License (per IFL), Server License (per vCPU).

With any valid and properly granted license to this Licensed Software, Licensee may reproduce and
distribute internally, in whole or in part, subject to the applicable License Option as set forth in this ALA and
the applicable Product Order, any software application program created by Licensee using Micro Focus
Enterprise Developer (if separately licensed to Licensee by Licensor) ("Licensee Application Software"). In
such event Licensee shall (a) include Licensor's copyright notice for the Licensed Software on any product
label and as a part of any sign-on message for such Licensee Application Software product; and (b)
indemnify, hold harmless and defend Licensor and its third-party suppliers from and against any claims or
lawsuits, including attorneys' fees, legal fees and court costs that arise out of, or result from, the use or
distribution of such Licensee Application Software.

Licensee can only reproduce and distribute Licensee Application Software to third parties after entering
into a separate distribution agreement with Licensor. Usage and distribution of the Licensee Application
Software arises both by the explicit distribution of any Licensee Application Software and by the implicit
distribution and usage of any of the Licensee Application Software's functionality when linked into another
software application program. Access and/or use of data, results and/or output obtained and/or generated,
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either directly or indirectly, and in any format whatsoever, through the use of any Licensed Software (such
as when a user accesses an application that calls or uses output from another application running the
Licensed Software, whether or not on the same machine or server) are deemed to be access and/or use of
such Licensed Software. Licensor offers specific production licensing options for distribution to third parties
which vary depending upon the license fees paid by Licensee and Licensee should contact its Licensor
sales representative for more details.

Enterprise Server for Stored Procedures

The following License Options apply: Server License (per core), Server License (per IFL), Server License
(per vCPU).

The terms applicable to Enterprise Server above apply to Enterprise Server for Stored Procedures, except
that Enterprise Server for Stored Procedures may only be used to enable deployment of stored procedures
(either COBOL, PL/I, or both depending on what is specified for such license in the applicable Product
Order) on a single database server per license.

Enterprise Test Server, Enterprise Test Server Premium, COBOL 2010 Runtime Test Server

The following License Option applies: Server License (per core), Server License (per vCPU) (Enterprise
Test Server only).

This Licensed Software may be used only for Licensee's internal testing purposes. At no time may
Licensee use the Licensed Software for any other purpose including production.

Relativity Designer Suite for MF COBOL

The following License Options apply: User License (Authorized Users).

Relativity for Windows Workstations for MF COBOL

The following License Options apply: User License (Authorized Users), Server License (Concurrent Users).
Relativity Server for MF COBOL

The following License Options apply: Server License (per core), Server License (Concurrent Users).
Visual COBOL (all variants)

The following License Option applies: Named User License.

Licensee shall not use the Licensed Software, nor reproduce or distribute any files supplied as part of the
Licensed Software, in order to create a compiler, interpreter, runtime support product or any other product
that is generally competitive with or a substitute for the Licensed Software or any other Licensor product.

This Licensed Software may include or generate limited licenses for COBOL Server or other application
deployment product If such licenses are included or generated, these limited licenses are provided solely
for use by the licensed user(s) of the Licensed Software in order to unit test an application developed with
the Licensed Software on the same machine or server used to develop the application and may not be
used for system testing, production or deployment, and may only be used if the Licensed Software is
current on support and maintenance. Any use of this limited license outside of the development and unit
testing of such applications is not permitted

Visual COBOL Database File Handler

The following License Options apply: Server License (Concurrent Users), Server License (per core).

SUITES

Suite Offering includes

Visual COBOL for Eclipse Distributed Edition « Visual COBOL Development Hub

« Visual COBOL for Eclipse

Visual COBOL for ISVs ¢ Visual COBOL Development Hub
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Suite Offering includes

* Visual COBOL for Eclipse

* Visual COBOL for Visual Studio
Visual COBOL Studio Distributed Edition for ISVs «  Visual COBOL Development Hub
e Visual COBOL for Eclipse
* Visual COBOL for Visual Studio

Additional License Terms

The following additional license terms shall apply to any software governed by this ALA:
Additional License Restrictions

Licensee shall not:

1. Permit use or access by any third party to any output directly or indirectly created by the Licensed
Software without first paying Licensor any applicable additional fees required by Licensor and entering
into a separate distribution license agreement with Licensor. For the avoidance of doubt, third party(ies)
include without limitation contractors, outsourcers, Licensee’s customers and the public.

2. Transfer, ship or use the Licensed Software outside the continent in which it was originally licensed to
Licensee without first purchasing an Off-Continent License Extension or otherwise paying Licensor any
applicable additional fees required by Licensor. For purposes of the foregoing, “continent” shall mean
North America, South America, Europe, Africa, Asia, Australia, or Antarctica.

3. Install, use, or access the Licensed Software on, in, or from a Hard Partition, Soft Partition, or Virtual
Machine, except with respect to Server License (per vCPU) and the Virtualization License Extension,
and except where Licensee is otherwise expressly authorized in each instance by Licensor in the
applicable Product Order or otherwise in writing separate from this ALA (the “Authorization”) which in
each event will be subject to Licensee’s payment to Licensor of additional applicable fees required by
Licensor and, if requested by Licensor, Licensee’s written confirmation to Licensor of Licensee’s
planned installation environment signed by a director or officer of Licensee (accompanied by all
information as Licensor reasonably requires to verify). Except as otherwise specified in the
Authorization, where authorized in accordance with the foregoing and to the extent applicable to the
subject license: (i) such Hard Partition, Soft Partition, or Virtual Machine, may only be tied to one
physical machine and shall be considered the entire machine for licensing purposes; and (ii) Licensee
shall provide to Licensor, at such times as Licensor may reasonably request, confirmation that
Licensee’s computer systems comply with the applicable Authorization and the requirements of this
ALA. Such confirmation shall be signed by a director or officer of Licensee and shall be accompanied
by all information as Licensor reasonably requires to verify that Licensee is utilizing the Licensed
Software in compliance with the terms and conditions of this ALA and the Applicable Agreement,
including without limitation any relevant hypervisor logs. The foregoing is in addition to Licensor’s audit
rights under the Applicable Agreement.

4. Utilize any software application and/or program created, in whole or in part, with any Development
License without first purchasing a valid and properly granted Deployment License.

5. Install, access or use the Licensed Software on a Platform other than the Platform for which the
Licensed Software was originally licensed to Licensee. Additional licenses for use of the Licensed
Software on a Platform other than the one set forth in the applicable Product Order may be available
upon payment of an additional license fee.

All-or-None Support and Maintenance

Where Licensee purchases support and/or maintenance for the Licensed Software, Licensee hereby
agrees that it shall purchase such support and/or maintenance services for all of Licensee’s licensed units
of such Licensed Software including all related Development Licenses and Deployment Licenses.

Academic Editions/Users

Where Licensed Software is licensed under the Micro Focus COBOL Academic Program:
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(i) Licensee shall not use the Licensed Software for any purpose other than for non-commercial
education or academic research activities;

(ii) Licensee shall not copy the Licensed Software, nor shall Licensee distribute, transfer or assign the
Licensed Software without specific permission from Licensor; and

(iii) If Licensee is the academic institution using the Licensed Software for teaching purposes, Licensee
will manage all student licenses through a license server provided by Licensor in accordance with
guidelines provided by Licensor. Licensee agrees to provide reports describing the number of licenses
Licensee has issued in each period upon Licensor's request.

Personal Editions

With respect to any Personal Edition versions of the Licensed Software:

(i) Licensee shall not use the Licensed Software for any purpose other than for personal educational
and non-commercial activities. The Licensed Software may not be used for training or teaching
purposes.

(ii) Licensee shall not: (a) use the Licensed Software to compile source code for applications of more
than two thousand, two hundred (2200) lines of procedural code (exclusive of lines containing
comments and/or blanks) in any one (1) application or deploy or transfer such application on or to any
other machine or third party; or (b) with respect to Enterprise Developer, use the Licensed Software for
any purpose other than to input, edit and syntax check code for personal educational use.

(i) Licensee shall not copy the Licensed Software, nor shall Licensee distribute, transfer or assign the
Licensed Software without specific permission from Licensor.

Subscription Licenses

Where any Licensed Software is designated as a Subscription or Conversion Subscription license (rather
than a "Sub" license) or is an existing Upfront Sub or No Upfront Sub license, then the following additional
terms apply:

1. Term. Each license shall automatically terminate at the end of term for such license as stated in the
applicable Product Order. The license must be de-installed upon termination unless Licensee
purchases an additional subscription term for such license from Licensor.

2. Payment for Existing No Upfront Sub Licenses.. Fees for No Upfront Sub licenses will be billed monthly
in advance or per the frequency noted in the applicable Product Order if different. Licensee irrevocably
commits to pay such fees to Licensor for the entirety of the subscription term purchased.

3. Applicable License Extensions. The Off Continent License Extension and Third Party Usage License
Extension are automatically included. The Licensed Software may be installed or used in a public cloud
service. Server License (per vCPU) is the only authorized Deployment License type for Subscription
and Conversion Subscription licenses. If Licensee has an Applicable Agreement that permits use of the
Licensed Software to provide services to end user customers, Licensee may only use a license for the
Licensed Software subject to this ALA to provide services to one end user customer.

4. Support and Maintenance. Standard support and maintenance are included during the term of the
license.

5. Platform Transfer. Licensee may freely transfer a license during the term of such license from one x86
platform to another for which a version of the Licensed Software is generally available as of the
commencement of such license.

6. Reporting and True-Up. Licensee shall provide to Licensor on a quarterly basis, or at such other times
as Licensor may reasonably request, with a written report detailing the amount of usage of the Licensed
Software in a format agreed in advance by the parties. At a minimum this report shall include, as
applicable, the number of (i) instances of the Licensed Software, (ii) users of products licensed by
named user, (iii) cores, vVCPUs or other processing devices accessed by instances of products licensed
by server or processing device, and (iv) hours of usage supported by hardware/infrastructure
consumption reporting. Such report shall be signed by a director or officer of Licensee and shall be
accompanied by all information as Licensor reasonably requires to verify that Licensee is utilizing the
Licensed Software in compliance with the terms and conditions of the Applicable Agreement, including
without limitation any relevant hypervisor logs. The foregoing is in addition to Micro Focus’ audit rights
under the Applicable Agreement. If the above report indicates that Licensee has exceeded the amount
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of instances, users, cores, VCPUSs, or IFLs, then Licensee agrees to immediately pay Licensor for such
additional usage at Licensor's On-Demand Subscription per-day price specified in the applicable
Product Order, or if no such pricing is specified, then Licensor’s then-current On-Demand Subscription
per-day list pricing.

Host Connectivity Products

The Licensed Software may come with one or more software products from Licensor’s Host Connectivity
portfolio, and in such event, Licensee may only use such Host Connectivity software with the Licensed
Software on the same machine as the Licensed Software subject to the terms and conditions applicable to
the Licensed Software. For example, if Rumba or Host Access for Cloud were included with Enterprise
Developer, the licensed Named User for Enterprise Developer could only use such products to access
applications being developed using Enterprise Developer on the same machine as the licensed installation
of Enterprise Developer and not applications on any other machine. Notwithstanding the foregoing, in the
event Host Access for Cloud is included with Enterprise Server or any other product licensed by a
Deployment License, such software may only be used by up to 25 Concurrent Users per Enterprise Server
licensed deployment solely to perform administrative functions to support and maintain the applications
utilizing Enterprise Server to run.

software.microfocus.com/legal/software-licensing - Latest version of software licensing documents
© Copyright 2022 Micro Focus.
June 3, 2022

Configuring an ODBC Data Source Name

An ODBC data source name (DSN) is a set of credentials for connecting with a database instance. If you
use Oracle or DB2, you must configure a DSN for the database that holds your workspace repositories.

Configuring an Oracle ODBC Data Source Name

To configure an Oracle Data Source Name (DSN), you must have specified a TNS Service Name for the
database in which your workspace repositories will be stored. This is the TNS Service Name you entered
when you installed the repository client.

Check the file tnsnames.ora in Repository Client. HOME to make sure the TNS Service Name exists.
The entry should look like this, where RMWPROD is the TNS Service Name:

RMWPROD
(DESCRIPTION=
(ADDRESS_LIST=
(ADDRESS=(PROTOCOL=TCP) (HOST=tiger) (PORT=1521))

(CONNECT_DATA=
(SI1D=Inx)

)

You will also need to obtain a database user ID and password from your DBA to configure the Oracle DSN.

Note: Keep the DSN handy. You will need to specify it when you create an EA workspace. For
instructions on how to create a workspace, see Getting Started in the EA documentation set.

1. In the Windows Control Panel, double-click Administrative Tools. The Administrative tools window
opens.

2. Double-click Data Sources (ODBC). The ODBC Data Source Administrator window opens.
3. Select the System DSN tab and click Add. The Create New Data Source dialog opens.

4. Select an appropriate Oracle driver and click Finish. The Oracle ODBC Driver Configuration window
opens.
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5. Specify the following information in the Oracle ODBC Driver Configuration window:

* Inthe Data Source Name field, enter a name of your choice to identify the data source. If your DBA
has supplied a common DSN for use across the enterprise, enter it here.

* In the Description field, enter an optional description for the data source.

* Inthe TNS Service Name drop-down, select the TNS Service Name for the database in which your
workspace repositories will be stored. If no choices are shown, or if you are unsure which name to
select, contact your DBA.

* Inthe User ID field, enter the database user ID supplied by your DBA.
6. Click Test Connection. The Oracle ODBC Driver Connect window opens.

7. In the Oracle ODBC Driver Connect window the Service Name and User ID fields are prefilled with the
information you supplied in the Oracle ODBC Driver Configuration window. Enter the password for your
user ID and click OK. You are notified that the connection was created successfully. Click OK.

Note: If you receive an error, verify the driver configuration settings and retest the connection. See
your DBA if the problem persists.

8. Click OK to exit the Driver Configuration window. Then click OK again to exit the ODBC Data Source
Administrator window.

Configuring a DB2 ODBC Data Source Name
You will need the following information from your DBA to configure a DB2 ODBC data source name (DSN):

« The name of the database in which your workspace repositories will be stored.
e The host name for the computer on which the database resides.
e The port number for communications with the host, if it is not the standard port number.

Note: Keep the DSN handy. You will need to specify it when you create an EA workspace. For
instructions on how to create a workspace, see Getting Started in the EA documentation set.

1. In the Windows Control Panel, double-click Administrative Tools. The Administrative tools window
opens.

2. Double-click Data Sources (ODBC). The ODBC Data Source Administrator window opens.
3. Select the System DSN tab and click Add. The Create New Data Source window opens.

4. Select IBM DB2 ODBC DRIVER - DB2COPY1 and click Finish. The ODBC IBM DB2 Driver
configuration dialog opens.

5. In the Data Source Name field, enter a name of your choice to identify the data source. If your DBA has
supplied a common DSN for use across the enterprise, enter it here.

In the Description field, enter an optional description for the data source.
In the Database alias field, select an existing database alias from the drop-down, then click OK.
If a database alias has not been defined, click Add. The CLI/ODBC Settings window opens.

In the Data Source tab, the Data source name and Description fields are pre filled with the information
you supplied in the ODBC IBM DB2 Driver configuration dialog. In the User ID field, enter your domain
user name. In the Password field, enter your domain user password. The fields are case-sensitive.

10.Select the TCP/IP tab and specify the following information:

© © N

* In the Database name field, enter the name of the database in which your workspace repositories
will be stored.

* Inthe Database alias field, enter a database alias.

* In the Host name field, enter the host name for the computer on which the database resides.

* Inthe Port number field, enter the port number for communications with the host. Use the standard
port number of 50000 unless otherwise instructed by your DBA.

11.Click OK. You are returned to the ODBC Data Source Administrator window. Select the new data
source name and click Configure. The CLI/ODBC Settings window for the data source opens.
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12.In the Data Source tab, the Data source name and Description fields are pre filled with the information
you supplied in the ODBC IBM DB2 Driver configuration dialog. In the User ID field, enter your domain
user name. In the Password field, enter your domain user password. The fields are case-sensitive.
Click Connect to test the database connection. You are notified that the connection was created
successfully. Click OK.

Note: If you receive an error, verify the driver configuration settings and retest the connection. See
your DBA if the problem persists.

13.Click OK to exit the CLI/ODBC Settings window. Then click OK again to exit the ODBC Data Source
Administrator window.

Creating a Shared Folder for Workspaces

The folder in which you plan to create workspaces must be shared with team members. It is typically more
convenient to share the folder before you create workspaces, but you can do it afterward if necessary, then
refresh the workspace path as described in Getting Started in the EA documentation set.

Follow the instructions below to create a shared folder for workspaces. You must be an administrator to
create a shared folder.

1. On the EA server, create a folder for EA workspaces.

2. Select the folder and choose Sharing and Security from the right-click menu. The Properties dialog for
the folder opens. In the Sharing tab for the Properties dialog, select Share this folder on the network
(or, on a machine in a Windows domain, Share this folder). Enter the share name in the Share name
field and click Apply.

Note: Do not embed spaces in the share name. Doing so may cause other users to be unable to
access the folder.

3. Click Permissions. The Permissions for Folder dialog opens. Specify the appropriate permissions for
users sharing the folder and click OK.

Upgrading Workspaces

When you modify your EA configuration, you must upgrade every workspace created with the previous
configuration. Only the master user can upgrade a workspace.

1. Choose Start > All Programs > Micro Focus > Enterprise Analyzer > Enterprise Analyzer
Administration. The EA Administration window opens.

2. In the Administration window, choose Administer > Upgrade Workspace. The Upgrade workspace
dialog opens.

3. Choose the workspace you want to upgrade, then click Open. A Workspace Upgrade window opens.

4. Click Start to begin the upgrade. In the Workspace Upgrade window you see the upgrade process (The
parts that are being upgraded are highlighted and the checkbox next to each upgraded part is checked
when the upgrade is complete.) You can Pause the upgrade and Resume it later.

f Note: Upgrades that have stopped due to an error can be reset from the File menu.

5. (optional) Click Workspace Upgrade > File >Export DDL Script to export the DDL script to perform
the upgrade and give it to a DBA.

Troubleshooting the Installation

Follow the instructions in this section to troubleshoot an EA installation.

Troubleshooting Oracle Errors

Follow the instructions in this section to troubleshoot common Oracle errors.
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ORA-00958: name is already used by an existing object

This error occurs because the schema for the workspace was created with an Oracle ID already used to
create another schema. A unique Oracle ID must be used to create an Oracle schema.

ORA-01034: ORACLE not available; ORA-27101

These errors occur because the Oracle instance is not running. You could be receiving ORA-27101
because you tried to modify database parameters such as SGA size.

"There were errors during Index Preparation."
This error occurs because the Oracle tablespace does not have enough free space to restore the indexes.

To check the space in all tablespaces, run the following query:

select
fs.tablespace name "Tablespace",
(df.totalspace - fs.freespace) "Used MB",
fs.freespace "Free MB",
df.totalspace "Total MB",
round(100 * (fs.freespace / df.totalspace)) "Pct. Free"
from
(select

tablespace_nhame,
round(sum(bytes) / 1048576) TotalSpace
from
dba_data_ files
group by
tablespace name
) df,
(select
tablespace nhame,
round(sum(bytes) / 1048576) FreeSpace
from
dba_free_space
group by
tablespace_name
) fs
where
df.tablespace name = fs.tablespace name

To add additional files to the tablespace, use the following command:

alter tablespace <name> add datafile "path\filename.ora" size 100M autoextend
on;

Troubleshooting Workspace Access

The folder in which you plan to create workspaces must be shared with team members. If users are unable
to access workspaces, it may be because:

* You have not shared the folder for workspaces. Share the folder, then refresh the workspace path as
described in Getting Started in the EA documentation set.

* You shared the folder for workspaces after creating a workspace. Refresh the workspace path as
described in Getting Started in the EA documentation set.

* You embedded spaces in the value of the Share name field for the folder. Remove the spaces, then
refresh the workspace path as described in Getting Started in the EA documentation set.

Getting Started
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Introducing Enterprise Analyzer

Micro Focus Enterprise Analyzer (EA) offers centralized storage and analysis of enterprise application
portfolios:

« Language-specific parsers generate a common repository of application objects, in the industrial-
strength DBMS of your choice.

« Sophisticated analysis tools give you convenient interactive access to the repository, in a multiuser
environment that facilitates exchange of information and insight across the enterprise.

The result is a single easy-to-use interface in which you analyze assets written in modern languages like
Java and C# alongside assets written in legacy languages like COBOL and PL/I. And in which you perform
the analysis with industry-leading tools that offer deep, detailed, and comprehensive insight into complex
modern distributed applications.

Enterprise Analyzer Products

Enterprise Analyzer is a suite of PC-based software products for storing, analyzing, and re-architecting
enterprise applications. The products are deployed in an integrated environment with access to a common
repository of program objects. Language-specific parsers generate repository models that serve as the
basis for a rich set of diagrams, reports, and other documentation. Each product is separately licensed.

Enterprise Enterprise Business Rule

Analyzer View Manager

A A A

Enterprise Application Knowledgebase

A

Parsers |

Enterprise Analyzer

Enterprise Analyzer is a robust set of non-invasive interactive tools that work with source code, system
files, DDL, screen maps, and more. Use it for analyzing and documenting legacy systems at both the
application and program levels.

Use Enterprise Analyzer at the application level to:

* Create diagrams of applications.
« Perform change analysis across applications.
» Estimate application complexity and effort.
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Use Enterprise Analyzer at the program level to:

» Perform program analysis in stages.
» Perform impact analysis on a program.
« Model and search the repository.

Enterprise View

Enterprise View (EV) is a Web server-based tool that offers IT executives "at-a-glance" application portfolio
management (APM). EV charts and tables provide powerful graphical insight into APM trends and current
status, on dashboards that make it easy to drill down from the "big picture" captured at the highest level to
the lower-level details that support it.

With EV you can:

« Create, distribute, and gather responses to surveys about your organization’s application portfolio and
business processes.

« Mine application complexity metrics from the EA repository.

« Track survey and repository metrics in EV's rich variety of interactive charts, displayed on dashboards
structured to show the rollup of data from lower to higher levels.

For users who need to drill down even deeper into an application portfolio, EV lets you search, filter, and
analyze EA repository data. You can:

* Query the repository for information about application objects.
» Search, browse, and edit business rules and triggers.

Business Rule Manager

Business rule mining encapsulates your application’s business logic, making the application easier to
understand, document, and test. It lowers the risk and cost of maintenance and enhancement, and ensures
that all business logic is implemented in modernization efforts.

A business rule is a named container for program code that performs a discrete task in a business process.
It identifies and documents the code segment that performs this task. A business rule named Calculate
Date Difference, for example, might consist of this segment:

COMPUTE WS-DATE-VARIANCE = WS-C-CARD-DATE-CCYYMM - WS-TODAYS-DATE-CCYYMM.

Business Rule Manager (BRM) offers a powerful set of tools for autodocumenting, business rules. You can
batch edit rule attributes; create custom attributes suited to your particular needs; match input/output data
elements with the business names you've assigned to them in your project glossary; and much more.

Differences between EA Analyst Client and EA Developer Client

Enterprise Analyzer Analyst Client provides tools for building and maintaining enterprise class repositories,
as well as tools for application and program level understanding, utilizing extensive metrics, reports,
diagrammatic views and querying tools to support various business initiatives.

Enterprise Analyzer Developer Client provides developers or anyone wishing to consume application
knowledge with a simple-to-use web interface that lets them search, query and extract information from a
centrally-maintained enterprise repository.

The following table outlines the key differences between the two Enterprise Analyzer clients.

Note: This does not reference any tools required to build and maintain a repository as these are
provided with both client tools.
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Capability Analyst Client Developer Client
Intended target audience for each Business Analyst Developer
client type

Client interface Windows-based GUI Web Interface
System Level Objects and Metrics

Search Assistant v’ v
Reference reports v £
Diagrammer (project) v £
Diagrammer (object) v v
CRUD Report (project) v =
CRUD Report (object based) v v’
Complexity metrics v’ x
Syntactical Analysis

Code Search v v
Source pane with navigation v x
Program Control Flow v »
Portability Assessment reports v £
Quality Assessment reports v £
Advanced Analysis Options

Field level data dependencies v =
Change Analyzer (full) v £
Change Analyzer (single data item) v v’
Impact pane v’ 3
Execution Path Analysis v x

How Enterprise Analyzer Models Applications

Enterprise Analyzer is a model-based technology that generates information about legacy applications at
two levels:

« Application-level information describes the relationships between the objects that comprise an
application: its programs, copybooks, JCLs, BMS files, and so forth.

« Object-level information describes the relationships between the abstract syntactical constructs that
comprise an object: its sections, paragraphs, statements, conditions, variables, and so forth.

At both levels, the models are conceived as Entity Relationship Diagrams (ERDs). Each object or construct
the parser generates is modeled as an entity in one of the diagrams. The models are represented in tree
form to users.
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Understanding Application-Level Information

The object model for an application defines the relationships between the objects that comprise the
application. These can be physical objects, like program source files or JCLs, or logical objects that identify
abstract program elements: entry points, data stores, screens, jobs, and the like.

The relationships between objects describe the ways in which they interact. In the figure, the source file
GSS.CBL defines the GSS program. The program, in turn, reads the data file GSS.FCSTSEC.

E% Cobol File
=-lgy Gss.ceL @
! E|’ f% Defines Program
=-[E] ass
El’ '_é Reads File
i @ G353.FCSTIEC

Understanding Object-Level Information

The construct model for an object defines its syntax. It shows in abstract form how the syntactical
constructs that comprise the object (its sections, paragraphs, statements, conditions, variables, and so
forth) are related. A variable, for example, can be related in the construct model to its declaration, a
dataport (if it is used in an I/O statement), or a condition (if the condition uses an expression of which the
variable forms a part).

The figure shows a portion of the construct model for the GSS program. The model shows that the
program executes a PERFORM statement if the value of the variable EIBRESP satisfies the condition
EIBRESP NOT EQUAL DFHRESP(NORMAL).

=-FE) A110-RECEIVE-MAP
-] _Par_f110-RECEIVE-MAP
- IF EIBAID = DFHCLEAR

E| IF EIBRESP NOT EQUAL DFHRESP{NORMAL)
=2} EIBRESP NOT EQUAL DFHRESP{NORMAL)

If you are interested in investigating other uses of EIBRESP in the program, you can navigate to the
declaration of the variable in the construct model, and from the declaration to each instance of the
variable’s use in the program.

Workspaces and Projects

Enterprise Analyzer uses the familiar notions of workspace and project to help users organize application
source files conveniently. A workspace is a named container for one or more applications. Every
workspace has a corresponding database repository of model objects.

You can divide a workspace up into projects that represent different applications or different portions of an
application. You might have a project for the batch portion of an application and another project for the
online portion, for example. You can also use a project to collect items for discrete tasks: all the source files
affected by a change request, for example.

When you set up a workspace in Enterprise Analyzer, the system creates a default project with the same
name as the workspace. You can create new projects and move or copy entities between projects as
needed.

A workspace can contain objects coded in different programming languages. You can create multiple
workspaces on the same machine.
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Single-User versus Multiuser Environments
Enterprise Analyzer can be deployed in a single-user or multiuser environment:

« In asingle-user environment, the workspace repository resides on the local machine, and can be
accessed by the owner of the machine only. Limited facilities exist for sharing work with other users.

* In a multiuser environment, the workspace repository resides on a database server, and can be
accessed by any user with appropriate database privileges.

Most installations deploy Enterprise Analyzer in a multiuser environment. Single-user mode typically is
reserved for special needs.

The guidelines that follow for multiuser environments apply equally to single-user environments. For
installation instructions, see the installation guide for your product.

Multiuser Environment Basics

A multiuser Enterprise Analyzer environment gives members of a development team common access to a
workspace repository on a database server. Workspace setup is the responsibility of a master user, leaving
team members free to focus on their tasks. Common access makes it easy to share insights across the
team, and ensures that team members view the same source and work with the same option settings.

Deployment Scenario

The figure below shows a standard deployment scenario for the Enterprise Analyzer multiuser
environment. The role each machine performs and its key relationships are described below. Keep in mind
that the view is logical. Machine roles can be combined or separated as required.

ODBC

Enterprise Analyzer
Clients

Nehwork FTP
Mainframe with Server
FTE/AFTE Server

Enterprise Analyzer
Senver

Application Saurce code
origingtes here

Mainframe and Network Server

The mainframe hosts the application to be modeled in Enterprise Analyzer. Application source files are
downloaded from the mainframe (and, if necessary, a network server) to the Enterprise Analyzer server via
FTP or SFTP.

Enterprise Analyzer Server

The Enterprise Analyzer server hosts workspaces, workspace support files (including the copies of
application source files the product creates at workspace loading), and workspace output. This server
leverages multiple processes to enhance parsing performance in online or batch mode.
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Parsed data is sent via ODBC to the database server. Some analysis output is stored on the EA server as
well.

Database Server

The database server hosts the database for one or more multiuser repositories. This server provides
centralized, network-accessible storage for parsed data and analysis output.

The EA server, Enterprise View Web Server, and EA clients access the database server via ODBC. For
guidance on database setup, see the installation guide for your product.

Enterprise Analyzer Client

EA clients host the link files that let team members connect to workspaces on the EA server. These clients
access repository data stored in the database server via ODBC.

Enterprise View Web Server

The Enterprise View web server hosts services used by intranet and internet clients to display charts and
to access web-based view of repositories.

Enterprise View Web Client

Enterprise View web clients provide multiuser access to charts and workspace repository data via the
Enterprise View web server.

EA Privileges
Privileges in a multiuser environment work on two assumptions:

« Team members typically do not need to modify files until they have completed analysis and are ready to
test a proposed change.
« The team lead is best situated to make the change and reverify the modified file.

For these reasons, the EA multiuser environment has no need for file checkout and locking of the kind seen
in conventional multiuser environments.

Understanding Master Users

The user who creates a workspace on a Enterprise Analyzer server machine is referred to as its owner.
Initially, only the owner has master user privileges for the workspace.

The master user can delete the workspace, upgrade the workspace configuration, register and verify
source files, modify source, autoresolve decisions, perform restricted Code Search searches, create,
assign, and delete tags, and so forth. The master user can also designate new master users for the
workspace.

Ordinary users connect to the workspace from Enterprise Analyzer client machines. These users can
perform any task not restricted to the master user: analyze programs, mine business rules, extract
components, and so forth.

If you do not have master user privileges for a workspace, you will not see menu choices for privileged
methods. The same team member can be a master user for one workspace and an ordinary user for
another.

Understanding Workspace Security Policies

When you create a workspace, you can choose from two workspace security policies:

e The Simple Security Policy recognizes two classes of users, master users and ordinary users.

e The Three-Group Security Policy recognizes a third class of users, subject matter experts (SMEs), with
special privileges to create, assign, and delete tags.
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In each policy, the master user can create new master users.

Using the Optional File Server

When you create a workspace, you can restrict Windows access to workspace source files to master
users, while using the optional File Server to make the source files available in EA only to ordinary users.
As long as you set up workspace folder privileges correctly, ordinary users can view and analyze sources
in the product, but cannot access them otherwise. For file server installation instructions, see the
installation guide for your product.

Public and Private Visibility

In a multiuser environment, the user who creates a workspace resource (a project or a Code Search list,
for example) is referred to as its owner. Only the owner can share the resource with other users.

A shared, or public, resource is visible to other members of your team. A private resource is not. If a public
resource is protected, team members can view but not edit or delete the resource. A Code Search list, for
example, is always protected.

You can turn sharing on and off in the tool you use to create the resource. Look for a symbol like this one

for a shared project IE to indicate that the resource is shared.

Protecting Projects

By default, projects are unprotected: any user to whom the project is visible can add source files, include or
exclude objects.

f Note: Only a master user or the owner of a shared unprotected project can delete it.

The project owner or master user can designate a project as protected, in which case no user can delete or
modify the project, including the project owner or master user: the project is read-only, until the project
owner or master user turns protection off.

Turn on protection by selecting the project in the Repository pane and choosing Project > Toggle
Protection. Choose Project > Toggle Protection again to turn it off. Look for a symbol like this one & to
indicate that a project is protected.

Dropping Indexes

If you are a master user with responsibility for verifying source files in a multiuser environment, you will
almost always want to drop database indexes to improve verification performance. You will be prompted to
drop indexes when you verify the application, or you can drop indexes at a time of your own choosing by
selecting Prepare > Drop Repository Indexes.

When you drop indexes, you are prompted to restore the indexes when you analyze the files. If you want to
restore indexes at a time of your own choosing, choose Prepare > Restore Repository Indexes.

Computing Statistics

You typically need to gather statistics for your system before the optimizer for your RDBMS can determine
the most efficient way to execute SQL statements. If you are a master user with responsibility for verifying
source files in a multiuser environment, you will almost always want to gather system statistics after
verification to improve performance of the Enterprise Analyzer analysis tools.

Note: Check with your DBA before gathering system statistics. In Oracle, you must have
GATHER_SYSTEM_STATISTICS privileges to execute this method. Make sure to restore indexes
before gathering system statistics.

To gather system statistics, choose Prepare > Compute Database Statistics. You can view the generated
statistics in your RDBMS.
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Enterprise Analyzer Basics

This section describes elementary EA tasks: how to create a workspace and project, register and verify
source files, use the browser and other EA windows, set options, and export system diagrams and reports.

Creating a Workspace in Oracle or DB2

You create a workspace on the Enterprise Analyzer server machine. Other users connect to the workspace
from Enterprise Analyzer client machines. The workspace repository resides on a database server, and
can be accessed by any user with database privileges to the repository.

Note: Do not modify the name of the workspace after you create it. Doing so will cause unpredictable
results.

Before creating a workspace, you must configure an ODBC data source name (DSN) for the database that
holds the workspace repository, as described in the installation guide for your product. You will need the
following DSN configuration information to create the workspace:

* The data source name.
e The database schema name your DBA created for the repository.
* The database user name and password that give access to the schema.

« If required by your DBMS, the name of the tablespace your DBA created for the repository. If the DBA
also created a tablespace for database indexes, you will need the name of that tablespace as well.

The folder in which you plan to create workspaces must be shared with team members. It's usually more
convenient to share the folder before you create workspaces, but you can do it afterward if necessary, then
refresh the workspace path.

It is the responsibility of the workspace creator to designate users for security policies. Perform this task as
soon as you have finished creating the workspace, then periodically edit the list of users as required.

1. Choose Start > All Programs > Micro Focus > Enterprise Analyzer > Enterprise Analyzer
Administration. The Administration window opens.

2. Choose Administer > New Workspace. The Create new workspace dialog opens.

3. In the Create new workspace dialog, double-click the New Workspace icon for the RDBMS in use at
your site or select it and click OK. The New workspace dialog opens.

4. In the New workspace dialog, choose the location for the workspace in the Save in drop-down. In the
File name field, enter the name of the workspace. Choose a name that describes the legacy application
as closely as possible. Click Save. The Define Connection Parameters dialog opens.

5. In the Define Connection Parameters dialog, click the Connection tab. On the Connection tab, enter:

« The ODBC data source name you defined at ODBC data source configuration. If you have not
defined a data source name, or want to use a different data source name, click ODBC Manager to
open the data source name configuration dialog, then follow the instructions for ODBC data source
configuration in the installation guide for your product.

e The database schema name your DBA created for the workspace repository.

« The database user name and password that give access to the schema.

« If required by your DBMS, the name of the tablespace your DBA created for the repository. If your
DBA also created a tablespace for database indexes, enter the name of that tablespace in the
Tablespace for Indexes field. These fields are displayed only for DBMSs that require a tablespace
name to be specified.

6. Click the Security tab. In the Policies list box, select:

« Simple Security Policy if you want to enforce a workspace security policy that recognizes two
classes of users, master users and ordinary users.
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* Three-Group Security Policy if you want to enforce a workspace security policy that recognizes a
third class of users, subject matter experts (SMEs), with special privileges to create, assign, and
delete tags.

7. In the Files access group box on the Security tab, select:

« Direct sources access via Windows share if your site does not restrict Windows access to
workspace source files to the master user.

e Secure sources access via EA file server if your site restricts Windows access to workspace
source files to the master user, while using the optional file server to make the source files available
in the product to ordinary users. Make sure the values for the server name and port number fields
are correct.

y Note: For File Server installation and setup instructions, see the installation guide for your product.

8. Click OK.

Note: If you created the workspace in a non-shared folder, you are warned to that effect and
prompted to share the folder. After you share the folder, make sure to refresh the workspace path.

You are notified that the workspace was created successfully. Enterprise Analyzer creates a workspace
file (.rwp) and a folder with the same name in the specified location. The workspace folder contains
support files and subfolders for EA output. A project with the same name as the workspace is displayed
in the Repository Browser.

Creating a Workspace in SQL Server

You create a workspace on the Enterprise Analyzer server machine. Other users connect to the workspace
from Enterprise Analyzer client machines. The workspace repository resides on a database server, and
can be accessed by any user with database privileges to the repository.

Note: Do not modify the name of the workspace after you create it. Doing so will cause unpredictable
results.

The folder in which you plan to create workspaces must be shared with team members. It's usually more
convenient to share the folder before you create workspaces, but you can do it afterward if necessary, then
refresh the workspace path.

It is the responsibility of the workspace creator to designate users for security policies. Perform this task as
soon as you have finished creating the workspace, then periodically edit the list of users as required.

You can use Microsoft SQL Server Express to create a workspace on your local machine. Enterprise
Analyzer creates a database for the workspace "on the fly," with no intervention on your part. If you do use
SQL Server Express, keep in mind that the Windows user who creates the workspace must have been
configured with appropriate permissions in SQL Server Express. The user who installed SQL Server
Express will always have the appropriate permissions. See the SQL Server Express documentation for
configuration instructions.

Note: For Windows XP installations using the Italian locale, you must set the Time format in the
Control Panel Regional Language Options to "HH:mm:ss" before attempting to verify an EA
workspace with a SQL Server repository. Click Settings > Control Panel > Regional and Language
Options > Customize > Time and choose "HH:mm:ss" from the Time format drop-down.

1. Choose Start > All Programs > Micro Focus > Enterprise Analyzer > Enterprise Analyzer
Administration. The Administration window opens.

2. Choose Administer > New Workspace. The Create new workspace dialog opens.

3. In the Create new workspace dialog, double-click the New Workspace icon for the RDBMS in use at
your site or select it and click OK. The New workspace dialog opens.

4. In the New workspace dialog, choose the location for the workspace in the Save in drop-down. In the
File name field, enter the name of the workspace. Choose a name that describes the legacy application
as closely as possible. Click Save. The Define Connection Parameters dialog opens.
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Note: This dialog does not open for Microsoft SQL Server Express. The product starts creating the
workspace immediately.

5. In the Define Connection Parameters dialog, click the Connection tab. Define the connection:

* Inthe Server field, enter the server name. The server name must be of the form <machine>\<SQL
server>,

Note: DNS issues can result in an SQL Server does not exist or access denied
error. If you get this error, try replacing the machine name with the IP address.
* In the Database Name field, enter the database name your DBA created for the workspace
repository.
* Inthe Integrated Security drop-down, select the integrated security provider interface in use at your
site. Choose:

* Windows Authentication if users connect to the workspace repository through a Windows user
account.
e Server Authentication if users connect to the workspace repository through an SQL Server
login account.
« If you chose Server Authentication, enter the database login name in the User Name field and the
login password in the Password field.

Note: The database user name and login name are typically, but not always, the same. If you
have trouble connecting, it may be because you are specifying the database user name rather
than the login name.

6. Click the Security tab. In the Policies list box, select:

« Simple Security Policy if you want to enforce a workspace security policy that recognizes two
classes of users, master users and ordinary users.

* Three-Group Security Policy if you want to enforce a workspace security policy that recognizes a
third class of users, subject matter experts (SMESs), with special privileges to create, assign, and
delete tags.

7. In the Files access group box on the Security tab, select:

* Direct sources access via Windows share if your site does not restrict Windows access to
workspace source files to the master user.

* Secure sources access Vvia EA file server if your site restricts Windows access to workspace
source files to the master user, while using the optional file server to make the source files available
in the product to ordinary users. Make sure the values for the server name and port number fields
are correct.

f Note: For File Server installation and setup instructions, see the installation guide for your product.

8. Click OK.

Note: If you created the workspace in a hon-shared folder, you are warned to that effect and
prompted to share the folder. After you share the folder, make sure to refresh the workspace path.

You are notified that the workspace was created successfully. Enterprise Analyzer creates a workspace
file (.rwp) and a folder with the same name in the specified location. The workspace folder contains
support files and subfolders for EA output. A project with the same name as the workspace is displayed
in the Repository Browser.

Creating a Workspace Using the Workspace Build Wizard

The Workspace Build Wizard helps you create an Enterprise Analyzer workspace. Stepping through it, you
add your source files, associate files with source types and analyze the files so that they are ready to be
used in Enterprise Analyzer.
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i Note: To use the wizard, you must have SQL Server Express installed on the machine.

Designating Users for Security Policies
When you create a workspace, you choose from two workspace security policies:

e The Simple Security Policy recognizes two classes of users, master users and ordinary users.
e The Three-Group Security Policy recognizes a third class of users, subject matter experts (SMESs), with
special privileges to create, assign, and delete tags.

In each policy, the master user can create new master users.

Designating Users in a Simple Security Policy

A Simple Security Policy recognizes two classes of users, master users and ordinary users. Initially, only
the workspace creator has master user privileges. The master user can designate new master users as
described in this section.

1. Choose Start > All Programs > Micro Focus > Enterprise Analyzer > Enterprise Analyzer
Administration. The Administration window opens.

2. Choose Administer > Edit Users. The Edit Users dialog opens.

3. In the Edit Users dialog, select the workspace (.rwp file) for which you want to edit users and click
Open. The Security dialog opens.

4. The Security dialog displays a list of users who have connected to the workspace in the Known Users
list box and a list of master users in the Master Users list box. Select a known user and click the =
button to move the known user into the list of master users. Select a master user and click the = button
to move the master user into the list of known users.

f Note: Click Refresh at any time to update the lists.

5. To create a new master user, click (New User...) in the Master User list box. A dialog opens prompting
you to enter the name of the new master user. Enter the name and click OK.

6. When you are satisfied with your entries, click Close.

Designating Users in a Three-Group Security Policy

A Three-Group Security Policy recognizes a third class of workspace users in addition to master users and
ordinary users: subject matter experts (SMESs), with special privileges to create, assign, and delete tags.
Initially, only the workspace creator has master user privileges. The master user can designate SMEs and
new master users as described in this section.

1. Choose Start > All Programs > Micro Focus > Enterprise Analyzer > Enterprise Analyzer
Administration. The Administration window opens.

2. Choose Administer > Edit Users. The Edit Users dialog opens.

3. In the Edit Users dialog, select the workspace (.rwp file) for which you want to edit users and click
Open. The Security dialog opens.

4. The Subject Matter Experts and Master Users tabs of the Security dialog display a list of users who
have connected to the workspace in the Known Users list box and a list of subject matter experts and

master users, respectively, in the opposite list box. Select a known user and click the * button to move
the known user into the list of subject matter experts or master users. Select a master user and click the

= button to move the subject matter expert or master user into the list of known users.

f Note: Click Refresh at any time to update the lists.

58 | Enterprise Analyzer



5. To create a new subject matter expert or master user, click (New User...) in the Subject Matter Experts
or Master Users list box. A dialog opens prompting you to enter the name of the new subject matter
expert or master user. Enter the name and click OK.

6. When you are satisfied with your entries, click Close.

Refreshing the Workspace Path

The folder in which you plan to create workspaces must be shared with team members. It's usually more
convenient to share the folder before you create workspaces, but you can do it afterward if necessary, then
refresh the workspace path as described below. You can also use the refresh path feature when you move
a workspace.

i Note: For instructions on how to share a workspace folder, see the installation guide for your product.

1. Click Start > All Programs > Micro Focus > Enterprise Analyzer > Enterprise Analyzer
Administration. The Administration window opens.

2. Click Administer > Refresh Workspace Path. The Select workspace dialog opens.

3. Select the workspace (- rwp file) you want to refresh and click Open. The Workspace directory network
path dialog opens. The Workspace directory network path dialog opens.

4. In the Workspace directory network path dialog, enter the path of the workspace in the text field. The
path must be of the form \machine_name\share_name\workspace_folder_name, where
machine_name is the name of the machine where the shared folder resides, share_name is the value
of the Share name field on the Sharing tab of the Properties dialog for the shared folder, and
workspace_folder_name is the name of the folder for the workspace.

Note: The shared folder is the folder that contains the . rwp file for the workspace, not the
workspace folder. The workspace folder (containing support files and subfolders for EA output)
resides on the same level as the . rwp file.

5. Click OK.

Connecting to a Workspace in Oracle or DB/2

Once a workspace has been created on the Enterprise Analyzer server machine, other users can connect
to the workspace from EA clients. When you connect to a workspace, you create a link file with connection
information that points to the workspace. Because the connection information is already stored in the file,
you don’t have to enter it again when you reopen the workspace connection. Like a workspace file, a link
file has a .rwp extension.

Before connecting to a workspace, you must configure an ODBC data source name (DSN) for the
database that holds the workspace repository you want to link to, as described in the installation guide for
your product. You will need the following DSN configuration information to connect to the workspace:

e The data source name.
* The database schema name your DBA created for the repository you want to link to.
e The database user name and password that give access to the schema.

1. Choose Start > All Programs > Micro Focus > Enterprise Analyzer. The Open Existing workspace
dialog opens above the Enterprise Analyzer main window. Click Cancel to dismiss the dialog.

2. Choose File > Build New Connection. The Define Server Workspace Connection dialog opens.

3. In the Define Server Workspace Connection dialog, select the ODBC driver for the RDBMS in use at
your site in the Database Provider drop-down. In the Required Parameters group box, enter:

« The ODBC data source name you defined at ODBC data source configuration. If you have not
defined a data source name, or want to use a different data source name, click ODBC Manager to
open the data source name configuration dialog, then follow the instructions for ODBC data source
configuration in the installation guide for your product.
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* The database schema name your DBA created for the workspace repository.
« The database user name and password that give access to the schema.

f Note: The Tablespace and Tablespace for Indexes fields are for future use.

4. When you are satisfied with your entries in the Define Server Workspace Connection dialog, click the
Browse button for the Save Link As (.rwp) field. The Save Server Workspace Connectivity dialog
opens.

5. In the Save Server Workspace Connectivity dialog, choose the location for the workspace link in the

Save in drop-down. In the File name field, enter the name of the link. Click Save. The linked workspace
opens in the Enterprise Analyzer main window. EA creates a link file (.rwp) in the specified location.

Connecting to a Workspace in SQL Server

Once a workspace has been created on the Enterprise Analyzer server machine, other users can connect
to the workspace from EA clients.

If you use the local MS SQL connection, you need db_owner permissions, because this type of connection
creates a database. But if you use the left option, MS SQL via OLE DB, you need a database already
created by an administrator. For this database you may have less permissions and the roles can be:
db_writer and db_reader.

To grant permissions, run these queries:

USE mydatabase;

GRANT ALTER TO myuser;
GRANT REFERENCES TO myuser;
GO

ALTER permissions are required when upgrading, or using Configuration Manager in the Administration
tool. ALTER is also needed by the Batch Refresh Process and Code Search.

When you connect to a workspace, you create a link file with connection information that points to the
workspace. Because the connection information is already stored in the file, you don’t have to enter it again
when you reopen the workspace connection. Like a workspace file, a link file has a .rwp extension.

1. Choose Start > All Programs > Micro Focus > Enterprise Analyzer. The Open Existing workspace
dialog opens above the Enterprise Analyzer main window. Click Cancel to dismiss the dialog.

2. Choose File > Build New Connection. The Define Server Workspace Connection dialog opens.
3. In the Define Server Workspace Connection dialog, click the Connection tab. Define the connection:

* Inthe Server field, enter the server name. The server name must be of the form <machine>\<SQL
server>,

Note: DNS issues can result in an SQL Server does not exist or access denied
error. If you get this error, try replacing the machine name with the IP address.
* Inthe Database Name field, enter the database name your DBA created for the workspace
repository.
* Inthe Integrated Security drop-down, select the integrated security provider interface in use at your
site. Choose:

* Windows Authentication if you connect to the workspace repository through a Windows user
account.

* Server Authentication if you connect to the workspace repository through an SQL Server login
account.

» If you chose Server Authentication, enter the database login name in the User Name field and the
login password in the Password field.
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Note: The database user name and login name are typically, but not always, the same. If you
have trouble connecting, it may be because you are specifying the database user name rather
than the login name.

4. When you are satisfied with your entries in the Define Server Workspace Connection dialog, click the
Browse button for the Save Link As (.rwp) field. The Save Server Workspace Connectivity dialog
opens.

5. In the Save Server Workspace Connectivity dialog, choose the location for the workspace link in the
Save in drop-down. In the File name field, enter the name of the link. Click Save. The linked workspace
opens in the Enterprise Analyzer main window. EA creates a link file (.rwp) in the specified location.

Opening a Workspace

The procedure for opening a workspace is the same whether you created the workspace or simply
connected to it. You can also open a workspace by double-clicking it in the file system. You don’t have to
close a workspace before opening another workspace.

1. Choose Start > All Programs > Micro Focus > Enterprise Analyzer. The Open Existing workspace
dialog opens above the Enterprise Analyzer main window.

y Note: If Enterprise Analyzer is already open, choose File > Open Workspace.

2. Click the tab you want to work in:

* In the Existing tab, choose the drive and folder for the workspace you want to open. A list of
workspaces in the selected folder is displayed in the righthand pane. Double-click the workspace you
want to open, or select it and click OK.

* In the Recent tab, double-click the recently opened workspace you want to open, or select it and
click OK.

Note: If you created the workspace in a previous release of Enterprise Analyzer, the system
prompts you to upgrade the workspace to the new release. Click Yes.

The workspace is displayed in the Enterprise Analyzer window. If a workspace was already open in the
window, the selected workspace replaces it.

Registering Source Files

Before you can analyze application source files in Enterprise Analyzer, you need to load, or register, the
source files in a workspace.

i Note: In a multiuser environment, only a master user can register source files.

EA registers sources files in-place from the location they are selected rather than creating copies of the
files in the workspace folder. These are the files you view and edit in the EA tools.

Note: Workspaces that were created without in-place registration and upgraded from previous
versions will continue to create copies of the files in the Sources folder for the workspace when
registering new files.

Source files must have recognized DOS file extensions before they can be registered. You can view and
add to the recognized extensions in the Workspace Registration options window. Files without extensions
are checked for content, and if the content is recognized, the files are registered with appropriate
extensions appended.

EA assumes that input source files are ASCII files in DOS format. Occasionally, files may be converted
incorrectly from other formats to DOS-based ASCII with an extra special character (like “M”) at the end of
each line. While Enterprise Analyzer accepts these files as input, some EA tools may not work correctly
with them. Make sure all source files are in valid ASCII format.

You can register source files in compressed formats (ZIP or RAR), as well as uncompressed formats.
Enterprise Analyzer automatically unpacks the compressed file and registers its contents.
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Note: EA extracts compressed source files using the command line syntax for archiver versions most
widely in use. If you use newer archiver versions, specify the command line syntax in the Archivers
tab of the User Preferences window.

Workspace Registration options determine registration behavior. The default values for these options are
preset based on your configuration and should be appropriate for most installations.

1. In the Repository Browser, create a project for the source files you want to register, or use the default
project. To create a project, choose Project > New Project. The Create Project dialog opens. Enter the
name of the new project and click OK. The new project is displayed in the Repository Browser.

2. Select the project in the Repository Browser, then copy-and-paste ( Ctrl+C and Ctrl+V) or drag-and-
drop (if UAC is disabled) the file or folder for the source files you want to register onto the Repository
Browser. You are notified that you have registered the files successfully and are prompted to verify the
files. Click Close. The Repository Browser displays the contents of the new workspace either by folder,
or by type, depending on the tab you have selected - Folders or Types. The former displays the
contents of the repository in the same folder structure as the one they have on the host environment,
the latter displays them by object type.

Note: For non-inplace registration workspaces, when updating or adding new sources through the
EA main window, the files or folders being registered will be included into the selected folder in the
Folders view. Registration into the Types view will copy the selected files and folders directly to the
root Sources folder, i.e. they will not be copied into any other existing folders. If you are registering
files or folders in Folders view, make sure you've selected in the tree the exact folder in which you
want them to be registered. If you haven't selected any folder, they will be copied into the root
Sources folder.

/1. Important: Before registering your source files, you must create a folder structure that replicates
~*~ the original. This helps to avoid errors when you work with homonyms. Micro Focus recommends
putting each application in a separate folder, putting system files that are common for more than
one application in one directory. After you do that, register your sources by selecting the folders

and including them in the project as described in step 2.

y Note: In the notification dialog, select Never ask again if you do not want to be prompted to verify
files. On the Environment tab of the User Preferences window, select Ask user about verification
if you want to be prompted again.

Host Environment Source Compatibility

When you register your source files, it is essential that they are organized in the same folder structure as
the one on your host environment. This allows EA to create the correct relationships when connecting
programs with their copybooks, JCLs with the proper version of the procedures that are used, etc. Run-
time connections are also established based on this structure. Furthermore, this structure allows for having
several members with the same name, i.e. homonyms.

The sources to be loaded into EA should be in folders named after the PDS libraries on the Mainframe and
those folders should be the ones loaded.

Example

There is an enterprise organization with 3 data centers: Data Center 1 with one Mainframe, Data Center 2
with two Mainframes, and Data Center 3 with one Mainframe.

The following image shows the folders in a Windows environment:
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Organize = Include in library = Share with Burn MNew folder

F

| Folder support Doc
| Data Center 1
| DC1 Mainframe 1
| Appl - Accounting
| DC1.PROD.APP.CARDLIB
| DC1.PROD.COMMON.PROCLIB —
| DC1APP1.PROD.COPYLIB
| DCl1APP1.PROD.JCLLIB
| DClAPP1.PROD.INCLIB
| PROD.APP.APP.2.COBOL
| PROD.APP.APP.2.LINKCARD
| PROD.APP1.APP.2.ASSEM
. PROD.CTLCDPDS =i
. SYS1.COPYLIB
| Data Center 2

MName

! Data Center 1
. Data Center 2
| Data Center 3

1

| Main Frame 1
| Accounting
| PROD.ACCT.AP2.COBOL
| PROD.ACCT.APZLINKCARD
| PROD.ACCTAPZMAP
| PROD.IMSIMSAP2.PSB

And this is what the three data center folders look like after they have been copied to the workspace:
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Resolving Include Files

When trying to resolve include files (copybooks, PL/I includes, JCL procedures, and so on), the EA parser
uses different search methods that you can set in the Homonyms tab in Project Options. The three
methods are described below:

Search all, use If you choose this option, the parser will look at all folders trying to find names that

the provided match the included file. If only one match is found, it will use that file. If more than one
paths as match is found, the parser will take the following steps to resolve which of the matching
preference include files is the one to use:

1. It will check if one of the folders is listed under Search Path in the Homonyms tab in
Project Options. The folder should be listed as the full path to the registered
sources. It could be local or shared, for example:

¢ Jocal:
C:\Sources\Data Center 1\DC1l Mainframe 1\SYS1.COPYLIB
* shared:

\\server\Sources\Data Center 1\DC1l Mainframe 1\SYS1.COPYLIB
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2. It will look for proximity of the included file to the including file in the source folder
structure. First, it will check the files that are in the same folder as the "including”
source, then the files in the dependent folder, and then up the folder hierarchy.

3. Finally, folder names will be matched and the "include" folder that has a name with a
better match to the source folder name will be selected.

Search only in  When this option is selected, only the paths specified in the Search Path list will be used

the provided as locations for looking for include files. As this option works on project level, you can

paths configure each subsystem or application in a separate project, and then specify the
copybook locations for each project. This option is useful when the number of
applications/subsystem is not too big.

Search in This option might help when there is a large number of applications/subsystems. It lets

common you use the folder structure in the file system to define the boundaries between

location and subsystems and to restrict retrieval of include files based on the physical folder

only the same structure. If you choose it, you can put all the sources in a single project and avoiding

subsystem the need to add a list of folders to search in. If you choose this option, you need to
specify the following two paths:

Common folder All common libraries need to be located inside the same root
folder, for example, C:\Sources\Common. Files in folders located
here will be "visible" to all programs being analyzed.

Subsystems All subsystems need to have a common root folder, for example,

root level C:\Sources\Subsystems. If you have two subsystems in this
folder, one of them will not get copybooks from the other and vice
versa, but they can both get copybooks from the common libraries
folder specified in the Common folder field.

Note: The subsystems root level selection is checked first and then the common
folder.

Note: For COBOL only, if there is a registered homonym (copybook) in the program's folder it will be
used in preference to the homonym search configuration.

Resolving Program-to-Program Calls

When resolving call relationships between programs, it is possible to reach a point where there is more
than one candidate for a called program. In this case EA works the same way as with includes (see
Resolving Include Files), but since the program objects themselves don't have folders, the folders of the
source files that generated them are used.

Note: This same algorithm applies to any relations between non-legacy entities (e.g. PROGRAM
reads TABLE, TRANSACTION starts PROGRAM, etc.).

Resolving Control Cards

Control cards can be any members explicitly mentioned in the JCL. When parsing JCLs, EA will look for a
file with the member name in the JCL in a folder with a name matching the PDS name from the mainframe.

Resolving JCL Procedures

When looking for JCL procedures, the parser uses the JCLLIB statement, if present. If there is only one
copy of the searched procedure, that copy is used. Otherwise, if more than one copy is available, the
libraries specified with the JCLLIB statement are used to pick the right one.
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Example:

Path to the JCL file: <workspace_path>\Sources\APP1\MYJCL\MYJOB.JCL

//MYJOB1  JOB S
//NMYLIBS1 JCLLIB ORDER=CAMPBEL .PROCS.JCL
//51 EXEC PROC=MYPROC1

In this case the procedure <workspace_path>\Sources
\APP1\CAMPBEL . PROCS . JCL\MYPROC1, if present, will be used.

Refreshing Registered Source Paths

The Refresh Registered Source Paths feature enables you to change the location of registered source files.
It is useful in cases when the sources have been moved to another location, or a folder that contains
sources has been moved or renamed, or sources were registered from a non-shared location, and the
location has since been shared.

To use this feature:

1.
2. From the Administer menu, click Refresh Registered Source Paths.

3.

4. Click OK. The Change Registered Source Paths window opens. It displays the registered source

Open Enterprise Analyzer Administration.

Choose a workspace from the list in the Select Workspace window.

paths and lets you select the new source paths.

You can choose whether to hide or display system paths in the list of source paths by toggling the Hide
System Paths check box.

Click the yellow folder icon 1 under New Source Path.
Choose the new directory of the source files and click Select Folder. The selected path and a red cross
icon # appear under New Source Path.

y Note: Clicking # removes the selected path.

Click Change. A message asking you if you are sure you want to change the registered source paths
comes up.

Click OK. You are notified that the paths have been refreshed.

Click OK. The Change Registered Source Paths window closes.

Note: Alternatively, you can change the registered source paths from Source Synchronization. See
Source Synchronization for more information.

After changing the registered source paths, a file must be verified again for a Logic Analyzer
extraction to work correctly.

Queue Processor

There are various ways to set parameters for the Queue Processor.

To launch the Queue Processor

1.
2.

Start EA Administration.
Open Administer > Launch Queue Processor or press F7.

The Launch Queue Processor window opens.

In the Serve workspace field type the name of the workspace you want to use or press the ... button to
browse for a workspace.

Check the Processing Mode - Conversion, Verification or both.

Choose the number of processors to start . The number depends on your system capabilities.

66 | Enterprise Analyzer



6. Check Produce Log File if you want to produce a log file and then click OK to start the verification or
Cancel to quit.

Check Workspace Queue

Check workspace Queue displays the queued processes that are waiting in queue for the current
workspace. To view them:

1. Open Start > All Programs > Micro Focus > Enterprise Analyzer > Enterprise Analyzer
Administration.

2. Select Tools > Check Workspace Queue. The Select workspace window opens.

3. Select a workspace file (- rwp) and click Open. A message with the number of queued records is
displayed.

Manage Queue

1. Click Start > All Programs > Micro Focus > Enterprise Analyzer > Enterprise Analyzer
Administration to start the Enterprise Analyzer Administration. Manage Queue shows the processes
that are waiting to be processed. After the Queue processor has finished the list is automatically
cleared.

2. Click Tools > Manage Queue. The Manage Queue window opens.

It contains a list of all processes waiting to be processed by the Queue Processor. The available actions
are:

¢ File > Close - closes the window.

* Record > Delete - if you delete an item from the list it remains unverified and you must re-verify the
sources again.

* Record > Unlock - unlocks records that are locked due to some verification error.

* Record > Select All - selects all records from the queue list.

* Record > Unselect All - deselects all records from the queue.

* Queue > Refresh - refreshes the queue list.

* Queue > Show All - shows all records for the queued processes.

¢ Queue > Auto Refresh - automatically refreshes the list.

Verifying Source Files

Parsing, or verifying, an application source file generates the object model for the file. Only a master user
can verify source files.

You can verify a single file, a group of files, all the files in a folder, or all the files in a project. It's usually
best to verify an entire project. Enterprise Analyzer parses the files in appropriate order, taking account of
likely dependencies between file types.

Note: You need not verify copybooks. Copybooks are parsed when the including source file is
verified.

If your RPG or AS/400 COBOL application uses copy statements that reference Database Description
or Device Description files, or if your MCP Cobol application uses copy statements that reference
DMSII DASDL files, you need to generate copybooks for the application before you verify program
files.

Workspace and Project Verification options determine verification behavior. The default values for these
options are preset based on your configuration and should be appropriate for most installations.

1. In the Repository Browser, select the project, folder, or files you want to verify and choose Prepare >
Verify.

2. You are prompted to drop repository indexes to improve verification performance. Click Yes. You will be
prompted to restore the indexes when you analyze the files.
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The parser builds an object model for each successfully verified file. For an unsuccessfully verified file, the
parser builds an object model for as much of the file as it understands.

How Verification Results Are Indicated

If you have not verified a workspace file, the file is displayed in the Repository pane in bold type. Since the
system has not generated an object model of the file’s contents, only the file itself is displayed.

A verified file shows all the objects in the model generated for the file. Verification results are denoted as
follows:

* Ablue dot @ means that the parser has verified the file successfully.
* Ared dot ® means that the parser has encountered an error in the file.

* Avyellow dot @ means that the parser has encountered an error in the file, but that the file has been
successfully verified under the relaxed parsing option.

Note: When you edit a file, the modified file and any dependent files are invalidated, and need to be
verified again. You can learn more about how objects are invalidated and how the system refreshes
the repository in Preparing Projects in the product documentation set.

Quick Inventory

Quick Inventory is a project related option that automatically registers and verifies referenced files using
JCL or PCT files as a starting point. Start by enabling and configuring Quick Inventory, register the JCL or
PCT files to be used as the starting points, then verify those files. If you have set all paths correctly, the
product will register and verify the external files. Enterprise Analyzer finds its dependencies registers them
in the project, and verifies them.

To enable Quick Inventory:

1. In Enterprise Analyzer open Options > Project Options.
2. On the Quick Inventory tab check Enable Quick Inventory and click Apply.

Quick Inventory first searches the workspace and if the files are not found there you need to specify the
directory where your sources are located. There is a list of pre-defined source types that are supported by
Enterprise Analyzer.

To edit, add, delete or select a search path where you want the Quick Inventory to look for sources:
1. In Enterprise Analyzer open Options > Project Options.

Click the Quick Inventory tab.
2. There is a list with pre-defined search paths suggestions with the names of the object types most
commonly used. Select a suggestion, right-click the selected suggestion and then click Edit.

a. Enter the search path to the sources. For example: COBOL = c:\Sources
\COBOL_Applications_Directory.

i Note: Make sure you enter the correct path. Otherwise EA is not able to find the sources.

b. Press Enter, then check the search path to select it and click Apply.

3. If the sources are located in more than one directory (for example if you need to search in more than
one COBOL directory outside the workspace), you have to add another entry to the Search Path list.
Right-click in the list of suggested directories and then click Add. A new item is created in the list. Enter
the values you need. For example: COBOL = C:\Sources\COBOL_Applications_Directory_ 1.

Add a new entry for each separate directory you need to search.
4. To delete an entry select it and right-click on it, then click Delete.

5. Click OK to save the changes, or Cancel to undo them and get back to the main Enterprise Analyzer
window.
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Using the Enterprise Analyzer Main Window

The Enterprise Analyzer main window lets you view and edit projects, set product options, and open EA
tools. The window’s state is saved across sessions.

Open a pane in the main window by selecting the appropriate choice in the View menu. Resize a pane by
using the mouse to grab its border with another pane, called a splitter, and dragging it to a new location.
Close a pane by clicking the %/ button in the upper right corner.

When you start Enterprise Analyzer for the first time, the main window displays the following panes:
Repository Browser, Getting Started, Chart Viewer and Activity Log.

The Getting Started pane gives you basic information about some of the main features and provides quick
access to them.

The other panes are described in the topics below.

Menus

Enterprise Analyzer menus let you access Enterprise Analyzer tools and other product functionality. Menus
are displayed only for the products you have enabled in the Configuration Manager. The table below shows
the relationship between products and menus.

Note: The screens shown in the product documentation set display the menu bar with all products
installed.

Most Enterprise Analyzer menu choices have equivalent choices in the right-click menu. Menu selections
for panes in the main window are available only if the pane has the focus.

Product Menu

Enterprise Analyzer Analyze

Enterprise View Profile

Business Rule Manager Extract
Toolbars

You can access a Enterprise Analyzer menu function by clicking its tool bar icon. The tool tip for an icon
tells you what it does. Place your cursor over the icon for a moment. The tool tip will display.

A tool bar is displayed only if its corresponding menu is displayed. You can change the position of a tool bar
by grabbing the delimiter at the left of the tool bar and dragging it to a new location.

Project Filtering

Filter the projects in the repository browser to see only the one(s) that you want to work with. The Project
filter field is on the toolbar. Enter the name of the project you want to see in the Project filter and all other
project will be hidden. The filter string is saved when closing and reopening the workspace. To clear the
filter, delete the text in the input box and press Enter.

Use wildcards and regular expressions to refine the project filtering.

y Note: An asterisk wildcard is assumed at the end of the filter name.

Example

If you have 5 projects named Project 1 through Project 5 and enter Project [1-3] in the
project filter, only Project 1, Project 2, and Project 3 will be shown in the browser. If no
projects match the filter, the Browser will be empty.
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Using the Repository Browser Pane

The Repository Browser pane shows the contents of the repository for the current workspace. It has two
tabs:

Folders Displays the contents of the repository in the same folder structure as the one they have in the
host environment. This allows for elements with the same name (homonyms) to be loaded and
displayed.

Types Displays the contents of the repository by project, object type, and object relationship.

Each of the two tabs consists of the following elements:

Browser Shows the objects in the repository of the current workspace in a tree structure. Depending on
the tab you have selected in the Repository Browser pane, the contents are displayed either by
type or by folder.

Search Lets you execute various searches in the repository of the current workspace.

In the Repository Browser window, hover your cursor over an object to display a tooltip that describes the
object in more detail.

Note: The Repository Browser pane displays automatically when you launch Enterprise Analyzer. If
you close it, you can reopen it by clicking View > Repository.

Using the Search Assistant

The Search Assistant is integrated in the Repository pane. It searches all sources in the current
workspace. The results are displayed in a tree in the browser window, either by type or by folder,
depending on the tab you have selected in the Repository pane - Folders or Types. The information in the
tree is grouped in three levels:

* Project level - shows the projects that contain the objects.

« Folder level - shows the relative folder structure. If there is more than one folder level, they are grouped
and displayed with slashes - Folderl/Folder2/Folder3(n). The number in brackets indicates the
number of search result objects in the folder.

« Object level - shows the objects that are the result of the search.

y Note: For information about customizing the search options, see Configuring the Search Assistant.

To use the Search Assistant:

1. fFl
Type in a search string in the search box and click |_" The search returns all workspace objects

whose names match the search criteria.
2. Drill down the tree to see the relationship types and available methods for the objects.
3. Double-click an object in the search result tree to see its source code.

Note: To see the source code of a declaration, double-click it or right-click and select Go To
Source.
4. Right-click the search result objects in the Browser to see the list of available context-sensitive actions
for the selected objects.

Note: Not all of the context menu options available in the Repository Browser are available in the
search results tree.

f Note: Multiselect is also available for the items in the search result tree.

To reset a search or change the search criteria in the search field:

L Click Close X in the left corner of the search field.
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The search is reset and the last Repository Browser view you used is displayed.

Enterprise Analyzer keeps a history of the searches you have done so when you start typing a search
string, it lets you select from a list of search strings you have previously used that begin with the same
characters as the ones you have typed.

Customizing the Search Assistant

You can customize the Search Assistant to suit your needs by setting some options in the Workspace
Options and User Preferences that you can access from the Options menu.

Setting Search Assistant options in the Workspace Options
There are two options that you can set in Options > Workspace Options > Search Assistant:

¢ Maximum number of results to display. The default is 10,000.

» Timeout for displaying a complete set of results. It is configured in seconds and the default is 60
seconds.

Setting Search Assistant options in the User Preferences
From the Search Assistant tab in Options > User Preferences you can set the following options:

« Select the type of the objects that will be shown in the search results. The available types are: all legacy,
system program, program entry point, data store, table, transaction and ADABAS file.

« Include hypercode objects. Depending on the source type, you can select different types of hypercode
entities. The table below displays the available source code types and their corresponding hypercode
objects.

Source type Hypercode entity
COBOL file » Declaration
e Paragraph
e Variable
JCL file Data set
Natural file « Declaration
» Variable
PL/ file » Declaration
e Variable
RPG file

» Declaration
* Variable

By default, declaration is selected for COBOL, Natural and PL/I files.

Using the Browser

The Browser displays the sources in the repository of the current workspace, organized in a tree.
Depending on the tab you have selected in the Repository pane, the contents are displayed either by type
or by folder. Switch between them to browse the repository in different ways.

« Type view - shows the object model for the workspace, organized in a tree form by project, object type,
and object relationship.

« Folder view - shows the sources in the tree in the same folder structure as the one they have in the host
environment.
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Note: When you work with homonyms, you will see a number in parentheses after the name of the
object if there is more than one instance of it.

Selecting Objects

Select an object in the Browser by clicking it with the left mouse button. You can select all, select multiple,
or type-ahead select.

Use the Select choices in the Edit menu to select objects based on their verification status. The choices
operate on the entire list in the Search tab and on the objects under the selected workspace, project, or
folder in the Browser.

The Project drop-down displays the current project. You can navigate quickly to another project in the
Browser by clicking the project name in the drop-down.

f Note: In the Folders view, you can use mutliselect for objects in different folders on the same level.
You cannot use multiselect for child and parent nodes.

You cannot use multiselect across projects.

Selecting All

To select all the objects in the tree or all the objects in the selected node, choose Edit > Select All. To
deselect the objects, choose Edit > Unselect All.

Selecting Multiple

To select a range of objects, hold down the Shift key, click the first object in the range, then click the last
object in the range. To select objects that are not in a range, hold down the Control key, then click each
object you want to select.

Using the Type-Ahead Select Functions

Use the simple type-ahead select function to select displayed objects as you type. To use the simple
function, make sure the Browser tab is current, then type the characters you want to match.

i Note: You cannot use the simple type-ahead select function in the Search tab.

Use the advanced type ahead select function to select objects in the Browser or Search tab whether or not

they are currently displayed. To use the advanced function, click an object that has the same type as the
A

-
button next to the * button at the bottom of the Repository

-

object you want to select, then click the

pane (or if the filter subtree function is enabled, next to the ? button). From the drop-down menu, choose:

* Select to match text explicitly.
* Wildcard Select to match text using wildcard patterns.

A

-
Enter the text you want to match in the field next to the * button. The tool selects matched objects as
A

-
you type, as long as they are in the same subtree. Click the * button to repeat the select with the same
criterion.

A
-+
To select multiple objects, enter the text you want to match in the field next to the * button, then click the

-

adjacent button. From the drop-down menu, choose:

» Select All to select multiple objects that match text explicitly.
* Wildcard Select All to select multiple objects that match text using wildcard patterns.
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A
-
The tool selects matched objects as long as they are in the same subtree. Click the * button to repeat
the select with the same criterion.

Expanding Subtrees

Click the # symbol next to an item to expand its subtree one level. Click the =/ symbol to collapse the
subtree one level.

In the Repository Browser, select an item and choose Expand Subtree in the right-click menu to expand
all its subtree levels in a single step. Select an item and choose Save Subtree in the right-click menu to
export the label text for expanded subtree levels to a text file.

Note: For subtrees with a great many objects, you can improve browser display performance by
filtering the subtree and/or by lowering the fetch buffer size in the General tab of the Workspace
Options window.

Filtering Subtrees

For a subtree with a great many objects, you can improve browser display performance by showing only
objects of interest in the subtree. To filter out objects from a subtree, select the subtree, then enter the text

you want to match in the field next to the ? button at the bottom of the Repository pane (or if the type-
A

-
ahead select function is enabled, next to the < button). Click the adjacent '™ button and choose Filter
from the drop-down menu.

The tool filters out unmatched objects from the subtree, and places a ¥ symbol next to the subtree in the
browser display. The filter and filter text are persistent for the subtree across sessions. To remove the filter
and its text, enter an empty string in the text field and choose Filter again.

Refreshing the Browser

In a multiuser environment, you need to refresh the browser after another user adds, deletes, or modifies a
workspace file. Choose View > Refresh Browser to refresh the browser.

Viewing the Entire Workspace

By default, the Browser tab displays repository trees for projects only. These trees show only objects you

can act on in the browser. To view all the objects in the workspace, choose View > Entire Workspace, or
select (none) in the Project drop-down. Choose View > Entire Workspace again, or select a project in

the Project drop-down, to display the project only.

Performing a Text Search in the Repository

The Find functionality lets you do a plain text search in the repository files. The results are displayed in the
Found Results tab in the Repository Browser. You can select to view the results by folder structure or
object types. Drilling down the results tree, you can see the object name as well as the specific line of code
where the searched text is.

To use this functionality, go to Search > Find, type a text and click Find All.

Before you click Find All, you can select various options such as skipping comments from the search or
matching the whole words and/or the case of the searched text. You can also specify the search mode, i.e.
whether to search for plain text, regular expressions and wildcards.

If you want to further specify your search, click Advanced Find. Here you can select the type of objects in
which to search depending on their parse status: unverified, verified with errors, verified with relaxed parser
and verified successfully. You can also specify the scope of the search (workspace or selection), the project
where to search and an object name.
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You can additionally customize the text search functionality from Options > Workspace Options > Find
Options. In this tab you can set the following options:

e Maximum number of results to display. The default is 10,000.
» Font style of the results: regular (default), bold, italic, strikeout or underline.

« Edge Color - lets you select the color in which the searched text appears in the results. The default color
is red.

Using Wildcard Patterns in Searches

In most searches you perform in the EA tools, you can use wildcard patterns allowed in LIKE statements by
Visual Basic for Applications (VBA). The table below shows the wildcard characters and what they match.

Character Matches

? Any single character.

* Zero or more characters.

# Any single digit (0-9).

[charlist] Any single character in charlist.
[lcharlist] Any single character not in charlist.

To match the special characters left bracket ([), question mark (?), number sign (#), and asterisk (*),
enclose them in brackets. The right bracket (]) cannot be used within a group to match itself, but it can be
used outside a group as an individual character.

Specify a range of characters in a charlist by using a hyphen (-) to separate the upper and lower bounds of
the range. [A-Z], for example, results in a match if the corresponding character position in a string contains
any uppercase letters in the range A—Z. You can specify multiple ranges in brackets without delimiters.

Finding and Replacing Text in Source Files

To find and replace text in the Editor:

1. In the Repository Browser, double-click a source file. The file opens in the Editor.
2. Right-click and select Find or click Edit > Find The Find and Replace dialog opens.

3. Click the tab for the operation you want to perform.
The find functionality in the Find tab is bidirectional. You can search up or down, and specify if you want
the search to wrap as well as match the whole word or the case. The find functionality in the Replace
tab is unidirectional. From both tabs you can specify the search mode, i.e. whether to search for plain
text, regular expressions and wildcards.

f Note: The remaining steps assume that you want to both search and replace.

4. In the Find What box, type the search criterion. Check the necessary check boxes.

5. In the Replace With box, select the replacement text. You can select text strings from previous replace
operations or type a new replacement text. If you have selected to search for regular expressions, click

the * button next to the box to display a list of elements you can insert in the replacement text field.

6. Click Find Next. When the search finds a match, click Replace. Click Find Next again to find the next
match, or click Replace All to replace all matching text.

Using the Editor and Viewer

The Editor lets you view and edit the source code for a file. The Viewer lets you view renderings of logical
objects like screens and transformation target models. Double-click a file in the Repository pane to view it
in the Editor or Viewer. Choose File > Recent Sources to open a file from a list of recently opened files.
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Editing Source

Edit file source as you would text in a word processor (cut-and-paste, drag-and-drop, undo, and so forth).
Click File > Save to save your changes. Edits are saved in the copy of the file maintained in the
\Workspace\Source subfolder.

Note: When you edit a file, the modified file and any dependent files are invalidated, and need to be
verified again. Only a master user can edit and verify source in a multiuser environment.

Finding and Replacing Source in a Selection

To find and replace source in a selection of text, select the text, then follow the instructions for the source
file find and replace function.

Viewing a List of Errors
For a source files with errors or warnings, right-click in the Editor and choose:

* Errors > View Errors from the popup menu to list the errors and warnings in a separate pane below the
Editor. Choose Edit > Errors > View Errors again to hide the pane.

« Errors > Next Error from the popup menu to navigate to the offending source code for the next error in
the list.

* Errors > Previous Error to navigate to the offending source code for the previous error in the list.
* Errors > Severity Filter from the popup menu to filter the list by severity.

i Note: You can set a severity filter for all your workspaces in the Editor User Preferences.

* Errors > Copy Errors in the pop-up menu to copy the list of errors and warnings to the clipboard.

To hide the Editor and show only the list of errors and warnings for the selected file, right-click in the
Repository pane and choose Show Errors in the pop-up menu. Double-click the source file in the
Repository pane to show the Editor again.

Commenting Out Source

To comment out a block of source, select the block and choose Edit > Comment Block. To uncomment
the block, select it and choose Edit > Uncomment Block.

Printing Source

To print the source for a file, choose File > Print.

Setting Editor User Preferences

Use the Editor tab of the User Preferences window to specify the display characteristics of the Editor.

1. Choose Tools > User Preferences. The User Preferences window opens. Click the Editor tab.
2. In the Font drop-down, select the display font for source code.

3. Select the Colorize Text check box if you want to use a color scheme to identify source elements, then
specify the color of each source element.

4. In the Show Errors pane, select the check box for each type of error you want to show in the error list.

Specifying the Color of ltems

You use a standard Windows color control to specify a color scheme for source elements and other items.
Use the Palette tab to select a color from the Windows palette. Use the System tab to match the color of a
standard Windows element. Depending on the element, you can specify the foreground color, background
color, and/or font color.
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Using the Chart Viewer

The Chart Viewer in the main window lets you view information about the objects in the workspace in the
form of various charts. You can choose between two types of views: Interactive Chart View, which is the
default one, and Report Chart View.

To switch between the two views, use the drop-down list at the top of the Chart Viewer.

To change the default chart view, go to Options > User Preferences > Environment > Chart Viewer and
select a new default view from the drop-down list. Note that there is also an option letting you choose
whether to have the Chart Viewer displayed when you start EA or not.

i Note: To open Chart Viewer when it's not displayed in the main window, go to View > Chart Viewer.

|
To refresh the charts, click .

Interactive Chart View

The Interactive Chart View provides information about the objects in the workspace in the form of
interactive charts. Clicking the charts lets you drill down and access more detailed information in the form

of charts and tables. To drill back up, click @

Right-clicking in the tables lets you select from a number of options: edit, copy or delete objects, include in
or exclude from the project, assign tags, view properties. You can also choose to have the files shown in
the Repository Browser pane or to open Interactive Analysis. The last option in the context menu, Query
Repository, lets you view additional information about the object such as: dependent or used sources,
direct references and what the legacy source is.

There are four main pie charts:

* Object Types - a pie chart representation of the types of objects and their number. Clicking on any
segment opens the Average Lines of Code chart which is a representation of all objects of the
selected type grouped by the number of lines of code. Clicking on a segment in this chart displays a
table with a list of all objects that fit into this segment as well as information about them such as: type,
source name, source path and lines of code.

e Cyclomatic Complexity - presents the cyclomatic complexity index for programs of all types. Clicking
on a segment in this chart displays a list of programs that fit the selected cyclomatic complexity index
boundary. The list is presented in a table containing information such as: type, program name,
cyclomatic complexity, maintainability index and legacy name.

« Average Modifications - represents the objects that have been modified grouped by the number of
modifications. Clicking on a segment drills down to the Object Types chart. Clicking further opens a
table with information about object type, source name and source path.

* Average Modification Date - represents the number of files of all types that have been modified within
specific time periods. Clicking on a segment drills down to the Object Types chart. Clicking further
opens a table with information about object type, source name and source path.

Report Chart View

The Report Chart View displays information about the objects in the workspace in three charts: Object
Types, Inventory Report and Complexity Report.

The Object Types is a pie chart representation of the types of objects and their number.

The Inventory Report Chart shows the number of objects that are verified, unverified, erroneous and
relaxed, grouped by type.

The Complexity Report chart provides additional information about the various types of objects such as
number of source lines, lines with comments, blank lines and include statements.
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Using the Object Information Pane

The Object Information pane displays comments you have entered for an object. Select an object in the
Repository pane and choose View > Object Information to show the Object Information pane.

Enter comments for an object by selecting the object in the Repository pane and choosing Properties in
the right-click menu. In the Description tab, enter your comment in the text area and click OK.

Note: You cannot use this method to enter comments for a workspace (that is, when an entire
workspace is displayed in the Repository Browser). Use the General tab of the Workspace Options
window to enter comments for a workspace.

Viewing Object Properties

The properties of an object describe its characteristics: its language, complexity metrics, relationships, and
the like. Select an object in the Repository pane and choose View > Properties to display a set of tabs
with object properties. The table below describes the tabs in the Properties window.

Note: In other EA tools, use the right-click menu or the View menu to display the properties of the
selected object.

Tab Description

Description Displays comments you have entered for the object.

General Displays the name and other general information for the object.

Internal Displays verification option settings and other internal information for
the object.

System Displays system information for the object.

Statistic Displays the complexity metrics for the object and their values.

Relationships Displays the relationships of the object. Only the first relationship level
is shown but if you want to explore a particular branch you can do it by
double-clicking the object. Select Restricted to the current project
to restrict relationships to those in the current project. Select
Workspace wide to show all the relationships of the object in the
workspace.

Object Tags Displays the tags assigned to the object.

Viewing Inventory Reports

Inventory Reports give high-level statistics for source file types in the current workspace: number of files of
each type, whether verified, number of lines of source code (verified files only), and the like. To generate an
Inventory Report, choose Reports > Inventory Report . The table below describes the columns in the
Inventory Report.

Column Description

Type The source file type.

Source Lines The number of physical source code lines in the source text files
(including blank lines and comments).

Quantity The number of source files of the specified type.

Unverified The number of source files of the specified type for which verification

was not attempted or for which verification failed completely .

Note: Copybooks do not need to be verified. Copybooks are
parsed when the including source file is verified.

Verified The number of successfully verified source files of the specified type.
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Column Description

Erroneous The number of unsuccessfully verified source files of the specified
type.

Relaxed The number of source files of the specified type that were verified
despite errors, under the relaxed parsing option.

Missing The number of missing support files (copybooks, JCL procedures, and
the like).

Note: The workspace might have more copybooks or include files than the projects because some
default system copybooks may be included automatically to support specific environments or dialects.

Viewing Key Object Relationships with Query Repository

The Query Repository feature lets you home in on key relationships of an object: all the programs that call
another program, or all the programs that update a data store, for example. From the results, you can
launch further queries without having to return to the Repository Browser. You can create printable
relationship reports and export them to a variety of standard formats.

1. In the Repository pane, select the workspace, project, folder, files, or objects you want to view
relationships for and choose Query Repository > <Relationship> in the right-click menu. The Query
Repository results pane opens over the Editor/Viewer.

2. To launch a query from the results, select one or more objects in the right-hand column and choose
Query Repository > <Relationship> in the right-click menu.

Using the Activity Log

The Activity Log is a chronological record of your activities in the current session. Choose View > Activity
Log to show the Activity Log pane.

Viewing Errors

If the parser generated errors or warnings for a file, double-click the Activity Log entry for the file or select
the entry and choose Expand in the right-click menu to show a list of the errors and/or warnings. Double-
click a message to navigate to the offending source in the Editor. Choose Collapse in the right-click menu
to collapse the list.

Viewing History

To view Activity Log entries across sessions, choose History in the right-click menu. Click a date to view
the session log. To clear the session log, right-click in the log and choose Clear Log in the pop-up menu.
To clear a log entry, select the entry and choose Delete in the right-click menu.

Copying Records

To copy Activity Log records to the clipboard, select the records and choose Copy in the right-click menu.

Generating Reports

To generate a report from the Activity Log, right-click in the log and choose Report in the pop-up menu.

Clearing the Log

To clear the Activity Log, right-click in the log and choose Clear Log in the pop-up menu. To clear a log
entry, select the entry and choose Delete in the right-click menu.
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Hiding a Column

To hide a column in the Activity Log, right-click in the log and deselect the column name in the Columns
choice in the pop-up menu. Select the column name to show the column again.

Creating a To Do List

Ato do list is a record of tasks you need to perform before completing your project. You can create a to do
list for a workspace, project, folder, source file, or extracted object.

1. In the Repository Browser, select a workspace, project, folder, source file, or generated object and
choose View > ToDo List. The ToDo List window opens.

2. If you selected:

* A workspace, project, or folder, choose Edit > Add to enter a task for the item and all the items it
contains. Otherwise, choose Add forltem to enter a task for the workspace, project, or folder only.

¢ A source file or generated object, choose Edit > Add to enter a task for the item.

3. The New Properties dialog opens. In the Subject field, enter the name of the task. In the Content field,
enter a description of the task. Click OK. The task is listed in the ToDo List window.

Viewing a To Do List

To view the to do list for an item, select the item in the Repository Browser and choose View > ToDo List.
Use the options in the ToDo List window Edit menu to mark a task as done, delete a task, or view its
properties. You can generate a report from a to do list by choosing File > Report.

Using Tool Windows

When you open a Enterprise Analyzer tool, the window for the tool appears above the product main
window. Simply move the tool window if you want to work in the main window again. A tool window's state
is saved across sessions. Close a tool window by clicking the %I button in the upper righthand corner.

Tool windows are modeless: in principle, you can open as many tool windows as you want. In practice,
Enterprise Analyzer will prompt you to close an “unprotected” tool window if the activity you want to
perform could result in a repository change. An unprotected tool window cannot be updated to reflect a
concurrent repository change.

In tool windows with lists, you can select all, select multiple, size columns, and sort by column.

Resizing Panes

Resize a pane in a tool window by using the mouse to grab its border with another pane, called a splitter,
and dragging the border to a new location. To control how panes are resized when you resize the window,
select the splitter and choose one of the following in the right-click menu:

« For a vertical splitter, Keep First preserves the size of the panes to the left of the splitter. For a
horizontal splitter, Keep First preserves the size of the panes above the splitter.

* For a vertical splitter, Keep Second preserves the size of the panes to the right of the splitter. For a
horizontal splitter, Keep Second preserves the size of the panes below the splitter.

» Keep Proportion preserves the length and width ratio of the panes on either side of the splitter.

Moving Panes

Move a pane in the window by grabbing its title bar to show the “virtual rectangle” for the pane. The virtual
rectangle is a dotted color frame that you can drag to the position in the window at which you want the
pane to appear. When you are satisfied with the new position, release the mouse button. The other panes
in the window are adjusted as necessary.
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Note: You may have to drag the virtual rectangle beyond the edge of the tool window to achieve the
effect you want.

To swap the positions of the panes on either side of a splitter, select the splitter and choose Swap in the
right-click menu. To change the color of the splitter when it is selected (and of its virtual rectangle), select
the splitter and choose Color in the right-click menu. Use the standard Windows color control to specify the
color.

Setting Options

Enterprise Analyzer options control the look and feel of the product tools and how they perform their tasks.
The Tools menu gives you access to three sets of options:

* Workspace Options control the appearance and behavior of EA tools for the current workspace.
* Project Options control the appearance and behavior of EA tools for the current project.

» User Preferences control the appearance and behavior of the Editor, Interactive Analysis, and Change
Analyzer across workspaces, and miscellaneous other tasks.

Each tool has an Options choice in the View menu that lets you set the options for that tool.

Note: Many options are preset based on your choices in the Enterprise Analyzer Configuration
Manager. For more information, see the installation guide for your product.

Tool options are described in detail in the relevant sections of the documentation set. This section shows
you how to manage option sets and how to set general EA and environment options

Managing Option Sets

An option set is a particular configuration of settings for one of the option groupings. In a given Project
Options set, for example, you might choose to show GO TO statements in the Interactive Analysis Program
Control Flow tool, while in the other Project Options sets you would not.

Option sets let you switch back and forth between configurations in the same session, without having to
change settings manually. You can also use them to ensure uniform results across your team by sharing
customized settings with team members.

Understanding the Options Manager Window

Use the Options Manager to define custom options sets. Choose Options > Options Manager to open the
Options Manager window.

The figure below shows the Options Manager window at startup, with the tab for the Workspace Options
grouping selected. For each grouping, there is an initial read-only default option set, denoted by a &
symbol, that reflects your current EA configuration. The active option set is displayed in bold type in the
Options Manager tab for the grouping. You make an option set active by assigning it. Assignments persist
across Enterprise Analyzer sessions.

The user who defines a custom option set is referred to as its owner. Only the owner can share a custom
option set with other users, as indicated by a = symbol. A shared option set cannot be deleted or
unshared if it is being used. The Used By drop-down at the bottom of the owner’s Options Manager
window lists the names of option set users. The owner’s name appears in the Owner column in the Options
Manager window displayed to other users (but not in the owner’s Options Manager window).

The initial default option set is always shared with other users. An owner can designate another option set
as the default, provided the option set is shared. The new default option set will automatically be assigned
to every user who has not explicitly defined a custom option set. A default option set cannot be modified or
deleted.
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Options Manager

Workspace Options l Project Options Liser Preferences ]
Mame | Owner | Location Edit
%. (Default) C:\Modernization Workbench Workspaces\FPTEST3 \OPTIONS.WOR
Copy
Assign...
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Import
L >
Used by: [~ | Close

Creating an Option Set

If there is only a “(Default)” option set for the grouping, select it and click Edit. Otherwise, select any option
set and click Edit. Options Manager displays the available tabs for the selected options grouping.

Modify the options displayed on each tab as necessary and click Apply. When you are satisfied with your
choices, click OK. The new option set is displayed in the Options Manager window with the name of the

grouping.
Note: If a default option set already uses one of the grouping names, Options Manager prepends
“Copy of” to the name.

Renaming an Option Set

To rename an option set, select it and click Rename. The system displays the current name in an edit box.
Enter the new name in the edit box and click outside the box.

Editing an Option Set

To edit an option set, select it and click Edit, then follow the instructions for creating an option set. You
cannot edit a default option set.

Copying an Option Set

To copy an option set, select it and click Copy. Options Manager prepends “Copy of” to the name of the
copied option set.
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Deleting an Option Set

To delete an option set, select it and click Delete. You cannot delete a default option set, or a shared option
set that has been assigned by another user.

Sharing an Option Set

To share an option set, select it and click Sharing. The button is a toggle. Select it again to revoke sharing.
You cannot revoke sharing for an option set that has been assigned by another user.

Making an Option Set the Default
To make a custom option set the default, share it first, then select it and click Default.

Note: In the Project Options tab, a dialog opens that prompts you to select or create a new project.
Select the project and click OK.

The new default option set is automatically assigned to every user who has not explicitly defined a custom
option set. A default option set cannot be modified or deleted.

Assigning an Option Set
To make an option set active, select it and click Assign.

Note: In the Project Options tab, a dialog opens that prompts you to select or create a new project.
Select the project and click OK.

Importing and Exporting Option Sets

To import an option set, click Import. A Load dialog opens, where you can specify the option set you want
to import.

To export an option set, select it and click Export. A Save dialog opens, where you can specify the name
and location of the option set.

Setting General Options

Use the General tab of the Workspace Options window to specify the description of the workspace
displayed in the Object Information pane, the attributes displayed in the Repository pane Search tab, and
the browser fetch buffer size.

1. Choose Options > Workspace Options. The Workspace Options window opens. Click the General tab.

2. In the Workspace description field, enter a description of your workspace. This description is shown in
the Object Information pane.

3. In Repository Browser (Search), check the boxes for the object attributes that should be displayed in the
Search tab of the Repository pane. Click Select All to check all the attributes.

Note: Only attributes in the repository model for an object are displayed. That is, if you choose
Cyclomatic Complexity, and only JCL files appear in the Search tab results list, the attribute will not
be displayed in the list, because Cyclomatic Complexity is not an attribute of a JCL file.

4. In the Browser Fetch Buffer Size field, enter the size of the buffer Enterprise Analyzer uses to
populate the repository tree. When you expand a node in the Repository Browser, Enterprise Analyzer
populates the display from a buffer that contains the objects last fetched from the repository. For very
large repositories, you may want to lower the buffer size so that you can work with objects in the
Repository Browser while the product performs subsequent fetches.

Setting Environment User Preferences

Use the Environment tab of the User Preferences window to specify whether you want to be prompted to
verify source files after registering them and the scope of relationships shown in the Object Properties
window.
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1. Choose Options > User Preferences > Environment.
2. In After new files are registered, choose:

* Verify registered files if you want Enterprise Analyzer to verify files after they have been registered.

« Ask user about verification if you want to be prompted to verify files after they have been
registered. Available whether or not Verify registered files is selected.

3. From the Code Search Report Options you can select whether to be prompted that queries will be run
on all programs when you try to run a Code Search report for a project.

4. The Chart Viewer options let you select:

* Show Chart Viewer on startup - if you want to have the Chart Viewer displayed when you start EA.
» Default Chart View - if you want to change the default chart view.

5. In Show relationships in the object properties view window, choose whether you want to restrict the
relationships displayed in the Relationships tab of the Object Properties window:

* Restricted to the current project if you want to restrict the relationships of the object to those in the
current project.

* Workspace wide if you want to display all the relationships of the object in the current workspace.
6. Select a main menu scheme: simplified or classic.

7. For Java support, specify the path of the folder for the Java Runtime Environment (JRE) on your
machine in the Path to JRE Folder field. If you do not enter a path, the current version specified in the
Windows registry is used. You must use JRE version 1.5 or later.

Note: If your application was compiled with a previous version of the JRE, specify the path of the
Java SE runtime library (rt.jar) used to compile the application in the Enter classpath to JAR
Files and/or path to external Java file root directories field in Workspace Options > Verification
> Settings.

Setting Archivers User Preferences

The EA registration process extracts compressed source files using the command line syntax for archiver
versions most widely in use. Use the Archivers tab of the User Preferences window to specify the
command line syntax for newer archiver versions.

1. Choose Options > User Preferences. The User Preferences window opens. Click the Archivers tab.

2. In the Command Line for Archiver drop-down, choose the archiver whose command line syntax you
want to specify.

3. In the Unpack All field, enter the command line syntax for the unpack all operation.
4. In the Extract File field, enter the command line syntax for the extract file operation.

Setting Export Options

Use the Export Options tab of the Project Options window to specify where Enterprise Analyzer stores
generated files. The default location is the \<Workspace Home>\Output folder.

1. Choose Options > Project Options. The Project Options window opens. Click the Export Options tab.
2. In the Target directory field, enter the folder you want Enterprise Analyzer to store generated files in.

3. Deselect the Move Files check box if you want to copy generated files to both the default and the
specified directories.

Adding a Selectable Item

Many options windows allow you to add an item to a list of available items. In the Extensions tab of the
Workspace Registration options, for example, you can add an extension to the list of recognized
extensions.
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Add an item by right-clicking in the selection pane and choosing Add in the pop-up menu. The EA displays
an empty text field next to a selected check box. Enter the name of the item in the text field and click
outside the field.

f Note: If you are entering a file extension, make sure to enter the dot (.).

Edit an item by selecting it and choosing Edit in the right-click menu. Delete an extension by selecting it
and choosing Delete in the right-click menu.

Working with Reports and Diagrams

When you generate a diagram or report in the Enterprise Analyzer, you typically have the option of saving it
to a file or printing it. You can save to a wide variety of standard formats.

Note: Word must be installed to save reports to RTF and Word. Excel must be installed to save
reports to Excel, CSV, and TXT. Visio 2002 must be installed to save a diagram to Visio. Visio 2002 is
not required to save to Visio XML.

Click Page Setup in a report window to set up the page for a printed report. Click Print to print the report.
The Print dialog opens, where you can set options for the print job. Click OK.

Click Save in a report window to export a report. A Save As dialog opens, where you can specify the name,
location, and file type of the report.
Using the Guide for a Tool

Many Enterprise Analyzer tools have guides that you can use to get started quickly in the tool. The guides
are help-like systems with hyperlinks that you can use to access functions otherwise available only in
menus and other program controls.

To open the guide for a tool, choose View > Guide. Use the table of contents in the Page drop-down to
navigate quickly to a topic.
Purge Activity Log

Activity Log grows in size. To remove unwanted information, use Purge Activity Log to permanently delete
contents from the database.

1. Open Micro Focus Enterprise Analyzer Administration.
2. Click Tools > Purge Activity Log. The Purge Activity Log window opens.
3. Select a date from which to delete Activity Log data.

» Click Delete to proceed with log deletion. This will actually delete items from the Activity Log history
table in the database.

« Click Close to exit without any change.

Preparing Projects

Registering Source Files

Before you can analyze application source files in Enterprise Analyzer, you need to load, or register, the
source files in a workspace.

i Note: In a multiuser environment, only a master user can register source files.

EA registers sources files in-place from the location they are selected rather than creating copies of the
files in the workspace folder. These are the files you view and edit in the EA tools.
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Note: Workspaces that were created without in-place registration and upgraded from previous
versions will continue to create copies of the files in the Sources folder for the workspace when
registering new files.

Source files must have recognized DOS file extensions before they can be registered. You can view and
add to the recognized extensions in the Workspace Registration options window. Files without extensions
are checked for content, and if the content is recognized, the files are registered with appropriate
extensions appended.

EA assumes that input source files are ASCII files in DOS format. Occasionally, files may be converted
incorrectly from other formats to DOS-based ASCII with an extra special character (like “M”) at the end of
each line. While Enterprise Analyzer accepts these files as input, some EA tools may not work correctly
with them. Make sure all source files are in valid ASCII format.

You can register source files in compressed formats (ZIP or RAR), as well as uncompressed formats.
Enterprise Analyzer automatically unpacks the compressed file and registers its contents.

Note: EA extracts compressed source files using the command line syntax for archiver versions most
widely in use. If you use newer archiver versions, specify the command line syntax in the Archivers
tab of the User Preferences window.

Workspace Registration options determine registration behavior. The default values for these options are
preset based on your configuration and should be appropriate for most installations.

1. In the Repository Browser, create a project for the source files you want to register, or use the default
project. To create a project, choose Project > New Project. The Create Project dialog opens. Enter the
name of the new project and click OK. The new project is displayed in the Repository Browser.

2. Select the project in the Repository Browser, then copy-and-paste ( Ctrl+C and Ctrl+V) or drag-and-
drop (if UAC is disabled) the file or folder for the source files you want to register onto the Repository
Browser. You are notified that you have registered the files successfully and are prompted to verify the
files. Click Close. The Repository Browser displays the contents of the new workspace either by folder,
or by type, depending on the tab you have selected - Folders or Types. The former displays the
contents of the repository in the same folder structure as the one they have on the host environment,
the latter displays them by object type.

Note: For non-inplace registration workspaces, when updating or adding new sources through the
EA main window, the files or folders being registered will be included into the selected folder in the
Folders view. Registration into the Types view will copy the selected files and folders directly to the
root Sources folder, i.e. they will not be copied into any other existing folders. If you are registering
files or folders in Folders view, make sure you've selected in the tree the exact folder in which you
want them to be registered. If you haven't selected any folder, they will be copied into the root
Sources folder.

1». Important: Before registering your source files, you must create a folder structure that replicates
’ the original. This helps to avoid errors when you work with homonyms. Micro Focus recommends
putting each application in a separate folder, putting system files that are common for more than
one application in one directory. After you do that, register your sources by selecting the folders

and including them in the project as described in step 2.

- -

f Note: In the notification dialog, select Never ask again if you do not want to be prompted to verify
files. On the Environment tab of the User Preferences window, select Ask user about verification
if you want to be prompted again.

Host Environment Source Compatibility

When you register your source files, it is essential that they are organized in the same folder structure as
the one on your host environment. This allows EA to create the correct relationships when connecting
programs with their copybooks, JCLs with the proper version of the procedures that are used, etc. Run-
time connections are also established based on this structure. Furthermore, this structure allows for having
several members with the same name, i.e. homonyms.
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The sources to be loaded into EA should be in folders named after the PDS libraries on the Mainframe and
those folders should be the ones loaded.

Example

There is an enterprise organization with 3 data centers: Data Center 1 with one Mainframe, Data Center 2
with two Mainframes, and Data Center 3 with one Mainframe.

The following image shows the folders in a Windows environment:

Organize = Include in library = Share with Burn MNew folder

| Folder support Doc Y Name
Data Center 1
DC1 Mainframe 1

Data Center 1

) Data Center 2
Appl - Accounting

DC1.PROD.APP.CARDLIB
DC1.PROD.COMMON.PROCLIB
DC1APP1.PROD..COPYLIB
DC1APP1.PROD.JCLLIB
DC1APP1.PROD.INCLIB
PROD.APP.APP.2.COBOL
PROD.APP.APP.2.LINKCARD
PROD.APP1.APP.2. ASSEM
PROD.CTLCDPDS
SYS1.COPYLIB
Data Center 2

| Data Center 3

1

Main Frame 1

Accounting
PROD.ACCT.AP2.COBOL

| PROD.ACCT.APZLINKCARD
PROD.ACCT.AP2ZMAP
PROD.IMSIMS.AP2.PSB

And this is what the three data center folders look like after they have been copied to the workspace:
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Resolving Include Files

When trying to resolve include files (copybooks, PL/I includes, JCL procedures, and so on), the EA parser
uses different search methods that you can set in the Homonyms tab in Project Options. The three
methods are described below:

Search all, use If you choose this option, the parser will look at all folders trying to find names that

the provided match the included file. If only one match is found, it will use that file. If more than one
paths as match is found, the parser will take the following steps to resolve which of the matching
preference include files is the one to use:

1. It will check if one of the folders is listed under Search Path in the Homonyms tab in
Project Options. The folder should be listed as the full path to the registered
sources. It could be local or shared, for example:

¢ Jocal:
C:\Sources\Data Center 1\DC1l Mainframe 1\SYS1.COPYLIB
* shared:

\\server\Sources\Data Center 1\DC1l Mainframe 1\SYS1.COPYLIB
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2. It will look for proximity of the included file to the including file in the source folder
structure. First, it will check the files that are in the same folder as the "including”
source, then the files in the dependent folder, and then up the folder hierarchy.

3. Finally, folder names will be matched and the "include" folder that has a name with a
better match to the source folder name will be selected.

Search only in  When this option is selected, only the paths specified in the Search Path list will be used

the provided as locations for looking for include files. As this option works on project level, you can

paths configure each subsystem or application in a separate project, and then specify the
copybook locations for each project. This option is useful when the number of
applications/subsystem is not too big.

Search in This option might help when there is a large number of applications/subsystems. It lets

common you use the folder structure in the file system to define the boundaries between

location and subsystems and to restrict retrieval of include files based on the physical folder

only the same structure. If you choose it, you can put all the sources in a single project and avoiding

subsystem the need to add a list of folders to search in. If you choose this option, you need to
specify the following two paths:

Common folder All common libraries need to be located inside the same root
folder, for example, C:\Sources\Common. Files in folders located
here will be "visible" to all programs being analyzed.

Subsystems All subsystems need to have a common root folder, for example,

root level C:\Sources\Subsystems. If you have two subsystems in this
folder, one of them will not get copybooks from the other and vice
versa, but they can both get copybooks from the common libraries
folder specified in the Common folder field.

Note: The subsystems root level selection is checked first and then the common
folder.

Note: For COBOL only, if there is a registered homonym (copybook) in the program's folder it will be
used in preference to the homonym search configuration.

Resolving Program-to-Program Calls

When resolving call relationships between programs, it is possible to reach a point where there is more
than one candidate for a called program. In this case EA works the same way as with includes (see
Resolving Include Files), but since the program objects themselves don't have folders, the folders of the
source files that generated them are used.

Note: This same algorithm applies to any relations between non-legacy entities (e.g. PROGRAM
reads TABLE, TRANSACTION starts PROGRAM, etc.).

Resolving Control Cards

Control cards can be any members explicitly mentioned in the JCL. When parsing JCLs, EA will look for a
file with the member name in the JCL in a folder with a name matching the PDS name from the mainframe.

Resolving JCL Procedures

When looking for JCL procedures, the parser uses the JCLLIB statement, if present. If there is only one
copy of the searched procedure, that copy is used. Otherwise, if more than one copy is available, the
libraries specified with the JCLLIB statement are used to pick the right one.
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Example:

Path to the JCL file: <workspace_path>\Sources\APP1\MYJCL\MYJOB.JCL

//MYJOB1  JOB S
//NMYLIBS1 JCLLIB ORDER=CAMPBEL .PROCS.JCL
//51 EXEC PROC=MYPROC1

In this case the procedure <workspace_path>\Sources
\APP1\CAMPBEL . PROCS . JCL\MYPROC1, if present, will be used.

Refreshing Registered Source Paths

The Refresh Registered Source Paths feature enables you to change the location of registered source files.
It is useful in cases when the sources have been moved to another location, or a folder that contains
sources has been moved or renamed, or sources were registered from a non-shared location, and the
location has since been shared.

To use this feature:

1. Open Enterprise Analyzer Administration.

2. From the Administer menu, click Refresh Registered Source Paths.
3. Choose a workspace from the list in the Select Workspace window.
4

. Click OK. The Change Registered Source Paths window opens. It displays the registered source
paths and lets you select the new source paths.

You can choose whether to hide or display system paths in the list of source paths by toggling the Hide
System Paths check box.

Click the yellow folder icon under New Source Path.
6. Choose the new directory of the source files and click Select Folder. The selected path and a red cross
icon % appear under New Source Path.

i Note: Clicking % removes the selected path.

7. Click Change. A message asking you if you are sure you want to change the registered source paths
comes up.

8. Click OK. You are notified that the paths have been refreshed.
9. Click OK. The Change Registered Source Paths window closes.

Note: Alternatively, you can change the registered source paths from Source Synchronization. See
Source Synchronization for more information.

After changing the registered source paths, a file must be verified again for a Logic Analyzer
extraction to work correctly.

Setting Registration Options: Extensions Tab

Source files must have recognized DOS file extensions before they can be registered. Files without
extensions are checked for content, and if the content is recognized, the files are registered with
appropriate extensions appended.

Files with unknown extensions are flagged, provided that you uncheck Ignore Unknown and Overloaded
Extensions on the Extensions tab of the Workspace Registration options window. If a file fails to register
because its extension is unknown, simply add the extension to the list of recognized extensions on the
Extensions tab and register the file again.

1. Choose Options > Workspace Options. The Workspace Options window opens. Click the Registration
tab, then the Extensions tab.
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2. In the Source Type pane, select the source file type whose extensions you want to view. The extensions
for the file type are listed in the Extensions pane. Select each extension you want the system to
recognize. Add extensions as necessary.

Note: If a source file does not specify an extension when it references an included file, the
verification process assumes that the included file has one of the recognized extensions. If multiple
included files have the same name but different extensions, the system registers the file with the
first extension in the list.

3. Check Ignore Unknown and Overloaded Extensions if you do not want the registration process to
issue warnings about unrecognized and overloaded extensions. An overloaded extension is one
assigned to more than one file type.

4. For COBOL programs and copybooks, check Remove Sequence Numbers if you want the system to
replace preceding enumeration characters, or sequence numbers, with blanks. Sequence numbers are
removed only from the source file versions maintained by the product.

Setting Registration Options: Source Files Tab

If your legacy application executes on a mainframe, it's usually best to convert the application source to
workstation encoding. If that’s not practical, you can have Enterprise Analyzer convert it for you, using the
options on the Registration > Source Files tab of the Workspace Options window.

1. Choose Options > Workspace Options. The Workspace Options window opens. Click the Registration
tab, then the Source Files tab.

2. Inthe Legacy Source Encoding group box, choose:

* Workstation if the source is workstation-encoded. For DBCS configurations, if Japanese-language
source files were downloaded in workstation (text) mode, specify how DBCS escape control
characters were handled.

* Mainframe if the source is mainframe-encoded. When this option is selected, the registration
process automatically converts source files to workstation-encoding. Only the source files
maintained by Enterprise Analyzer are converted.

3. In the Object System Encoding group box, choose:

¢ English - US (ANSI MS-1252) if the original source was U.S. English ANSI-encoded (Unisys 2200
and HP3000 Cobol).

* English - US (EBCDIC-CCSID-37) if the original source was U.S. English EBCDIC-encoded (IBM
Cobol).

« Japanese (EBCDIC-CCSID-930, 5026) if the original source was Japanese EBCDIC-encoded,
CCSID-930, 5026 (DBCS configurations only).

« Japanese (EBCDIC-CCSID-939, 5035) if the original source was Japanese EBCDIC-encoded,
CCSID-939, 5035 (DBCS configurations only).

During analysis and transformation, hexadecimal literals in Cobol programs and BMS files are
translated into character literals using this setting.

f Note: Do not change these settings after source files are registered in a workspace.

4. Check Strip trailing numeration if you want the system to strip trailing numeration characters (columns
73 through 80) from source lines. Trailing numeration characters are removed only from the source files
maintained by EA.

5. Check Expand tabulation symbols if you want the system to replace tabulation symbols with a
corresponding number of spaces. Tabulation symbols are replaced only in the source files maintained
by EA. You must select this option if you want to view Interactive Analysis information for C or C++
programs.

6. Check Do not invalidate dependent files if you do not want the system to invalidate files that are
dependent on a file you are refreshing. Normally, the system invalidates all dependent files. Selecting
this option shifts the burden of determining which files need to be invalidated (and reverified) onto the
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user. If you select this option and know that a file is affected by a change in the file being refreshed, you
must reverify the affected file.

Creating New Source Files

To create a new source file, select the project for the source file in the Repository Browser and choose File
> New. A dialog box opens, where you can specify the file name (with extension) and source file type. To
create a new source file with the same content as an existing file, select the file and choose File > Save
As. The system automatically registers the created files and stores them in the appropriate folder.

Updating Source Files with Source Synchronization

Source Synchronization checks if the source files registered in Enterprise Analyzer have been modified or
deleted from their original location. It also detects if new files or folders have been added to a folder
registered in EA.

To use Source Synchronization, do one of the following:

* Select Workspace > Source Synchronization.

Click =,

If there are any new, modified or deleted files or folders, Source Synchronization informs you about that
and asks you if you want to synchronize the workspace. To view the updates, click Show Changes. Click
Close to go back to the Source Synchronization window.

If you click Yes, the new files will be added to the workspace and verified, the modified files be updated
and re-verified, and the deleted files will be removed.

Sources that were registered in-place but are not found in the expected locations are not automatically
deleted from the repository during Source Synchronization. If files have been deleted from the original
location, you can view them if you click Missing files button on the Source Synchronization confirmation
dialog. You can then decide if you need to restore the missing files to the expected locations, or you can
manually select which of the missing files to be removed from the repository.

For in-place registration workspaces, source files removed from registered source directories can be
deleted from the workspace during BRP. If you check the Automatically unregister missing sources
when running update option in the BRP configuration Advanced tab, the missing sources will be deleted
from the workspace when running BRP. The deleted files are logged in the Update. log. If the option is
unchecked, the removed sources will not be deleted. This option is unchecked by default.

Source Synchronization Settings

To set Source Synchronization options, go to Options > Workspace Options > Registration > Source
Synchronization.

The first option allows you to enable or disable Source Synchronization. The default is enabled. Disabling
Source Synchronization stops any related checks and automated executions (if any were set). On a non-in-
place workspace, Source Synchronization is automatically disabled if BRP registration is run. BRP on in-
place registration workspace still uses Source Synchronization for updating, ignoring whether Source
Synchronization is enabled or not.

In this tab you can select to check for updated sources automatically. If you do so, you must select whether
to have the checks performed periodically or at a specific time. If you want to have periodic checks, you
must select an interval. The default is 20 hours. When this option is selected, the check is added as a task
to the Windows Task Scheduler.

Another option in this tab is to select to execute a batch file on the files in the original source location
before the workspace is synchronized.
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If you select Synchronize the workspace after checking for outdated sources without asking me,

+

every time you click = or select Workspace > Source Synchronization the workspace will be
automatically synchronized.

Source Synchronization and Interactive Analysis

If you select a file that has been modified in the original location and try to run Impact Analysis, you will be
notified that it has been changed and will be asked to synchronize the workspace.

Note: If you have selected the Synchronize the workspace after checking for outdated sources
without asking me option in Options > Workspace Options > Registration > Source
Synchronization, the workspace will be synchronized when you try to run Impact Analysis on a
modified file.

The Source Synchronization window also pops up when you try to select a file that has been modified in
the Objects pane in Interactive Analysis.

Using Source Synchronization to Change the Registered Source Paths

When the folder containing the registered source files has been changed or renamed, or the files have
been moved to a different location, or sources were registered from a non-shared location, and the location
has since been shared, you can refresh the registered source paths from the Source Synchronization
window.

In these cases, a Change Registered Source Paths appears in the Source Synchronization window.

To refresh the registered source paths from the Source Synchronization window, perform the following
steps:

1. Click Workspace > Source Synchronization.
2. Select the Removed folders / subfolders tab to see the list of folders that could not be found.

Note: Only top-level folders can be refreshed. This means that if the location of a top-level folder
has been changed, you cannot choose to update only one or more of its subfolders.

3. Click Change Registered Source Paths. The Change Registered Source Paths window opens. This
displays the registered source paths and lets you select the new source paths.

You can choose whether to hide or display system paths in the list of source paths by toggling the Hide
System Paths check box.

Click the yellow folder icon 1 under New Source Path.
5. Choose the new directory of the source files and click Select Folder. The selected path and a red cross
icon ¥ appear under New Source Path.

f Note: Clicking ¥ removes the selected path.

6. Click Change. A message asking you if you are sure you want to change the registered source paths
comes up.

Note: If you click Change without selecting a new source path before that, a message that there is
nothing to change will pop up.

7. Click OK. You are notified that the paths have been refreshed.

Click OK. You are notified that all files are up-to-date.

9. Click OK. Source Synchronization closes.

©

Note: Alternatively, you can change the registered source paths from the Enterprise Analyzer
Administration tool. See Refreshing Registered Source Paths for more information.

After changing the registered source paths, a file must be verified again for a Logic Analyzer
extraction to work correctly.
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Exporting Source Files from a Workspace

To export the workspace source for a project or file to a new location, select the project or file in the
Repository Browser and click File > Export Sources. A dialog box opens, where you can specify the
location.

Deleting Objects from a Workspace

To delete an object from a workspace, select it and choose File > Delete from Workspace. To delete a
folder and all its contents from a workspace, select it and choose File > Delete Contents from
Workspace.

Deleting a Workspace

To delete a workspace, choose Administer > Delete Workspace... in the Enterprise Analyzer
Administration tool. A Delete workspace dialog opens, where you can select the workspace you want to
delete.

i Note: Only a master user can delete a workspace in a multiuser environment.

Japanese Language Support

Enterprise Analyzer provides full support for mainframe-based Cobol or PL/I Japanese-language
applications. Make sure you set Windows system and user locales to Japanese before registering source
files.

You can register Japanese source files downloaded in text or binary mode:

« Source files downloaded in text (workstation) mode must be in Shift-JIS encoding. If Shift-Out and Shift-
In delimiters were replaced with spaces or removed during downloading, Enterprise Analyzer restores
them at registration.

» Source files downloaded in binary (mainframe) mode are recoded by Enterprise Analyzer from EBCDIC
to Shift-JIS encoding at registration.

Use the options on the Registration > Source Files tab of the Workspace Options window to specify how
DBCS escape control characters were handled in source file downloaded in text mode:

* Replaced with spaces if DBCS escape control characters were replaced with spaces.
* Removed if DBCS escape control characters were removed.
* Retained or not used if DBCS escape control characters were left as is or were not used.

We recommend you preserve delimiters during download. Replacing delimiters with spaces during
download generally yields better restoration results than removing them.

In all Enterprise Analyzer tools that offer search and replace facilities, you can insert Shift-Out and Shift-In
delimiters into patterns using Ctrl-Shift-O and Ctrl-Shift-1, respectively. You need only insert the delimiters if
you are entering mixed strings.

Setting Up Projects

Workspace projects typically represent different portions of the application modeled in the workspace. You
might have a project for the batch portion of the application and another project for the online portion. You

can also use a project to collect items for discrete tasks: all the source files affected by a change request,

for example.
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Creating Projects

When you set up a workspace in Enterprise Analyzer, the system creates a default project with the same
name as the workspace. Create projects in addition to the default project when you need to analyze
subsystems separately or organize source files in more manageable groupings.

1. Choose Project > New project. The Create Project dialog opens.

2. Enter the name of the new project and click OK. The new project is displayed in the Repository
Browser. The project is selected by default.

Sharing Projects

In a multiuser environment, the user who creates a project is referred to as its owner. Only the owner can
share the project with other users.

A shared, or public, project is visible to other members of your team. A private project is not. If the project is
not protected, these team members can delete the project, add source files, or remove source files.

Projects are private by default. Turn on sharing by choosing Project > Toggle Sharing. Choose Project >

Toggle Sharing again to turn it off. A ¥ symbol indicates that the project is shared.

Protecting Projects

By default, projects are unprotected: any user to whom the project is visible can add source files, include or
exclude objects.

/ Note: Only a master user or the owner of a shared unprotected project can delete it.

The project owner or master user can designate a project as protected, in which case no user can delete or
modify the project, including the project owner or master user: the project is read-only, until the project
owner or master user turns protection off.

Turn on protection by selecting the project in the Repository pane and choosing Project > Toggle
Protection. Choose Project > Toggle Protection again to turn it off. Look for a symbol like this one & to
indicate that a project is protected.

Moving or Copying Files into Projects

Copy the contents of a project, folder, or file to a different project by selecting it and dragging and dropping
the selection onto the project, or by using the Edit menu choices to copy and paste the selection. Use the
Project menu choices described below to move selections, or to include referenced or referencing objects
in a move or copy.

i Note: In other EA tools, use the right-click menu or the File menu to include files in projects.

1. In the Repository Browser, select the project, folder, or file you want to move or copy, then choose
Project > Copy Project Contents (if you selected a project) or Project > Include into Project (if you
selected a folder or file). The Select Project window opens.

2. In the Select Project window, select the target project. Click New to create a new project.
3. Select either:

* Include All Referenced Obijects if you want to include objects referenced by the selected object
(the Caobol copybooks included in a Cobol program file, for example).

* Include All Referencing Objects if you want to include objects that reference the selected object.

i Note: This feature is available only for verified files.
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4. Select:

« Copy to copy the selection to the target project.
* Move From Current Project to move the selection to the target project.
* Move From All Projects to move the selection from all projects to the target project.

5. Click OK to move or copy the selection.

Including Referenced and Referencing Objects in a Project

After verifying a project, you can ensure a closed system by including referenced or referencing objects in
the project. The objects to be included must also have been verified, so it's best to verify every project in
the workspace before including objects.

You can include all referencing objects or only “directly referencing” objects: if program A calls program B,
and program B calls program C, A is said to directly reference B and indirectly reference C.

To include in a project:

« Every object referenced by the objects in the project (including indirectly referenced objects), select the
project in the Repository Browser and choose Project > Include All Referenced Objects.

« Every object that references the objects in the project (including indirectly referencing objects), select
the project in the Repository Browser and choose Project > Include All Referencing Objects.

« Every object that directly references the objects in the project, select the project in the Repository
Browser and choose Project > Include Directly Referencing Objects.

Removing Unused Support Objects from a Project

To move unused support objects (Cobol copybooks, JCL procedures, PL/I include files, and so forth) from a
project to the workspace, select the project in the Repository Browser and choose Project > Compact
Project.

Emptying a Project

To empty a project (without deleting the project or its contents from the workspace), select the project and
choose Project > Empty Project Contents.

Deleting a Project

To delete a project from a workspace (without deleting its source files from the workspace), select it and
choose either File > Delete from Workspace or Project > Delete Project.

i Note: Only the owner of a project can delete it.

Verifying Source Files

Parsing, or verifying, an application source file generates the object model for the file. Only a master user
can verify source files.

You can verify a single file, a group of files, all the files in a folder, or all the files in a project. It's usually
best to verify an entire project. Enterprise Analyzer parses the files in appropriate order, taking account of
likely dependencies between file types.

Note: You need not verify copybooks. Copybooks are parsed when the including source file is
verified.

If your RPG or AS/400 COBOL application uses copy statements that reference Database Description
or Device Description files, or if your MCP Cobol application uses copy statements that reference
DMSII DASDL files, you need to generate copybooks for the application before you verify program
files.
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Workspace and Project Verification options determine verification behavior. The default values for these
options are preset based on your configuration and should be appropriate for most installations.

1. In the Repository Browser, select the project, folder, or files you want to verify and choose Prepare >
Verify.

2. You are prompted to drop repository indexes to improve verification performance. Click Yes. You will be
prompted to restore the indexes when you analyze the files.

The parser builds an object model for each successfully verified file. For an unsuccessfully verified file, the
parser builds an object model for as much of the file as it understands.

Enabling Parallel Verification

Parallel verification typically improves verification performance for very large workspaces by using multiple
execution agents, called Queue Processor, to process source files concurrently. You can start any number
of Queue Processors on the local machine, remote machines, or some combination of local and remote
machines. You can run parallel verification online in the Enterprise Analyzer or in batch mode with the
Batch Refresh Process (BRP).

/. Important: When you run parallel verification on more than one machine, you need to make sure that

~*~ workspace and project verification options are set identically on each machine. The easiest way to do
this is to log in as the same Windows user on each machine. Alternatively, you can define a default
option set that is automatically assigned to every user in the environment who has not explicitly
defined a custom option set. See the related topics for more information on option sets.

You enable parallel verification in three steps:

« Select the parallel verification method and the minimum number of concurrent Queue Processors on the
Verification > Parallel Verification tab of the Workspace Options.

» Start the Queue Processors on the local and/or remote machines. If you start fewer than the minimum
number of Queue Processors specified on the Parallel Verification tab, the verification process starts the
needed Queue Processors automatically on the local machine.

« Verify the workspace online in the Enterprise Analyzer or in batch mode using the Batch Refresh
Process (BRP).

Note: Verification results are reported in the Activity Log History window. They are not reported in the
Activity Log itself (for online verification) or BRP log files (for batch verification). You can also use a
Verification Report to view the results.

Follow the instructions below to launch Queue Processors and to specify the type of work they perform.
You can launch multiple Queue Processors on the same machine. Once the minimum number of Queue
Processors has been started, you can launch them at any point in the verification process.

1. Inthe Enterprise Analyzer Administration window, choose Administer > Launch Queue Processor.
The Launch Queue Processor window opens.

2. In the Serve workspace combo box, specify the workspace to be processed.
3. In the Processing Mode pane, select any combination of:

« Conversion to perform operations used to generate a Interactive Analysis construct model.
« Verification to perform verification operations.
* Code Search Query to perform Code Search searches in offline mode.
4. Select Produce Log File to generate a log file for parallel verification. The log file has a name of the

form <workspace_name>HCC.<random_number>.log and is stored at the same level as the workspace
(.rwp) file.

S. Click OK. The product launches the Queue Processor. Click the = button on the Windows toolbar to
view the Queue Processor window.
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Note: Once verification has started, you can change the processing mode for a Queue Processors
by selecting the appropriate choice in the Processing menu in the Queue Processor window.

Invalidating Files Before Reverification

Invalidating a source file restores it to its state before it was verified, deleting the object model the parser
created for the file. Enterprise Analyzer automatically invalidates previously verified files when you reverify
them.

When reverifying sources in the repository, all selected objects are invalidated prior to being verified. When
the reverification is cancelled, all selected objects that were not verified, are invalidated.

You can save time reverifying very large applications by invalidating some or all of the source files in them
before you reverify. You can invalidate:

* The entire workspace in the Enterprise Analyzer Administration tool. Choose Administer > Invalidate
Workspace. The Select workspace dialog opens, where you can select the workspace you want to
invalidate.

« Selected projects, folders, or files in the Enterprise Analyzer Repository pane. Select the items you want
to invalidate and choose File > Invalidate Selected Objects.

Invalidated files are displayed in bold type in the Repository pane.

Note: To improve performance when reverifying objects in the repository, all selected objects will be
invalidated prior to being verified. When the reverification is cancelled, all selected objects that were
not verified will be invalidated.

Note: To prevent the database transaction log from filling up during the invalidation of a large number
of files, commits to the database are made regularly rather than waiting until the completion of the
invalidation process.

Note: Invalidating an entire workspace is significantly faster than invalidating projects, folders, or files.
You must be a master user to invalidate source files.

The invalidate workspace process opens several console windows displaying the progress of
component tasks. Close these windows manually when invalidation is complete.

Setting Workspace Verification Options: Legacy Dialects Tab

Use the Verification > Legacy Dialects tab of the Workspace Options window to identify the dialect of the
source files in your application.

1. Choose Options > Workspace Options. The Workspace Options window opens. Click the Verification
tab, then the Legacy Dialects tab.

2. In the Source Type pane, select the source file type whose dialect you want to specify, then select the
dialect in the dialect pane.

3. Set verification options for the dialect. The table below shows the available options.

Option Dialect Description
48-character set All PL/ Specifies that the parser handle the 48-character
set used with older hardware for logical operators.
Allow long copybook names COBOL/390, Enterprise Specifies that the parser allow references to
COBOL copybooks with names longer than 8 characters.

The reference is flagged as unresolved.

Note: By default, names longer than 8
characters are truncated in the parse tree.

Enterprise Analyzer | 97



Option

Dialect

Description

Allow long program names

COBOL/390, Enterprise
COBOL

Specifies that the parser allow references to
programs with names longer than 8 characters.
The reference is flagged as unresolved.

Note: By default, names longer than 8
characters are truncated in the parse tree.

ASCII Compatibility

Unisys 2200 UCS COBOL

Specifies that the parser ensure consistency with
the ASCII version of Unisys COBOL. Emulates
behavior of compiler COMPAT option.

Binary Storage Mode

ACUCOBOL-GT®, Micro
Focus COBOL

Specifies the binary storage mode: Word (2, 4, or
8 bytes) or Byte (1 to 8 bytes).

Comment out unsupported
statements

Micro Focus
COBOL, .NET/JVM
COBOL

Excludes directives and unsupported statements
which are set implicitly in the source files and/or
the directive files used in source files.

Note: XMLGEN and any other directive
affecting the kenlygen . xml generation
set explicitly in the EA Options will not be
excluded and will lead to failures in
verification.

Compiler Directives

All COBOL

Specifies directives to be used during compilation.
To add a directive, right-click in the Compiler
Directives field and select Add from the context
menu. The format is: <directive>="<value>".

Using the context menu you can also delete, edit,
select, unselect, move up/down the directives.

Note: Project-level compiler directives
override workspace-level directives.

Copybook Directories

Micro Focus
COBOL, .NET/JVM
COBOL

Specifies copybook directories that contain
system copybooks, frameworks and other
copybooks that are not part of the source code
but are used by it.

Partial Words

COPY REPLACING Substitutes

All COBOL

Specifies that the application was compiled with
partial-word substitution enabled for COPY
REPLACE operations.

COPY statements as in
COBOL-68

All COBOL

Specifies that the application was compiled with
the OLDCOPY option set.

Currency Sign

All COBOL, all PL/I

Specifies the national language currency symbol.

Data File Assignment

Micro Focus COBOL

Specifies the setting of the compiler ASSIGN
option: Dynamic or External.

Decimal Separator

All Natural

Specifies the type of the Decimal Separator.
Leading and trailing commas are not supported
as decimal separators, only the full format [0-9]...,
[0-9]... is supported.

Note: Mixing decimal-separator commas
and item separator commas (i.e. in lists)
cannot be done directly (as per Natural
documentation), so commas that are list
separators should be surrounded by at
least one space, preferably two (leading
and trailing). This is required to parse
ambiguous commas like those separating
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Option

Dialect

Description

numeric literals, which have comma as the
decimal point.

When the decimal point is set to a period, comma
is no longer recognized as the decimal separator
and is treated as a list separator, thus producing
syntax errors for numeric values with comma as
the decimal separator.

Note: When the option is set to comma, a
dot is still recognized as a valid separator.
The option does not disable the dot but
enables the comma as an additional
separator.

Enable MF comments

Micro Focus COBOL

Specifies that the application contains comments
in the first position.

Environment

Micro Focus
COBOL, .NET/JVM
COBOL

Specifies environment variables.

Extralingual Characters All PL/I Add the specified lower-case national language
characters to the supported character set. Do not
separate characters with a space.

Extralingual Upper Characters All PL/I Add the specified upper-case national language

characters to the supported character set. Do not
separate characters with a space.

Graphical System

ACUCOBOL-GT®

Specifies that the application was executed on a
graphical rather than character-based system.

In Margins

All

Specifies the current margins for source files.

Line Number Step

All Natural

Specifies the line-numbering increment to use in
restoring stripped line numbers in Natural source
files: User defined, to use the line-numbering
increment you specify. If you select User defined,
enter the increment in the Value field.

Logical Operators

All PL/I

Specifies handling of logical operator characters
used in source files: Characters, to use the logical
operator characters you specify. If you select
Characters, specify the characters used for NOT
and OR operations.

Micro Focus compiler
compatibility level

Micro Focus
COBOL, .NET/JVM
COBOL

Enables forward compatibility with Micro Focus
COBOL systems by selectively enabling Micro
Focus-specific reserved words and changing the
behavior of certain features to be compatible with
particular versions.

Out Margins

All PL/

Specifies the margins for components to be
created with the Enterprise Analyzer Component
Maker tool.

PERFORM behavior

ACUCOBOL-GT®, Micro
Focus COBOL

Specifies the setting of the compiler PERFORM-
type option: Stack, to allow recursive
PERFORMS, or All exits active, to disallow them.

Picture clause N-symbol

COBOL/390, Enterprise
COBOL

Specifies the national language behavior of
picture symbol N and N-literals: DBCS or
National. Emulates behavior of compiler
NSYMBOL option.
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Option

Dialect

Description

Preprocessors

Micro Focus
COBOL, .NET/JVM
COBOL

Specifies the preprocessors' order of execution.
To change the order of execution, right-click in the
Compiler Directives field and select Move Up or
Move Down from the context menu. Using the
context menu you can also add, delete, edit,
select or unselect the preprocessors.

Preserve dialect for verified
objects

All COBOL

Specifies that the parser reverify COBOL files with
the same dialect it used when the files were
verified first.

RM/COBOL compatibility

ACUCOBOL-GT®

Specifies that the parser ensure proper memory
allocation for applications written for Liant RM/
COBOL. Emulates behavior of -Ds compatibility
option.

Source Format

ACUCOBOL-GT®

Specifies the ACUCOBOL-GT® source format:
ANSI, Long or Terminal.

SQL Dialect All SQL Specifies the SQL dialect. The options are:
Standard SQL, DB2 for AS/400, Unisys RDMS.
For ANSI SQL-92 and DB2 for 0S/390 use
Standard SQL.

Support Hogan Framework All COBOL Specifies that the parser create relationships for

Hogan COBOL and Hogan batch applications.
Specify the full path of the folder for Hogan
Framework configuration files in the Hogan Files
Location field. For more information, see "Hogan
Framework Support.”

Treat COMP-1/COMP-2 as
FLOAT/DOUBLE

ACUCOBOL-GT®

Specifies that the parser treat picture data types
with COMP-1 or COMP-2 attributes as FLOAT or
DOUBLE, respectively.

Unisys MCP Control Options

Unisys MCP COBOL-74,
Unisys MCP COBOL-85

Specifies that the application was compiled with
control options set or reset as specified. Add
control options as necessary.

Setting Workspace Verification Options:

Settings Tab

Use the Verification > Settings tab of the Workspace Options window to specify verification behavior for
the workspace. Among other tasks, you can:

» Enable staged parsing, which may improve verification performance by letting you control which
verification stages the parser performs.
« Enable relaxed parsing, which lets you verify source despite errors.

1. Click Options > Workspace Options. The Workspace Options window opens. Click the Verification

tab, then the Settings tab.

2. In the Source Type pane, select the source file type whose verification options you want to specify.
3. Set verification options for the source file type. The table below shows the available options.

Note: Click the More or Details button if an option listed below does not appear on the Settings

tab.
Option Source File Description
Allow Implicit Instream Data JCL

Specifies that a DD * statement be inserted
before implicit instream data if the statement was
omitted from JCL.
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Option

Source File

Description

Allow Keywords to Be Used as
Identifiers

COBOL, Copybook

Enables the parser to recognize COBOL
keywords used as identifiers.

At Sign

System Definition File

Specifies the national language character for the
at symbol.

C/C++ Parser Parameters

C, C++

Specifies the parameters used to compile the
application. You can also specify these
parameters in the Project Verification options, in
which case the project parameters are used for
verification.

Create Alternative Entry Point

COBOL

Specifies that an additional entry point be created
with a name based on the conversion pattern you
enter in the Conversion Pattern field. Supports
systems in which load module names differ from
program IDs. For assistance, contact support
services.

Cross-reference Report

TWS Schedule

Specifies the full path of the TWS cross-reference
report (.xrf).

Currency Sign

System Definition File

Specifies the national language character for the
currency symbol.

Debugging Lines COBOL Specifies parsing of debugging lines: Off, to parse
lines as comments; On, to parse lines as normal
statements; Auto, to parse lines based on the
program debugging mode.

Detect Potential Code COBOL Enables generation of Interactive Analysis

Anomalies

information on potential code anomalies.

Enable Interactive Analysis

COBOL, Natural, PL/I,
RPG, JCL

Enables generation of Interactive Analysis
information.

Enable Quoted SQL Identifiers

Assembler File, COBOL,
DDL, PL/I

Enables the parser to recognize quoted SQL
identifiers. Strings delimited by double quotation
marks are interpreted as object identifiers.

Enable Reference Reports

COBOL, Control
Language, ECL, JCL,
Natural, PL/I, RPG, W.L.

Enables generation of complete repository
information for logical objects.

Enter classpath to JAR Files
and/or path to external Java file
root directories

Java

Specifies any combination of:

* JAR files containing class libraries referenced
in the Java application, or Zip files containing
external Java files referenced in the
application. Alternatively, specify the path of
the folder for the JAR or Zip files, then select
Include Jar/Zip Files From Directories.

» Paths of the root folders for external Java files
referenced in the application.

Note: This option is checked after the
identical option in the project verification
options. Setting the project verification
option effectively overrides the setting
here.

Extralingual Characters

System Definition File

Adds the specified lower-case national language
characters to the supported character set. Do not
separate characters with a space.
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Option

Source File

Description

Extralingual Upper Characters

System Definition File

Adds the specified upper-case national language
characters to the supported character set. Do not
separate characters with a space.

Generate program entry points
for functions with same name as
file

Specifies that a program entry point be created
for the function that has the same name as the
file. Typically used to trace calls to C programs
from COBOL, PL/I, Natural, RPG, or Assembler
programs.

Generate program entry points
for main functions

Specifies that a program entry point be created
for functions named "main". Typically used to
trace calls to C programs from COBOL, PL/I,
Natural, RPG, or Assembler programs.

Ignore Duplicate Entry Points

All

Enables the parser to recognize duplicate entry
points defined by the COBOL statement ENTRY
‘PROG-ID’ USING A, or its equivalent in other
languages. The parser creates an entry point
object for the first program in which the entry
point was encountered and issues a warning for
the second program. To use this option, you must
select Enable Reference Reports. You cannot use
this option to verify multiple programs with the
same program ID.

Ignore Text After Column 72

DDL

Enables the parser to ignore trailing enumeration
characters (columns 73 through 80) in source
lines.

Imply CMPAT=Yes

PSB

Specifies that CMPAT=Yes is assumed even if it
hasn't been set in PSBGEN. When CMPAT=Yes
is specified, it instructs IMS to generate an /O
PCB for all uses, even in environments where it is
not used, such as batch or CICS. If you use this
option, you won't need to recompile the program
between batch and online executions.

Import instream data from DSN

JCL

Imports data sets in HyperCode:

* Instream data sets.
« Control card patterns.

Note: This option can increase the
verification time of JCL and also increase
the size of the database.

JCL Variable Definitions

JCL

Use this to set global symbol definitions used
during JCL parsing. This works in the same way
as the SystemSymbols element in the JCL
section of Legacy - xml file.

You can specify a Name=Value pair for each line.
To add a new entry right-click in the JCL Variable
Definitions field, and then click Add. Only lines
with a checked box will be used in verification.

Note: Do not specify the "&" character
used in a symbol reference. For example,
use PRG not &PRG as the name.
Delimiters are not required around the
values; all text after the "=", including any
spaces, are treated as the value.
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Option

Source File

Description

In JCL files, a reference to &Name will be
substituted with the available Value, unless there
is a more local definition of that symbol name in
the context of that reference. For example, a
PROC statement might have a symbol definition
that redefines the value of that symbol within the
scope of that procedure. There is no special
processing done based on the type of Value -
values with spaces or digits are substituted in for
the reference as they are specified in the option.

Libraries support Natural Enables Natural library support. For more
information, see "Natural Support” in the online
help.

List of Include Directories C, C++ Specifies the full path of the folders for include

files (either original folders or Repository Browser
folders if the include files were registered).
Choose a recognized folder in the List of Include
Directories pane. Add folders as necessary. You
can also specify these folders in the Project
Verification options, in which case the parser
looks only for the folders for the project.

Number Sign

System Definition File

Specifies the national language character for the
number symbol.

Perform Dead Code Analysis

COBOL, PL/I, RPG

Enables collection of dead code statistics.

Perform DSN Calling Chains
Analysis

Control Language, ECL,
JCL, WFL

Enables analysis of dataset calling chains.

Perform System Calls Analysis

JCL

Enables analysis of system program input data to
determine the application program started in a
job step.

Relaxed Parsing

AS400 Screen, BMS,
COBOL, Copybook, CSD,
DDL, Device Description,
DPS, ECL, MFS, Natural,
Netron Specification
Frame, PL/I

Enables relaxed parsing.

Relaxed Parsing for Embedded
Statements

Assembler File, COBOL,
PL/I

Enables relaxed parsing for embedded SQL,
CICS, or DLI statements.

Resolve Decisions Automatically

Control Language, WFL

Enables automatic decision resolution.

Show Macro Generation

C, C++

Specifies whether to display statements that
derive from macro processing in Interactive
Analysis.

Sort Program Aliases

JCL

Enables batch sort card analysis. Choose a
recognized sort utility in the Sort Program Aliases
pane. Add sort utilities as necessary.

SQL Statements Processor

COBOL

Specifies whether the SQL Preprocessor or
Coprocessor was used to process embedded
SQL statements.

System Procedures

JCL

Specifies the system procedures referenced by
JCL files. Add system procedures as necessary.

Timeout in seconds to stop
verification execution

All

The number of seconds to wait before stopping a
stalled verification process.
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Option Source File Description

Treat every file with main C, C++ Specifies whether to treat only files with main

procedure as a program functions as programs.

Trim Date from Active Schedule | TWS Schedule Specifies whether to append the effective date

Names range to a TWS jobstream object.

Truncate Names of Absolute ECL Allows the parser to truncate suffixes in the

Elements names of COBOL programs called by ECL.

Specify a suffix in the adjoining text box.

Use Database Schema Assembler File, COBOL, Specifies whether to associate a program with a

PL/ database schema. When this option is selected,

the parser collects detailed information about
SQL ports that cannot be determined from
program text (SELECT *). If the schema does not
contain the items the SQL statement refers to, an
error is generated.

Workstation Report TWS Schedule Specifies the full path of the TWS workstation
report (.wdr).

Enabling Staged Parsing

File verification generates repository information in four stages, as described in this section. You can
control which stage the EA parser performs by setting the staged parsing options on the Settings tab for
Workspace Verification options. That may save you time verifying very large applications.

Rather than verify the application completely, you can verify it one or two stages at a time, generating only
as much information as you need at each point. When you are ready to work with a full repository, you can
perform the entire verification at once, repeating the stages you've already performed and adding the
stages you haven't.

Basic Repository Information

To generate basic repository information only, deselect Enable Interactive Analysis, Enable Reference
Reports, and Perform Dead Code Analysis on the Workspace Verification options Settings tab. The
parser:

« Generates relationships between source files (COBOL program files and copybooks, for example).

* Generates basic logical objects (programs and jobs, for example, but not entry points or screens).

* Generates Defines relationships between source files and logical objects.

e Calculates program complexity.

« |dentifies missing support files (COBOL copybooks, JCL procedures, PL/I include files, and so forth).

Note: If you generate only basic repository information when you verify an application, advanced
program analysis information is not collected, regardless of your settings in the Project Options
Verification tab.

Full Logical Objects Information

To generate complete repository information for logical objects, select Enable Reference Reports on the
Workspace Verification options Settings tab. Set this option to generate all relationships between logical
objects, and to enable non-Interactive Analysis tools, including Reference Reports and Orphan Analysis.

Note: If you select this staged parsing option only, verify all legacy objects in the workspace
synchronously to ensure complete repository information.
Interactive Analysis Information

To generate an Interactive Analysis construct model, select Enable Interactive Analysis on the
Workspace Verification options Settings tab. An Interactive Analysis construct model defines the
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relationships between the constructs that comprise the file being verified: its sections, paragraphs,
statements, conditions, variables, and so forth.

To generate Interactive Analysis information on potential code anomalies, select Detect Potential Code
Anomalies on the Workspace Verification options Settings tab.

Note: If you do not generate Interactive Analysis information when you verify an application, impact
analysis, data flow, and execution flow information is not collected, regardless of your settings on the
Project Verification options tab.

Dead Code Statistics

To generate dead code statistics, and to set the Dead attribute to True for dead constructs in Interactive
Analysis, select Perform Dead Code Analysis on the Workspace Verification options > Settings tab. The
statistics comprise:

« Number of dead statements in the source file and referenced copybooks. A dead statement is a
procedural statement that can never be reached during program execution.

* Number of dead data elements in the source file and referenced copybooks. Dead data elements are
unused structures at any data level, all of whose parents and children are unused.

« Number of dead lines in the source file and referenced copybooks. Dead lines are source lines
containing dead statements or dead data elements.

You can view the statistics in the Statistic tab of the Properties window for an object or in the Complexity
Metrics tool.

Enabling Relaxed Parsing

The relaxed parsing option lets you verify a source file despite errors. Ordinarily, the parser stops at a
statement when it encounters an error. Relaxed parsing tells the parser to continue to the next statement.

Use relaxed parsing when you are performing less rigorous analyses that do not need every statement to
be modeled (estimating the complexity of an application written in an unsupported dialect, for example).
Select Relaxed Parsing or Relaxed Parsing for Embedded Statements as appropriate on the
Workspace Verification options Settings tab.

Note: Relaxed parsing may affect the behavior of other tools. You cannot generate component code,
for example, from source files verified with the relaxed parsing option.

Truncating Names of Absolute Elements

If you are verifying ECL files for an application in which absolute element names differ from program IDs,
you can tell the parser to truncate suffixes in the names of Cobol programs called by ECL. Select Truncate
Names of Absolute Elements on the Workspace Verification options Settings tab for the ECL file.

If a Cobol program named CAP13MS.cob, for example, defines the entry point CAP13M, and an ECL
program named CAP13M.ecl executes an absolute element called CAP13MA, then setting this option
causes the parser to create a reference to the entry point CAP13M rather than CAP13MA.

Setting Workspace Verification Options: Parallel Verification Tab

Use the Verification > Parallel Verification tab of the Workspace Options window to enable online or
batch parallel verification and to specify the minimum number of Queue Processors EA should expect.

/. Important: When you run parallel verification on more than one machine, you need to make sure that

“* workspace and project verification options are set identically on each machine. The easiest way to do
this is to log in as the same Windows user on each machine. Alternatively, you can define a default
option set that is automatically assigned to every user in the environment who has not explicitly
defined a custom option set. See the related topics for more information on option sets.

1. Choose Options > Workspace Options. The Workspace Options window opens. Click the Verification
tab, then the Parallel Verification tab.
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2. Select:

* Run Parallel Verification in the Online Tool to enable parallel verification online. In the Minimum
Queue Processors combo box, specify the minimum number of concurrent Queue Processors the

product should expect.

* Run Parallel Verification in BRP to enable parallel verification in the Batch Refresh Process (BRP)
tool. In the Minimum Queue Processors combo box, specify the minimum number of concurrent

Queue Processors EA should expect.

Note: Before running verification, start the necessary Queue Processors on the local and/or
remote machines. If you start fewer than the minimum number of Queue Processors, the
verification process starts the required Queue Processors automatically on the local machine.

Setting Project Verification Options

Use the Verification tab of the Project Options window to specify verification behavior for the selected
project. Among other tasks, you can:

Specify how the parser treats environment-related code.

Specify the conditional constants the parser uses to compile programs in the project.
Specify schedule IDs for CA-7 jobs triggered by datasets.

Optimize verification for advanced program analysis.

Choose Options > Project Options. The Project Options window opens. Click the Verification tab.
In the Source Type pane, select the source file type whose verification options you want to specify.
Set verification options for the source file type. The table below shows the available options.

Note: Click the Environments, CopyLibs, Advanced, or Cobol Dialect button if an option listed

below does not appear on the Verification tab.

Option Source File

Description

AIM/DB Environment COBOL

Specifies how the parser treats AIM/DB-
environment-related code or its absence.

C/C++ Parser Parameters C, C++

Specifies the parameters used to compile the
application.

CAP Processor predefined Netron Specification
variables Frame

Specifies the values of predefined environment
variables the parser uses to compile Netron
Specification Frames. Select each predefined
variable you want the parser to recognize, then
enter its value. Add variables as necessary.

CICS Environment Assembler, COBOL, PL/I

Specifies how the parser treats CICS-environment-
related code or its absence.

Compiler Directives COBOL

Specifies directives to be used during compilation.
To add a directive, select Use project-specific
compiler directives, then right-click in the
Compiler Directives field and select Add from the
context menu. The format is:
<directive>="<value>".

Using the context menu you can also delete, edit,
select, unselect, move up/down the directives.

Note: Project-level compiler directives
override workspace-level directives.

Context-Sensitive Value COBOL
Analysis

Specifies that the parser perform context-sensitive
automatic decision resolution for Unisys MCP
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Option

Source File

Description

COMS analysis. Choosing this option may degrade
verification performance.

Dialect Specific Options

COBOL

Specifies dialect-specific options, including the
conditional constants the parser uses to compile
programs in the project. Select the Cobol dialect,
then choose the constant in the Macro Settings
pane. Add constants as necessary.

DMS Environment

COBOL

Specifies how the parser treats DMS-environment-
related code or its absence.

DMSII Environment

COBOL

Specifies how the parser treats DMSII-
environment-related code or its absence.

DPS routines may end with error

COBOL

Specifies that the parser perform call analysis of
Unisys 2200 DPS routines that end in an error.
Error-handling code for these routines is either
analyzed or treated as dead code.

Enable Data Element Flow

COBOL, Natural, PL/I,
RPG

Enables the Global Data Flow, Change Analyzer,
and impact trace tools.

Enable Execution Flow

COBOL, PL/

Enables the Execution Path tool.

Enable Impact Report

COBOL, Natural, PL/I,
RPG

Enables the impact trace tools. You must also set
Enable Data Element Flow to perform impact
analysis.

Enter classpath to JAR Files
and/or path to external Java file
root directories

Java

Specifies any combination of:

* JAR files containing class libraries referenced
in the Java application, or Zip files containing
external Java files referenced in the application.
Alternatively, specify the path of the folder for
the JAR or Zip files, then select Include
Jar/Zip Files From Directories.

» Paths of the root folders for external Java files
referenced in the application.

Note: This option is checked before the
identical option in the workspace
verification options. Setting it here
effectively overrides the setting in the
workspace verification options.

Helproutines

Natural Map

Specifies how you want the parser to treat
helproutines, as programs or helpmaps.

IDMS Environment

COBOL

Specifies how the parser treats IDMS-environment-
related code or its absence.

IMS Environment

COBOL

Specifies how the parser treats IMS-environment-
related code or its absence.

Java Classpath

JSP

For JSP files that reference Java types or
packages defined in JAR files, external Java files,
or Java files, specifies a list of patterns used to
resolve the location of the files. For more
information, see "Resolving the Location of Java
Types and Packages Referenced in JSP Files" in
the "JSP Support" section of the help.

Java Source Level

Java

Specifies the Java version. Set this option if your
application uses constructs that are incompatible
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Option

Source File

Description

with the latest Java version. You would set this
option to 1.4, for example, if your application used
"enum" as an identifier, since "enum" is a reserved
word in Java 5.

Job to Schedule Ids File

CA-7 Schedule

Specifies the full path of a file that supplies
schedule IDs for CA-7 jobs triggered by the
creation of a dataset.

Libraries

Natural

When Libraries support is selected in the
Verification > Settings tab of the Workspace
Options window for Natural files, specifies the
order in which the parser searches for library
names when it resolves program calls. Place a
check mark next to a library to include it in the
search. The parser always searches for the current
library first. For more information, see "Natural
Support" in the online help.

List of Include Directories

C, C++

Specifies the full path of folders for include files
(either original folders or Repository Browser
folders if the include files were registered). Choose
a recognized folder in the List of Include
Directories pane. Add folders as necessary.

Limit Maximum Array Size

PL/

Controls the maximum size of arrays to be
calculated during analysis. The default is 75.

Maximum Number of Variable’s
Values

COBOL

Specifies the maximum number of values to be
calculated for each variable during verification for
advanced program analysis. Limit is 200.

Maximum Size of Variable to Be
Calculated

COBOL

Specifies the maximum size in bytes for each
variable value to be calculated during verification
for advanced program analysis.

Override CICS Program
Terminations

COBOL, PL/

Specifies that the parser interpret CICS RETURN,
XCTL, and ABEND commands as not terminating
program execution. Error-handling code after these
statements is either analyzed or treated as dead
code.

Perform COMS Analysis

COBOL

Specifies that the parser define relationships for
Unisys MCP COMS SEND statements.

Perform Generic APl Analysis

COBOL, PL/

Specifies that the parser define relationships with
objects passed as parameters in calls to
unsupported program interfaces, in addition to
relationships with the called programs themselves.

Perform Program Analysis

COBOL

Enables program analysis and component
extraction features.

Perform Unisys Common-
Storage Analysis

COBOL

Specifies that the parser include in the analysis for
Unisys COBOL files variables that are not explicitly
declared in CALL statements, but that participate
in interprogram communications. You must set this
option to include Unisys COBOL common storage
variables in impact traces and global data flow
diagrams.

Perform Unisys TIP and DPS
Calls Analysis

COBOL

Specifies that the parser perform Unisys 2200 TIP
and DPS call analysis.
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Option Source File Description

Report Writer Environment COBOL Specifies how the parser treats Report Writer-
environment-related code or its absence.

Resolve Decisions Automatically | COBOL, Natural, PL/I, Specifies that the parser autoresolve decisions

RPG after successfully verifying files.

SQL Environment Assembler, COBOL, RPG | Specifies how the parser treats SQL-environment-
related code or its absence.

Support CICS HANDLE COBOL Specifies that the parser detect dependencies

statements between CICS statements and related error-

handling statements.

Use overwritten VALUEs COBOL Specifies that the parser use constants from
VALUE clauses as known values even if they are
overwritten in the program by unknown values.

Use Precompiled Header File C, C++ Specifies that the parser verify the project with the
precompiled header file you enter in the adjacent
field. Do not specify the file extension. Using a
precompiled header file may improve verification
performance significantly. The content of the
header file must appear in both a .c or .cpp file and
a .h file. The precompiled header file need not
have been used to compile the application.

Use VALUEs from Linkage COBOL Specifies that advanced analysis tools not ignore
Section parameter values in the Linkage Section.

Specifying the Processing Environment

The Enterprise Analyzer parser autodetects the environment in which a file is intended to execute, based
on the environment-related code it finds in the file. To ensure correct data flow, it sets up the internal parse
tree for the file in a way that emulates the environment on the mainframe.

For Cobol CICS, for example, the parser treats an EXEC CICS statement or DFHCOMMAREA variable as
CICS-related and, if necessary:

* Adds the standard CICS copybook DFHEIB to the workspace.
« Declares DFHCOMMAREA in the internal parse tree.
e Adds the phrase Procedure Division using DFHEIBLK, DFHCOMMAREA to the internal parse tree.

Autodetection is not always appropriate. You may want the parser to treat a file as a transaction-processing
program even in the absence of CICS- or IMS-related code, for example. For each autodetected
environment on the Project Verification options tab, select:

« Auto, if you want the parser to autodetect the environment for the file.

* Yes, if you want to force the parser to treat the file as environment-related even in the absence of
environment-related code.

* No, if you want to force the parser to treat the file as unrelated to the environment even in the presence
of environment-related code. The parser classifies environment-related code as a syntax error.

Specifying Conditional Compiler Constants

Compiler constant directives let you compile programs conditionally. Specify the conditional constants the
parser uses to compile programs in the project in the Dialect Specific Options for your dialect on the
Project Verification options tab. For Micro Focus COBOL, two formats are supported:

Enterprise Analyzer | 109



e constant_name=value (where no space is allowed around the equals sign). In the following example, if
you specify WHERE=PC on the Project Verification options tab, the source that follows the $if clause is
compiled:
$if WHERE="PC"

evaluate test-field
when 5 perform test-a
end-evaluate

e constant_name. In the following example, if you specify NOMF on the Project Verification options tab,
the source that follows the $if clause is compiled:
$if NOMF set

$display Not MF dialect
go to test-a test-b depending on test-field
$end

Optimizing Verification for Advanced Program Analysis

When you enable advanced program analysis options for COBOL projects, the parser calculates constant
values for variables at every node in the Interactive Analysis parse tree. For this reason very large COBOL
applications may encounter performance or memory problems during verification.

You may be able to improve verification performance and avoid out-of-memory problems by manipulating
the Maximum Number of Variable’s Values and Maximum Size of Variable to Be Calculated options in
the Project Verification Options tab. The lower the maximums, the better performance and memory
usage you can expect.

For each setting, you are warned during verification about variables for which the specified maximum is
exceeded. It's usually best to increase the overflowed maximum and re-verify the application.

Identifying System Programs

A system program is a generic program provided by the underlying operating system and used in
unmodified form in the legacy application: a mainframe sort utility, for example. You need to identify system
programs to the parser so that it can distinguish them from application programs and create relationships
for them with their referencing files.

The most convenient way to identify the system programs your application uses is to run an unresolved
report after verification. Once you learn from the report which system programs are referenced, you can
identify them in the System Programs tab of the Workspace Options window and reverify any one of their
referencing source files.

Note: The reference report tool lets you bring up the System Programs tab of the Workspace Options
window while you are in the tool itself. Choose View > System Programs in the reference report
window to display the tab.

1. Choose Options > Workspace Options. The Workspace Options window opens. Click the System
Programs tab.

2. In the System Program Patterns pane, select the patterns that match the names of the system
programs your application uses. Add patterns as necessary.

Specifying Boundary Decisions

Specify a boundary decision object if your application uses a method call to interface with a database,
message queue, or other resource. Suppose the function £1F() in the following example writes to a queue
named abc:

nt flf(char¥*)
return O;

i
{
s
int f2FQ
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As far as the parser is concerned, f1f(“abc’) is a method call like any other method call. There is no
indication from the code that the called function is writing to a queue.

return f1f(“abc™);

When you specify the boundary decisions for a workspace, you tell the parser to create a decision object of
a given resource type for each such call. Here is the decision object for the write to the queue:

int f2f().InsertsQueue.int f1f(char*)
You can resolve the decision objects to the appropriate resources in the Decision Resolution tool.

1. Choose Options > Workspace Options. The Workspace Options window opens. Click the Boundary
Decisions tab.

2. In the Decision Types pane, select the decision types associated with called procedures in your
application. For the example, you would select the Queue decision type.

3. In the righthand pane, select each signature of a given method type you want to associate with the
selected decision type. For the example, the method type signature would be int F1f(char*). Add
signatures as necessary. Do not insert a space between the parentheses in the signature. You can use
wildcard patterns allowed in LIKE statements by Visual Basic for Applications (VBA).

Note: Keep in mind that the signatures of C or C++ functions can contain an asterisk (*) character,
as in the example. So if you specify a signature with a * character, you may receive results
containing not only the intended signatures but all signatures matching the wildcard pattern. Delete
the unwanted decision objects manually.

4. Select the project, folder, or source files for the application and choose:

* Prepare > Verify if the source files have not been verified.

* Prepare > Apply Boundary Decisions if the source files have been verified, but boundary
decisions have not been specified for the application, or the specification has changed.

A decision object is added to the tree for the source files in the Repository Browser.

Generating Copybooks

RPG programs and COBOL programs that execute in the AS/400 environment often use copy statements
that reference Database Description or Device Description files rather than copybooks. MCP COBOL
programs occasionally use copy statements that reference DMSII DASDL files. If your application uses
copy statements to reference these types of files, you need to verify the files and generate copybooks for
the application before you verify program files.

Copybook generation takes place in two steps:

» For each database and device file object generated at verification, the system creates a target
copybook object.
« For each target copybook object, the system creates one or more physical copybooks.

Settings on the Generate Copybooks tab of the Project Options window determine conversion behavior.
The default values should be appropriate for most installations.

1. Verify:

« Database Description files. For each Database Description file, the system creates a database file
object with the same name as the Database Description file.

» Device Description files. For each Device Description file, the system creates a device file object with
the same name as the Device Description file.

- DMSII DASDL files. For each DMSII DASDL file, the system creates a DMSII database file object
with the same name as the DMSII DASDL file.
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2. In the Repository Browser, select the project, database file, or device file and choose between:

* Prepare > Generate RPG Copybooks for Project for RPG.
* Prepare > Generate Copybooks for Project for AS/400 COBOL or MCP COBOL.

Note: Skip this step for MCP Cobol if you selected Generate After Successful Verification on
the Generate Copybooks tab of the Project options window.

The system creates a target copybook for each database or device file object, with a name of the form
database file. DBCOPYBOOK or device file. DVCOPYBOOK, in the Target Copybooks folder.

3. The system automatically converts the target copybooks to physical copybooks if you selected Convert
Target Copybooks to Legacy Objects on the Generate Copybooks tab of the Project options window.
If you chose not to convert target copybooks automatically, select the target copybooks and choose
Prepare > Convert to Legacy. The system generates physical copybooks with names of the form
DD_OF_database file.CPY or DV_OF_device file.CPY.

Note: After generating copybooks, you can generate screens for AS/400 COBOL device file
objects by selecting the objects in the Repository Browser and clicking Prepare > Generate
Screens.

Setting Generate Copybooks Options

For RPG or AS/400 Cobol application that use copy statements to reference Database Description or
Device Description files, or MCP Cobol applications that use copy statement to reference DMSII DASDL
files, use the Generate Copybooks tab of the Project Options window to specify how the system converts
the files to physical copybooks.

1. Choose Options > Project Options. The Project Options window opens. Click the Generate
Copybooks tab.

2. For Cobol MCP only, select Generate After Successful Verification if you want to generate target
copybooks automatically on verification of DMSII DASDL files.

3. Select Convert Target Copybooks to Legacy Obijects if you want to convert target copybooks
automatically to physical copybooks when they are generated, then select:

« Assign Converted Files to the Current Project if you want the system to create physical
copybooks in the current project.

* Keep Old Legacy Objects if you want the system not to overwrite existing physical copybooks, or
Replace Old Legacy Objects if you want the system to overwrite existing physical copybooks.

* Remove Target Copybooks After Successful Conversion if you want the system to remove target
copybooks from the current project after physical copybooks are generated.

Copybook Generation Order

It's usually best to generate copybooks for an entire project, because the system processes objects in the
appropriate order, taking account of the dependencies between them. That is not the case when you
generate copybooks for given objects. Follow these rules to ensure correct results:

« Copybooks for database file objects must be generated before copybooks for device file objects.
« Copybooks for referenced objects must be generated before copybooks for referencing objects.

Performing Post-Verification Program Analysis

Much of the performance cost of program verification for COBOL projects is incurred by the advanced
program analysis options in the Project Verification Options window. These features enable impact
analysis, data flow analysis, and similar tasks.

You can improve verification performance by postponing some or all of advanced program analysis until
after verification. As long as you have verified source files with the Enable Reference Reports and Enable
Interactive Analysis workspace verification options, you can use the post-verification program analysis
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feature to collect the remaining program analysis information without having to re-verify your entire legacy
program.

To perform post-verification program analysis, select the project verification options for each program
analysis feature you want to enable. In the Repository Browser, select the programs you want to analyze
(or the entire project) and click Prepare > Analyze Program.

The system collects the required information for each analysis feature you select. And it does so
incrementally: if you verify a COBOL source file with the Enable Data Element Flow option selected, and
then perform post-verification analysis with both that option and the Enable Impact Analysis option
selected, only impact analysis information will be collected.

The same is true for information collected in a previous post-verification analysis. In fact, if all advanced
analysis information has been collected for a program, the post-verification analysis feature simply will not
start. In that case, you can only generate the analysis information again by reverifying the program.

Restrictions on Cobol Post-Verification Program Analysis

With the exception of Enable Impact Report and Enable Execution Flow, you should select all of the
Perform Program Analysis options you are going to need for Cobol program analysis the first time you
collect analysis information, whether during verification or subsequent post-verification analysis.This is
because, with the exception of Enable Impact Report and Enable Execution Flow, selecting any of the
options dependent on the Perform Program Analysis project verification option, whether during a
previous verification or a previous program analysis, results in none of the information for those options
being collected in a subsequent post-verification program analysis.

Therefore if you verify a program with the Resolve Decisions Automatically option selected, then perform
a subsequent program analysis with the Perform Generic APl Analysis option selected, APl analysis
information is not collected, whereas if you perform the subsequent program analysis with the Enable
Impact Report option selected, impact analysis information is collected.

Similarly, if you perform program analysis with the Enable Impact Report option selected, then perform a
subsequent program analysis with the Enable Parameterization of Components option selected, no
parameterization information is collected, whereas if you perform the subsequent program analysis with the
Enable Execution Flow option selected, execution flow information is collected.

Restrictions on PL/I Post-Verification Program Analysis

For PL/I programs, selecting Resolve Decisions Automatically causes information for Enable Data
Element Flow also to be collected, whether or not it already has been collected. Select these options
together when you perform program analysis.

Using Post-Verification Reports

Use Enterprise Analyzer post-verification reports to check verification results, perform detailed executive
assessments of the application, and view key data operations:

« Verification Reports offer a convenient way to analyze project verification results.

« Executive Reports offer HTML views of application inventories that a manager can use to assess the
risks and costs of supporting the application.

« CRUD Reports show the data operations each program in the project performs, and the data objects on
which the programs operate.

Viewing Verification Reports

Use Verification Reports to display the verification errors and warnings for each source file in the selected
project and to navigate to the offending code in source. To open the Verification Report window, select a
project in the Repository Browser and choose Reports > Verification Report . The verification report is
displayed in the Verification Report window.
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To show the verification report for a different project, select the project in the Projects drop-down on the
toolbar. To refresh the report after reverifying a file, click File > Refresh Errors.

Errors Pane

The Errors pane of the Verification Report window displays the errors and warning for the project, sorted by

the Files Affected column. Click & Errers | o display the errors for the project. Click |-ﬂwar”i”95 to display
the warnings for the project. The buttons are toggles. Click the buttons again to hide errors or warnings.

Click an error or warning to display the affected files in the Files Affected pane and to highlight each
instance of offending code in the Source pane. Mark an error or warning to mark the affected files in the
Files Affected pane. The table below describes the columns in the Errors pane.

Column Description

Severity The severity of the error or warning.

Number The error or warning number.

Count The number of occurrences of errors or warnings of this type in the
project.

Files Affected The number of files affected by the error or warning.

Sample Text The text of the error or warning message. If there are multiple
occurrences of the error or warning, and the text of the message
differs among occurrences, then the text of a sample occurrence.

Files Affected Pane

The top portion of the Files Affected pane displays the files affected by the error or warning selected in the
Errors pane, the verification status of the file, and the numbers of occurrences of the error and warning in
the file. Click a file to display the occurrences in the Details portion of the Files Affected pane. Select Show
All Errors to display every error and warning for the selected file.

Errors are indicated with a @ symbol. Warnings are indicated with a £ symbol. Click an occurrence of an
error or warning to navigate to the offending code in the Source pane.

Source Pane

The Source pane displays view-only source for the file selected in the Files Affected pane. Offending code
is highlighted in red.

Usage is similar to that for the Enterprise Analyzer Interactive Analysis Source pane. For more information,
see Analyzing Programs in the product documentation set.

Marking Items

To mark an item, place a check mark next to it. To mark all the items in the selected tab, choose Edit >
Mark All. To unmark all the items in the selected tab, choose Edit > Unmark All.

Including Files into Projects

In very large workspaces, you may find it useful to move or copy files into different projects based on the
errors they contain. Follow the instructions below to move or copy files listed in a Verification Report into a
project.

1. Inthe Files Affected pane, mark the items you want to move and choose File > Include Into Project.
The Select Project window opens.

2. In the Select Project window, select the target project. Click New to create a new project.
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3. Select either:

* Include All Referenced Obijects if you want to include objects referenced by the selected object
(the Cobol copybooks included in a Cobol program file, for example).

* Include All Referencing Objects if you want to include objects that reference the selected object.

y Note: This feature is available only for verified files.

4. Select:

« Copy to copy the selection to the target project.
* Move From Current Project to move the selection to the target project.
* Move From All Projects to move the selection from all projects to the target project.

5. Click OK to move or copy the selection.

Generating HTML Reports

To generate HTML reports of Verification Report results, choose File > Report > <Report Type>. Before
generating the Details for Checked Files report, mark each file on which you want to report.
y Tip: The Missing Files reports are a convenient alternative to an Unresolved Report when you are
~ interested only in missing source files, and not in unresolved objects like system programs. You can

generate a missing files report for a project or for the entire workspace.

Viewing Executive Reports

Executive Reports offer HTML views of application inventories that a manager can use to assess the risks
and costs of supporting the application:

« The Application Summary view gives statistics for industry-standard metrics such as program volume,
maintainability, cyclomatic complexity, and number of defects.

« The Potential Code Anomalies view gives statistics for potential code anomalies that may mark
programs as candidates for re-engineering: GOTO non-exits, range overlaps, and the like. You can
customize potential code anomalies using the Define Anomalies feature. To get potential code
anomalies to appear on the report, select the Code Defects option on the Options > Project Options
> Reports > Executive Report tab.

Note: You must set Detect Potential Code Anomalies in the Verification > Settings tab of the
Workspace Options window to generate these statistics.
« The Repository Statistics view gives statistics for Enterprise Analyzer verification results and unresolved
or unreferenced application elements.
« The Standard Deviations view displays graphs that plot the deviation of the programs in the application
from the means for six key industry-standard metrics.

To generate an Executive Report, choose Reports > Executive Report . Project options on the Options >
Project Options > Reports > Executive Report tab determine the entities included in the report, and the
functions the report performs. The report is stored in \<Workspace Home>\Output\Executive
Report\Project\index.htm.

The figure below shows an Executive Report. The top page in each view displays the available statistics
and graphs. Click the links to view the detail for each type of statistic or graph. In the statistic or graph
detail page, click the link for a program to view the detail for that program.

Note: After generating an Executive Report, use the Executive Report category in the Interactive
Analysis Code Search tool to view potential code anomalies in program context.

Setting Executive Report Options

Use the Report > Executive Report tab of the Project Options window to specify the entities included in
executive reports, and the functions the report performs. Generally, the fewer entities and functions you
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choose, the better report generation performance you can expect. You should especially consider not
reporting on:

» Detail for code anomalies. Leave Generate Details unchecked.
+ Data stores. Leave data store entities unchecked.
¢ Relationships, if you do not need cross-reference information. Leave Relationships unchecked.

1. Choose Options > Project Options. The Project Options window opens. Click the Report tab, then the
Executive Report tab.

2. Click Functionality, then select each report function you want to enable. For the Application Summary
function, click Select Metrics. In the Application Summary (Averages) window, select Application
Summary (Averages) to enable the function, then choose each metric you want to include in the
report.

3. Select each type of entity you want to include in the report. To edit the attributes included in the report
for the entity type, click Attributes. In the Attributes window, select each attribute of the selected entity
type to include in the report.

Defining Potential Code Anomalies

You can view and modify existing definitions of potential code anomalies (other than range overlaps and
range jumps) in the Interactive Analysis advanced search criteria in the Coding Standards folder.

To define a new code anomaly, you must define an advanced search criterion for the anomaly and a
matching entry in the file <EA Home>\Data\CodeDefects.xml. The entry has the form:

<DEFECT Id=""name"
Internal="True|False"
Enabled="True|False"
Caption="display name"
ListName="1list name"
Criterion="path of criterion"
Model="Model Type'/>

where:

e 1dis a unique name identifying the code anomaly in the product.
< Internal specifies whether the anomaly is implemented internally in program code (True), or
externally in an advanced search criterion (False).

i Note: You must specify False. Code anomalies with an Internal value of True cannot be modified.

« Enabled specifies whether the code anomaly is displayed in the Executive Report.

e Caption is the display name for the anomaly in the Executive Report.

« ListName is the name of the list of anomalous code constructs displayed in the Executive Report
category of the Interactive Analysis Code Search tool.

e Criterion is the full path name of the criterion in the Interactive Analysis Advanced Search tool,

including the tab name (General) and any folder names. For example, General:Coding Standards
\MOVE Statements\Possible Data Padding.

* Model is the Interactive Analysis model for the source files to be searched, e.g., "COBOL".
Some of the commonly used model types are:

e COBOL - COBOL source files

e JAVAFILE - Java source files

e JCL - JCL source files

* NATURAL - NATURAL source files
e PLI - PL/I source files
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Note: Not all possible model types are listed above. Some model types like PL/SQL files do not
have level 2 support, so cannot have Code Search queries run against them. For more
information, see Supported Features by Language.

For some languages, such as C and C++, there are no pre-defined Code Search queries, so they
have not been listed.

Note: You can find the full list of models in the Enterprise Analyzer installation directory, under
\ModeI\HyperCode. You can find the exact name of the model to use in the CodeDefects.xml
in the model file itself. For example, you can find the model name for COBOL in the NAME attribute
in the following line in the Cobol . xml file:

<HYPERCODEMODEL NAME="COBOL' DESCRIPTION="COBOL Programs' VERSION="1.1">

Note: To get the code anomalies to appear on the report, you need to not only enable the Code
defect entry, but to also select the Code Defects option from Project Options > Reports > Executive
Report.

The following are examples of different defect entries:

<DEFECT Criterion="General:Coding Standards\MOVE Statements\Possible Sign
Loss"

ListName="Possible Sign Loss"

Caption="Possible Sign Loss"

Group=""Cobol Coding Standards"

Enabled=""True"

Internal="False"

Id=""Sign"

Model=""COBOL""/>

<DEFECT Criterion="General:Coding Standards\Unaligned Assignments"
ListName=""Unaligned Assignment"

Caption="Unaligned Assignment"

Group="Pli Coding Standards"

Enabled=""True"

Internal="False"

Id=""Unaligned"

Model="PLI1"/>

<DEFECT Criterion="General:Java Best Practices\Basic\Empty If Statements"
ListName="Empty If Stats"

Caption="Empty If Statements"

Group="Java Results"™ Enabled="True"

Internal="False"

Id=""Empl fStnts"

Model="JAVAFILE"/>

You can display the anomaly caption in Japanese or Korean in the Executive Report by creating an entry
for the anomaly in the file <EA Home>\Language\[Jpn|Kor]\CodeDefects.xrc. The entry has the form:

<String name="name"
listname="list name"
caption="translated display name"
description="description"/>

where:

* name is the unique name of the code anomaly in the product (1d attribute of CodeDefects.xml entry).

< listname is the name of the list of anomalous code constructs displayed in the Executive Report
category of the Interactive Analysis Code Searchr tool (ListName attribute of CodeDefects.xml entry).

» caption is the translated display name for the anomaly in the Executive Report.
e description contains a description of the entry.
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COBOL Range Overlaps and Range Jumps Detected in the Executive Report

This section lists COBOL range overlaps and range jumps detected in the Executive Report. S* defects
appear in the report under “Range Overlaps” as the sum of all defects S1+S2+S3+S4+S5+S6. G* defects
appear in the report under “Range Jumps” as the sum of all defects G1+G2+G3+G5+G6+G7.
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Viewing CRUD Reports

The CRUD Report for a project shows the data operations each program in the project performs, and the
data objects on which the programs operate. To generate a CRUD Report, select a project in the
Repository Browser and choose Reports > CRUD Report . The figure below shows a CRUD Report.

Project options on the Options > Project Options > Reports > CRUD Report tab determine the data
operations and program-to-data object relationships displayed in CRUD reports. To refresh the report after
modifying display options, choose File > Refresh in the CRUD Report window. To generate the report in
HTML, choose File > Report.

Note: The IMS data column of the CRUD report behaves differently from the columns for other data
types. What appears in the IMS data column cells depends on what can be determined. If the
segment can be determined, the cell is populated with the PSB name and segment name. Otherwise,
the segment name is left blank. The format is XXXXXX . yyyyyyy, where xxxxxx is the PSB name
and yyyyyyy is the segment hame or blank if the segment cannot be determined.

Setting CRUD Report Options

Use the Report > CRUD Report tab of the Project Options window to specify the data operations and
program-to-data object relationships displayed in CRUD Reports.

1. Choose Options > Project Options. The Project Options window opens. Click the Report tab, then the
CRUD Report tab.

2. Place a check mark next to each type of program-to-data object relationship you want to display.

3. Place a check mark next to each type of data operation you want to display.

Exporting for Fortify Security Analysis (MBS)

You can create and save a Mobile Build Session (MBS) using verified COBOL files. The MBS includes
COBOL files and their respective copybooks. When created the MBS is saved to a single file with a _.mbs
file extension. The _mbs file can then be imported into the Fortify Static Code Analyzer (SCA) for security
analysis.

To create and export an MBS file, perform the follow steps:

1. In the Repository browser, select a project that contain verified COBOL files or select individual verified
COBOL files.

2. Click Reports > Export for Fortify Security Analysis (MBS).

This opens the Export for Fortify Security Analysis (MBS) dialog box.
3. Browse to the location you want to save the file to.
4. In the File name field, type the name of the file to save.
5. Click Save.

Distinguishing between Homonyms in the Reports

Sometimes there are several items with the same name in the repository. To distinguish between them in
the reports, you can set Enterprise Analyzer to display their location.

To do so:

1. Go to Options > Woorkspace Options > Homonyms.
2. Check Show Source Path in Reports.
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i Note: This option is unchecked by default.

When Show Source Path in Reports is enabled, the Complexity Metrics report, Unresolved Report, Cross
Reference Report, and CRUD Report will contain a column showing the path with the file name to
distinguish between objects with the same name. In the Complexity Metrics report the column is called
Source Path.

Inventorying Applications

Users often ask why the Enterprise Analyzer parser encounters errors in working production systems. The
reasons usually have to do with the source file delivery mechanism: incorrect versions or copybooks,
corruption of special characters because of source code ambiguities, FTP errors, and so forth.

Use Enterprise Analyzer inventory analysis tools to ensure that all parts of your application are available to
the parser:

» Reference Reports let you track referential dependencies in verified source.

« Orphan Analysis lets you analyze and resolve objects that do not exist in the reference tree for any top-
level program object, so-called orphans. Orphans can be removed from a system without altering its
behavior.

« Decision Resolution identifies and lets you resolve dynamic calls and other relationships that the parser
cannot resolve from static sources in Cobol, PL/I, and Natural programs.

Using Reference Reports

When you verify a legacy application, the parser generates a model of the application that describes the
objects in the application and how they interact. If a Cobol source file contains a COPY statement, for
example, the system creates a relationship between the file and the Cobol copybook referenced by the
statement. If the copybook doesn’t exist in the repository, the system flags it as missing by listing it with a

P symbol in the tree view of the Repository Browser.

Reference Reports let you track these kinds of referential dependencies in verified source:

« An Unresolved Report identifies missing application elements.

< An Unreferred Report identifies unreferenced application elements.

« A Cross-reference Report identifies all application references.

« An External Reference Report identifies references in object-oriented applications to external files that
are not registered in the workspace, such as .java, Java Archive (JAR), or C++ include files (assuming
you have identified the locations of these files in the Workspace Verification options window for the
source files). These references are not reported as unresolved in the Unresolved Report.

| Tip: The Missing Files report in the Verification Report tool is a convenient alternative to an
~ Unresolved Report when you are interested only in missing source files, and not in unresolved objects

like system programs.

Understanding the Reference Reports Window

Use Reference Reports to track referential dependencies in verified project source. To open the Reference
Reports window, select a project in the Repository Browser and choose Reports > Reference Reports .

When the Reference Reports window opens, choose the Reference Report type in the Report type drop-
down. To limit the report to references in the current project, choose View > Restrict References to
Project. To generate the report in HTML, choose File > Report.

The figure below shows an Unreferred Report window. The windows for the other reports are similar. By
default, all Reference Report panes are displayed. Select the appropriate choice in the View menu to hide
a pane. Select the choice again to show the pane.
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Main Pane

The Main pane displays the objects in the Reference Report and their relationships. The table below
describes the columns in the Main pane.

reference Report

Column Report Type Description

Object Name All The name of the unresolved, unreferenced, cross-
referenced, or externally referenced object.

Object Type All The entity type of the unresolved, unreferenced,
cross-referenced, or externally referenced object.

Legacy Object Unreferred Report, Cross- | The source file that contains the unreferenced or

reference Report cross-referenced object.
Source Unreferred Report, Cross- | The location in the workspace folder of the source

file that contains the unreferenced or cross-
referenced object.

Referred by

Unresolved Report, Cross-
reference Report, External
Reference Report

The name of the referring object.

Referring Object Type

Unresolved Report, Cross-
reference Report, External
Reference Report

The entity type of the referring object.

Relationship

Unresolved Report, Cross-
reference Report, External
Reference Report

The relationship between the unresolved, cross-
referenced, or externally referenced object and the
referring object.

Object Description

All

The description of the unresolved, unreferenced,
cross-referenced, or externally referenced object
entered by the user on the Description tab of the
Object Properties window.

Preview Pane

The Preview pane lets you browse Interactive Analysis information for the object selected in the Report
pane. The information available depends on the type of object selected. You see only source code for a
copybook, for example, but full Interactive Analysis information for a program. Choose the information you
want to view for the object from the Source drop-down.

Setting Reference Reports Options

Use the Report > Reference Reports tab of the Project Options window to specify the entity types for

which reference report information is collected.

1. Choose Options > Project Options. The Project Options window opens. Click the Report tab, then the
Reference Reports tab.

2. Place a check next to each type of entity you want to be included in reference reports.

Using Orphan Analysis Reports

An object that does not exist in the reference tree for any top-level object is called an orphan. Orphans can
be removed from a system without altering its behavior. Use the Orphan Analysis tool to find orphans.

What's the difference between an orphan and an unreferenced object?

« All unreferenced objects are orphans.
« Not every orphan is unreferenced.
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Suppose an unreferred report shows that the copybook GSS3.CPY is not referenced by any object in the
project. Meanwhile, a cross-reference report shows that GSS3.CPY references GSS3A.CPY and
GSS3B.CPY.

These copybooks do not appear in the unreferred report because they are referenced by GSS3.CPY. Only
orphan analysis will show that the two copybooks are not in the reference tree for the GSS program and,
therefore, can be safely removed from the project.

Understanding the Orphan Analysis Window

Use the Orphan Analysis tool to determine whether an object exists in the reference tree for a top-level
program object. To open the Orphan Analysis tool window, select a project in the Repository Browser and
choose Prepare > Orphan Analysis.

Project options on the Report > Orphan Analysis tab specify the search filter for the report. To refresh the
report after modifying the options, choose Orphans > Refresh in the Orphan Analysis window. To
generate the report in HTML, choose File > Save Report As.

Note: The Filter, Startup, and Find panes let you use hyperlinks to set up and apply the Orphan
Analysis search filter. Use these panes instead of the options window if you prefer.

The figure below shows the Orphan Analysis window. By default, all Orphan Analysis panes are displayed.
Select the appropriate choice in the View menu to hide a pane. Select the choice again to show the pane.
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Found Objects Pane

The Found Objects pane shows the name, type, and source location of orphans. To show the list of
orphans only, deselect View > Report View.

Orphan Source Pane

The Orphan Source pane lets you browse Interactive Analysis information for the object selected in the
Found Objects pane. The information available depends on the type of object selected. You see only
source code for a copybook, for example, but full Interactive Analysis information for a program. Choose
the information you want to view for the object from the Source drop-down.

Setting Orphan Analysis Options

Use the Report > Orphan Analysis tab of the Project Options window to specify the search filter for an
Orphan Analysis report.

1. Choose Options > Project Options. The Project Options window opens. Click the Report tab, then the
Orphan Analysis tab.
2. In the Startup pane, click Select Startup Types. The Startup dialog opens.

3. In the Startup dialog, set up a search filter for the startup objects in the orphan analysis. You can filter
on entity type, entity name, or both:

« To filter on entity type, place a check next to the entity type you want to search for in the Roots pane.

« To filter on entity name, place a check next to a recognized matching pattern in the Like pane, the
Unlike pane, or both. Add patterns as necessary. You can use wildcard patterns allowed in LIKE
statements by Visual Basic for Applications (VBA).

4. When you are satisfied with your choices in the Startup dialog, click OK.

5. In the Find pane, define the terms of the search by selecting the appropriate choice in the
Relationships to Checked Startups drop-down, the Relationships to Unchecked Startups drop-
down, or both.

6. In the Entities pane, click Displayed Types. The Entities dialog opens. In the Entities dialog, place a
check next to each type of entity to include in the report. When you are satisfied with your choices in the
Entities dialog, click OK.

Deleting Orphans from a Project

To delete an orphan from a project (but not the workspace), select the orphan in the Found Objects pane
and choose Orphans > Exclude from Project.

Deleting Orphans from a Workspace

To delete an orphan from the workspace, select the orphan in the Found Objects pane and choose
Orphans > Delete from Workspace.

Resolving Decisions

You need to have a complete picture of the control and data flows in a legacy application before you can
diagram and analyze the application. The parser models the control and data transfers it can resolve from
static sources. Some transfers, however, are not resolved until run time. Decision resolution lets you
identify and resolve dynamic calls and other relationships that the parser cannot resolve from static
sources.
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Understanding Decisions

A decision is a reference to another object, a program or screen, for example, that is not resolved until run
time. Consider a Cobol program that contains the following statement:

CALL “NEXTPROG”.

The Enterprise Analyzer parser models the transfer of control to program NEXTPROG by creating a Calls
relationship between the original program and NEXTPROG.

But what if the statement read this way instead:

CALL NEXT.

where NEXT is a field whose value is only determined at run time. In this case, the parser creates a Calls
relationship between the program and an abstract decision object called PROG.CALL.NEXT, and lists the

decision object with a B icon in the tree view of the Repository Browser.

The Decision Resolution tool creates a list of such decisions and helps you navigate to the program source
code that indicates how the decision should be resolved. You may learn from a declaration or MOVE
statement, for example, that the NEXT field takes either the value NEXTPROG or ENDPROG at run time.
In that case, you would resolve the decision manually by telling the system to create resolves to
relationships between the decision and the programs these literals reference.

Of course, where there are hundreds or even thousands of such decisions in an application, it may not be
practical to resolve each decision manually. In these situations, you can use the autoresolve feature to
resolve decisions automatically.

The Decision Resolution tool analyzes declarations and MOVE statements, and any other means of
populating a decision point, to determine the target of the control or data transfer. The tool may not be able
to autoresolve every decision, or even every decision completely, but it should get you to a point where it is
practical to complete decision resolution manually.

Understanding the Decision Resolution Tool Window

Use the Decision Resolution tool to view and manually resolve decisions. To open the Decision Resolution
tool window, select a project in the Repository Browser and choose Prepare > Resolve Decisions.

To save decision resolutions to the repository, choose File > Save. To generate the Decision Resolution
report in HTML, choose File > Report.

The figure below shows the Decision Resolution window. By default, all Decision Resolution panes are
displayed. Select the appropriate choice in the View menu to hide a pane. Select the choice again to show
the pane.
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Decision List Pane

The Decision List pane displays the decisions in the project. To filter the list, choose the type of decision
you want to display in the Decision Type drop-down. The table below describes the columns in the
Decision List pane.

Column Description

Name The name of the object that contains the decision.

Type The type of the object that contains the decision.

Variable The program variable that requires the decision.

Completed Whether the decision has been resolved.

Unreachable Whether the decision is in dead code.

Manual Whether the decision was resolved manually.

Resolved to The target object the variable resolves to (an entry point, for
example). An unresolved decision contains the grayed-out text Some
Object.

Available Targets Pane

For the selected decision type, the Available Targets pane lists the objects in the workspace to which the
decision can be resolved. To resolve a decision to an available target, select the decision in the Decision
List pane and place a check next to the target.
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To limit the targets to objects in the current project, choose View > Restrict to Current Project. To delete
a decision resolution, uncheck the target. To undo changes, choose Edit > Undo all changes.

Source Pane

The Source pane lets you browse Interactive Analysis information for the object selected in the Decision
List pane. The information available depends on the type of object selected. You see only source code for a
copybook, for example, but full Interactive Analysis information for a program. Select the information you
want to view for the object from the drop-down in the upper lefthand corner of the pane.

Resolving Decisions Manually

Follow the instructions below to resolve decisions manually to targets in or out of the workspace.

1. To resolve decisions to available targets, select one or more entries in the Decision List pane and check
one or more target objects in the Available Targets pane. If you link an entry to multiple targets, the
Decision Resolution tool creates as many entries in the Decision List pane as there are targets.

Note: If you are linking an entry to multiple targets, you can save time by selecting the targets and
choosing Edit > Link Selected Targets. You can also choose Edit > Copy to copy selected
targets to the clipboard, then Edit > Paste to link the targets to an entry.

2. To resolve decisions to targets not in the workspace, select one or more entries in the Decision List
pane and choose Edit > Link New Target. The Link New Target window opens.

3. Inthe Link New Target window, enter the name of the new target in the field on the righthand side of the
window, or populate the field by clicking a literal in the list of program literals on the Literals tab. Filter
the list by using:

« The Minimum Literal Length slider to specify the minimum number of characters the literal can
contain.

¢ The Maximum Literal Length slider to specify the maximum number of characters the literal can
contain.

* The Names Like field to enter a matching pattern for the literal. You can use wildcard patterns
allowed in LIKE statements by Visual Basic for Applications (VBA).

4. Check Completed if you want the resolution to be marked as completed. When you are satisfied with
your entry, click OK.

Restoring Manually Resolved Decisions

Reverifying a file invalidates all of its objects, including its manually resolved decisions. The decision
persistence feature lets you restore manually resolved decisions when you return to the Decision
Resolution tool.

After reverifying a file for which you have manually resolved decisions, reopen the Decision Resolution tool.
A dialog box prompts you to restore manually resolved decisions. Click Yes if you want to restore the
decisions. Click No otherwise.

Note: Check Don’t show me again if you want the Decision Resolution tool to open without
prompting you to restore manually resolved decisions. In the Decision Resolution Tool tab of the User
Preferences window, check Ask before restoring previous manual changes if you want to be
prompted again.

Resolving Decisions Automatically

You can autoresolve decisions during verification by setting the Resolve decisions automatically option
on the Verification tab of the Project Options window for a source file type.

For programs only, you can autoresolve decisions after verification by selecting the project, folder, or files
for which you want to autoresolve decisions and choosing Prepare > AutoResolve Decisions. Only a
master user can autoresolve decisions in a multiuser environment.
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Note: Decision Resolution cannot autoresolve every decision. The target name may be read from a
data file, for example.

Setting Decision Resolution Tool User Preferences

Use the Decision Resolution Tool tab of the User Preferences window to specify whether you want to be
prompted to restore invalidated manually resolved decisions when you reopen the Decision Resolution
tool.

1. Choose Tools > User Preferences. The User Preferences window opens. Click the Decision
Resolution Tool tab.

2. Select Ask before restoring previous manual changes if you want to be prompted to restore
manually resolved decisions when you reopen the Decision Resolution tool.

Identifying Interfaces for Generic API Analysis

Use the Generic API Analysis feature if your legacy program calls an unsupported API to interface with a
database manager, transaction manager, or similar external facility. In this call, for example:

CALL "XREAD® using X

where X refers to a table name, the call to XREAD is of less interest than its parameter, the table the called
program reads from. But because the parser does not recognize XREAD, only the call is modeled in the
EA repository.

You enable the Generic API Analysis feature by identifying unsupported APIs and their parameters in the
file \<EA Hone>\Data\lLegacy .xml. Before you verify your application, set Perform Generic API
Analysis on the Verification tab of the Project Options window. That option tells the parser to define
relationships with the objects passed as parameters in the calls, in addition to relationships with the
unsupported APIs themselves.

This section shows you how to identify the programs and parameters to the parser before verifying your
application. You can specify both object and construct model information, and create different relationships
or entities for the same parameter in a call.

/v, Attention:

The specification requires a thorough understanding of the Enterprise Analyzer repository models.
For background information on the repository models, see the following documentation sections:

* How Enterprise Analyzer Models Applications in Getting Started.
« Understanding the Application-Level Metamodel in Using Architecture Modeler
¢ Using the Model Reference Pane in Interactive Analysis

y Note: Only the predefined definitions described in this section are guaranteed to provide consistent
data to EA databases.

f Note: For altered Legacy . xml files: The Legacy . xml file that resides in the \<EA Hone>\Data
directory gets overwritten when a new HotFix is installed. To preserve the changes made to the file:

1. Create an empty file Legacy .xml in the workspace directory. You can use the \<EA Hone>
\Data\Legacy.xml _user file as a template.

2. Add only the tags that need to be added or altered

3. Save the file and verify the sources.

We do not recommend copying the \<EA Home>\Data\Legacy.xml file to the workspace directory and
then altering it as needed, since the altered file is merged with the original file every time the parsers are
required to read them. An example of a user-defined Legacy - xml is:

<Legacy>
<Cobol>
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<OverloadedDiagnostics>
<msg num="'2054" sev="'2"/>
</OverloadedDiagnostics>
</Cobol>
</Legacy>

Identifying Unsupported API Calls to the Parser

Follow the instructions in the steps below and the detailed specifications in the following sections to identify
unsupported API calls to the parser. For each call, you need to define an entry in \<Enterprise Analyzer
Home>\Data\Legacy.xml that specifies at a minimum:

e The name of the called program and the method of invocation in the <match> tag.

* The program control flow in the <flow> tag, and the direction of the data flow through the parameters of
interest in the <param> subtags.

* How to represent the call in the object model repository in the <rep> tag, and in the construct model
repository in the <hc> tag.

Use the optional <vars> tag to extract values of a specified type, size, and offset from a parameter for use
in a <rep> or <hc> definition.

Most repository entities can be represented in a <rep> or <hc> definition with the predefined patterns in
\<Enterprise Analyzer Home>\Data\Legacy.xml.api. These patterns do virtually all of the work of the
specification for you, supplying the relationship of the entity to the called program, its internal name, and so
forth.

The syntax for specifying predefined patterns in a <rep> or <hc> definition is described in the section for
the tag. Consult Legacy.xml.api for supported patterns and for required parameters and values.

1. Open the file \<Enterprise Analyzer Home>\Data\Legacy.xml in an editor.
2. Locate the <GenericAPI> section for the language and dialect you use.

3. Create entries for each unsupported API call, following the specifications in the sections below and the
samples of Generic API usage in Legacy.xml.

4. Click Options > Project Options > Verification tab. Click Advanced in the Advanced Program
Analysis section, then check Perform Generic APl Analysis and then click OK.

5. Verify the project.

Using the API Entry Tag

The name attribute of the <API Entry> tag is the name of the entry, used for error diagnostics only.

Using the match Tag

The stmt attribute of the <match> tag identifies the method of invocation: a CALL, LINK, or XCTL
statement. The value attribute of the <name> subtag identifies the name of the program to be matched. It
can also be used to specify an alternative name for the entry.

Note: The name of the program to be matched must be unique in the <GenericAPI> section. If names
are not unique, the parser uses the last entry in which the name appears.

Example

<match stmt="CALL">
<name value=""XREAD"/>
</match>
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Using the flow Tag

The <flow> tag characterizes the program control flow. The halts attribute of the <flow> tag specifies
whether the calling program terminates after the call:

« yes, if control is not received back from the API.
* no (the default), if the calling program returns normally.

The <param> subtag identifies characteristics of the call parameters. Attributes are:

« index is the index of the parameter that references the item of interest, beginning with 1. Use an asterisk
(*) to specify all parameters not specified directly.

» usage specifies the direction of the data flow through the parameter: r for input, w for output, rw for
input/output. Unspecified parameters are assumed to be input/output parameters.

Note: halts is supported only for call statements. For PL/I, input parameters are treated as input/
output parameters.

Example

<flow halts="no">
<param index="1" usage="r"/>
<param index="2" usage="r"/>
<param index="3" usage="rw"/>
<param index="*" usage="rw"/>
</flow>

Using the vars Tag

Use the <vars> tag to extract values of a specified type, size, and offset from a call parameter. You can
then refer to the extracted values in the <rep> and <hc> tags using the %var_name notation.

The <arg> subtag characterizes the argument of interest. Attributes are:

» var specifies the variable name.

« param specifies the index of the parameter.

« type specifies the variable type.

« offset specifies the offset of the field in bytes.
» Dbitoffset specifies the offset of the field in bits.
» size specifies the size of the field in bytes.

« bitsize specifies the size of the field in bits.

Additional attributes for PL/I are:

« len specifies the size of a character or bit string field.

* mode specifies the binary or decimal mode for a numeric field.

» scale specifies the scale of a fixed-point numeric field.

» prec specifies the precision of a fixed-point or floating-point numeric field.

« varying specifies whether a bit string variable is encoded as a varying-length string in the structure (yes
or no, the default).

Supported data types are described in the language-specific sections below.

Example

Suppose a call to a database-entry API looks like this:

CALL "DBNTRY®" USING DB-USER-I1D
DB-XYZ-REQUEST-AREA
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XYZ01-RECORD
DB-XYZ-ELEMENT-LIST.

If the second parameter contains a 3-character table name in bytes 6-8, the following definition extracts the
name for use as the right end of a relationship:

<vars>
<arg var="TableName~
param="2*
type="auto”
offset="5"
size="3"/>
</vars>
<rep>
<rel>
<target type="TABLE"
name="%TableName"/>

</rel>
</rep>

COBOL-Specific Usage
For COBOL, use the following data types in the <vars> tag:

» data extracts a subarea of the parameter as raw byte data. You must specify the size and offset.

< auto automatically determines the type of the variable, using the offset. If that is not possible, auto looks
for a matching variable declaration and uses its type. You must specify the offset.

e int behaves as auto, additionally checking that the resulting value is a valid integer and converting it to
the canonical form. Offset defaults to O.

Note: Do not use auto when the content of a numeric field is binary. Use int. The parser extracts the
binary content and converts it to the corresponding numeric string.

bitoffset and bitsize are currently not supported.

auto is not always reliable. Use data whenever possible.

PL/I-Specific Usage
For PL/I, use the following data types in the <vars> tag:

» data extracts a subarea of the parameter as raw byte data. You must specify the size and offset.

» char specifies a character variable, with attribute varying if the string is encoded as a varying-length
string in the structure. Offset defaults to 0, and size is specified via the required len attribute, which
specifies the string length.

« bit specifies a bit string variable, with attribute varying if the string is encoded as a varying-length string
in the structure. Offset defaults to 0, and size is specified via the required len attribute, which specifies
the string length in bits.

» fixed specifies a fixed-point numeric variable, with attributes mode (binary or decimal, the default), scale
(default 0), and prec (precision, default 5). Offset defaults to 0, and size is overridden with a value
calculated from the type.

» float specifies a floating-point numeric variable, with attributes mode (binary or decimal, the default) and
prec (precision, default 5). Offset defaults to 0, and size is overridden with a value calculated from the

type.
f Note: Do not use bitoffset and bitsize for types other than bit string.
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Natural-Specific Usage

For Natural, use the auto data type in the <vars> tag. auto automatically determines the type of the
variable, using the offset. If that is not possible, auto looks for a matching variable declaration and uses its
type. You must specify the offset.

Using the rep and hc Tags

Use the <rep> tag to represent the API call in the object model repository. Use the <hc> tag and the
<attr> subtag to represent the construct model (HyperCode) attributes of entities defined in the call.

You can use predefined or custom patterns to specify the relationship of interest. Expressions let you
extract parameter values and context information for use in specifications of entity or relationship
characteristics.

Use the case statement to produce relationships between programs. When a Legacy . xml value resolves
to" Fail__"in a case statement, the relationship will not be produced. For example:

<progname switch-var="%fname">
<case eg="LINKDATA" value="%pname" type="Calls" params="%3"/>
<case eg="LINK" value="%pname®" type="Calls"™ params="%3"/>
<case eq="READQTS" value="__ fail__" type="__ fail__"/>
</progname>

will not produce a relationship for 'READQTS'

Using Predefined Patterns

Most repository entities can be represented with the predefined patterns in \<EA Home>\Data
\Legacy.xml.api. These patterns do virtually all of the work of the specification for you, supplying the
relationship of the entity to the called program, its internal name, and so forth. They are guaranteed to
provide consistent data to EA databases.

To specify a predefined pattern, use the pattern name as a tag (for example, <tip-file>) anywhere you might
use a <rel> tag. If the predefined pattern is specified at the top level of the entry, the parser creates a
relationship with the calling program. If the predefined pattern is nested in an entity specification, the parser
creates a relationship with the parent entity.

Each pattern has parameters that you can code as XML attributes or as subtags. So:

<transaction name="%2" params="" hc-kind="dpsSETRX"/>

is equivalent to:

<transaction params="">

<name value="%2"/>

<hc-kind value ="dpsSETRX"/
</transaction>

Use the subtag method when a parameter can have multiple values:

<file filename= "%2" data-record="%3">
<action switch-var="%op">
<case eg="1" value="Reads"/>
<case eg="2" value="Reads"/>
<case eg="4" value="Updates®"/>
<case eg="28" value="Inserts"/>
</action>
<hc-kind switch-var="%op">
<case eg="1" value="fcssRR"/>
<case eg="2" value="fcssRL"/>
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<case eg="4" value="fcssWR"/>
<case eg="28" value="fcssAW"/>
</hc-kind>
</File>

Look at Legacy.xml.api for further details of predefined pattern usage and for required parameters and
values.

Using Custom Patterns

Use custom patterns only when a predefined pattern is not available. Custom patterns are not guaranteed
to provide consistent data to EA databases.

Using the entity Subtag
The <entity> subtag represents an entity in the object model repository. Attributes are:

* type specifies the entity type.
* name specifies the entity name.

» produced optionally indicates whether the entity is extracted, in which case it is deleted from the
repository when the source file is invalidated (yes or no, the default).

Use the <attr> subtag to specify entity attributes. Attributes of the subtag are:

* name specifies the attribute name.
« value contains an expression that defines the attribute value.
« join specifies the delimiter to use if all possible variable values are to be joined in a single value.

Use the <cond> subtag to specify a condition.

Using the rel Subtag
The <rel> subtag represents a relationship in the object model repository. Attributes are:

« name specifies the relationship end name, which can be unrolled into a separate tag like the name or
type of an entity.
« decision specifies a decision.

The <target> and <source> subtags represent, respectively, the right and left ends of the relationship.
These subtags are equivalent in function and syntax to the <entity> tag. Use the <cond> subtag to specify
a condition.

i Note: As a practical matter, you will almost never have occasion to use the <entity> subtag.

If the <rel> subtag is specified at the top level of the entry, and no <source> tag is specified, the parser
creates the relationship with the calling program; otherwise, it creates the relationship between the
<source> and <target> entities. If the <rel> subtag is nested in an entity specification, the parser creates
the relationship with the parent entity.

Example

Assume that we know that the second parameter in the API call described earlier for the <vars> tag
contains a variable in bytes 1-3 that specifies the CRUD operation, in addition to the variable in bytes 6-8
specifying the table name. The following definition extracts the CRUD operation and table name:

<vars>
<arg var="%0OpName*
param="2*
type="data“
offset="0"
size="3"/>
<arg var="TableName*"
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param="2*
type="auto”
offset="5"
size="3"/>
</vars>
<rep>
<rel>
<target type="TABLE"
name="%TableName*" />
<name switch-var="%0pName">
<case eg="RED" value="ReadsTable"/>
<case eg="UPD" value="UpdatesTable"/>
<case eq="ADD" value="InsertsTable"/>
<case eg="DEL" value="DeletesTable"/>
</name>
</rel>
</rep>

Using Expressions

Expressions let you extract parameter values and context information for specifications of entity or
relationship characteristics. You can use simple variable names in expressions, or apply a primitive function
call to a variable.

Basic Usage

Use the %var_name or %parameter_number notation to define variables for parameter values. The number
corresponds to the index of the parameter; parameters are indexed beginning with 1. Negative numbers
index from the last parameter to the first.

Variables with names beginning with an underscore are reserved for special values. They generally have
only one value. The table below describes the reserved variable names.

Name Description

_line, _col Line and column numbers of the call in source code.

_file Index of the file in the file table.

_uid UID of the node of the call in the syntax tree.

_fail A permanently undefined variable. Use it to cause explicit failure.

_yes A non-empty string for use as a true value.

_no An empty string for use as a false value.

_pgmname Name of the calling program.

_hcid HyperCode ID of the call node.

_varname nn If parameter number nn is passed using a simple variable reference
(not a constant or an expression), this substitution variable contains
its name. Otherwise, it is undefined.

Simple Notation

The simplest way to use a variable is to include it in an attribute value, prefixed with the percent character
(%). (%% denotes the character itself.) If the character directly after the % is a digit or a minus sign (-), the
end of the variable name is considered to be the first non-digit character. Otherwise, the end of the name is
considered to be the first non-alphanumeric, non-underscore character. In:

"habc.%2def"
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the first variable name is abc and the second is 2. It is also possible to specify the end of the variable name
explicitly by enclosing the name in curly brackets:

"%{abc}.%{2}def"

When evaluated, a compound string like this produces a string value that concatenates variable values and
simple text fragments, or fails if any of the variables is undefined.

Switch Usage

Use a switch-var attribute instead of the value attribute when a tag expects a value with a compound string
expression. The switch-var attribute contains a single variable name (which may be prefixed by %, but
cannot be enclosed in curly brackets). Use <case>, <undef>, or <default> subtags to specify switch cases.
These tags also expect the value attribute, so switches can be nested:

<name switch-var="%var">
<case eg="valuel® value="_._"/>
<case eg="value2® switch-var="%var2">
<undef value="..."/>
</case>
<undef value="..."/>
<default value="..."/>
</name>

When a switch is evaluated, the value of the variable specified using the switch-var attribute is matched
against the literal specified in the <case> tags. The literal must be the same size as the variable. (The
literals valuel and value2 in the example assume that var is defined as having six bytes.) If an
appropriate case is found, the corresponding case value is evaluated.

Set the value and type of the variable to __ Fail__ (two underscores) if you do not want a relationship to
be produced for the variable:

<progname switch-var="%fname">
<case eg=""LINKDATA" value="%pname" type="'Calls' params="%3" />
<case eg=""LINK"™ value="%pname'" type="Calls" params="%3" />
<case eq=""READQTS™ value="_ fail__" type="__ fail__" />
<default value=""" />
</progname>

If the variable is undefined, and the <undef> tag is specified, its value is used; if not, the switch fails.
Otherwise, if the <default> case is specified, it is used; if not, the switch fails.

In cases where more than one switch variable is used, than the result will not be context dependent, this
means that all possible combinations between possible values will be produced. The following example
legacy.xml file demonstrates the behavior:

<Legacy>
<Cobol>
<MicroFocus>
<GenericAPI>
<APIEntry name="CALL XBASE">
<match stmt="CALL">
<name value="XBASE"/>
</match>
<flow halts="no">
<param index="1" usage="r"/>
<param index="2" usage="r"/>
<param index="3" usage="r"/>
<param index="4" usage="r"/>
<param index="5" usage="r"/>
<param index="6" usage="r-/>
</Flow>
<vars>
<arg var="code" param="1" type="data®" offset="0" size="1"/>
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<arg var="filecode®™ param="2°" type="data® offset="0" size="1"/>
</vars>
<rep>
<sqgl-database>
<table switch-var = "%filecode">
<case eg="1" value="FILE1"/>
<case eg="2" value="FILE2"/>
</table>
<column switch-var = "%filecode">
<case eg="1" value="FILE1"/>
<case eg="2" value="FILE2"/>
</column>
<origin value="XBASE" />
<action switch-var ="%code">
<case eg="1" value="Inserts"/>
<case eg="2" value="Deletes"/>
</action>
</sql-database>
</rep>
</APIEntry>
</GenericAPI>
</MicroFocus>
</Cobol>
</Legacy>

Using the following code:

IDENTIFICATION DIVISION.
PROGRAM-1D. testl.
AUTHOR.

ENVIRONMENT DIVISION.

DATA DIVISION.

FILE SECTION.
WORKING-STORAGE SECTION.
01 CODE1 PIC 9.

01 FILECODE PIC 9.
LINKAGE SECTION.

PROCEDURE DIVISION.
FIRST-SECTION SECTION.
FIRST-PARAGRAPH.

MOVE 1 TO CODEL1l.

MOVE 1 TO FILECODE.

PERFORM SECOND-PARAGRAPH.

MOVE 2 TO CODE1.

MOVE 2 TO FILECODE.
PERFORM SECOND-PARAGRAPH .
GOBACK .

SECOND-PARAGRAPH.
CALL "XBASE®" USING CODE1 FILECODE.
EXIT.

This results in the following relations being generated:
e Insertinto FILEL.

e Delete from FILEL.

e Insertinto FILE2.

e Delete from FILE2.

Fallback Chain Usage

Whenever multiple tags specifying a single attribute are presented in a <name>, <type>, or <case>/
<undef>/<default> specification, those tags are joined into a fallback chain. If an entry in the chain fails,
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evaluation proceeds to the next entry. Only when the last entry of the chain fails is the failure propagated
upward:

<name value="%a"/>
<name value="%b"/>
<name value="UNKNOWN®/>

If %a is defined, the name is its value. Otherwise, if %b is defined, the name is %b. Finally, if both are
undefined, the name is UNKNOWN.

Fallback Semantics for Attributes

To determine the value of an attribute, the <attr> definitions for that attribute are processed one by one in
order of appearance within the parent tag. For each definition, all combinations of variables used within it
are enumerated, and all non-fail values produced are collected into a set:

« |If the set contains exactly one value, it is taken as the value of the attribute.

« If the set contains multiple values, and the <attr> tag has a join attribute specified, the values are
concatenated using the value of the join attribute as a delimiter, and the resulting string is used as the
value for the repository attribute.

« Otherwise, the definition fails, and the next definition in the sequence is processed. If there are no
definitions left, the attribute is left unspecified.

This behavior provides a way to determine if the variable has a specific value in its value set. The following
example sets the attribute to False if the first parameter can be undefined, to True otherwise:

<attr name="Completed” switch-var="%1">
<undef value="False"/>

</attr>

<attr name="Completed” value="True"/>

Using a Function Call

When a variable name contains commas, it is split into a sequence of fragments at their boundaries, and
then interpreted as a sequence of function names and their parameters. In the following example:

%{substr,0,4,myvar}

the substr function extracts the first four characters from the value of %myvar. The table below describes
the available functions.

Functions can be nested by specifying additional commas in the last argument of the preceding function. In
the following example:

%{int,substr,0,4,map}

switch-var="trim,substr,4, ,map*”

the first line takes the first four characters of the variable and converts them to a canonical integer, the
second line takes the remainder, removes leading and trailing spaces, and uses the result in a switch, and

so forth.
Function Description
substr,<start>,<size>,<variable> Extracts a substring from the value of the variable. The substring
begins at position <start> (counted from 0), and is <size> characters
long. If <size> is an empty string, the substring extends up to the end
of the value string.
int,<variable> Interprets the value of the variable as an integer and formats it in
canonical form, without preceding zeroes or explicit plus (+) sign. If
the value is not an integer, the function fails.
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Function Description

trim,<variable> Removes leading and trailing spaces from a string value of the
variable.

const,<string> or =,<string> Returns the string as the function result.

warning,<id-num>[,<variable>] Produces the warning specified by <id-num>, a humeric code that

identifies the warning in the backend.msg file, and returns the value
of the variable. If the variable is not specified, the function fails. So %
{warning,12345} is equivalent to %{warning,12345,_fail}.

lookup, <file>, <keyCol>, <valueCol>, Looks up a value from a comma-separated value (CSV) file. The CSV
<variable> file is located on disk at <file>. For each line in that file, <keyCol>
specifies the column (counted from 0) containing the key to match
against <variable> and <valueCol> specifies the column containing
the value to return. If <keyCol> is an empty string, column 0 is
assumed. If <valueCol> is an empty string, column 1 is assumed. If
no matching row is found in the file, an empty string is returned.

upper, <variable> Returns the value of the variable converted to all upper-case
characters.

lower, <variable> Returns the value of the variable converted to all lower-case
characters.

Understanding Enumeration Order

If the definition of the name of a relationship or the name or type of an entity contains substitution variables
that have several possible values, the parser enumerates the possible combinations. The loops are
performed at the boundary of the innermost <entity> or <rel> tag that contains the reference. (Loops for the
target or source are raised to the <rel> level.)

Once the value for a variable has been established at a loop insertion point, it is propagated unchanged to
the tags within the loop tag. So an entity attribute specification that refers to a variable used in the name of
the entity will always use the exact single value that was used in the name.

If the expression for a name or type fails, the specified entity or relationship is locked out from processing
for the particular combination of values that caused it to fail. This behavior can be used to completely block
whole branches of entity/relationship definition tags:

<entity ...>
<type switch-var="%a">
<case eg="1" value="TABLE"/>
</type>
<rel name="InsertsTable® ..../>
</entity>
<entity ...>
<type switch-var="%a">
<case eg="2" value="MAP*"/>
</type>
<rel name="Sends"..../>
</entity>

If %a is 1, the first declaration tree is used, and the table relationship is generated; the second declaration
is blocked. If %a is 2, the second declaration tree is used, and the map relationship is generated; the first
declaration is blocked.

Note: These enumeration rules require that the value of a repository entity attribute not depend on
variables used in the name of an enclosing <rel> tag, unless that variable is also used in the name of
the entity itself. Otherwise, the behavior is undefined.
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Understanding Decisions

A decision is a reference to another object (a program or screen, for example) that is not resolved until run
time. If there are multiple possible combinations of values of variables used in the name of the target entity,
or if some of the variables are undefined, the parser creates a decision entity, replacing the named
relationship with a relationship to the decision and a set of relationships from the decision to each instance
of the target entity.

When you use the <rel> tag at the top level of the repository definition, you can specify a decision attribute
that tells the parser to create a decision regardless of the number of possible values:

¢ yes means that a decision is created regardless of the number of possible values.
* no means that a decision is never created (multiple values results in multiple direct relationships).

e auto means that a decision is created if more than one possible value exists, and is not created if there
is exactly one possible value.

Both the relationship hame and the type of the target entity must be specified as plain static strings, without
any variable substitutions or switches:

<rep>
<rel name="ReadsDataport® decision="yes">
<target type="DATAPORT" name="%_pgmname.%x"/>
</rel>
</rep>

Understanding Conditions

The <cond> subtag specifies a condition that governs the evaluation of declarations in its parent <entity> or
<relationship> tag. The evaluation semantics of the tag follow the semantics for the <attr> tag: a non-empty
string as a result indicates that the condition is true, an empty string or a failure indicates that the condition
is false. Multiple <cond> tags can be specified, creating a fallback chain with <attr>-style fallback
semantics.

Notice in the example given in the section on decisions that the parser creates a decision entity even when
the name of the target resolves to a single value. Use a <cond> subtag in the relationship definition to
avoid that:

<rel name="ReadsDataportDecision”">
<cond if-multi="%x" value="%_yes"/>
<target type="DECISION">
<attr name="HCID" value="%_hcid"/>
<attr name="DecisionType® value="DATAPORT"/>
<attr name="AKA*
value="%_pgmname.ReadsDataport.%_ varnamel®/>
<attr name="AKA"
value="%_pgmname .ReadsDataport. "/>
<attr name="VariableName® value="%_ varnamel®/>
<attr name="Completed” if-closed="%x"
value="True"/>
<rel name="ResolvesToDATAPORT ">
<target type="DATAPORT"
name="%_pgmname .%x"/>
</rel>
</target>
</rel>
<rel name="ReadsDataport”>
<cond if-single="%x" value="%_ yes"/>
<target type="DATAPORT® name="%_pgmname.%x"/>
</rel>
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This repository definition produces the same result as the example in the section on decisions, except that
no decision is created when the name of the target resolves to a single value.

_yes and _no are predefined variables that evaluate, respectively, to a non-empty and empty string for true
and false, respectively. The if-single attribute means that the <cond> tag should be interpreted only if the
specified variable has a single defined value. The if-multi attribute means that the <cond> tag should be
interpreted if the variable has multiple values, none, or can be undefined. The if-closed attribute blocks the
<cond> tag if the variable has an undefined value.

f Note: if-single, if-multi, and if-closed can also be used with the <attr> tag.

Conditions have join set to an empty string by default, resulting in a _yes outcome if any combination of
values of the variables used in switches within causes it to evaluate to _yes. If a particular condition
definition should fail when some of the values evaluate to _no and others to _yes, use a yes-only='yes'
attribute specification. That causes join to be unset, and the condition to give a non-fail outcome only when
all values evaluate to _yes.

In a relationship definition, <cond> determines whether the relationship is generated. For a decision
relationship, it also determines whether the decision entity should be generated.

In an entity definition, <cond> governs all attribute and subrelationship definitions in the tag, and the
creation of the entity in case of a standalone entity. For an entity specified in a <target> or <source> tag,
instantiation of the relationship automatically spawns the corresponding entity, meaning that a false
condition on the source or target of a relationship does not prevent creation of corresponding entities.

Usage Example

The following example illustrates use of the Generic API Analysis feature:

<APIEntry name="Call another program®>
<match stmt=""CALL">
<name value=""INVOKEPGM"/>
</match>
<flow halts="no">
<param index="1" usage="r"/>
<param index="*" usage="w"/>
</flow>
<vars>
<arg var="a" param="2° type="bit" len="5"/>
</vars>
<rep>
<rel name="CallsDecision”™>
<target type="DECISION">
<attr name="AKA*
value="%_pgmname.
Calls. INVOKEPGM(%_varnamel) "/>
<attr name="AKA"
value="%_pgmname.
Calls. INVOKEPGM*" />
<attr name="DecisionType~
value="PROGRAMENTRY " />
<attr name="HCID" value="%_ hcid"/>
<attr name="VariableName*
value="%_ varnamel~/>
<attr name="Completed” switch-var="1">
<undef value="False"/>
</attr>
<attr name="Completed” value="True"/>
<rel name="ResolvesToProgramentry">
target type="PROGRAMENTRY "
name="%1"/>
</rel>
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</target>
</rel>
</rep>
<hc>
<attr name="test" switch-var="%a" join=","
<case eg="00101" value="X"/>
<undef value="?"/>
<default value="%a"/>
</attr>
</hc>
</APIEntry>

Support for IMS Aliases

The <IMSC> subtag in the <Auxiliary> section of Legacy.xml contains definitions for the standard CBLTDLI
or PLITDLI programs. You can also use it to define aliases for non-standard IMS batch interfaces.

If the order of parameters in the alias program is the same as the order of parameters in the standard
program, simply enter the alias name in the <Detect> and <APIEntry> tags, as follows:

<IMSC>
<Cobol>
<Detect>
<item> "CBLTDLI" </item>
<item> "MYCBLTDLI" </item>
</Detect>

<Process>
<APIEntry name="IMS call">
<match stmt="CALL">
<name value="CBLTDLI"/>

<name value="MYCBLTDLI"/>
</match>

é}ﬁrocess>
</Cobol>
</IMSC>

If the order of parameters in the alias program differs from the order in the standard program, you also
need to specify a full API entry, using the:

« <match> tag to define the alias name and method of invocation.
» <flow> tag to characterize the program control flow
* <ims-call> tag to specify the call parameters.

Use the definitions for CBLTDLI or PLITDLI as examples.
Attributes of <ims-call> are:

« count specifies the index of the parameter that contains the argument count.

» opcode specifies the index of the parameter that contains the operation code.

» pcb specifies the index of the parameter that contains the Program Control Block (PCB) pointer.
« arg-base specifies the index of the first data parameter, usually io-area.

Note: Alternative parameter order is allowed only for the params-num, function-code, and pcb
parameters. All other parameters (io-area and ssa) must appear in the same order as they do in the
standard IMS call, at the end of the parameter list.

Skip Type Usage

Use the skip-type attribute of the <param> subtag in the <halts> section to ensure that the optional first
parameter of a Cobol IMS CALL is parsed only if necessary. If the actual parameter passed by the program
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in the first position has the type specified by the regular expression in skip-type, the parameter is filled with
a dummy value and the actual value is used in the next parameter.

i Note: Skip definitions are also available for use in non-IMS generic API entries.

Example
If the first parameter in a call is a 4-character picture, the following definition inserts a dummy value in the
first position and treats the actual value as that of the second parameter:

<param index="1%
usage="r"
skip-type="PIC: (X\(4\) " />

Note: Skip definitions are currently limited to declarations with picture clauses. Use regular
expression syntax to specify normalized picture strings.

Analyzing Projects

Managing Tags

You use a simple tagging language to identify workspace objects as members of functional, structural, or
other types of groupings. After you set up these groupings, you can chart them in EV or “black-box” them in
the Diagrammer.

Each member of a grouping is identified by a tag, "Payroll," for example. Each grouping can, in turn,
reference a more inclusive grouping, "HR," for instance. The figure below shows the tag hierarchy for a
typical enterprise:

Enterprize

Finance

Accounting Fayroll

In fact, this is the default tag structure that ships with EA. The "Enterprise” tag is the root of the structure.
The "Finance,"” "HR," and "Sales" tags represent departments in the enterprise. The "Accounting,"
"Payroll," and "CRM" tags are the applications owned by the departments.
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Understanding the Tag Manager Window

Use the Tag Manager to create and assign tags to objects, and create relationships between tags. To open
the Tag Manager, click Analyze > Tag Manager.

The figure below shows the Tag Manager window. The Objects List pane shows repository objects and
their tags. Your selections in the other Tag Manager panes filter the objects displayed in the Objects List
pane.

By default, all Tag Manager panes are displayed. Select the appropriate choice in the View menu to hide a
pane. Select the choice again to show the pane.

Tag Manager - TrainingAccess1 (TrainingAccess1) |: E|g|

File Edit View Query Help
“ Project Name Access “  Object Type # || [Pbject Name:
Al Objects Entire Workspace All Types E| |
Generated Objects Test Private @BMS Copybook File
Legacy Objects TrainingAccess1 Public %BMS File
Cobnl File
@Copybook File
g?mam Connector —
&% Data Store
'-:4? Dedsion
ffig FCT File
3 File
< | | | g 3cL File il
éﬁunhng EEE::E E:i:ig} £ Object Type Object Name Object Tag ~
Enterprise Public apminisTRAT| [ [E5BMS Copybook File  Test
Finance Public ADMINISTRAT [ [g5BMsS File INQSET1.BMS —
HR Public ADMINISTRAT| f [A0 BMS File MENSET 1.BMS
S . E:i:;gjl [R5 BMS File MMTSET 1.BMS
[E5EMS File ORDSET 1.BMS
Cobol File AR7100.CBL Enterprise
(g5 Coboal File AR7200.chl Accounting
[y Coboal File AR7300.chl
[EqCoboal File CheckDigitécompl, CCP
- (g5 Coboal File CheckDigit.CCP
FLET (& Cobol File CUSTING 1. ccp
Ei?l'tagge 4 Objects (2 Cobol File CUSTMNT L.ccp
Cobol File DCEL.CCP =

Note: When you launch a query based on All Types selection in the Object Types pane, a dialog
opens prompting that you are about to run a long running query and asking if you want to proceed.
This message appears only when the query is likely to run for more than a few seconds. If you choose
not to run it, the Object List's header turns red to indicate that the displayed information does not
match the query.

Object List Pane

The Object List pane displays workspace objects filtered by your selections in the Category, Project, Object
Types, Search, and/or Query panes; or by your selections in the Tags pane.

-

By default, the Object List pane displays up to 100 repository objects and their tags. Click next to the

icon on the toolbar and choose one of:

146 | Enterprise Analyzer



* More Objects in the drop-down menu to display the next 100 objects that match the filter criteria.
« All Objects in the drop-down menu to display all the objects that match the filter criteria.

Category Pane
The Category pane displays the categories you can use to filter objects in the Object List pane:

« All Objects comprises source and generated objects in the workspace.
« Generated Objects comprises generated objects in the workspace.
« Legacy Objects comprises source objects in the workspace.

Projects Pane

The Projects pane displays the workspace projects you can use to filter objects in the Object List pane.
Entire Workspace comprises all the projects in the workspace.

Object Types Pane
The Object Types pane displays the object types you can use to filter objects in the Object List pane.

Search Pane

The Search pane lets you filter the objects in the Object List pane using wildcard patterns allowed in LIKE
statements by Visual Basic for Applications (VBA). Enter the pattern in the Object Name field. The Object
List pane is refreshed as you type.

Note: In large repositories, the Object List pane may not immediately refresh as you type. Press the
Enter key to instantly display matching objects for the current string.

Query Pane

The Query pane lets you filter the objects in the Object List pane using complex queries. Select a query to
filter the Object List by its terms. Select another query and choose one of:

e Add Tags > with <And> in the right-click menu to add its results to the results of previous queries.
* Add Tags > with <Or> in the right-click menu to compare its results with the results of previous queries.

Tags Pane

The Tags pane lists the tags in the workspace. To view the objects that have tags assigned, select one or
more tags and the result will be displayed in the Object List pane.

Creating Tags

To create a tag, choose Edit > Create in the Tag Manager window. A dialog box prompts you to enter the
name of the new tag. Enter the name and click OK. The tag is displayed in the Tags pane.
Specifying Access to Tags

By default, the tags you create are public. To make a tag private, that is, visible only to you, select it and
choose Set Access > Private in the right-click menu. To make the tag public again, choose Set Access >
Public in the right-click menu.

y Note: Tags shipped with the product are always public. You cannot change their access.
Assigning Tags

You can assign tags to objects individually, or to all the objects generated from a source file. You can also
assign tags to objects in the Repository pane, by selecting the objects and choosing Assign/Remove Tags
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in the right-click menu. Select a project or folder to assign tags to every first-level object in the project or
folder.

1. In the Object List pane, select the object(s) you want to assign a tag and choose Edit > Assign/
Remove Tags. The Entity Tag Browser window opens.

Entity Tag Browsern

Tags

£ plame
M e

CRM
Enterprise Delete
Finance

Finance Applications
HF.

HR. Applications
Payrall

Sales

Sales applications

f* Assign
" Remove Reference
v Apply to Derived Objects oK cancel

2. In the Entity Tag Browser window, select the tag(s) you want to assign and click Assign.

3. If you are assigning a tag to a legacy source file, check Apply to Derived Objects to assign the
selected tag(s) to all objects generated from the source file.

4. Click OK to assign the selected tags.

The Object Tag column for the selected object(s) is updated to show the assigned tag(s) in the Objects List
pane.

Removing Tags

Removing a tag simply “unassigns” the tag from the selected object. The tag is not deleted from the
repository. You can also remove tags from objects in the Repository pane, by selecting the objects and
choosing Assign/Remove Tags in the right-click menu. Select a project or folder to remove tags from
every first-level object in the project or folder.

1. In the Object List pane, select the object(s) for which you want to remove tags and choose Edit >
Assign/Remove Tags. The Entity Tag Browser window opens.
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2. In the Entity Tag Browser window, select the tag(s) you want to remove and click Remove.

3. If you are removing a tag from a legacy source file, check Apply to Derived Objects to remove the
selected tag(s) from all objects generated from the source file.

4. Click OK to remove the selected tags.

The Object Tag column for the selected object(s) is updated in the Objects List pane.

Creating Relationships Between Tags

The relationships between tags define the tag hierarchy. Create relationships between tags as described
below.

1. Choose Edit > Reference in the Tag Manager window. The References window opens.
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2.
In the References window, click the Eﬂ button on the toolbar.
3. The Select dialog opens. Select the tags you want to create relationships between and click OK.

Note: You can also draw relationships between tags by clicking the il button on the toolbar.
Select the first tag in the relationship and drag the mouse to the second tag in the relationship,
then release the mouse button. See the Diagrammer help for instructions on how to use the other
diagramming functions in the References window.

The tool draws a line between the referenced tags. To delete a relationship line, select it and click the ﬁn
button on the toolbar.

Deleting Tags

To delete tags from the repository, select them in the Tags pane and choose Edit > Delete Tags. You can
also delete tags in the References window, by selecting them and clicking the & button on the toolbar.

Creating Tag Queries

Use tag queries to filter the objects in the Object List pane in more complex ways than the other panes
allow. Create a tag query as described below.

1. Choose Query > New Query in the Tag Manager window. A dialog box prompts you to enter the name
of the new query. Enter the name and click OK. The query is displayed in the Query pane.

2. Select the query in the Query pane and choose Query > Edit Query. The Query window opens.
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3. Define the terms of the query. Click in the term field you want to define, then select the tag you want to
add to the term definition and click Add. Tags added to the same term are ORed. Tags added to a
different term are ANDed. Click Clear to clear the term definition.

4. When you are satisfied with the query definition, click OK.

Deleting Tag Queries

To delete a tag query, select it and choose Delete in the right-click menu.

Refreshing the Tag Manager Window

To refresh the Tag Manager window with the latest information from the repository, including changes made

*

Cu
by other users, click the button next to the & button on the toolbar and click Refresh in the drop-
down menu. If objects have been deleted from the repository, they will remain visible in the Object List
pane until you clean up the Tag Manager window.

Cleaning Up the Tag Manager Window

When objects are deleted from the repository, Tag Manager continues to display them in the Object List

Cu
pane until you clean up the Tag Manager window. To clean up the window, click '™ next to the ' ®  button
on the toolbar and click Clean Up in the drop-down menu.

Note: This feature is only available to master users. Running a clean up may take several minutes,
depending on the size of your repository.
Generating Reports

To generate an HTML report for all objects currently displayed in the Object List pane, choose File > Save
Report.

Analyzing Relationship Flows

Use the Diagrammer to view the relationships between objects in a scope, a data flow or call map, for
example. These relationships describe the ways in which objects in the scope interact. In the data flow
fragment below, for example, the GSS2 program reads the file GSS2.STATEMS. The file, in turn, is
assigned to the CXXCP.OPKO0O.SNFILE data store.
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Program File | __| Data Store
G552 G552 STATEMS CXXCP.OPKO00.SNFILE

Reads File | Assigned to Data Store |

The Diagrammer’s high-level analysis of relationships lets you quickly trace the flow of information in an
application. You can use it to view program to program calls; program, transaction, and screen flows; job,
program, and data store flows; and much more.

Understanding Relationship Flow Diagrams

Relationship flow diagrams use boxes and lines to show the relationships between objects in a scope.
Depending on the Diagrammer mode, you can display the relationships for:

« All the objects in the selected project.
< Only the objects you copy and paste onto the canvas.

In each mode, all related workspace objects are included in the diagram. In copy-and-paste mode, you can
add objects to an existing diagram and expand the diagram one level at a time.

Objects are color-coded, based on a color scheme of your choosing. If you have assigned business names
to objects, their business names appear in the diagram as well as their technical names. You can “black-
box” items in higher-level groupings that make it easy to visualize their roles in your application, cluster
highly related objects, filter drivers and utilities, and much more.

Understanding Diagram Scopes

The scope of a diagram determines the relationships it displays. To view a diagram of the relationships,
select the scope in the Scope drop-down and choose Scope > View Scope.

The Diagrammer provides default scopes that you can use for most analysis tasks, but you can create your
own scopes if you like. You might want to exclude data stores from a data flow, or include source files in a
call map. Use the Scope Editor to create your own scopes.

Understanding Diagram Layouts

Diagrammer layout styles are designed to produce aesthetically pleasing, easy-to-understand diagrams for

-

a wide variety of needs. To choose a layout style, click on the button for the active layout style, then
select the layout style in the drop-down menu. The following styles are available:
* The & Circular Layout style organizes nodes in clusters of related objects.

* The & Hierarchical Layout style organizes nodes in precedence relationships, with levels for parent
and child object types.

The Orthogonal Layout style organizes nodes in relationships drawn with horizontal and vertical
lines only.

The & Symmetric Layout style (the default) organizes nodes based on symmetries detected in their
relationships.

f Note: The symmetric style typically offers the best performance for very large diagrams.

The & Tree Layout style organizes nodes in parent-child relationships, with child nodes arranged on
levels farther from the root node than their parents.

Click a layout style button in the drop-down to change the style after a diagram is drawn.
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Generating a Diagram for the Selected Project

Follow the instructions below to generate a relationship flow diagram for the selected project. You can
exclude related workspace objects that are not in the project, colorize project boundaries, and show
incomplete relationship chains. You can use tags to “black-box” objects in the diagram.

Note: The Browser pane and project drop-down list in Diagrammer will use the same project filter
from the main window when Diagrammer is opened. Any changes made to the project selection or
project filter in the main window after Diagrammer is opened will not be reflected in Diagrammer.

Chose the type of the diagram - Project Based or Entity Based.

Select a Project from the drop-down list.

In the Scope drop-down, choose the scope of the diagram.

Select a Group By criterion from the drop-down list.

On the Diagram pane tool bar, choose the layout style for the diagram.

In the Project drop-down or Browser pane, select the project.

Click Build Diagram on the Diagrammer tool bar. The diagram is displayed.

N o oD E

Generating a Diagram for Objects Copied and Pasted onto the Canvas

Follow the instructions below to generate a relationship flow diagram for objects copied and pasted onto
the canvas. In this mode, you can expand the diagram one level at a time and add objects to an existing
diagram. You can exclude related workspace objects that are not in the project, colorize project boundaries,
and show incomplete relationship chains. You can use tags to “black-box” objects in the diagram.

1. Inthe Scope drop-down, choose the scope of the diagram.
2. On the Diagram pane tool bar, choose the layout style for the diagram.
3. In the Browser pane, select the startup objects for the diagram, then press CTRL-C to copy them onto
the clipboard.
Note: Make sure to select startup objects in the diagram'’s intended scope. Most scopes include
logical objects rather than source files.

4. To show the entire relationship flow for the selected objects, choose View > Auto Expand. Turn off
Auto Expand if you want to expand the diagram one level at a time after it is drawn. Only immediate
relationships of the selected objects are drawn initially.

5. Click in the Diagram pane, then choose Diagram > Paste or press CTRL-V to paste the objects onto
the Diagrammer canvas.

6. Repeat the preceding step for each object whose relationships you want to add to the diagram. The
diagram is automatically redrawn.

Understanding the Diagrammer Window

Use the Diagrammer to view the relationships between application objects interactively. To open the
Diagrammer, select a project in the Repository Browser and choose Analyze > Diagrammer.

By default all panes in the Diagrammer are empty. Select the attributes for your diagram and click Build
Diagram to create the diagram. Select the appropriate choice in the View menu to hide a pane. Select the
choice again to show the pane.

Diagram Pane
The Diagram pane displays the diagram for the selected scope. To save a diagram in one of the supported
diagram formats, click the n on the Diagram pane tool bar. To save a diagram in one of the supported

image formats, click the @ on the Diagram pane tool bar.
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To print a diagram, click the =) button on the Diagram pane tool bar. To preview the printed diagram, click
the =4 button on the Diagram pane tool bar.

Selecting an Object or Relationship

To enable select mode, click the 3 button on the Diagram pane tool bar.

« To select an object in a diagram, click it on the diagram canvas. Use Ctrl-click to select multiple objects,
or click a blank area of the canvas, then drag the mouse over multiple objects to “lasso” the objects.
Selected objects are displayed with handles that you can use to size the object.

» To select a relationship in a diagram, click it on the diagram canvas. The selected relationship is
displayed in blue.

Searching for an Object

To search for an object in a diagram, enter the text you want to match in the Search field on the
Diagrammer tool bar and press Enter. You can use wildcard patterns allowed in LIKE statements by Visual
Basic for Applications (VBA).

Navigating to an Object from a Relationship

To navigate to the diagram object on the left side of a relationship, select the relationship and choose
Locate Left in the right-click menu. To navigate to the diagram object on the right side of a relationship,
select the relationship and choose Locate Right in the right-click menu.

i Note: Use the Overview pane to navigate to general locations in a diagram.

Expanding and Collapsing Relationships

To expand the incoming relationships for an object in a diagram generated in copy-and-paste mode, select
the object on the diagram canvas and choose Expand > Expand Incoming in the right-click menu. To
expand the outgoing relationships, select the object on the diagram canvas and choose Expand > Expand
Outgoing in the right-click menu.

To collapse the incoming relationships for an object, select the object on the diagram canvas and choose
Collapse > Collapse Incoming in the right-click menu. To expand the outgoing relationships, click the
object on the diagram canvas and choose Collapse > Collapse Outgoing in the right-click menu.

Moving an Object or Relationship

To move an object or relationship in a diagram, select it and drag it to the desired location on the diagram
canvas.

Resizing an Object

To resize an object in a diagram, select it on the diagram canvas and drag one of its handles to the desired
location.

Hiding an Object

To hide objects on the canvas, select an object and choose:

* Hide > Selected in the right-click menu to hide the selected object.
* Hide > Incoming in the right-click menu to hide incoming nodes of the selected object.
* Hide > Outgoing in the right-click menu to hide outgoing nodes of the selected object.

To display the object again, double-click the & button for a related object.

154 | Enterprise Analyzer



Deleting an Object or Relationship

To delete an object or a relationship in a diagram, select it on the diagram canvas and choose Delete
Selected in the right-click menu.

Assigning Tags

You can assign tags manually in Diagrammer or automatically, to all the objects in a cluster. Follow the
instructions below to assign tags manually.

1. Select the objects you want to assign tags on the diagram canvas and click Assign Tags in the right-
click menu. The Entity Tag Browser window opens.

2. In the Entity Tag Browser window, select the tag(s) you want to assign and click Assign.

3. If you are assigning a tag to a legacy source file, check Apply to Derived Objects to assign the
selected tag(s) to all objects generated from the source file.

4. Click OK to assign the selected tags.

Assigning Business Names

To assign a business name and business description to an object, select the object and choose Set
Business Attributes in the right-click menu. A dialog box opens, where you can enter the business name
and business description. To unassign a business name or business description, simply delete the value in
the dialog box.

Note: If multiple objects are selected, Diagrammer displays the dialog box as many times as there are
objects.

Displaying Labels for Multiple Relationships

The Diagrammer denotes that an object has multiple relationships with another object by displaying a
number in parentheses (n) along the relationship line, where n represents the number of relationships.
Double-click the parenthesis to display the relationship labels. Double-click the relationship labels to hide
them again.

Hiding Relationship Labels

To hide relationship labels on the canvas, click the - button on the tool bar and choose Hide

Relationship Labels in the drop-down menu. To show the relationship labels again, click the i~ button
on the tool bar and choose Show Relationship Labels in the drop-down menu. To show hidden nodes as

well as hidden relationship labels, click the i~ button on the tool bar and choose Unhide All in the drop-
down menu.

Displaying the Legend for a Diagram

To display the legend for a diagram, click the - button on the tool bar and choose Show Legend in the
drop-down menu.

Zooming

To zoom in interactive mode, click @ button on the Diagram pane tool bar, then drag the mouse over the
diagram to zoom in on it.

To zoom in marquee mode, click = button on the Diagram pane tool bar, then drag the mouse over the
diagram to draw a marquee. The Diagrammer displays the portion of the diagram inside the marquee.

To fit the diagram in the Diagram pane, click the A, button on the Diagram pane tool bar.
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Moving a Diagram

To move a diagram in the Diagram pane, click the €7 button on the Diagram pane tool bar to choose
panning mode, then hold down the left mouse button and drag the mouse to move the diagram.

Clearing a Diagram

To clear the Diagram pane, choose Diagram > Clear.
Saving a Diagram

Click the n button on the Diagram pane tool bar to save a diagram in one of the supported diagram
types. A Save dialog opens, where you can specify the name, type, and location of the file.

Click the @ button on the Diagram pane tool bar to save a diagram in one of the supported image types.
A Save dialog opens, where you can specify the image type and characteristics. You may also change the
name and location of the file.

Printing a Diagram

Click the = button on the Diagram pane tool bar to print a diagram. A Print dialog opens, where you can
specify the properties of the print job. Click the &4 button to preview the printed diagram.

Generating Diagram Reports

Choose File > Save Type Report to display a printable report based on a diagram. Choose File > Save
Blackbox Interface Report to display a printable report showing the relationships between objects in
different black boxes. In the printable report, click Print to print the report. Click Save to export the report to
HTML, Excel, RTF, Word, or formatted text.

Browser Pane

The Browser pane displays the workspace repository in tree form. The current project is expanded one
level when you first open the Diagrammer.

Note: To improve Diagrammer startup performance in your next session, hide the Browser pane
before you end your current session. Click the close box in the upper righthand corner to hide the
pane. To show the pane again, choose View > Browser.

Relationships Pane

The Relationships pane displays the relationships in the selected scope, as they appear from left to right in
the diagram. Select the relationship for an object in the Relationships pane to navigate to the object in the
Diagram pane.

The list includes relationship chains, or composite relationships, such as
Program[lsDefinedInCobol]Cobol[Includes]Copybook[GeneratesTargetXml]TargetXML. If you chose View >
Potential Incomplete Composite Relationships when you drew the diagram, the list shows incomplete
relationship chains, in which the final object in the chain is unresolved or otherwise unavailable.

Quick View Pane

The Quick View pane lets you browse Interactive Analysis information for the object selected in the
Diagram pane. The information available depends on the type of object selected. You see only source code
for a copybook, for example, but full Interactive Analysis information for a program. Select the information
you want to view for the object from the drop-down in the upper lefthand corner of the pane.
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Overview Pane

The Overview pane lets you navigate to a general location in a diagram. It displays the entire diagram, with
a frame surrounding the portion of the diagram visible in the Diagram pane. Drag the frame to the area of
the diagram you want to view in the Diagram pane. Diagrammer displays the selected area in the Diagram
pane.

Excluding Objects Outside the Project

To restrict the diagram to related objects in the current project, choose View > Exclude Objects Outside
Project. Otherwise, all related workspace objects are included in the diagram.

Showing Incomplete Composite Relationships

A composite relationship defines the indirect interaction of two objects. If a job runs a program entry point
that belongs to a program, for example, the relationship between the job and program is said to be
composite: defined by the chain of relationships between the job and program.

To show incomplete relationship chains in the diagram and list of relationships, choose View > Potential
Incomplete Composite Relationships. Intermediate objects in the chain are displayed even if the final
object in the chain is unresolved or otherwise unavailable. Relationships are displayed in red in the
diagram.

Colorizing Project Boundaries

Boundary objects are objects with relationships to objects outside the project. To colorize boundary objects
in the diagram, choose View > Project Boundary Entities. Boundary objects are displayed in the diagram
with a red border. Related external objects are displayed in the diagram with a blue border.

Showing and Hiding Object Labels

The View > Show in Label menu choice controls the labels displayed for objects in a diagram. Choose
one of:

* View > Show in Label > Show Type to display the type of an object in its label.
* View > Show in Label > Show Name to display the name of an object in its label.
* View > Show in Label > Show Business Name to display the business name of an object in its label.

* View > Show in Label > Show Business Description to display the business description of an object
in its label.

A check mark next to a choice means that the label will be displayed. The choices are toggles. Click the
choice again to hide the information in the label.

Working with Groups

Grouping objects reduces diagram clutter and makes it easy to visualize the roles of the grouped objects in
your application. Groups are automatically created when you black-box tagged objects and when you filter
or cluster objects.

Grouping and Ungrouping Objects

To group objects manually, select the objects on the diagram canvas, then click the - button on the tool
bar and choose Group Selected in the drop-down menu. Inclusive groups are allowed.

To ungroup objects, select the group on the diagram canvas, then click the fi- button on the tool bar and
choose Ungroup Selected in the drop-down menu.
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Expanding and Collapsing Groups
Expand a group to view its contents. Collapse a group to hide its contents.

e Ifagroup is collapsed (including a group in a more inclusive group), double-click it to expand its
contents. To expand all the groups in an inclusive group, select the group on the diagram canvas, then

click the i~ button on the tool bar and choose Expand Groups in the drop-down menu.
» If a group is expanded (including a group in a more inclusive group), double-click it to collapse it. To

collapse all the groups in an inclusive group, select the group on the diagram canvas, then click the -
button on the tool bar and choose Collapse Groups in the drop-down menu.

To view a diagram consisting only of objects in a group, select the group and choose Navigate to Child

Diagram in the right-click menu. To restore the full diagram, click the i~ button on the tool bar and
choose Return to Parent in the drop-down menu.

Moving Objects Between Groups

To move objects between groups, expand the groups, then click the 'I'EI button on the toolbar. Select the
object you want to move and drag it to the new group.

Naming Groups
To rename a group, select it and choose Rename Group in the right-click menu.

f Note: The name does not persist after ungrouping. You cannot rename a black box.

Deleting Groups

To delete a group, select it and choose Delete Group in the right-click menu. You are prompted to confirm
the deletion. Click Yes.

Black-Boxing Tagged Objects

The deeper your understanding of your application, the more confidently you can abstract from its lower-
level details to a “bigger picture” view, one that organizes related programs in functional, structural, or other
types of groupings: a Customer Maintenance subsystem, for example, in an Order Acceptance application.
This is the kind of view a subject matter expert uses to evaluate whether an application does everything it
is supposed to do, in the appropriate order.

The Diagrammer black-box feature lets you assign lower-level objects to higher-level groupings that make it
easy to visualize their roles in your application. Your diagram might have one black box for the Customer
Maintenance subsystem, another for the Order Entry subsystem, and so forth. Because the details of these
relationships are hidden in the black box until you need to view them, the subject matter expert can home
in quickly on the higher-order functions you have abstracted from them.

You use the Tag Manager to identify the items in each higher-level grouping. Each grouping can, in turn,
reference a more inclusive grouping. If you assign the Customer Maintenance tag to one set of programs,
for example, and the Order Entry tag to another, and both tags reference the Application Functions tag,
then when you choose Application Functions in the Diagrammer Group By drop-down, the Diagrammer
puts the programs in black boxes named Application Functions Customer Maintenance and Application
Functions Order Entry.

1. To black-box objects in a diagram, choose the tag for the objects in the Group By drop-down.

y Note: To show only top-level tags in the drop-down, choose View > Root Tags Only.

2. Generate the diagram in project or copy-and-paste mode. The figure below shows expected results.

158 | Enterprise Analyzer



Diagrammer - TrainingG5S (OrderEntry) - Call Map

File Scope Diagram Object View Tom Sawyer Help

Project: [FERE ~!|| scope: [==rmm ~| || Group By: |[application Functions _+ |
Search: | g2 B == |- e B W
Diagram E||

sHHESHd hMAAQA X &3 B 4 e Pe

Program
DCE3

Application Functions Customer Maintenance

Application Functions Order Entry

Application Functions

| £

Filtering Objects

A driver is an object with many outputs, a startup program, for example. A utility is an object with many
inputs, DATEFMT, for example. Filtering drivers and utilities from large diagrams reduces diagram clutter
and typically provides a better picture of what your application does.

You set thresholds for filtering in the Diagrams User Preferences. If you set the driver threshold for outgoing
relationships to 40, for example, then any object with 40 or more outgoing relationship will be considered a
driver and displayed outside the main relationship flow. The driver and its related nodes in the relationship
flow appear with a B symbol in the diagram. Click the E1 symbol to display the relationships for the driver
and its related nodes again.

You generate a filtered diagram the same way you generate any diagram. The only difference is that when
the filtering thresholds are met, Diagrammer displays the Large Dataset Returned dialog. Choose Enable
Node Filtering in the dialog to draw the diagram with the filter applied. Choose Disable Node Filtering

and Clustering in the dialog to draw the diagram without the filter applied. A v symbol on the tool bar
indicates that a diagram is filtered.

Y

'u‘l Tip: Use the Filter Override options on the - drop-down menu to override the thresholds in the
Diagrams User Preferences. If the diagram has already been generated, choosing an override option
redraws the diagram with the new filter applied.
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Setting Filter Overrides

Use the Filter Override Options window to override the filtering thresholds in the Diagrams User
Preferences. If the diagram has already been generated, choosing an override option redraws the diagram
with the new filter applied.

i Note: These settings do not persist between Diagrammer sessions.

1. - . . . . . .
Click f on the tool bar and choose Filter Override Options in the drop-down. The Filter Override

Options window opens.
2. Select Filters Enabled to enable filtering.

3. Select Hide Utilities to hide objects with many inputs, DATEFMT, for example. Specify the filtering
thresholds for inputs and outputs:

* Inthe Incoming Relationships field, enter the filtering threshold for incoming relationships.
* In the Outgoing Relationships field, enter the filtering threshold for outgoing relationships.

4. Select Hide Drivers to hide objects with many outputs, a startup program, for example. Specify the
filtering thresholds for inputs and outputs:

* Inthe Incoming Relationships field, enter the filtering threshold for incoming relationships.
* In the Outgoing Relationships field, enter the filtering threshold for outgoing relationships.

5. Select Hide High Input Nodes to hide objects with many inputs that do not meet the incoming
relationship threshold for utilities. Specify the thresholds for inputs in the With Incoming Relationships
field.

6. Select Hide High Output Nodes to hide objects with many outputs that do not meet the outgoing

relationships threshold for drivers. Specify the thresholds for outputs in the With Outgoing
Relationships field.

Tip: Select Reset Values to restore the filtering thresholds to
their settings in the Diagrams User Preferences.

Clustering Objects

Clustering objects on a diagram groups them by their degree of relatedness. Once clusters are generated,
you can move objects in and out of the groups, name the groups, and create new clusters as needed.
When you are satisfied that a cluster meets your needs, you can assign an existing tag to its members or
generate a tag from the cluster itself, each member of which receives the tag.

To enable clustering click - and then click Clustering Options. Check if the appropriate filtering
thresholds are met, drivers and utilities are grouped in special clusters named "Drivers" and "Utilities." A
third special cluster, "Miscellaneous Components,” contains relationship flows with too few objects to
cluster.

You generate a clustered diagram the same way you generate any diagram. The only difference is that
Diagrammer displays the Large Dataset Returned dialog. Choose Enable Node Clustering in the dialog to
draw the diagram with clustering applied. Choose Disable Node Filtering and Clustering in the dialog to
draw the diagram without clustering applied.

Creating Clusters Manually

To create a cluster manually, right-click on white space on the Diagrammer canvas. The Clustering dialog
opens. Select Create New Cluster, then enter the cluster name in the Cluster Name field. Click OK.
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Generating Tags from Clusters

To generate tags based on cluster names, right-click on white space on the Diagrammer canvas. The
Clustering dialog opens. Select Create Tags from Clusters, then enter the name of the parent tag in the
Top Level tag field.

f Note: The parent tag is required.
Click OK. Each member of a cluster is assigned a tag based on the cluster name.

Setting Clustering Factors

Use the Clustering Options window to specify values to use when factoring how closely related cluster
objects are.

f Note: These settings do not persist between Diagrammer sessions.

1. = . . . . .
Click Ll on the tool bar and choose Clustering Options. The Clustering Options window opens.

2. In the Quality drop-down, select one of:

« Draft for the lowest clustering quality and best performance.
* Proof for the highest clustering quality and worst performance.
¢ Medium for the best balance of clustering quality and performance.

3. In the Balance combo box, specify the clustering balance factor. The higher the balance factor, the
lower the number of relationships between objects in different clusters.

4. In the Cluster Size Factor combo box, specify the clustering size factor. The higher the clustering size
factor, the larger and fewer the clusters.

5. In the Max Number of Clusters combo box, specify the maximum number of clusters. A value of O
means any number of clusters.

6. In the Min Number of Clusters combo box, specify the minimum number of clusters. A value of 0
means any number of clusters.

Setting Diagrams User Preferences

Use the Diagrams tab of the User Preferences window to specify the color-coding used in relationship flow
diagrams, the thresholds for clustering and filtering, and performance limits for large diagrams.

1. Choose Tools > User Preferences. The User Preferences window opens. Click the Diagrams tab.

2. Select Prompt When Diagram Mode Changes to be prompted when you switch between a diagram
generated for a project and a diagram generated for copied-and-pasted objects.

3. In the Color Scheme pane, click the object type whose color you want to edit. The current background
color of the type (if any) is displayed in the Color drop-down.

-

Click the adjacent button and choose ForeColor from the pop-up menu if you want to specify the
color of the caption for the object type, or BackColor if you want to specify the color of the background
for the object type.

5. In the Shape drop-down, select the shape of the object type in the diagram. Select Lock Shape Aspect
to specify that the shape not be adjusted to fit the caption.

6. Click Performance button. The Performance Option Limits dialog opens.
7. Deselect Relayout Subgraphs if you do not want child groups to be redrawn when you choose a new
layout style.

y Note: Selecting this option may result in poor performance for very large diagrams.

8. In the Maximum relationships to return from repository field, enter the maximum number of
relationships to display in the diagram. Relationships are truncated when the maximum is exceeded.
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i Note: Setting this option too high may result in poor performance for very large diagrams.

9. In the Force Symmetric Layout (all relationships) field, enter the maximum number of relationships to
display in the diagram before forcing symmetric layout style.

Note: Symmetric layout style typically offers the best performance for very large diagrams. Setting
this option too high may result in poor performance for very large diagrams.
10.In the Offer Auto Clustering Layout (all relationships) field, enter the maximum number of
relationships to display in the diagram before offering to perform clustering.

11.Select Filter Options Enabled to enable filtering.
12.In the Hide Drivers (all relationships) field, enter the maximum number of relationships to display in

the diagram before filtering drivers. (A driver is an object with many outputs, a startup program, for
example.) Specify the filtering thresholds for inputs and outputs:

* In the Incoming Relationships field, enter the filtering threshold for incoming relationships.
* In the Outgoing Relationships field, enter the filtering threshold for outgoing relationships.

13.In the Hide Utilities (all relationships) field, enter the maximum number of relationships to display in
the diagram before filtering utilities. (A utility is an object with many inputs, DATEFMT, for example.)
Specify the filtering thresholds for inputs and outputs:

* Inthe Incoming Relationships field, enter the filtering threshold for incoming relationships.
* In the Outgoing Relationships field, enter the filtering threshold for outgoing relationships.

14.In the Hide High Output Nodes (all relationships) field, enter the maximum number of relationships to
display in the diagram before filtering objects with many outputs that do not meet the outgoing
relationships threshold for drivers. Specify the filtering thresholds for outputs in the Outgoing
Relationships field.

15.1n the Hide High Input Nodes (all relationships) field, enter the maximum number of relationships to
display in the diagram before filtering objects that do not meet the incoming relationship threshold for
utilities. Specify the filtering threshold for inputs in the Incoming Relationships field.

Using the Scope Editor

Use the Scope Editor to manage the scopes in your repository, create custom composite relationships, and
define relationship filters. To open the Scope Editor, choose Scope > Scope Editor. The Scope Editor
opens, with the workspace scopes listed in the lefthand pane and their relationships in the righthand pane.
The figure below shows the Scope Editor.
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Understanding the Lefthand Pane of the Scope Editor

The lefthand pane of the Scope Editor window lists every scope in the repository. The table below
describes the columns in the lefthand pane.

Column Description
Scope The name of the scope. Scopes are color-coded as follows:

» Blue means that the scope is available in the Diagrammer Scope
drop-down.

* Gray means that the scope is not available in the Scope drop-
down, because it is hidden or because it is a private scope owned
by another user. You can copy a private scope, then edit it as you
would your own scope

* Red means that the scope has no relationships associated with it.

Type The type of the scope, public or private. The type determines
availability of the scope in the Diagrammer Scope drop-down:

* A public scope is available to every user of the workspace.

« A private scope is available only to its owner. You can copy a
private scope, then edit it as you would your own scope.

Owner The owner of the scope. SYSTEM denotes a default scope.
Hide Whether the scope is hidden in the Diagrammer Scope drop-down. A
check mark means that the scope is hidden.

Understanding the Righthand Pane of the Scope Editor

The righthand pane of the Scope Editor window lists every relationship in the repository. The table below
describes the columns in the righthand pane.
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Column Description

Use Whether the relationship is used in the selected scope. A check mark
means that the relationship is used.

Relationship Name The name of the relationship. Relationships for which a filter has
been defined are color-coded magenta.

Left Entity The entity on the left end of the relationship. Entities for which a
relationship filter has been defined are color-coded magenta. A tool
tip displays the text of the condition.

Caption The caption of the relationship.

Right Entity The entity on the right end of the relationship. Entities for which a
relationship filter has been defined are color-coded magenta. A tool
tip displays the text of the condition.

Class The class of the relationship, basic or composite:

* A basic relationship defines the direct interaction of two objects: a
program and a program entry point, for example.

* A composite relationship defines the indirect interaction of two
objects. If a job runs a program entry point that belongs to a
program, for example, the relationship between the job and
program is said to be composite: defined by the chain of
relationships between the job and program.

Occurs The number of times a basic relationship occurs in the repository. For
composite relationships, N/A, indicated with an asterisk (*).

Managing Scopes

Use the Scope Editor to edit the Diagrammer Scope drop-down, view scope diagrams, create, edit, copy,
and delete scopes, import and export scopes, and more.

Hiding a Scope in the Scope Drop-down

To hide a scope in the Diagrammer Scope drop-down (but not remove it from the repository), select the
scope in the Scope Editor and put a check mark next to it in the Hide column.

Displaying Only the Relationships Used in a Scope

To display only the relationships used in a scope, select the scope in the Scope Editor and click Hide
Unused button in the righthand pane.

Hiding Empty Relationships

To hide relationships that have no instances in the repository, click the Hide Empty button in the righthand
pane.

Viewing a Diagram of a Scope

To view the diagram of a scope, select the scope in the Scope Editor and choose File > Diagram. You can
also view a scope diagram by selecting the scope in the Diagrammer Scope drop-down and choosing
Scope > View Scope.

Viewing a Diagram of a Composite Relationship

To view the diagram of a composite relationship, select the relationship in the Scope Editor and choose
Diagram in the right-click menu.
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Creating a Scope

To create a scope, choose File > New Scope. A dialog box prompts you to enter the name, optional
caption, class, and owner of the scope. Enter the requested information and click Save.

Specifying the Relationships in a Scope

To specify the relationships in a scope, select the scope in the Scope Editor and put a check mark in the
Use column next to each relationship you want to include in the scope. To save the scope, choose File >
Save.

y Note: You can specify relationships only for a scope you own.

Editing Scope Details

To edit the name, caption, class, and owner of a scope, select the scope in the Scope Editor and choose
File > Edit. A dialog box displays the current details for the scope. Enter the new information and click
Save.

y Note: You can edit details only for a scope you own.

Copying a Scope

To copy a scope, select the scope in the Scope Editor and choose File > Copy. A dialog box prompts you
to enter the name, optional caption, class, and owner of the new scope. Enter the requested information
and click Save. You can copy default scopes and public or private scopes owned by another user, then edit
them as you would your own scope.

Deleting a Scope
To delete a scope, select the scope in the Scope Editor and choose File > Delete.

f Note: You can delete only a scope you own.

Deleting a Composite Relationship

To delete a composite relationship, select the relationship in the Scope Editor and choose Delete in the
right-click menu.

y Note: You can delete only a composite relationship you own.

Importing and Exporting Scopes

To import a scope from an XML file, choose File > Import. A dialog opens, where you can specify the
scope you want to import. The type of an imported scope defaults to public. The owner defaults to the
current user.

Note: If a scope or relationship being imported conflicts with an existing scope or relationship, you are
notified and the conflicting item is ignored.

To export a scope to an XML file, select the scope in the Scope Editor and choose File > Export Selected.
A Save dialog opens, where you can specify the name and location of the scope. To export all the scopes
in the repository to an XML file, choose File > Export All.

Hiding Columns in the Scope Editor

To hide a column in the Scope Editor, deselect the column name in the View menu.
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Creating Custom Composite Relationships

A composite relationship defines the indirect interaction of two objects. If a job runs a program entry point
that belongs to a program, for example, the relationship between the job and program is said to be
composite: defined by the chain of relationships between the job and program.

You can use the default composite relationships provided with the system, or use the Scope Editor to
create custom composite relationships. Custom composite relationships are available to all users of the
workspace.

Note: Custom composite relationships are not copied or exported when a scope is copied or
exported.

1. Inthe Scope Editor, choose File > New Relationship.

2. The New Relationship Wizard opens. In the Enter Relationship Name field, enter the name of the
composite relationship, then select the object you want to appear on the left side of the relationship
chain in the Select First Entity pane. Click Next.

3. In the Select relationship pane, select the relationship you want to appear next in the relationship chain.
Click Next.

4. Repeat the preceding step for each relationship you want to include in the chain. When you are satisfied
with your choices, click Finish. The New Relationship Wizard closes and the new composite
relationship is added to the Scope Editor window.

Defining a Relationship Filter

You can define a relationship filter by setting conditions for either side of the relationships defined in a
scope you own. You might want a scope to be restricted to programs that have a cyclomatic complexity
greater than 300 and that are defined in COBOL source files, for example. The example below shows you
how to do that step by step.

Condition definitions are based on the Repository Exchange Protocol (RXP), an XML-based API that you
can use to interact with application-level information in the workspace repository.

In the Scope Editor, relationships and entities for which a filter has been defined are color-coded magenta.
A tool tip over the filtered entity displays the text of the condition.

1. Inthe Scope Editor, select the relationship you want to set conditions for and choose:

* Left Cond in the right-click menu to qualify the entity on the left side of the relationship.
* Right Cond in the right-click menu to qualify the entity on the right side of the relationship.
2. The Condition window opens. In the Condition window, click:

« attribute to qualify the entity according to the value of a given attribute. Programs that have a
cyclomatic complexity greater than 300, for example.

* has (not) related object to qualify the entity according to a given relationship type. Programs
defined in COBOL source files, for example.

« add AND condition to qualify the entity according to inclusive criteria using an AND operator.
Programs that have a cyclomatic complexity greater than 300 and that are defined in COBOL source
files, for example.

« add OR condition to qualify the entity according to exclusive criteria using an OR operator.
Programs that have a cyclomatic complexity greater than 300 or that are defined in COBOL source
files, for example.

3. The Condition window displays the shell definition for the selected condition. The following steps
describe how to qualify the program entity using an AND operator. The procedure for other entities and
conditions is similar.

4. In the definition for the AND condition, click attribute. The definition for the attribute condition is
displayed:

<attr name="_.." op="..." arg="..." negate="._."/>

166 | Enterprise Analyzer



f Note: Click the X in a definition to delete the condition.

5. Click the ellipsis (...) in name=".."". The User Input dialog opens. In the User Input dialog, select the
Program entity in the Choose entity drop-down and the Cyclomatic Complexity attribute in the
Attributes for Program drop-down, then click OK. The attribute is added to the condition definition.

i Note: Click Delete in the User Input dialog to delete the criterion defined in the dialog.

6. Click the ellipsis (...) in op=""..."". The User Input dialog opens. In the Choose new value drop-down,
choose the greater than (>) symbol, then click OK. The greater than symbol is added to the condition
definition.

7. Click the ellipsis (...) inarg=".."". The User Input dialog opens. In the Enter new value drop-down,
enter 300, then click OK. The new value is added to the condition definition:

<attr name="Cyclomatic Complexity' op=">" arg="300"
negate="__.."/>

y Note:

In a condition definition, negate means “not the specified criterion.” Programs that do not have a
cyclomatic complexity greater than 300, for example. Click the ellipsis (...) in negate=".."" to set
its value to true. Ignore the field otherwise.

8. In the definition for the AND condition, click has (not) related object. The definition for the relationship

type condition is displayed:

<hasrelated negate="...">

9. In the choices for the relationship type condition, click define relationship type.

10.The choices for the relationship type are displayed. Click define relationship. The definition for the
relationship type is displayed:

<rel name="__.." negate="._."/>

11.Click the ellipsis (...) in name=".."". The User Input dialog opens. In the Choose entity drop-down,
select the Program entity. In the Relations for Program drop-down, select the IsDefinedIinCobol
relationship, then click OK. The relationship is added to the condition definition:

- <hasrelated negate=""..."">

- <reltype>

<rel name="IsDefinedInCobol™ negate=""...""/>
</reltype>

</hasrelated>

12.The AND condition is now complete. The diagram scope will be restricted to programs that have a
cyclomatic complexity greater than 300 and that are defined in COBOL source files. The full condition
looks like this:

- <cond>

<and negate="'._."">

<attr name="Cyclomatic Complexity" op=">"
arg="'300" negate="'__.""/>

- <hasrelated negate="...">
- <reltype>

<rel name=""1sDefinedInCobol"
negate="_.."/>

</reltype>

</hasrelated>

</and>

</cond>
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Pruning a Scope

You can prune relationships from a scope you own directly in the Diagrammer window. When you prune a
scope, keep in mind that:

* You are deleting relationships from the current scope exactly as if you were deleting them in the Scope
Editor window. For that reason, you might want to save the original scope with a different name and use
the renamed scope as the basis for the pruned diagram.

« All the relationships of the selected type are deleted for the selected object, not just the single
relationship you selected in the diagram.

1. To prune a scope, select the relationship you want to prune in the diagram and choose:

* Prune type for right object in the right-click menu to delete from the current scope all relationships
of the selected type for the right object in the relationship.

* Prune type for left object in the right-click menu to delete from the current scope all relationships of
the selected type for the left object in the relationship.

2. Generate the diagram in project or copy-and-paste mode. The Diagrammer deletes the relationships
from the redrawn diagram.

Mirroring a Scope

By default, Diagrammer shows the flow of relationships from a diagrammed object rather than to a
diagrammed object. Choose Scope > Mirror Scope to show the flow of relationships to the object. Choose
Scope > Mirror Scope again to return to the original view.

Analyzing Global Data Flow

The Global Data Flow traces incoming and outgoing data flows for a program variable up to a dataport, an
I/O statement or call to or from another program. You can view the memory allocation and offset for the
variable to determine how changes to the variable may affect other variables, and trace assignments to and
from the variable across programs.

Note: Projects must have been verified with the Enable Data Element Flow option set in the Project
Verification options.

The Global Data Flow tool is available in Interactive Analysis by clicking View > Data Flow.

Understanding the Global Data Flow Panes

Use the Global Data Flow panes to trace incoming and outgoing data flows for a program variable up to a
dataport, an I/O statement or call to or from another program. To open the Global Data Flow panes, select
a program in the Repository Browser and choose View > Data Flow.

By default, all Global Data Flow panes are displayed. If you want to show/hide one of the panes click View
and then click the name of the pane you want to hide/show.

Data View Pane

For the selected program, the Data View pane shows variable structures, substructures, and fields in
hierarchical order from left to right. Double-click a variable name to generate a data flow diagram for the
variable in the Data Flow pane, and a list of offsets and memory allocations for the variable and any related
variables in the Origin pane.

Data Flow Pane

For the variable selected in the Data View pane, the Data Flow pane displays a diagram that traces its
incoming and outgoing data flows up to a dataport, an I/O statement or call to or from another program.
The selected variable is displayed in red, constants in gray, and dataports in blue.
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Note: Make sure you have enabled incoming and/or outgoing data flows appropriately in the Global
Data Flow project options.

Two diagram views are available:

« The Expanded View displays as many nodes for the selected variable as it has assignments.
« The Compact View displays a single node, regardless of the number of assignments.

Click the tab for the view you want to display.

Select a dataport and choose Data Flow > Reconstruct to display the data flow diagram for the variable
identified at the dataport. Select a relationship line to display all the statements that determine the data
flow between variables in the Origin pane.

Place your cursor over a variable for a moment to display a tool tip that identifies the memory offset and
allocation for the variable. The diagram uses Enterprise Analyzer common diagramming features.

Origin Pane

For the variable selected in the Data View or Data Flow panes, the Origin pane displays a list of offsets and
memory allocations for the variable and any related variables. For the dataport selected in the Data Flow
pane, it displays related variables. For the relationship selected in the Data Flow pane, it displays the
intraprogram or interprogram relationship detected by data flow analysis.

Data Flow Relationships

The table below describes the intraprogram and interprogram relationships detected by the data flow
analysis tools.

Relationship Definition Type Icon Description
calls N/A interprogram N/A A parameter passed in a call to
another program.
cast MOVE A TO B with | intraprogram A data item moved to a data item
data conversion (r PN of a different type.
common area N/A interprogram N/A For Unisys 2200 Cobol, a
transitions common-storage data area item

passed in a call to another
program. Perform Unisys
Common-Storage Area Analysis
must be set in the project
verification options.

comp STRING A ... INTO [ intraprogram An arbitrary computation. The
B (@) result is produced by applying
complex rules to the argument,
such as STRING.

comp+ ADDATOB intraprogram An addition-like operation: ADD,
(r P SUBTRACT, or corresponding
parts of COMPUTE.
comp* MULTIPLY A BY B | intraprogram A multiplication-like operation:
(r EE MULTIPLY, DIVIDE, or
corresponding parts of
COMPUTE.
comp@ MOVE ARRAY intraprogram An operation with array elements.
(IDX) TO A @[
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Relationship Definition Type Icon Description

cond IFA=B.. intraprogram - Comparison of data items with a

=y symmetric relationship.

cond* IFA*X=B.. intraprogram - Comparison of a multiple of a data

@ item with another data item.

const cond IFA=1.. intraprogram a Comparison of a data item with a

o=y constant.

const.move MOVE 1 TO B intraprogram - A constant moved into a data item.

const.comp ADD1TO B intraprogram An arithmetic operation with

O+ constants.

const.init 03 A..VALUE1 intraprogram A data item initialized by a

o=+ constant.

DMS records N/A interprogram N/A For Unisys 2200 Cobol, data
communication via Unisys DMS
database records.

files N/A interprogram N/A Data communication via files.
Traced only when corresponding
JCL, ECL, FCT, or CSD files are
verified.

files in jobs N/A interprogram N/A Data flow in JCL datasets when
files is selected.

input port N/A intraprogram t A data item in which data is

[i received.

move MOVE ATO B intraprogram A data item moved to a data item

= of the same type.

network records N/A interprogram N/A For Unisys 2200 Cobol, data
communication via network
records.

output port N/A intraprogram -l-_[i A data item from which data is

@ sent.

screens N/A interprogram N/A Data sent to a screen by one
program and received in a screen
by another.

screen definitions | N/A interprogram N/A Data flow in screen fields when
screens is selected.

start N/A intraprogram E The startup item in an Impact pane
consolidated analysis.

used MOVE ... TOA ... intraprogram @ A value assigned in a statement

MOVE ATO ... s used as an argument in another

statement.

Assigning Business Names Manually

To assign a business name and business description to an object, select the object and choose Set
Business Attributes in the right-click menu. A dialog box opens, where you can enter the business name
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and business description. To unassign a business name or business description, simply delete the value in
the dialog box.

Setting Global Data Flow User Preferences

Use the Interactive Analysis > Data View tab of the User Preferences window to specify the color-coding
used in the Data View pane and the order of display of variables with the same offset.

1. Choose View > User Preferences. The User Preferences window opens. Click the Interactive
Analysis > Data View tab.

2. In the Same offset order group box, specify the order you want variables with the same offset to be
displayed in the Data View pane. Choose:

+ Data item size if you want variables with the same offset to be displayed in size order, largest to
smallest.

* Appearance in the source code if you want variables with the same offset to be displayed in the
order they appear in the source code.

3. Click the arrow beside the drop-downs for Free Space Color, Used Space Color, and FILLER Color
to specify the color of each item in the Data View pane.

4. Select Display Business Names to display business names for objects in the Data View pane.

Setting Global Data Flow Project Options

Use the Global Data Flow tab of the Project Options window to specify whether data flow diagrams include
literals, variable values set at initialization, and Unisys Cobol common storage variables; whether they
show incoming, outgoing, and recursive data flows; and the number of nodes they display.

1. Choose Options > Project Options. The Project Options window opens. Click the Global Data Flow
tab.

2. In the Relationships pane, choose any combination of:

« Literal Flow to include literals in the data flow diagram for the selected variable

« Initial Values to include variable values set at initialization in the data flow diagram for the selected
variable.

¢ Common Area Transition to include Unisys Cobol common storage variables in the data flow
diagram for the selected variable. Common storage variables are not explicitly declared in CALL
statements.

Note: To include Unisys Cobol common storage variables, you must have verified the project with
the Perform Unisys Common-Storage Analysis option set in the project verification options.
3. In the Directions pane, choose any combination of:

* Causes to generate data flows into the selected variable.
« Consequences to generate data flows from the selected variable.
+ Self-Dependencies to show recursive data flows for the selected variable.
4. In the Node Limit combo box, enter the maximum number of diagram nodes you want to display. You

might restrict the number of nodes to improve performance or make the diagram easier to read. You can
also use the slider on the Node Limit tool bar to adjust the number of displayed nodes.

Note: All children of a parent node are displayed even if some of them exceed the specified
maximum.

Analyzing Batch Applications

The Batch Application Viewer lets you perform low-level analysis of batch processes. Use the Batch
Application Viewer's rich set of tables and diagrams to determine if batch jobs are dependent on one
another, the programs that use a data store, and the flow of data into or out of a data store.
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f Note: Batch Application Viewer analyzes JCL jobs.

Understanding the Batch Application Viewer Window

Use the Batch Application Viewer to determine if batch jobs are dependent on one another, the programs
that use a data store, and the flow of data into or out of a data store. To open Batch Application Viewer,
select a project in the Repository Browser and choose Analyze > Batch Application.

The Batch Application Viewer window displays job, procedure, and data set views of the batch application.
Your selection in the current view, displayed in the lefthand pane, filters the objects displayed in the other
two views. Click the appropriate tab at the bottom of the window to make a view current. To generate a
report for the current view in HTML, choose File > Report.

Use the Search button and adjacent field on the toolbar to perform a standard Interactive Analysis
search of the current view. In any view or diagram, select an object and click Interactive Analysis at the
bottom of the window to view the object in Interactive Analysis.

You can hide a view by clicking the close box in the top right corner of the pane. Select the appropriate
choice in the View menu To show the view again, .

The figure below shows the Batch Application Viewer window.
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Job View

When the Job View is current, select a job to view the steps the job uses, the procedure or program each
step executes, and the data stores each procedure or program reads from or writes to.

Procedure View

When the Procedure/Program View is current, select a procedure or program to view the jobs and steps
that execute it, and the data stores programs read from or write to.

Note: For programs executed by procedures, Batch Application Viewer displays data stores
referenced by DD statements added after the substitution of the procedure.

Dataset View

When the Dataset View is current, select a dataset to view the procedure or program that reads from or
writes to it, the step that executes the procedure or program, and the job that contains the step.

To view the flow of data into or out of a dataset, select the dataset in the Dataset View and a step in the

Procedure/Program View, then click the Q button in the Data Set Flow pane. Click the # button in the

Data Set Flow pane to view the flow of data into the dataset, click the =% button to view the flow of data out
of the dataset.

Generating Batch Application Diagrams

Batch application diagrams show the relationships between jobs, programs or procedures, and data stores.
The diagram uses Enterprise Analyzer common diagramming features.

1. Inthe current view, mark the objects you want to diagram.
2. In the Diagram menu, choose the relationships you want to view in the diagram:

« Job Dependencies shows dependencies between jobs. Jobs are regarded as dependent if one
writes to a dataset and the other reads from the same dataset.

« Data Set Usage shows interactions with datasets.
* JCL Procedures Usage shows interactions with procedures.
* Program Usage shows interactions with programs.

Note: The menu choice is grayed out with a check mark beside it if the relationship must be
displayed in the diagram. You can also set these choices after you display the diagram.

3. Click Diagram at the bottom of the Batch Application Viewer window.

The diagram is displayed in the Diagram View.

Assigning Business Names Manually

To assign a business name and business description to an object, select the object and choose Set
Business Attributes in the right-click menu. A dialog box opens, where you can enter the business name
and business description. To unassign a business name or business description, simply delete the value in
the dialog box.

Marking Items

To mark an item, place a check mark next to it. To mark all the items in the current view, choose Edit >
Check All. To unmark all the items in the current view, choose Edit > Uncheck All.

To mark selected items, select the items and choose Edit > Check Selected. To unmark selected items,
choose Edit > Uncheck Selected.
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Creating Job Dependencies in Batch Application Diagrams

Batch Application Viewer treats jobs as dependent if one writes to a dataset and the other reads from the
same dataset. Occasionally, you may want to define dependencies between jobs based on other criteria:
administrative needs such as scheduling, for example. Batch Application Viewer modifies the diagram only,
not the repository.

Defining Dependencies Between Jobs

To define dependencies between jobs in a batch application diagram, hold down the Alt key, select either
job, and drag-and-drop the relationship to the other job. The relationship is displayed in red with three plus
(+) signs at either end of the relationship line.

Importing and Exporting Job Dependencies

To import job dependencies from a file, choose File > Import Dependency Changes. A dialog opens,
where you can specify the file you want to import.

To export job dependencies to a file, choose File > Export Dependency Changes. A Save As dialog
opens, where you can specify the name and location of the file.

Removing Job Dependencies

To remove all user-defined dependencies from a batch application diagram, choose File > Clean Up
Dependencies.

Note: In certain circumstances (jobs that use cataloged file generation, for example), Batch
Application Viewer may create false dependencies. You must remove these relationships manually by
right-clicking the dependency and choosing Remove from the pop-up menu.

Creating User Names for Objects in Batch Application Diagrams

You can give diagram objects friendlier names, called user names. Batch Application Viewer modifies the
diagram only, not the repository.

Note: To display user names in a diagram, select User Names in the Batch Application Viewer
workspace options.

Specifying User Names

To specify a user name for an object in a batch application diagram, select the object and choose View >
User Name. The User Name dialog opens, where you can specify the user name.

Importing and Exporting User Names

To import user names from a file, choose File > Import User Names. A dialog opens, where you can
specify the file you want to import.

To export user names to a file, choose File > Export User Names. A Save As dialog opens, where you
can specify the name and location of the file.
Removing User Names

To remove all user names from a batch application diagram, choose File > Clean Up User Names.

Setting Batch Application Viewer Options

Use the Batch Application Viewer tab of the Workspace Options window to specify the color-coding used
for relationship lines in batch application diagrams. Diagram objects are color-coded based on the color
scheme in the Diagrams User Preferences.
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1. Choose Options > Workspace Options. The Workspace Options window opens. Click the Batch
Application Viewer tab.

2. In the Diagram Relations pane, click the relationship type whose color you want to specify, then specify

the color in the Edge Color drop-down.

To display user names in a diagram, select User Names.

4. In the Node Limit combo box, enter the maximum number of diagram nodes you want to display. You
might restrict the number of nodes to improve performance or make the diagram easier to read. You can
also use the slider on the Node Limit tool bar to adjust the number of displayed nodes.

w

Note: All children of a parent node are displayed even if some of them exceed the specified
maximum.

Estimating Complexity and Effort

Enterprise Analyzer Legacy Estimation tools let you compare programs based on weighted values for
selected complexity metrics. The metrics used in the calculation are a combination of industry standard
and Enterprise Analyzer-generated statistics. Based on the comparison, you can develop a credible
estimate of the time required to satisfy a change request or perform other maintenance tasks.

Note: For definitions of the supported complexity metrics, see the "Complexity Metrics" section of this
help.

Viewing Complexity Metrics

Use the Complexity Metrics report to compare raw complexity values for the objects in your project. To
open the Complexity Metrics report, select a project in the Repository Browser and choose Analyze >
Complexity.

When the Complexity Metrics window opens, choose the type of object you want to compare in the Entity
Type drop-down. To generate the report in HTML, choose File > Report. The figure below shows the
Complexity Metrics window.
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Setting Complexity Metrics User Preferences

Use the Complexity Metrics tab of the User Preferences window to specify the metrics displayed in the
Complexity Metrics report for each type of object in your application.

1. Choose Tools > User Preferences. The User Preferences window opens. Click the Complexity Metrics
tab.

2. In the Source Type drop-down, select the type of object you want to display complexity metrics for.
3. In the Attributes pane, select each complexity metric you want to be displayed for the selected object
type.

Estimating Effort

Use the Effort Estimation tool to compare source files based on weighted values for selected complexity
metrics. To open the Effort Estimation tool, select a project in the Repository Browser and choose Analyze
> Effort.

Select the source files types to be included in the calculation and the weighted values for the metrics in the
Effort Estimation options. When you are satisfied with your selections, choose File > Compute Effort.

When the effort estimation report is displayed, select a source file in the Effort pane to show the effort
statistics for its generated objects in the Details pane and the Interactive Analysis information for the file in
the Preview pane. To generate the report in HTML, choose File > Report. The figure below shows the
Effort Estimation window.
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Setting Effort Estimation Options

Use the Effort Estimation tab of the Project Options window to specify the file types included in the effort
estimation calculation and the complexity metrics for each type. These options also control the percentage
factor for the change magnitudes used in the calculation.

1. Choose Options > Project Options. The Project Options window opens. Click the Effort Estimation
tab.

2. In the Factors pane, select each source file type you want to include in the calculation.

3. For each source file type selected in the Factors pane, click Attributes to edit the complexity metrics
used in the calculation.

4. In the Attributes window, select each complexity metric you want to use in the calculation, then enter its
weight in the Weighting Factor field. For example, if you want Cyclomatic Complexity to have twice the
weight of Conditional Complexity, set the weighting factor for Cyclomatic Complexity to 2 and the
weighting factor for Conditional Complexity to 1.

5. To set the percentage factor for the change magnitudes used in the calculation, enter the percentage
you want to be applied in the combo box for each change magnitude.

Specifying the Change Magnitude for a Source File

Suppose you are planning to implement a change request and want to know how long it will take to
complete the change. In that situation, you typically run an effort estimation report for your project based on
weighted values for selected complexity metrics.

But what if your own analysis of the project shows that a given program will actually take much less time to
change than the weighted calculation would suggest. The program might have thousands of source lines,
for example, increasing its calculated complexity, while actually being very easy to modify.

A change magnitude is a way of overriding the calculated value for a source file. Your "subjective" estimate
of the effort involved, Small, Medium, Large, Extra Large, becomes an input to the effort calculation, along
with the weighted values.

You can specify a change magnitude in the Interactive Analysis Source or Context pane, or in the Effort
Estimation tool itself. Select the source file and choose Set Change Magnitude in the right-click menu. Set
the change magnitude to S for Small, M for Medium, L for Large, or XL for Extra Large. The effort
estimation calculation for the selected file is automatically updated.

Identifying Classes of Data Items with Change
Analyzer

Change Analyzer identifies the class of data items used to perform a business function in a legacy
application. Amongst other uses, it lets you answer the kind of “What if?” questions posed in the past by
industry-wide changes for Y2K, Zip+4, and the Euro dollar: “What if | change the type of this variable, or
the length of this field? What other fields in the class will | also have to change?”

For each field in the class, you can use Change Analyzer to perform an impact trace that shows the flow of
data to the field, and to detect and resolve program ports. You can generate reports showing source
entities that might require modification, lines of affected code, and the like.

Note: Projects must have been verified with the Enable Data Element Flow option set (see Setting
Project Verification Options).

The project options on the Impact > Relationships tab of the Project Options window control the
relationships detected during synonym and impact trace processing.

Understanding Data Item Classification

Suppose your organization is considering adding support for a new currency and that you are going to
have to expand the existing exchange rate data field from 9(5)V9(3) to 9(5)V9(6) to accommodate the
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currency. You will need to know the data fields that are affected in the database, intermediate fields that
might contain or use the exchange rate field in calculations, and so forth.

Seed Fields
Use Change Analyzer to search for the exchange rate field. The object of the search is called a seed field:

« If the application uses field names like EX-RATE, EXCH-RATE, EXCHANGE-RATE, and RATE-OF-
EXCHG, you would search for data names that contain *EXCH* or *RATE*.

« If you know that some fields already contain the required number of decimal positions, and are
interested only in those that don’t, you might further limit the search by filtering on the PICTURE clause
format of the variable, selecting only data items that have a format of 9(5)V9(3).

* You might limit the search even further by choosing fields that have a given initial value.
» If you know there are data fields that will meet the search criteria for name, but are not what you are
looking for, you might set up a list of names to exclude, such as INTEREST-RATE and *PRORATE?*.

Synonyms

Once you have found the exchange rate field, you can use Change Analyzer to detect its synonyms. A
synonym is a data field whose value is related to the value of a seed field: a field whose value is assigned
by a MOVE or REDEFINE statement, for example. In these cases, if you increase the size of the seed field,
you will probably need to increase the size of its synonyms as well.

Analyzing Seed Fields and Synonyms

Not every seed field or synonym will be affected by a proposed change. You need to examine the source
code for each instance of the field carefully in the Change Analyzer Source pane and in the Interactive
Analysis tools accessible from the Source pane. You may want to perform an impact trace showing the flow
of data to the field as documentation, or to ensure that you have accounted for each instance.

Seed Lists

Once you determine which fields are affected by a proposed change, you can move the fields between
seed lists: Working and Affected, for example. You can generate reports based on your lists, as well as
reports showing the affected source code in context.

Getting Started in Change Analyzer

Sample Usage of Change Analyzer

This section describes a sample use of Change Analyzer that should help you get oriented in the tool.
Assume that you want to evaluate the impact of changing the YEAR field in your application.

1. In the Repository Browser, select the project you want to analyze and then click Analyze > Change
Analyzer. This opens the Change Analyzer dialog box.

2. Click Tools > Analysis Options. This opens the Options - Change Analyzer dialog box.
3. Check Use Cross Program Analysis and then click OK.

e

51%1
Fa
Click Step 1: Find Change Candidates ( ). This opens the Search dialog box.

Click New Criterion ( D) on the tool bar. This opens the Search dialog box.

Type YEAR and then click OK. The new criteria, YEAR is added to the Change Analyzer tab.
Click YEAR and then type *DATE* in the Name Like tab.

Click Find All Constructs. The number of constructs found are displayed in a dialog box.
Click OK. The Change Candidates pane now displays a list matching objects.

© ©® N o O
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10. Step 2

L=

Click Setp 2: Find Fields Affected by the Change Candidates ( ®® ) and then Find Affected
Fields for All Programs. If a messages pops up informing you that all existing analysis results will be
cleared, click OK. The Status dialog box appears and displays progress.

11.In the Change Candidates pane, a list of change candidates and nested affected fields are displayed.
Clicking on an affected field will display more information in the Fields affected by pane. Double-
clicking on an affected field in either the Change Candidates or Fields affected by panes will display
the relevant code in the Source tab.

12.In the Fields affected by pane, right-click any of the affected fields, and then click Trace. More
information on the affected field is displayed in the Impact Tracing pane as well as displaying the
relevant lines of code in the Source pane.

13.You can use this to examine the declarations for each affected field to determine whether the field will
be affected by the proposed change.

14.Click Tools > Reports. This opens the Report Selection dialog box.

15.1n the Report Type list, select Report On The Whole List and click OK and then click Yes if a
message is displayed asking you if you want to continue. Change Analyzer displays a report for the
affected fields.

16.You can now print or save the report.

Understanding the Change Analyzer Window

Use the Change Analyzer to identify classes of data items. To open the Change Analyzer, select a project
in the Repository Browser and choose Analyze > Change Analyzer.

By default you see four panes which you can adjust - Programs, Lists, Synonyms and Ports, and Source.

Change Candidates Pane

The Change Candidates pane lists each program that contain matches to your search criterion. The
number in parentheses after the program name indicates the number of affected fields in the program.
Expanding the program node displays all the parent field names that matched your search criterion.

Field Pane

The Field pane displays a context dependent list of affected fields. The fields displayed is dependent on
whether you click on a program displayed in the Change Candidate pane or one of the fields listed under
a program. If you click on a program in the Change Candidate pane, only parent fields are displayed in the
Field pane. Clicking on a program'’s field in the Change Candidate pane will displays all of its affected
fields in the Field pane.

Clicking a field will display its declaration in the Source pane.

The table below describes the columns in the Field pane:

Column Description

Name The name of the field.

Length The length of the field.

Value The value of the field.

Picture The format of the field.

Normalized Picture The normalized picture of the field.

Comment The comment for the field.

Program File The program in which the field is used.

File The source file that contains the declaration for the field.
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Column Description

Usage The value of the USAGE clause.

Normalized Usage The format of the data item in computer storage.

You can filter the field list by clicking the ™ icon in a column and selecting an item you want to filter by.

y Tip: You can specify your own comment by right-clicking a field and then click Comment. This opens
the Edit Comment Field dialog box. In the Comment filed, type a comment and then click OK. This
can be used to provide information on working process and can also be used for filtering.

i

Selecting Fields

Click a field in the list to select it. Use Ctrl + click to select multiple fields. Use Shift + click to select a
range of fields. To select all the fields on a list, click the tab for the list and click Lists > Select All.

Editing the Comment for a Field

To edit the comment for a field, select the field and click Lists > Comment.... A dialog opens where you
can edit the comment.

Clearing Fields
To clear a field from a list:

1. Click a field from the list.
2. Click Lists > Clear and then choose between:

e Clear This Term Only to clear the selected field.
* Clear All List Contents to clear the whole list.

Impact Tracing Pane

The Impact Tracing pane displays a tree view of an affected field and its relationship to other synonyms,
parent, child, or moved fields.

To display the synonyms and/or the impact trace, click the required field in the Field pane, this highlights
the field row. Right-click the field row and then click Trace.

To delete an impact trace, select it in the tree and click Delete.

To clear the Impact Traces tree, click Delete All.

Source Pane

The Source pane lets you browse information for the object selected in the Lists or the Impact Tracing
pane. You can select the information you want to view for the object from the drop-down in the upper
lefthand corner of the pane. The available options are:

Source

Context

Code Search

Bird's Eye

Program Control Flow
Flowchart

Data View

Data Flow

Impact
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Diagrammer
Properties.

Usage is similar to that for the Source pane in Interactive Analysis. For Interactive Analysis usage
information, see Analyzing Programs in the product documentation set.

Searching for Change Candidates in Change Analyzer
The Change Analyzer search facility contains two tabs:

« The General tab opens the Interactive Analysis advanced search facility.
« The Change Analyzer tab opens a scoped version of the advanced search facility for Change Analyzer.

Ordinarily, the scoped version of the tool should be sufficient for most searches. If you are already familiar
with the advanced search facility, however, you may want to use it instead of the scoped tool.

Note: For COBOL programs, Change Analyzer returns only constants and literals found in the
Procedure section.

1. 5%1
4

Select a file from the list of programs and click (Step 1: Find Change Candidates). A message
informing you that all existing search and analysis results will be cleared is displayed in a dialog box.

Click OK.

2. The Change Analyzer Search window opens. Click the Change Analyzer tab. The Change Analyzer
tab displays a list of recognized search criteria.

i Note: Define a new criterion as described in the help for the advanced search facility.

3. Click a criteria to edit its definition in the Criterion tabs. Each tab specifies a condition in the definition.
The definition can consist of any combination of conditions.

4. For each condition, enter a list of patterns you want to match, one pattern per line. You can use wildcard
patterns used in LIKE statements by Visual Basic for Applications (VBA). Select:

* In the Name Like tab, specify patterns that are like the name of the field you are searching for.

* Inthe Name Not Like tab, specify patterns that are unlike the name of the field you are searching
for.

* Inthe Picture Like tab, specify patterns that are like the format of the field you are searching for.

¢ Inthe Value Like tab, specify patterns that are like the initial value of the field you are searching for.
5. Check Use OR Connection Between Lists if you want the conditions specified in the tabs to have the

OR operator applied. If this field is unchecked, the conditions have the AND operator applied.

6. Check Used Data Items Only if you want the search results to consist only of fields that are used in the
selected programs. If you do not select this option, search results include fields that are declared but not
used.

7. In the Search In list on the tool bar, you can choose from the following:

* The selected file only.

e The selected file with all included files.
* The selected construct - Declaration.
« All objects in the project.

* A Code Search report.

8. Click Find All Constructs to execute the search.

Change Analyzer returns the change candidates for the criterion in the starting point list. Any previous
results are deleted.
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Creating Projects in Change Analyzer

You can create a project directly in Change Analyzer from the results of your analysis. The project contains
only source files with fields in the selected list.

1.
2.

Click Tools > Add to Project. This opens the Select List window.

Click the list you want to add to the new project and click OK. This opens the new project hame dialog
box.

Type the name of the new project and click OK. This opens the Change Magnitude window.

Check Automatically calculate Change Magnitude if you want Change Analyzer to set change
magnitudes for the listed source files based on the ranges specified for the fields in the Change
Magnitude ranges group. The Change Analyzer settings will override any existing change magnitudes
for the files.

Click OK. The new project is created and displayed in the Repository pane.

Setting Change Analyzer Options

To specify the default depth of synonym and impact trace processing and the amount of information to
display:

1.

Click Options > Project Options. The Project Options window opens. Click the Change Analyzer tab.

Note: You can also set the Change Analyzer from the Change Analyzer window . To do so, select
Tools > Analysis Options.

. In the Synonyms pane, specify the depth of synonym and impact trace processing in the Default Depth

combo box. In this pane you can also select to use file descriptors in the analysis, use cross-program
analysis and/or if you want to have a cross-program analysis warning before starting the analysis. When
the Check for variables that write to synonym option is checked, the analysis traces both variables
that use the synonym and variables that affect the synonym. If it is unselected, the analysis traces only
the variables that use the synonym. Note that unselecting the Use Cross-Program Analysis, Use File
Descriptors in Analysis and Check for variables that write to synonym options increases the
analysis performance.

In the Affected Code Report pane, specify in the Neighborhood Size combo box the number of lines of
unaffected code you want the Affected Code report to display above and below the line of affected code.
(The line of affected code is displayed in bold in the report.) Select Show unused datanames if you
want the report to include unused data fields.

Generating Change Analyzer Reports

To generate HTML reports in Change Analyzer, click Tools > Reports. The Report Selection dialog opens.
In the Select Lists pane, select the list you want to report on, then select the report type in the Report Type
drop-down. Choose:

Report on the Whole List to report the contents of the list.

Report on Selected Program to report the contents of the list filtered by the program selected in the
Programs pane.

Metrics Report to report, for each program with a list item, the percentage of declarations in the list
relative to the total number of declarations in the program.

Affected Code Report to report, for each program with a list item, code that would be impacted by
changing the definition or usage of items in the list. The line of affected code is displayed in bold in the
report.

Note: Use Change Analyzer project options to specify the amount of information to display in the
Affected Code Report.

Click Generate Report. Change Analyzer displays the report.
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Repository Exchange Protocol Syntax

The Repository Exchange Protocol (RXP) is an XML-based API that you can use to interact with
application-level information in the workspace repository. This part of the documentation describes the
RXP query syntax and provides examples of its use.

Query Syntax

An RXP query consists of the tags and attributes described in this section.

Query

<query [name="QueryName*]> { Object } </query>
Objects

<object [global="false"]>

[ <objecttype> ObjectTypeCondition </objecttype> ]
[ <cond> Condition </cond> ]

[ <fetchtype as="FieldName*/> ]

[ <fetchid as="FieldName"/> ]

[ <fetchdisplay as="FieldName"/> ]

[ <fetchorigin as="FieldName"/> ]

[ <fetchsource as="FieldName"/> ]

[ <fetchsize as="FieldName"/> ]

{ <fetchconst type="FieldType® value="Constant”
as="FieldName"/> }

{ <fetchattr attr="AttrName® as="FieldName®"/> }

[ <related [countas="FieldName"][optional="true"]>
RelatedSpec

</related>]

</object>

ObjectTypeCondition

<typeset flag="FlagName" [negate="true"]/>

| <type name="EntityName® [negate="true"]/>

| <and [negate="true"]> { ObjectTypeCondition }
</and>

| <or [negate="true"]> { ObjectTypeCondition }
</or>

RelatedSpec

[ <reltype> RelTypeCondition </reltype> ]

[ <cond> Condition </cond> ]

[ <fetchtype as="FieldName"/> ]

{ <fetchattr attr="AttrName® as="FieldName®"/> }
Object

RelTypeCondition

<relset flag="RelFlagName® [negate="true"]
[incoming="true"]/>

| <rel name="RelationName® [negate="true"]/>

| <and [negate="true"]> { RelTypeCondition } </and>
| <or [negate="true"]> { RelTypeCondition } </or>
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Condition

<attr name="AttrName" op="Operation”
arg="Argument® [negate="true*]/>

| <hasrelated [negate="true®]> RelatedSpec
</hasrelated>

<id equals="Integer™ [negate="true"]/>

<id in="Integer{, Integer}" [negate="true"]/>
<source equals="String" [negate="true"]/>
<source In="String{,String}" [negate="true-]/>
<origin equals="SID" [negate="true"]/>
<origin in="SID{,SID}" [negate="true"]/>
<and [negate="true®]> { Condition } </and>
<or [negate="true"]> { Condition } </or>

EntityName

The name of a repository entity.

AttrName

The name of an entity attribute.

FieldName

The field name of the returned record set.

Operation
=|<>|>|>=|<|<=]like | in| between

Note: Since the RXP queries are XML constructs, make sure you use &lt; and &gt; instead of the
less-than and greater-than signs.

FlagName
LEGACY | PROGRAMCODE | SYSTEM | KNOWLEDGE | GENERATED | EXTRACT | COMPOSITE

RelFlagName
REFER | USE | GENERATE | PRODUCE

RelationName

The name of a relationship.

Argument
The argument of the operation. Depends on both argument type and operation.

QueryName

A string.

Example 1

This example queries the repository for the object ID and parse status of the GSS.cbl source file:
<query name="Select a COBOL object by name'>
<object>

<objecttype>
<type name="'COBOL"/>
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</objecttype>
<fetchid as="ID"/>
<fetchattr name="'ParseStatus" as="Parsed"/>
<cond>
<attr name="Name' op="=" arg="GSS.cbl"/>
</cond>
</object>
</query>

Example 2

This example queries the repository for copybooks used in three Cobol programs:

<query name="Find COPYBOOKs used in given programs'>
<object>
<objecttype>
<type name="'COBOL"/>
</objecttype>
<cond>
<attr name="Name'" op="in"
arg="""GSS1.CBL","GSS2.CBL","GSS3.CBL"""/>
</cond>
<related>
<reltype>
<relset flag=""USE"/>
</reltype>
<object>
<fetchid as="1D2"/>
<fetchtype as="'ObjectType2"/>
<fetchdisplay as="ObjectName2'/>
</object>
</related>
</object>
</query>

Portability Assessment

Portability Assessment lets you quickly generate HTML reports to identify points of interest for migrations.
All reports are presented under an easy to navigate main page. To run the report:

» Start Enterprise Analyzer.
* Click Reports > Portability Assessment.

The Portability Assessment window opens.

« Select the types of HTML reports you want to generate. Use the checkbox next to each report or check
Enable/Disable All.

* Enter the Folder Name and Folder Location where the report will be generated.
¢ Click Start to generate the reports or Close to quit.

When the report is ready a message is displayed asking if you want to see the report.
* Click Yes to view the report.

The results are displayed in your browser. Navigate through the reports. Check Hide empty reports to
hide/display empty reports. The reports are organized in tables. Click on the heading of the columns to
sort the data.

Note: Some of the reports may be available as advanced search queries in Interactive Analysis or
in the Repository Browser > Query Repository feature. Running these queries interactively or
editing them will not affect the results generated in the Portability Assessment report.
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Quality Assessment

Quality Assessment lets you quickly generate HTML reports to monitor applications for conformity to quality
rules or to identify candidates for quality improvements. All reports are presented under an easy to
navigate main page. To run the report:

» Start Enterprise Analyzer.
* Click Reports > Quality Assessment.

The Quality Assessment window opens.

« Select the types of HTML reports you want to generate. Use the checkbox next to each report or check
Enable/Disable All.

« Enter the Folder Name and Folder Location where the report will be generated.

* Click Start to generate the reports or Close to quit.

When the report is ready a message is displayed asking if you want to see the report.
* Click Yes to view the report.

The results are displayed in your browser. Navigate through the reports. Check Hide empty reports to
hide/display empty reports. The reports are organized in tables. Click on the heading of the columns to
sort the data.

Note: Some of the reports may be available as advanced search queries in Interactive Analysis.
Running these queries interactively or editing them will not affect the results generated in the
Quality Assessment report.

Analyzing Programs

Introducing Interactive Analysis

Much of the power of Enterprise Analyzer resides in a set of program analysis tools collectively called
Interactive Analysis. Interactive Analysis lets you analyze legacy programs interactively, by examining
synchronized, complementary views of the same information: source, context, impacts, and so forth. You
can use Interactive Analysis to analyze procedure and data flows, stage program analyses, create a project
glossary, extract business rules, and much more.

Interactive Analysis is designed primarily for programs, but you can also use it to analyze map files, JCL or
ECL files, IDMS schemas, and the like.

Understanding Interactive Analysis Models

For each object that comprises an application, Interactive Analysis generates a construct model that
defines its syntax. The construct model shows in abstract form how the syntactical constructs that
comprise the object (its sections, paragraphs, statements, conditions, variables, and so forth) are related.

A variable, for example, can be related in the construct model to its declaration, a dataport (if it is used in
an 1/O statement), or a condition (if the condition uses an expression of which the variable forms a part).
You view the construct model for a source file in the Interactive Analysis Context pane.

The figure below shows a portion of the construct model for the GSS5 . CBL program. The model shows that
the program executes a PERFORM statement if the value of the variable EIBRESP satisfies the condition
EIBRESP NOT EQUAL DFHRESP(NORMAL).
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=) A110-RECEIVE-MAP

=-f] _Par_al10-RECEIVE-MAP

- IF EIBAID = DFHCLEAR

- EXEC CICS RECEIVE

=& IF EIBRESP NOT EQUAL DFHRESP{NORMAL)

- =3 EIBRESP NOT EQUAL DFHRESP(NORMAL)
e
. @ 0

= THEN

If you are interested in investigating other uses of EIBRESP in the program, you can navigate to the
declaration of the variable in the construct model. Select EIBRESP in the Context pane and choose Edit >
Declaration.

E..@ LIMKAGE SECTION
=~ @ DFHEIELE
@ EIBAID
@ EIBATT
..... @ EIBRECY
@ EIBREQID
..... @ {FE
@ EIBRESPZ

From the declaration, you can generate a list of instances in which the variable is used. Select the
declaration in the Context pane and choose Edit > Instances.

& Properties - Declaration (SU3)
EIBRESF

@ &

File: SOURCES\COPYBOOK\DFHEIB.CPY Location: (27,12) - (27,41)
Offset: 1019 - 10449

Attributes  Instances ]

Entity | File | Position A~
# EIBRESP SOURCES\COB... 384 22
#® EIBRESP SOURCES\COB... 385 20
#® EIBRESP SOURCES\COB...  387: 15
#® EIBRESP SOURCES\COB...  448: 23
# EIBRESP SOURCES\COB...  450: 20
# EIBRESP SOURCES\COB... 452 15
# EIBRESP SOURCES\COB...  456: 15
#2 EIBRESP SOURCES\COB...  468: 23 v
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Select an instance in the list to navigate to that instance in the construct model.

Using the Interactive Analysis Main Window

The Interactive Analysis main window consists of a series of panes that offer complementary views of code
constructs in the selected source file. The display in each pane is synchronized with the others: selecting a
construct in one pane automatically moves the cursor to the construct in the other panes.

You can invoke Interactive Analysis directly by selecting a source file in the Repository Browser and
choosing Analyze > Interactive Analysis. Interactive Analysis is also available within the project analysis
tools (Diagrammer, Change Analyzer, and so forth) but "silently”, that is, without you ever actually invoking
it as such. Tool usage is identical in either case.

The first time you open Interactive Analysis it displays the Source and Context panes. Select the
appropriate choice in the View menu to show the other panes. A pane is available only if the view it offers
is relevant for the source file type selected in the Objects pane. You will not see the Program Control Flow
pane, for example, if a JCL file is selected in Objects pane. Choose the type of file to display from the
Select Type list under the title bar of the Objects pane, and then click Search. Select the file you want to
open from the resulting list in the Objects tab.

Use the choices at the top of the View menu to configure the panes in logical groupings. Choose Control
Flow, for example, to view the Source, Flowchart, Program Control Flow, and Animator panes. You can
hide a pane by clicking the close box in the upper right corner. Edit menu choices and pane-specific menu
choices have equivalent choices in the right-click menu.

) Tip: Double-click the title bar of a pane to maximize the pane in Interactive Analysis, hiding any other

~ open panes. Double-click the title bar again to restore the previous view.

The Interactive Analysis window's state (size, location, configuration, and option settings) is saved across
sessions. Interactive Analysis provides access to the product Activity Log and relevant options windows. To
view these items, select the appropriate choice in the View menu.

Note: Usage for the Data View and Data Flow panes is identical to that for the corresponding panes
in the Global Data Flow tool. For more information, see Analyzing Projects in the product
documentation set.

For Component pane usage, see Creating Components in the product documentation set.

Using Basic Navigation Controls

Interactive Analysis offers Explorer-style navigation controls on the tool bar, with corresponding choices in
the Edit menu:
Click the - button on the tool bar to navigate backward in the history of your selections in the

-

Interactive Analysis window (regardless of the pane in which they were made). Click the adjacent
button to display the selection history in a drop-down menu. Choose a selection by clicking it in the
menu.

Click the = button on the tool bar to navigate forward in the history of your selections in the Interactive

L4

Analysis window (regardless of the pane in which they were made). Click the adjacent ™ button to
display the selection history in a drop-down menu. Choose a selection by clicking it in the menu.

Click the button on the tool bar to navigate to the parent of the selected construct in the parse tree.

-

Click the adjacent button to display all of the ancestors of the selected construct in a drop-down
menu. Choose a selection by clicking it in the menu.

Using the Properties Window

The Interactive Analysis Properties window for a construct identifies its attributes and related constructs.
Attributes are the construct's type, name, location, and characteristics. Related constructs are the
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constructs with which the construct interacts. The Properties window is hot modal, so you can leave it up
throughout your Interactive Analysis session.

Opening the Properties Window

You can open the Properties window from any Interactive Analysis pane except the Model Reference pane.
Select the construct whose properties you want to view and choose Properties in the right-click menu. The
Properties window opens.

& Properties - File (SC)

MASTER-CAT
By A
File: SOURCES\COBOL\AR7100.CBL
Location: (26,8) - (29,24) Offset: 2058 - 2321
Attributes lF'.emrd Key ] Data Record ] Assignment] Instances ]
Mame Value -
Drganization Indexed
AcCcess Random
Lok
Duplicates False
Assignment
MName MASTER-CAT
Length 8
Picture
MormalizedPicture
Usage
MormalizedUsage Display
Digits 0
Fraction ] b
< >

Viewing and Navigating to Related Constructs

To view related constructs in the Properties window, click the tab for the type of related constructs you want
to view. Click a related construct to navigate to it in the Source or Context panes.

i Note: Click the B button in the Properties window to navigate back to the original construct.

Opening a Properties Window for a Related Construct

To open a Properties window for a related construct, select the related construct in the Properties window

and choose Properties in the right-click menu.

b 4 Tip: Click the + button to "pin" a Properties window, so that it remains open when you open
another Properties window. Click the button again to unpin the window.

Assigning Business Names Manually

To assign a business name and business description to an object, select the object and choose Set
Business Attributes in the right-click menu. A dialog box opens, where you can enter the business name
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and business description. To unassign a business name or business description, simply delete the value in
the dialog box.

Understanding Program Context

The Interactive Analysis panes described in this chapter offer a set of complementary views of legacy
source code. Together these views provide all the information you need to understand the context of a
program item:

* The Source pane displays view-only source for the selected file.

* The Context pane displays the same code in hierarchical form, in a parse tree that defines the
relationships between the code constructs that comprise the source.

* The Objects pane lists the files in the project. Select a file to open it in the Source or Context panes.

* The Watch pane displays program context in summary fashion, showing, in a single view, object model
context for the selected source file and construct model context for the selected construct.

* The Screen pane displays the screen object defined in the selected map file, complementing the
"bottom-up" analysis of application business processes in the Source and Context panes with a "top-
down" view that lets you navigate quickly to an item of interest.

Using the Source Pane

The Source pane displays view-only source for the selected file. The name of the file appears in the File
drop-down.

You can display the source code for an included file by choosing the file in the File drop-down. Use the
Objects pane to select a different file.

/ Note: Use the Editor in the Enterprise Analyzer main window to modify program source code.

HyperView - Training (Training) - AR7300.cbl
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Navigating and Searching for Source

Click in the Source pane to navigate to a construct. Enter a line number in the field next to the "= button
and click the button or press Enter to navigate to the line. Tool tips show line numbers in the source file
when you scroll the Source pane vertically.
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Using the Simple Search Facility
Interactive Analysis provides simple and advanced search facilities for source code. To use the simple
search facility, enter the text for the search in the field next to the @ button on the tool bar. Interactive

Analysis locates text matches as you type. Click the =4 button or press Enter to navigate to the next
matching construct.

-

To view matching constructs in a list, click the adjacent button. From the drop-down menu, choose:

* Find All to display pattern matches in a list.

* Wildcard Find All to display wildcard pattern matches in a list. You can use wildcard patterns allowed
in LIKE statements by Visual Basic for Applications (VBA).

* Recent Search List to display the results of the last simple search.

Double-click an item in a list to navigate to it in the Source pane.

Navigating to Related Constructs

The Edit menu lists choices corresponding to each type of relationship the selected construct has with
other constructs in the parse tree. If you select a variable in the Source pane, for example, the Edit menu
shows Conditions, Port, and Declaration choices. The choices are grayed-out if no relationships of the
given type exist for the selected construct.

To view all the constructs in the source file that have a given relationship with a construct, select the
construct in the Source pane and choose the appropriate relationship in the Edit menu:

< If only one construct has the specified relationship, Interactive Analysis simply moves the cursor to that
construct in every open Interactive Analysis pane.

» If more than one construct has the specified relationship, Interactive Analysis opens a list of related
constructs in the Properties window and moves the cursor to the first item in the list in every open
Interactive Analysis pane. To navigate to another item in the list, choose it in the Properties window.

Navigating to Multiple Occurrences of an Included Construct

If an included file is referenced multiple times in a program (in different structures, for example), you can
use the arrows in the upper right corner of the Source pane to navigate between each occurrence of an
included construct in the Context pane.

In the Source pane, click on the construct in the included file. The numbers in the upper right corner
indicate the sequence number of the current construct versus the total number of constructs. The notation
"2/3," for example, identifies the second occurrence of a construct that occurs three times. Use the arrows
to navigate between each occurrence.

Selecting and Copying Code

There are two ways to select and copy code in the Source pane, as construct or as text. The one you
choose depends on the task you want to perform.

Selecting and Copying Constructs

Click inside a construct in the Source pane to select it. The selected construct is highlighted. The number
of the first line of the selection is displayed in the Ln field above the source code. To copy the construct to
the clipboard, choose Copy Selected Construct in the Source menu.

Selecting and Copying Text

Copy code as text when you are assigning code segments to business rules manually and want to select
either more or less code than a construct contains. To select a code segment as text, click-and-drag from
the first line of the segment to the last line of the segment. The selected text is highlighted in blue. To copy
the selected segment to the clipboard, choose Source > Copy Selected Text.
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| Tip: Click the minus sign (-) next to a paragraph, procedure, or data definition to collapse its contents.

= Click the plus sign (+) to expand its contents.

Setting Source Pane User Preferences

Use the Interactive Analysis > Source tab of the User Preferences window to specify the color-coding used
in the Source pane and other display features.

1. Choose Tools > User Preferences. The User Preferences window opens. Click the Interactive Analysis
> Source tab.

2. select Iconic cursor to specify that the icon for a selected construct (Cﬂ for a data port, for example)
replace the standard cursor.

3. In the Selected Construct Color field, click the adjacent '™ button to edit the color used to highlight
the selected construct.

4, -

In the List Highlighting Color field, click the adjacent button to edit the color used to highlight lists.

5. In the Color Scheme pane, click the construct types whose text you want to colorize, or click Select All
to select all the construct types. The current color of the selected types (if any) is displayed in the Fore

-

Color drop-down. Click the adjacent '™ button to edit the color of the construct types.

6. Select Display Business Names to display business names rather than original identifiers in the
Context pane.

Collapsing and Expanding Paragraphs or Subprograms

In very long programs, it may be helpful to display the names of paragraphs or subprograms only and hide
their source code. To collapse paragraphs or subprograms, choose Edit > Collapse All. Click the plus sign
(+) next to a collapsed paragraph or subprogram to show its source code again. To show the source code
for all collapsed paragraphs or subprograms, choose Edit > Expand All.

Showing Source Code Boundaries

To demarcate source code from leading and trailing enumeration characters in source lines, choose Edit >
Show Boundaries.

Using the Context Pane

The Context pane displays the parse tree for the selected source file. The parse tree displays source code
constructs (sections, paragraphs, statements, conditions, variables, and so forth) in hierarchical form,
making it easy to locate code constructs quickly. Constructs are displayed in the order they appear in your
code.

Note: Interactive Analysis adds artificial "owning" sections or paragraphs to the parse tree as
necessary. An added, or faked, section or paragraph is denoted in the parse tree with a leading
underscore: _S1, for example.

The scope of the parse tree determines the constructs and relationships it displays: all constructs, only
control statements, only declarations, and so forth. Scopes include the lists Interactive Analysis generates
when you perform advanced searches, navigate to a related construct, or identify candidates in Code
Search. Choose the scope of the parse tree in the Scopes drop-down on the Context pane tool bar.

Click the plus sign (+) next to a construct to expand its hierarchy. Click the minus sign (-) to collapse the
hierarchy. The Edit menu lists every relationship type for the construct selected in the Context pane.

Perform other tasks as you do in the Source pane. Select Display Business Names in the User
Preferences for the Source pane to display business names rather than original identifiers in the Context
pane.
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Using the Objects Pane
The Objects Pane lists the files in the selected project. To view the files you want:
1. Select a type from the drop-down list.

y Note: The drop-down menu shows only types that have objects in the project.

2. (optional) Enter a search criteria.

ty Note: You can use wildcard characters in the search.

3. Click Search.

The first 100 rows matching the search criteria will be displayed.
4. (optional) Click View More to load another 100 objects to the list.

i Note: Once all objects have been loaded the button becomes inactive.

Using the Watch Pane

The Watch pane displays current program context in summary form, showing, in a single view, object
model context (Level 1) for the selected source file and construct model context (Level 2) for the selected
construct. Both the content of the Watch pane and its layout are customizable with the externalized XML
queries and CSS stylesheets provided with the product. For more information, contact support services.

Follow the instructions below to view current context summaries in the Watch pane.

HyperView - Training 13 (Training 13) - AR7200.cbl
File Edit View Help
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Level 2: <=Hide
Name: FCO0-KEY Location: SOURCES\COBOLVART200.CBL
Bus Name: FCO0-KEY Row: 168, Col: 36

Length: 13 FldOffset: 0

Digits: 0 Init: True

Fraction: 0

Data Source

FCSTMSTR. SOURCESVWCOBOLVART200.CBL at Row 168, Col 12

Data Destination

FCETMSTR SOURCES\WCOBOLVWART200.CBL at Row 168, Col 12
Received Values

‘999999

1. Select the source file you want to view in the Objects pane.
2. Select the construct you want to view in the Source or Context pane.
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3. Click the |2 button in the Watch pane to refresh the display:

* The object model context (Level 1) displays the logical object extracted from the selected source file
and its key metrics and relationships.

e The construct model context (Level 2) displays the selected construct, its business name, its location
in source, and other characteristics. For a variable, click the Build link to view a summary of impact
trace results:

« Data Source displays the flow of data through each port in the trace to the originating port.

- Data Destination displays the flow of data through each port in the trace to the destination port.

* Received Values displays the value of the watched variable at each location in the impact trace.
4. Click the Hide link to hide a summary. Click the Show link to restore a summary.
5. Click the & button to save the contents of the Watch pane to an HTML file. The Save Watch View dialog

opens, where you can specify the name and folder of the HTML file. The report opens when the save
operation is complete.

Using the Screen Pane

The Screen pane displays the screen object defined in the selected map file. It complements the "bottom-
up" analysis of application business processes in the Source and Context panes with a "top-down" view
that lets you navigate quickly to data items of interest in your application.

To view a screen object in the Screen pane, select the map file in the Objects pane, then select the screen
in the Source or Context panes. Choose Screen > Best Fit to fit the screen to the Screen pane. Choose
Screen > Actual Size to restore the screen to its actual size.

HyperView - Training 3 (Training 3) - MNTSET1.BEMS

File Edit SoeenPane  Wiew Help

@ ||Mm-e-o- | EHa @D #-

Screen Pane

Gray areas on the Screen pane represent screen fields. Click on a field or screen label to select it. Select a
field and choose Data Items in the right-click menu to view the declarations for the field in the Properties
window.

Manually Extracting Business Names for Program Variables

One of the most powerful features of Enterprise Analyzer lets you auto-extract screen labels as business
names for program variables. For each screen field with a label immediately to its left in the Screen pane,
the Glossary tool generates a business name for the program variable whose value is displayed in the field.
If the screen field has the label Customer Number, for example, Glossary assigns the business name
"Customer Number" to the variable whose value is displayed in the field.
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Occasionally, however, you may need a finer-grained approach than the auto-extract feature offers. The
field of interest may not be immediately to the right of the label, or the field may have no label at all. In
these situations, you can extract business names for program variables manually in the Screen pane.

1. Double-click a screen label and select the portion of the label you want to use as the business name,
then click Ctrl+C.

Note: You don't have to use the screen label. You can put any text on the clipboard and assign it
as the business name.

2. Select the field of interest and click Ctrl+V. Interactive Analysis paints a yellow box in the lower lefthand
corner of the field to indicate that the program variable for the field has been assigned a business name.
Double-click the field to navigate to the variable in the Glossary.

Using the Bird's Eye Pane

The Bird's Eye pane lets you quickly identify the location of a code construct relative to the entire program
and any included files. Click a construct in the Source or Context panes to view its location in the Bird's Eye

pane.
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Using the Model Reference Pane

The Model Reference pane displays the Interactive Analysis metamodel in text and diagram form. Check
the model reference embedded in the advanced search utility for the data types and definitions of construct
attributes you use in searches.
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Performing Advanced Searches

The Interactive Analysis Advanced Search facility distills the parse tree metamodel into a series of prompts
that help you build complex filters for construct searches. It also offers predefined filters that you can use to
search for dead code, hard-coded constants, nested conditionals, file and screen reads and writes,
program calls, SQL ports, and more.

Note: Certain performance-intensive searches, with criteria such as Contains or Is Nested In, may be
restricted to the master user.

You typically use the batch advanced search facility, embedded in the Code Search pane, to find constructs
in all files of a given type in your project. But you can also use standalone advanced search to find
constructs in a single file.

Note: The Change Analyzer tab opens a scoped version of the Advanced Search facility for Change
Analyzer. For Change Analyzer usage, see Analyzing Projects in the product documentation set.
Defining a Search Filter

The Advanced Search facility uses the attributes and relationships of a construct to define the conditions
you set in your search for the construct. As an example of how the facility works, let's look at how you might
define a search filter for the conditions a program uses to validate the variable EIBRESP.

1. Select the file you want to search in the Objects pane, then choose Edit > Find. The Search window
opens.

/ Note: Skip this step if you are using Code Search to perform a batch search.

2. Click the General tab.
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3. In the General tab, select a folder for the new criterion, then click the [ button on the tool bar. The New

Criterion dialog opens. Enter Field Validation in the text field and click OK. Interactive Analysis creates
the Field Validation criterion in the selected folder.
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4. Click the here link in the righthand pane of the Search window. The Select Construct Types window
opens.
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5. Select Condition in the list of constructs in the lefthand pane. In the righthand pane, review the
definition of a condition in the parse tree metamodel, then click OK. Interactive Analysis adds the
condition construct to the filter definition in the righthand pane of the Search window:

Find All Condition
6. Click the All link. The Condition window opens.

Enterprise Analyzer | 199



-

B " Condition

Applies to: |Relationship

Relationship Type

Child

Conditional Operator

Contains

Controlled PERFORM Statement
Implied Branch

Is Mested In

Parent

Variables

Entity Type

Expression

Expression (with all descendants)
File

GO TO statement

Handler Statement

1/O Statement
_ statement

m

Mext Sentence statement

Paragraph

Paragraph (with all descendants)

Perform

Perform Exit -

4 1L} I

[ Does not have the relationship

L

QK Cancel

7. In the Condition window, choose:

* Relationship in the Applies to drop-down.
* Is Nested In in the Relationship Type list box.
« |If Statement in the Entity Type list box.

Click OK. Interactive Analysis adds the relationship to the filter definition in the righthand pane of the
Search window:

Find Condition
which is nested in any IF statement

8. Click the any link. The Condition window opens. In the Condition window, choose:

* Relationship in the Applies to drop-down.
» Contains in the Relationship Type list box.
* Perform in the Entity Type list box.

Click OK. Interactive Analysis adds the relationship to the filter definition in the righthand pane of the
Search window:

Find Condition
which is nested in IF statement which contains any
Perform

9. Click the any link. The Condition window opens. In the Condition window, choose:

« Attribute in the Applies to drop-down.
e Caption in the Name list box.
e Like in the Operations drop-down.

Enter *ERROR™* in the Values field and click OK. Interactive Analysis adds the attribute to the filter
definition in the righthand pane of the Search window:

Find Condition
which is nested in IF statement which contains
Perform such that Caption Like "*ERROR*"

200 | Enterprise Analyzer



Note: Except for the # symbol, you can use wildcard patterns allowed in LIKE statements by
Visual Basic for Applications (VBA). Consult the Model Reference pane for attribute values.

10.Click the is nested in link. In the pop-up menu, choose And. The Condition window opens. In the
Condition window, choose:

* Relationship in the Applies to drop-down.
* Contains in the Relationship Type list box.
* Variable in the Entity Type list box.

Click OK. Interactive Analysis adds the relationship to the filter definition in the righthand pane of the
Search window:

Find Condition

which is nested in IF statement which contains
Perform such that Caption Like "*ERROR*"

and

which contains any Variable

11.Click the any link. The Condition window opens. In the Condition window, choose:

» Attribute in the Applies to drop-down.
* Caption in the Name list box.
¢ Like in the Operations drop-down.

Enter *E1B* in the Values field and click OK. Interactive Analysis adds the attribute to the filter
definition in the righthand pane of the Search window:

Find Condition

which is nested in IF statement which contains

Perform such that Caption Like "*ERROR*"

and

which contains Variable such that Caption Like "*EIB*"

Note: To edit an element in the filter definition, select its link and choose Edit in the pop-up menu.
To delete an element from the filter definition, select its link and choose Delete in the pop-up
menu.

12.Enter a description of the filter definition in the Description pane.

13'Click = on the tool bar to save the filter definition.
14.Click Find All Constructs to start the search.

Note: Check Run as Offline Job to run the search in background mode. You will see a message
Code Search job was successfully submitted to the Queue.

Executing Advanced Searches

You can execute an advanced search in standalone mode, against the file or construct selected in the
Source or Context pane, or in batch mode, in the embedded search pane in Code Search.

1. In the Search In drop-down on the tool bar, choose:

« Source file name with all included files if you want to execute the search against the selected
source file and any included files.
« Source file name only if you want to execute the search against the selected source file only.
« Selected Construct - Construct if you want to execute the search against the construct selected in
the Source or Context panes.
2. Choose the criterion for the search you want to execute from the list of criteria in the lefthand pane.
3. Select Case Sensitive Search if you want the search to match case.

4. Select Find All Constructs. Interactive Analysis displays a dialog box with the results of the search.
Click OK. The dialog and Search window are dismissed. Interactive Analysis displays the results in a list
named Last Search Results in the Internal category in Code Search.
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Advanced String Attribute Operations

The advanced string attribute operations can be set when you execute Code Search and when you have

defined a search filter.

y Note: The operations are available only for string objects.

You can execute a Code Search using different criteria. When you set a condition to search string
attributes, you can specify the following operations:

Like / Not Like

Regular
Expression

Length is Less
than/ Length is
Greater than

Match other
attribute value/ Do
not match other
attribute value

Contain other
attribute value/ Do
not contain other
attribute value

Partial Attribute
match
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Performs a wildcard (mask) match where ? (question mark) represents any
single character and * (asterisk) represents any character sequence.

Example:

» Select Name from the Name list, then select Like from the Operations drop-
down list, and then write * DAY in the values field. The new criterion returns all
names ending with "DAY".

» If the search criterion is: "Name" like "???DAY", the search finds all 6 character
long names ending with "DAY".

Performs regular expression matching. This function uses syntax specific to the
RDBMS.

Example (Oracle only): "Name" matches ""Ste(v|ph)en”, will match names which
begin with "Ste" and end with "en" with either "v" or "ph" in between, so both
"Steven" and "Stephen" will be selected.

On Microsoft SQL Server databases, you need to install an additional package on
the SQL Server machine to get regular expression support. This package is
provided by Microsoft.

f Note: There are significant differences in regular expression syntax between
the Oracle and MS SQL Server implementations. For more information check
their corresponding documentation.

/ Note: Due to the nature of the regular expressions, utilization of a database
index is not possible for their evaluation, therefore the performance for such
queries is expected to be relatively slower.

Compares attribute value lengths.

Example: "Name" length is "6", finds all 6 character long names.

Compares two attribute values.

Example: "Name" matches attribute "JobName", finds all names matching the
"JobName" as well.

Checks if an attribute value contains another attribute value.

Example: "Name" contains attribute "JobName", finds all names which also contain
"JobName" value.

Partial Match compares part of an attribute value with another part of another
attribute value.

Example: "Name" pos 10-12 matches pos 5-7 of "JobName", finds all names where
the value from character position 10 to 12 matches the "JobName" value from
character position 5to 7.



Working with Advanced Search Criteria

This section describes common tasks you perform with advanced search criteria.

Creating a Search Criterion

To create a search criterion, select the folder for the new criterion in the General tab, then click the O
button on the tool bar. The New Criterion dialog opens. Enter the name of the criterion in the text field and
click OK.

Editing a Search Criterion

To edit a search criterion, select the criterion, then select the link for the element you want to change in the
filter definition. Choose Edit in the pop-up menu to edit the element, or Delete to delete the element.

y Tip: To restore the original definition of a predefined search criterion, select the criterion and click the
&3 button on the tool bar.

Copying a Search Criterion

To copy a search criterion, select the criterion and click the button on the tool bar. The New Criterion
dialog opens. Enter the name of the new criterion in the text field and click OK.

Saving a Search Criterion

To save a search criterion, select the criterion and click the = button on the tool bar. The criterion is
available to every project in the workspace.

Deleting a Search Criterion

To delete a search criterion, select the criterion and click the #% button on the tool bar. You are prompted
to confirm the deletion. Click OK.

f Note: You cannot delete a predefined search criterion.

Creating a Folder for Search Criteria

To create a folder for search criteria, click the ! button on the tool bar. The New Folder dialog opens.
Enter the name of the new folder in the text field and click OK. The new folder appears in alphabetical
order in the tree in the lefthand pane of the window. Drag-and-drop search criteria to move them to the
folder. You can create folders within folders.

To copy a folder and all its contents, select the folder and click the button on the tool bar. The New
Folder dialog opens. In the text field, enter text to be prepended to the folder name and to the names of
each of its subfolders and search criteria, and click OK.

To modify a folder name, click in the name area for the folder to make the name editable, enter the new

name, and press Enter. To delete a folder, select it and click the #% button on the tool bar. You are
prompted to confirm the deletion. Click OK.

Saving a Search Criterion as HTML

To save a search criterion in an HTML file, select the criterion and click the button on the tool bar. The
Save Criteria dialog opens, where you can specify the name and folder for the HTML file.
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Exporting and Importing a Search Criterion

To export a search criterion to an XML file, select the criterion and click the E'h button on the tool bar. The
Export Criteria dialog opens, where you can specify the name and folder for the XML file.

To import a search criterion, click the ﬁ button on the tool bar. The Import Criteria dialog opens, where
you can select the criterion you want to import.

Staging Program Analysis with Code Search

Use the Code Search pane to stage the results of a batch search as input for subsequent tasks: viewing
source and context, colorizing sliced code, extracting business rules, and the like. A system analyst, for
example, might use Code Search to create a list of programs impacted by a change request, then create a
project that contains only the source files for those programs.

Code Search searches are executed against the current project. You can also execute searches against
the results of a previous search.

Note: Certain performance-intensive Code Search searches, with criteria such as Contains or Is
Nested In, may be restricted to the master user.

Getting Started in Code Search

Code Search is project related. It executes a search over all verified files in the project.

This section describes a sample use of Code Search that should help you get oriented in the tool. Assume
that you want to create business rules for segments of code that write to a file:

1. Inthe Interactive Analysis window, if the Code Search pane is not visible, click View > Code Search.
This displays the Code Search pane in the Interactive Analysis window.

In the Code Search pane, click the Top view link. The Top view opens.
Double-click the Rule Finder category. The Rule Finder view opens.

On the tool bar, click Add ('—_f.'}). This opens the New list dialog box.

In the Enter new list name field, type Fille Writes and then click OK. An empty list named File
Writes is added to the Rule Finder view.

Click Advanced Search. This opens the Search dialog box.
In the top left, select the file type you want to execute the search against. In this case COBOL File.
In the Search In list, select All Objects.

In the Criteria tree, expand the Data Ports folder, then expand the Files folder. Select the predefined
All File Writes criterion and then click Find All Constructs.

o M w N

© © N o

Note: You can modify the predefined search criterion or create your own search criterion as you
do in the Advanced Search facility.

10.Interactive Analysis displays a list of files that match the search criteria in the Code Search pane. The
count column displays the number of constructs found in the file.

11.Click Execute (%) and then click Create Rules from the displayed list. This opens the Rules dialog
box. Which displays the following message:
You are about to generate templated business rules into a specified rule set. Continue?

12.Click Yes to continue. This opens the Create Rules From List dialog box.
13.Select an existing Business Function from the list or create a new one by clicking New:

a) If you choose New, the Business Function dialog box opens.
b) In the Business Area field, select a business area from the list or type a new one.
¢) Inthe Name field, type a name.
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d) (Optional) In the Technical Description field, type a technical description of the function.
e) (Optional) In the Business Description field, type a business description of the function.
f) Click OK to create the business function and to return to the Create Rules From List dialog box.
The newly created Business Function is selected.
14.Select an existing Rule Set from the list or create a new one by clicking New:
a) If you choose New, the Create Rule Set dialog box opens.
b) The Name field has an auto-generate name, if you want you can type your own name.
c) (Optional) In the Technical Description field, type a technical description of the function.
d) (Optional) In the Business Description field, type a business description of the function.
e) Click OK to create the rule set and to return to the Create Rules From List dialog box.
15.(Optional) Click the Business Description Template tab, and then type a description.
16.(Optional) Click the Technical Description Template tab, and then type a description.
17.Click OK.

This creates the rule.

18.To view the new rule, click View > Rules This opens the Rules pane which contains the new rule
created. In the Grouping tab you can see a tree displaying all the instances that match the rule created.

Understanding the Code Search Pane

Interactive Analysis lists offer convenient ways to navigate program code and record the results of program
analyses. Use the hierarchy of views in the Code Search pane to display Interactive Analysis lists and
perform other list-related tasks:

« The Top view displays the folders, or categories, for lists.

« The Category view displays the lists in the selected category.

* The List view displays source files with non-zero counts in the selected list.

* The File view displays each construct in the list for the selected source file. Click a construct in the list to
navigate to it in other Interactive Analysis panes.

Each view gives you access to the next-level view in the hierarchy. Click the label for a view to navigate to

it. Double-click an item in the view to drill down to the next view in the hierarchy. Click the button on
the tool bar to navigate to the parent of the current view.

Working with Categories

The Top view of the Code Search pane displays the categories for Interactive Analysis lists. Categories are
displayed only for lists you can create for the source file type selected in the Objects pane.

You can use predefined categories or create your own. All predefined categories are shared. Use the
General and Internal categories for unenumerated tasks.

Note: Interactive Analysis puts the results of standalone advanced searches in a predefined list called
Last Search Results in the Internal categories.

To create a category, select the parent category and click Code Search > Add. The New category dialog
opens, where you can specify the new category name. A list with the category name is automatically
created in the category. To edit the category name, click the name and type over it in the text box.

By default, user-defined categories are not shared. To share a user-defined category, select it and click the

s button on the tool bar. A ¥ symbol indicates that the category is shared. Click the e button again to
turn sharing off.

Note: Sharing a user-defined category automatically makes its parent categories shared. Unsharing a
user-defined category automatically makes its children unshared.
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Working with Lists

The Category view of the Code Search pane displays the lists in the selected category. You can use
predefined lists or create your own. Use Code Search to populate lists.

Creating a List

To create a list, double-click the category for the list in the Top view and choose Code Search > Add. The
New List dialog opens, where you can specify the name of the new list.

Deleting a List

To delete a list, select it and click the #% button on the tool bar. You are prompted to confirm the deletion.
Click OK.

Copying a List

To copy a list, select it and click the button on the tool bar. In the Top view, select the category you want

to copy the list into and click the e} button. The Copy List dialog opens, where you can enter the name of
the new list. You can copy a list into the same category.

Sharing a List

By default, lists are not shared. To share a list, select it and click the

J_:I button on the tool bar. A ¥ symbol indicates that the list is shared. Click the lj—:l button again to turn
sharing off.

Adding a Construct to a List Manually

To add a construct to a list, select a source file in the List view, then choose a construct in the Source or

Context panes. Click the 2 button on the tool bar to add the construct to the list of constructs for the
selected file.

Deleting a Construct from a List

To delete a construct from a list, select the construct in the File view and click the % button on the tool
bar. You are prompted to confirm the deletion. Click OK.

Executing Code Search Searches

Code Search is project related. It executes a search over all verified files in the project. All categories,
criteria and lists with results are global options for all repository projects and show the results for the
current search. After completing the search, the result is saved in the List View. The last executed search
can be used as a starting point for the next search and can be accumulated with the new one by checking
Accumulate search results in the search view. Otherwise the previous content from the list will be lost.

Use a Code Search to generate Code Search lists. You can modify the predefined search criteria or create
your own criteria as needed. You can use a construct list itself to narrow the search.

&
L Select a list, then click the '™ button next to the %l button on the tool bar. In the drop-down, choose

the type of object you want to execute the search against. The Search window opens.
2. In the Search In drop-down, select:

« All Sources to execute the search against all the sources of the specified type in the project.

< Alist if you want to execute the search only against sources of the specified type with non-zero
counts in the selected list. If you select Rule Finder.File Writes, for example, the search will be
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executed only against sources of the specified type with non-zero counts in the File Writes list in the
Rule Finder folder.

3. Choose the criterion for the search you want to execute from the list of criteria in the lefthand pane.
Modify the predefined criteria or create your own criteria as needed.

4. Select Accumulate Search Results if you want the results of the search to be added to the results of
the previous search. Otherwise, the new results overwrite the previous results.

5. Select:

* Find All Constructs if you want Interactive Analysis to create for each searched file a list of all the
constructs found by the search.

« List Sources Only if you want Interactive Analysis simply to indicate for each searched file (with the
notation >0) whether the construct of interest exists in the file.

Interactive Analysis displays a dialog box with the results of the search operation. Click OK. The Search
window is dismissed and the results of the search are displayed in the List view.

Using Construct Lists to Narrow a Code Search

Once you have generated a construct list in Code Search, you can use the list itself as a condition of a
search. That is, you can use the search results to refine a subsequent search.

Suppose you have performed a Code Search for duplicate paragraphs in COBOL programs, storing the
results in a list called Matched Paragraphs in the General folder. The next step might be to search for all
PERFORM statements that reference the duplicate paragraphs. The example below shows how you might
use a Code Search list of duplicate paragraphs as a condition of the search.

L]
L Select a list, then click the '™ button next to the %l button on the tool bar. In the drop-down, choose

the type of object you want to execute the search against. The Search window opens.

" Select a folder for the new criterion in the General tab, then click the [3 button on the tool bar. The New
Criterion dialog opens. Enter Perform Duplicates in the text field and click OK. Interactive Analysis
creates the Perform Duplicates criterion in the selected folder.

3. Click the here link in the righthand pane of the Search window. The Select Construct Types window
opens.

4. Select Perform in the list of constructs in the lefthand pane, then click OK. Interactive Analysis adds the
condition construct to the filter definition in the righthand pane of the Search window:

Find All Perform
5. Click the All link. The Condition window opens. Choose:

* Relationship in the Applies to drop-down.
» Called Paragraph in the Relationship Type list box.

6. Click OK. Interactive Analysis adds the relationship to the filter definition in the righthand pane of the
Search window:

Find Perform
which has related any Paragraph (as Called Paragraph)

7. Click the any link. The Condition window opens. Choose:

« Listin the Applies to drop-down.
* General.Matched Paragraphs in the Name drop-down.

You can filter out list constructs by selecting Does not belong to the list in the Condition window.
8. Click OK. Interactive Analysis adds the list to the filter definition in the righthand pane of the Search
window:

Find Perform
which has related Paragraph (as Called Paragraph)
which is in list

General _.Matched Paragraphs

Enterprise Analyzer | 207



9. Execute the search. Interactive Analysis displays a dialog box with the results of the search operation.
Click OK. The Search window is dismissed and the results of the search are displayed in the List view.

y Tip: As a practical matter, you would probably also want to search for GO TO statements that

= reference the duplicate paragraphs. You could simply add the results of this search to the results of

the search for PERFORM statements by using the Accumulate Search Results button.

Searching for Similar Constructs in Code Search
To search for similar constructs, select a construct in the Source or Context panes, then select a list. Click

the #h button on the tool bar. The New Criterion dialog opens. Enter a criterion name or accept the
default.

The Search window opens with a predefined search criterion that will generate a list of constructs similar to
the selected construct. The new criterion is added to the General tab of the advanced search facility. Edit
the criterion if necessary, then execute the search.

Extracting Business Rules in Code Search
To extract business rules for multiple constructs, use the following method:

* Generate rules for listed constructs in a specified rule set. When you choose this option, you batch
process rule attributes in the generation step.

y Tip: As long as the Rules pane is open, you can generate a rule for a single construct by selecting the
= construct in the File view and choosing Rule > Create Rule.

Generating Business Rules in a Specified Rule Set

Follow the instructions below to generate rules in a specified rule set with predefined attributes. Code
Search creates a rule for each construct in the Code Search list.

1.

-

Select a list in the Rule Finder category, then click the button next to the % button on the tool bar
and choose Create Rules in the drop-down menu. The Select Method dialog opens.

2. In the Select Method dialog, select templated rules into a specified rule set and click OK. The Create
Rule Set window opens.

3. In the Business Function drop-down, select the business function for the rule set. The current
business function is displayed. To create a new business function, click New.

4. In the Name field, enter the name of the rule set for the rules you want to create and click OK. The
Create Rules From List window opens.
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