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Micro Focus Visual COBOL 2.3 for ISVs
Release Notes

The Micro Focus Visual COBOL for ISVs package comprises the following products which you can
download from your Electronic Product Delivery Note:

• Visual COBOL for Visual Studio - delivers the richest development experience for COBOL programming
available on Windows using Microsoft's Visual Studio in one of the following versions 2012, 2013 or
2015. Visual COBOL supports the development and deployment of both managed .NET and native
COBOL applications.

• Visual COBOL for Eclipse - provides an Eclipse-based integrated COBOL development environment for
Windows or Linux. Provides COBOL JVM support and enhanced compatibility with ACUCOBOL. Can
be used standalone for developing local applications or in conjunction with the Development Hub to
develop remote projects in Linux and UNIX.

• Visual COBOL Development Hub - provides a rich desktop development environment based on the
Eclipse IDE with high-performance server-based tools for managing builds, source code access and
debugger engine. The Development Hub also provides a central administration site, simplifying the
development tool distribution and maintenance process.

These release notes contain information that might not appear in the Help. Read them in their entirety
before you install the product.

Note:

• This document contains a number of links to external Web sites. Micro Focus cannot be
responsible for the contents of the Web site or for the contents of any site to which it might link.
Web sites by their nature can change very rapidly and although we try to keep our links up-to-date,
we cannot guarantee that they will always work as expected.

• Check the Product Documentation section of the Micro Focus SupportLine Web site and the Micro
Focus Infocenter for any updates to the documentation which might have been uploaded.

• Starting with this product release, Micro Focus no longer supports Visual COBOL for Visual Studio
2010.

• This product includes OpenSSL version 1.0.1m.

Important: Application executables that were compiled using earlier Micro Focus products must be
recompiled from the sources using Visual COBOL.
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System Requirements

System Requirements for Visual COBOL for Visual Studio

Hardware Requirements
Visual COBOL has the following requirements in addition to the requirements of Microsoft Visual Studio.
See the Visual Studio documentation for details of the Microsoft requirements.

The maximum disk space requirements are, approximately:

Visual COBOL Sentinel RMS License Manager

1.2Gb 75MB

• This includes the space needed to cache information locally so that you can modify the installation
without the original source media.

• The disk space requirements include the versions of JRE and .NET Framework supplied with the setup
file.

Operating Systems Supported
Note: If you are using Visual COBOL on a 64-bit operating system, you can produce either 32-bit or
64-bit applications.

For a list of the supported operating systems, check the Product Availability section on the Micro Focus
SupportLine Web site: http://supportline.microfocus.com/prodavail.aspx.

Note:

• Visual COBOL for Visual Studio is not supported on versions of Windows earlier than Windows 7.
• The Enterprise Server feature is not supported on Windows XP.

Software Requirements

Windows:

Note:

• The setup file will check your machine for whether the prerequisite software is installed and will
install any missing prerequisites and the product components.

• Besides the software listed below, the setup file also installs the 32-bit Java 8 Update 51.

Visual Studio IDE

This product requires Microsoft's Visual Studio - either the Visual Studio Integrated Shell or a more
advanced version of Visual Studio.

The following advanced editions of Visual Studio are required:

Professional, Premium, or Ultimate (for Visual Studio 2012)
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Professional, Premium, Ultimate or Community Edition (for Visual Studio 2013)
Professional, Enterprise or Community Edition (for Visual Studio 2015)

If there is no Visual Studio installed on your machine, the setup file for Visual COBOL for Visual Studio
2012 or 2013 will install the Visual Studio Integrated Shell.

Important:

• A problem with Microsoft's Windows 10 prevents installing the Visual Studio 2013 Shell on that
version of the OS. You must install an advanced edition of Visual Studio 2013 on Windows 10
before you start the installation of Visual COBOL for Visual Studio 2013.

• Code generation issues in Microsoft's 64-bit JIT (just-in-time) compiler delivered as part of .NET
Framework version 4.6 can result in incorrect execution of some COBOL code compiled to .NET.
Version 4.6 of the .NET Framework is currently shipped as default with Visual Studio 2015 and
Microsoft's Windows 10. The problems include incorrect execution of MOVE and STRING
statements applied to alphanumeric operands, and incorrect execution of the ROUNDED phrase
for arithmetic statements.

Some of these issues only seem to be reproducible in COBOL language applications compiled
to .NET and some can be reproduced in other languages (C# or Visual Basic).

These problems have been reported and acknowledged by Microsoft and it is our belief that they
either have resolutions or are working on fixes for all of them. For further information about these
issues and guidelines on how to disable the latest version of the 64-bit JIT compiler, see RyuJIT
Bug Advisory and Troubleshooting RyuJIT.

As of October 2015, Microsoft have released the following updates that address these issues with
the .NET Framework 4.6:

• Hotfix rollup 3088955 for the .NET Framework 4.6 on Windows Server 2012 and Windows 8 -
see: http://www.microfocus.com/docs/links.asp?vc=mskb3088955.

• Hotfix rollup 3088956 for the .NET Framework 4.6 on Windows Server 2012 R2 and Windows
8.1 - see: http://www.microfocus.com/docs/links.asp?vc=mskb3088956

• Hotfix rollup 3088957 for the .NET Framework 4.6 on Windows 7 SP1, Windows Server 2008
SP2, Windows Server 2008 R2 SP1, and Windows Vista SP2 - see: http://
www.microfocus.com/docs/links.asp?vc=mskb3088957.

• Cumulative update 3093266 for Windows 10: September 30, 2015 (available through Windows
Update) - see: http://www.microfocus.com/docs/links.asp?vc=mskb3093266.

• Visual COBOL for Visual Studio 2015 does not support Visual Studio 2015 Shell as the Shell has a
number of restrictions to COBOL development. The Visual Studio 2015 Shell is not included in the
setup for Visual COBOL for Visual Studio 2015 and before you start the installation, ensure that
there is an advanced edition of Visual Studio 2015 installed on your machine.

Note:

• On Windows 8.1 RT, Windows 8.1 or Windows Server 2012 R2, you must have the Windows
update KB 2919355 before you install Visual Studio 2015. Download KB 2919355 from the 
Microsoft Download Center.

• Microsoft Visual Studio Express Edition is not supported.
• You can download the Visual Studio Integrated Shell from the Microsoft Download Center. If you

choose to install the Shell, ensure you run the installer to complete the installation - run
vsintshell.enu.exe from the location where you installed the download.

Note that some Visual Studio features might not be available with the Shell. This includes WCF or
the Visual Studio 2013 Connected IDE experience in the Visual Studio 2013 Shell - the help for
more details.

The following software is also required:
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• Microsoft Windows SDK is required if you are using the Visual Studio Shell. See the Microsoft
Download Center and search for Windows SDK.

• Microsoft .NET Framework 4.5. This is included with Visual Studio 2012.
• Microsoft .NET Framework 4.5.1. This is included with Visual Studio 2013.
• Microsoft .NET Framework 4.6. This is included with Visual Studio 2015.

Internet Explorer 10

Internet Explorer 10 (IE 10) is required by the installation of Visual Studio 2013. If you are installing Visual
COBOL on a machine that has no Visual Studio 2013 installed, the setup file installs Visual Studio 2013
Shell provided that IE 10 is installed beforehand. You can download IE 10 from Microsoft's Web site.

IIS Express

IIS Express is required if you want to use the Web development tools. You can download IIS Express from
the Microsoft Download Center.

Other Requirements

Important: This release requires version 10000.2.990 or later of the Micro Focus License
Administration tool. For local servers, you do not need to install it separately, as the setup file installs
a new Visual COBOL client and a new licensing server on the same machine.

If you have a network server, you must update the license server before installing the product as the
client is not able to communicate with license servers of versions older than 10000.2.660. On
Windows, you can check the version of your license server by clicking Help > About in the Micro
Focus License Administration tool. To check the version of the license server on UNIX, run /var/
microfocuslicensing/bin/mfcesver or /var/microfocuslicensing/bin/
cesadmintool.sh.

You can download the new version of the license server software from the Micro Focus SupportLine
Web site: http://supportline.microfocus.com.

System Requirements for Visual COBOL for Eclipse
(Windows)

Hardware Requirements
Visual COBOL has the following requirements in addition to the requirements of Eclipse. See the Eclipse
documentation for details of its requirements.

The disk space requirements are, approximately:

Visual COBOL Sentinel RMS License Manager

3.7GB 75MB

Note: The disk space requirements include the size of the Eclipse IDE and the version of Java and
the .NET Framework provided with the Visual COBOL setup file. This includes the space needed to
cache information locally so that you can modify the installation without the original source media.

Operating Systems Supported
Note: You can produce 64-bit and 32-bit applications on 64-bit operating systems.
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For a list of the supported operating systems, check the Product Availability section on the Micro Focus
SupportLine Web site: http://supportline.microfocus.com/prodavail.aspx.

Note: The Enterprise Server feature is not supported on Windows XP.

Software requirements
The setup file will check your machine for whether the prerequisite software is installed and will install any
missing prerequisites and the product components.

Eclipse requirements

• Though Visual COBOL does not support the 64-bit Eclipse, you can use the 32-bit Eclipse to create
both 32-bit and 64-bit applications.

• Visual COBOL requires a 32-bit Java installation.
• Visual COBOL ships with Eclipse 4.4.2. After the installation, you can install the Visual COBOL plug-in

into other instances of Eclipse available on the same machine. The supported versions are 4.2 and 4.3
for the 32-bit Eclipse only. See Installing Visual COBOL into other instances of Eclipse for instructions.

Other software requirements

• Oracle's Java Platform, Enterprise Edition (Java EE) 7 or Java 8 is required to run the Eclipse IDE, to
execute COBOL JVM code and for native COBOL and Java interoperability. The setup file installs Java
8 u51 32-bit. You can download Oracle's Java EE from Oracle's Web site and install it anywhere on your
machine.

Note: If you have Java 7 installed on your machine and you do not want the setup file to install
Java 8, you can install the product silently and use the skipjre=1 command line option to skip
installing Java 8. See Installing Silently for more details.

• The setup file also installs .NET Framework v4.5.2 and the Microsoft Visual C++ 2010 and 2012
Redistributables.

See the Java Support Considerations for the Eclipse IDE in the Known Issues and Restrictions section in
your product help for considerations that apply to using the Eclipse IDE and Java.

Important: This release requires version 10000.2.990 or later of the Micro Focus License
Administration tool. For local servers, you do not need to install it separately, as the setup file installs
a new Visual COBOL client and a new licensing server on the same machine.

If you have a network server, you must update the license server before installing the product as the
client is not able to communicate with license servers of versions older than 10000.2.660. On
Windows, you can check the version of your license server by clicking Help > About in the Micro
Focus License Administration tool. To check the version of the license server on UNIX, run /var/
microfocuslicensing/bin/mfcesver or /var/microfocuslicensing/bin/
cesadmintool.sh.

You can download the new version of the license server software from the Micro Focus SupportLine
Web site: http://supportline.microfocus.com.

System Requirements for Visual COBOL for Eclipse
(UNIX)
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Hardware Requirements for Visual COBOL for Eclipse
Visual COBOL has the following requirements in addition to the requirements of Eclipse. See the Eclipse
documentation for details of its requirements.

The disk space requirements are approximately:

Platform Installer type Setup

file size

(MB)

Disk space

required for

the installation

(GB)

Disk space

required for

running

the product

(GB)

Sentinel RMS

license
server

(MB)

x86-64
running Red
Hat Linux

Micro Focus installer 923 3.69 1.84 46

x86-64
running SUSE
SLES

Micro Focus installer 927 3.71 1.85 46

Operating Systems Supported
Note: You can produce both 64-bit and 32-bit applications on 64-bit operating systems.

For a list of the supported operating systems, check the Product Availability section on the Micro Focus
SupportLine Web site: http://supportline.microfocus.com/prodavail.aspx.

Software Requirements

Eclipse requirements

• Visual COBOL only supports the 32-bit Eclipse IDE and requires a 32-bit Java installation.
• Though Visual COBOL does not support the 64-bit Eclipse, you can use the 32-bit Eclipse to create

both 32-bit and 64-bit applications.
• Visual COBOL ships with Eclipse 4.4.2. After the installation, you can install the Visual COBOL plug-in

into other instances of Eclipse available on the same machine. The supported versions are 4.2 and 4.3
for the 32-bit Eclipse only. See Installing Visual COBOL into other instances of Eclipse for instructions.

Other software requirements

Before installing this product, you must have the following software installed on your computer:

• The unzip utility is required by the setup file.

• The pax archiving utility is required by the setup file. Pax is distributed with most UNIX/Linux systems
but, if it is missing, you must install it separately. To verify pax is installed, run pax --help or pax --
version at the command line.

• The following libraries must be installed:

Library Platform

SUSE 11 SUSE 12 Red Hat 6.x Red Hat 7

glibc-locale-32bit X X

10 | System Requirements

http://supportline.microfocus.com/prodavail.aspx


Library Platform

SUSE 11 SUSE 12 Red Hat 6.x Red Hat 7

gcc X X

gtk2 (libgtk2, gtk2-
tools-32-bit)

X

libXcomposite1-32
bit

X

libgdk_pixbuf-2_0-
0-32bit

X

gdk-pixbuf-query-
loaders-32bit

X

libjasper1-32bit X

gtk2-x11
(libgthread-2_0-0-
32bit)

X

libXtst6-32bit X

gcc*.i686 X X

glibc-*.x86_64 X X

glibc-*.i686 X X

libgcc-*.x86_64 X X

libgcc-*.i686 X X

libstdc++-*.x86_64 X X

libstdc++-*.i686 X X

gtk2-*.x86_64 X X

gtk2-*.i686 X X

gtk2-
engines.*.i686

X

gtk2-
engines.*.s390

X

gtk2-
engines.*.x86_64

X X

libXtst-*.x86_64 X X

libXtst-*.i686 X X

libcanberra-gtk2-
*.x86_64

X X

libcanberra-gtk2-
*.i686

X X

libgnome.x86_64 X X

libgnome.i686 X X

PackageKit-gtk-
module-*.x86_64

X X

System Requirements | 11



Library Platform

SUSE 11 SUSE 12 Red Hat 6.x Red Hat 7

PackageKit-gtk-
module-*.i686

X

PackageKit-gtk-
module-*.s390

X

PackageKit-gtk3-
module-*.i686

X

PackageKit-gtk3-
module-*.s390

X

webkitgtk.x86_64 X

webkitgtk.i686 X

webkitgtk3.x86_64 X

webkitgtk3.i686 X

xterm (any
version)

X X

gdb* X X X X

* Additional libraries required to use the core_on_error runtime variable. The gdb packages (for the
GNU Project Debugger) can be installed from the install media for your OS.

** Operating system libraries required for PL/I support on both SUSE and Red Hat.

Visit the Red Hat Web site for more information.

• Xterm, the terminal emulator for the X Window System, is part of your UNIX/Linux distribution but is not
installed by default. Use your UNIX/Linux installation media to install it.

• Oracle's Java Platform, Enterprise Edition (Java EE) 7 or Java 8 is required to run the Eclipse IDE, to
execute COBOL JVM code and for native COBOL and Java interoperability. The setup file installs Java
8 u51 32-bit. You can download Oracle's Java EE from Oracle's Web site and install it anywhere on your
machine.

Note: On Linux, the 32-bit version of Java is required to install and use Visual COBOL for Eclipse.
When you start the installation, if the 64-bit version of Java is already installed on your Linux
machine, you might not be able to install Visual COBOL. This is a known issue with the Oracle
Java installers for Linux which prevent you from installing both the 32-bit and the 64-bit versions of
Java on the same machine. To work around this problem:

• Download the 32-bit Java distribution in a compressed .tar format from the Oracle Web site.
• Untar the distribution into a location different from the one used for the 64-bit Java version. For

example, untar in /usr/local/java32 and not in /usr/local/java.
• Set JAVA_HOME and LD_LIBRARY_PATH to the 32-bit version of Java so that it is used to

install and run Visual COBOL.

Before you start the installation, you need to set the environment as follows:

• You need to set the JAVA_HOME environment variable. When installing the product, set this variable to
a 32-bit Java installation or the installation terminates. For example, execute the following:

JAVA_HOME=java_install_dir

where java_install_dir is the path to the JAVA installation directory such as /usr/java/javan.n
• You need to add $JAVA_HOME/bin to your system PATH variable. To do this, execute:

export PATH=$JAVA_HOME/bin:$PATH
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• You need to set the LANG environment variable to pick up localized messages. The LANG settings are
English and Japanese only.

Important: This release requires version 10000.2.990 or later of the Micro Focus License
Administration tool. For local servers, you do not need to install it separately, as the setup file installs
a new Visual COBOL client and a new licensing server on the same machine.

If you have a network server, you must update the license server before installing the product as the
client is not able to communicate with license servers of versions older than 10000.2.660. On
Windows, you can check the version of your license server by clicking Help > About in the Micro
Focus License Administration tool. To check the version of the license server on UNIX, run /var/
microfocuslicensing/bin/mfcesver or /var/microfocuslicensing/bin/
cesadmintool.sh.

You can download the new version of the license server software from the Micro Focus SupportLine
Web site: http://supportline.microfocus.com.

System Requirements for Visual COBOL Development
Hub

Hardware Requirements for Micro Focus Visual
COBOL Development Hub
The disk space requirements are approximately:

Platform Installer type Setup

file size

(MB)

Disk space

required for

the installation

Disk space

required for

running

the product

(MB)

Sentinel RMS

license
server

(MB)

POWER
running AIX

Micro Focus installer 419 1.68 GB 838 36.5

HP IA Micro Focus installer 763 3.05 GB 1526 69

System Z
running Red
Hat Linux

Micro Focus installer 346 1.38 GB 692 36

x86-64
running Red
Hat Linux

Micro Focus installer 359 1.44 GB 718 46

SPARC
running
Solaris

Micro Focus installer 405 1.62 GB 810 40

x86-64
running
Solaris

Micro Focus installer 375 1.60 GB 750 31

System Z
running SUSE
SLES

Micro Focus installer 349 1.40 GB 698 36
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Platform Installer type Setup

file size

(MB)

Disk space

required for

the installation

Disk space

required for

running

the product

(MB)

Sentinel RMS

license
server

(MB)

x86-64
running SUSE
SLES

Micro Focus installer 364 1.46 GB 728 46

Operating Systems Supported
For a list of the supported operating systems, check the Product Availability section on the Micro Focus
SupportLine Web site: http://supportline.microfocus.com/prodavail.aspx.

Software Requirements
Note: This product includes OpenSSL version 1.0.1m.

Before installing this product, you must have the following software installed on your computer:

• Xterm, the terminal emulator for the X Window System, is part of your UNIX/Linux distribution but is not
installed by default. Use your UNIX/Linux installation media to install it.

• The pax archiving utility is required by the setup file. Pax is distributed with most UNIX/Linux systems
but, if it is missing, you must install it separately. To verify pax is installed, run pax --help or pax --
version at the command line.

• The following operating system libraries must be installed:

Library Platform

SUSE 11 Red Hat 6.x Red Hat 7

glibc-locale-32bit X

gcc (gcc-32-bit) X

gcc*.i686 X X

glibc-*.x86_64 X X

glibc-*.i686 X X

libgcc-*.x86_64 X X

libgcc-*.i686 X X

libstdc++-*.x86_64 X X

gcc*.s390 X X

glibc-*.s390 X X

glibc-*.s390x X X

glibc-devel-*.x86_64 X X

glibc-devel-*.i686 X X

glibc-devel-*.s390 X X

glibc-devel-*.s390x X X

libstdc++-*.i686 X X
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Library Platform

SUSE 11 Red Hat 6.x Red Hat 7

gdb* X X X

• Visit the Red Hat Web site for more information.

• Oracle's Java Platform, Enterprise Edition (Java EE) Java 7 or Java 8 is required to execute COBOL
JVM code and for native COBOL and Java interoperability. You can download Oracle's Java EE from 
Oracle's web site and install it anywhere on your machine.

Note:

• On AIX and zLinux, you need to have IBM's JDK. The earliest supported release of IBM's JDK
is 7.0 Service Refresh 8. You can get IBM's AIX JDK from IBM's Web site.

• On HP-UX, you need to have HP-UX JDK. The earliest supported release of HP-UX is JDK
7.0.11. You can get the HP-UX Java JDK from HP's Web site.

Before you start the installation, you need to set the environment as follows:

• You need to set the JAVA_HOME environment variable. When installing the product, set this variable to
a 32-bit Java installation or the installation terminates. For example, execute the following:

JAVA_HOME=java_install_dir

where java_install_dir is the path to the JAVA installation directory such as /usr/java/javan.n
• You need to add $JAVA_HOME/bin to your system PATH variable. To do this, execute:

export PATH=$JAVA_HOME/bin:$PATH

• You need to set the LANG environment variable to pick up localized messages. The LANG settings are
English and Japanese only.

Important: This release requires version 10000.2.990 or later of the Micro Focus License
Administration tool. For local servers, you do not need to install it separately, as the setup file installs
a new Visual COBOL client and a new licensing server on the same machine.

If you have a network server, you must update the license server before installing the product as the
client is not able to communicate with license servers of versions older than 10000.2.660. On
Windows, you can check the version of your license server by clicking Help > About in the Micro
Focus License Administration tool. To check the version of the license server on UNIX, run /var/
microfocuslicensing/bin/mfcesver or /var/microfocuslicensing/bin/
cesadmintool.sh.

You can download the new version of the license server software from the Micro Focus SupportLine
Web site: http://supportline.microfocus.com.
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Installation

Installing Visual COBOL for Visual Studio

Installation Restrictions and Requirements
Before starting the installation you should consider the following:

• Visual COBOL and Enterprise Developer cannot coexist on the same machine.
• If, when you install Visual COBOL for Visual Studio , the machine does not have Microsoft Visual C++

Redistributable Runtime already installed, it is installed as required by Visual COBOL. The installation of
Microsoft Visual C++ Redistributable Runtime adds a number of .dll files, without digital signatures,
into the winsxs directory.

• If, when you install Visual COBOL for Eclipse, the machine does not have Microsoft Visual C++ 2012
Redistributable Runtime already installed, it is installed as required by Visual COBOL. The installation of
Microsoft Visual C++ Redistributable Runtime adds a number of .dll files, without digital signatures,
into the winsxs directory.

• If, when you install Visual COBOL for Visual Studio 2015, the machine does not have Microsoft Visual C
++ 2013 Redistributable Runtime already installed, it is installed as required by Visual COBOL. The
installation of Microsoft Visual C++ Redistributable Runtime adds a number of .dll files, without digital
signatures, into the winsxs directory.

• You need to be logged in with a user-ID that has write access to the registry structure under
HKEY_LOCAL_MACHINE, HKEY_CLASSES_ROOT, and HKEY_CURRENT_USER so the installation
software can set the environment appropriately. You also need to be logged on with Administrator
privileges.

• Before installing this product, make sure that any existing Micro Focus Directory Server (MFDS) or
CCITCP2 Windows service (on Windows) or a process (on UNIX) from an existing product is stopped
and uninstalled. On Windows, do this as follows:

1. Stop the MFDS and CCITCP2, using either the Windows Service Management Console GUI
(services.msc) or from a command line prompt by typing:

net stop mf_ccitcp2

Only one instance of the MFDS or CCITCP2 service can run on a Windows machine.
2. Uninstall the MFDS or CCITCP2 service.

For MFDS, from a command line prompt enter: mfds -u

For CCITCP2: ccitcp2 -u

To run an earlier version of MFDS as a service after you have installed a later version:

1. Stop and uninstall the MFDS service, as described above.
2. Reinstall the earlier version, as follows:

a. Open a  Visual COBOL command prompt.
b. Install the service. Enter the following command: mfds -i
c. Start the service. Enter the following command: net start mf_ccitcp2
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Note: The two versions use different paths for environment and registry values, so the list of
configured enterprise servers might be different depending on which version has been started,
since, by default, different MFDS data repositories are used.

MFDS 5.1 and later are able to import or use Enterprise Server configuration data generated by earlier
versions of MFDS, but 5.0 or earlier versions of MFDS might not be able to read data generated by later
versions.

It is possible to run MFDS from a command prompt ("mfds") rather than as a service, but by default the
"mfcobol" port is used (86) and this can only be used by one process at a time

Downloading the Product
You can download Visual COBOL from the Micro Focus SupportLine Web site and from the Product
Updates section.

Installing Visual COBOL for Visual Studio
Note:

To install this product:

1. Run the vcvs2010_22.exe (or vcvs2012_22.exe when installing the product for Visual Studio
2012) file and follow the wizard instructions to install the prerequisite software and the product.

Note:

• When the installation has completed, on some editions of Windows you might receive a notification
that Visual Studio 2012 has compatibility issues. This is a known Microsoft issue. To resolve it,
follow the instructions in the notification for obtaining help online, or download the KB2781514
update for Visual Studio 2012 from the Microsoft Download Center.

• If you are installing onto a machine that has an existing Micro Focus product that uses an older
Sentinel RMS License Manager, you might be prompted to remove it and install the Micro Focus
License Administration. By doing this you maintain the existing Sentinel RMS license files while
adding the Micro Focus License Administration. If you are unsure about existing licenses on your
computer or removing the Sentinel RMS License Manager, consult your System Administrator. If
you want to proceed, remove Sentinel RMS License Manager by using Program and Features
(Windows Vista or later), and rerun the installation file.

• Trial licenses cannot be used with remote desktop services. If you want to use your product in this
way, please contact Micro Focus SupportLine to obtain a relevant license.

• We recommend that you install any updates for Visual Studio and the .NET Framework that are
available at the Microsoft Download site.

• If you install JDK you might be prompted to install the latest update. The latest update is not
required for use with Visual COBOL but you can install it if you wish.

Installing as an Upgrade
• This release will not upgrade previous versions of the product. Any previous releases and HotFixes of

the product installed on your machine must be uninstalled before installing 2.3.

• Before installing this release as an upgrade, ensure you create a back-up of your Enterprise Server
configuration. To do this, on the Enterprise Server Administration home page, click Export and then
select Export Enterprise Server configuration and Security Manager definitions. This creates a
backup folder in the c:\programdata\micro focus\Enterprise Developer\MFDS. You can
restore the Enterprise Server configuration after installing this release - click Import on the Enterprise
Server Administration home page.
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After Installing
You are now ready to run Visual COBOL. From the Windows taskbar click Start > All Programs > Micro
Focus Visual COBOL > Visual COBOL for Visual Studio nnnn.

Note: The Start menu is not available on Windows 8 and Windows Server 2012. You use the Start
screen to invoke programs.

Code
generation
issues in .NET
Framework
version 4.6

• Code generation issues in Microsoft's 64-bit JIT (just-in-time) compiler delivered as
part of .NET Framework version 4.6 can result in incorrect execution of some COBOL
code compiled to .NET. Version 4.6 of the .NET Framework is currently shipped as
default with Visual Studio 2015 and Microsoft's Windows 10. The problems include
incorrect execution of MOVE and STRING statements applied to alphanumeric
operands, and incorrect execution of the ROUNDED phrase for arithmetic statements.

Some of these issues only seem to be reproducible in COBOL language applications
compiled to .NET and some can be reproduced in other languages (C# or Visual
Basic).

These problems have been reported and acknowledged by Microsoft and it is our
belief that they either have resolutions or are working on fixes for all of them. For
further information about these issues and guidelines on how to disable the latest
version of the 64-bit JIT compiler, see RyuJIT Bug Advisory and Troubleshooting
RyuJIT.

As of October 2015, Microsoft have released the following updates that address these
issues with the .NET Framework 4.6:

• Hotfix rollup 3088955 for the .NET Framework 4.6 on Windows Server 2012 and
Windows 8 - see: http://www.microfocus.com/docs/links.asp?vc=mskb3088955.

• Hotfix rollup 3088956 for the .NET Framework 4.6 on Windows Server 2012 R2
and Windows 8.1 - see: http://www.microfocus.com/docs/links.asp?
vc=mskb3088956

• Hotfix rollup 3088957 for the .NET Framework 4.6 on Windows 7 SP1, Windows
Server 2008 SP2, Windows Server 2008 R2 SP1, and Windows Vista SP2 - see: 
http://www.microfocus.com/docs/links.asp?vc=mskb3088957.

• Cumulative update 3093266 for Windows 10: September 30, 2015 (available
through Windows Update) - see: http://www.microfocus.com/docs/links.asp?
vc=mskb3093266.

Note:

For applications created with earlier Micro Focus products or earlier versions of Visual COBOL, note
the following:

Building
Applications

If, after upgrading to this version of Visual COBOL, you start receiving unexpected
build errors when compiling an existing multi-project solution, this may be a result of
enabling parallel project builds in this release. These are a couple of examples of
issues that might be causing these errors:

• Using file references to project outputs in the same solution. You need to use
project-to-project references instead.

Use Project > Project Dependencies to manage the project dependencies and
build order within your solution.

• A customized build process such as one that is using pre- or post- build events.

If resolving any of these issues does not help resolve the build errors, consider
disabling the parallel build support - click Tools > Options > Projects and
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Solutions > Build and Run and set maximum number of parallel project builds
to 1.

Note: Parallel builds are not supported with Personal Edition licensing.

Database Access Managed applications using SQL(DBMAN=ODBC) that were compiled in
Visual COBOL 2.1 Update 1 must be recompiled in Visual COBOL 2.3.

Existing
Applications

Application executables that were compiled using earlier Micro Focus products
must be recompiled from the sources using Visual COBOL.

Please refer to the Start Here and Product Information sections in your product Help. Here, you will find
information on getting started including tutorials and demonstration programs.

Note:

• To view the help in Visual Studio 2012, ensure that the Visual Studio Help Library is pointing to
local help. From the Visual Studio menu click Help > Set Help Preferences > Launch in Help
Browser.

• For full details of the Visual Studio 2012 Help system, see the locally installed Microsoft Help
Viewer 2.0 Help, which is available from Help menu in the IDE.

• On Windows 8 and Windows Server 2012, an issue with Microsoft Help Viewer 2.0 and Internet
Explorer's security being turned on can cause the Help content to be displayed as raw HTML
code. To resolve the issue, you need to turn off the Internet Explorer Enhanced Security
Configuration (IE ESC) for both administrators and users. Check the Microsoft Windows help for
more information on how to do this.

• To view the help in Visual Studio 2013, ensure that the Visual Studio Help Library is pointing to
local help. From the Visual Studio menu click Help > Set Help Preferences > Launch in Help
Browser.

• For full details of the Visual Studio Help system, see the locally installed Microsoft Help Viewer 2.1
Help, which is available from Help menu in the IDE.

• To view the help in Visual Studio 2015, ensure that the Visual Studio Help Library is pointing to
local help. From the Visual Studio menu click Help > Set Help Preferences > Launch in Help
Browser.

• For full details of the Visual Studio Help system, see the locally installed Microsoft Help Viewer 2.2
Help, which is available from Help menu in the IDE.

Repairing
If any product files, registry settings or shortcuts are accidentally removed at any point, you can perform a
repair on the installation to replace them.

To repair your installation on versions of Windows Vista or later:

1. From the Control Panel, click Uninstall a program under Programs.
2. Right-click your Micro Focus product and select Repair.

Uninstalling
To uninstall the product, you cannot simply delete its files from your hard disk. To uninstall the product:

1. Log in with the same user-ID as you used when you installed the product.
2. Click Uninstall a program under Programs in Control Panel.
3. Select the product and click Remove or Uninstall as appropriate.
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When you uninstall, the only files deleted are those that the installation software installed. If the product
directory has not been removed, delete any unwanted files and subdirectories within it using Windows
Explorer.

Note: The installer creates separate installations for Micro Focus Visual COBOL and Micro Focus
License Administration. Uninstalling only Visual COBOL does not automatically uninstall the Micro
Focus License Administration or any of the prerequisite software.

To completely remove the product you must uninstall the Micro Focus License Administration as well.

You can optionally remove the prerequisite software. For instructions, check the documentation of the
respective software vendor.

Some registry entries are not removed by the uninstallation process and you need to manually delete
them.

The following folders might not be removed:

• The Micro Focus Product Name folder in the Start menu - you can delete it manually.
• %systemdrive%\Users\Public\Documents\Micro Focus - includes the binaries and the log

files of the samples which you have built.
• %ProgramData%\Micro Focus - includes some data files used by the Micro Focus licensing system.
• %Program Files%\Micro Focus - you can delete it manually.

To silently uninstall the product, you need the setup file and you need to execute the following at the
command line:

start /wait install-file.exe /quiet /uninstall

In addition, the following registry entries are not removed. These are created the first time that an
Enterprise Server that has been enabled for performance monitoring starts up:

• Micro Focus Server\Performance\Active Servers
• Micro Focus Server\Performance\PerfIniFile

Installing Visual COBOL for Eclipse (Windows)

Installation restrictions and requirements
Before starting the installation, you should consider the following:

• Visual COBOL and COBOL Server cannot coexist on the same machine.
• Visual COBOL and Enterprise Developer cannot coexist on the same machine.

Downloading the Product
1. Use the download links in your Electronic Product Delivery email.

For more information follow the links for the installation instructions and the End User License
Agreement.

Installing as an Upgrade
• This release will not upgrade previous versions of the product. Any previous releases and HotFixes of

the product installed on your machine must be uninstalled before installing 2.3.

• Before installing this release as an upgrade, ensure you create a back-up of your Enterprise Server
configuration. To do this, on the Enterprise Server Administration home page, click Export and then
select Export Enterprise Server configuration and Security Manager definitions. This creates a
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backup folder in the c:\programdata\micro focus\Enterprise Developer\MFDS. You can
restore the Enterprise Server configuration after installing this release - click Import on the Enterprise
Server Administration home page.

Installing
Note:

• Before installing, check System Requirements. Also, check Installing as an Upgrade, if you have
an earlier version of Visual COBOL installed on your machine.

• This version of the product is a full install.
• The setup file installs Visual COBOL and Eclipse 4.4.2. After the installation is completed, you can

install Visual COBOL into other versions of Eclipse such as version 4.2 or 4.3 for the 32-bit Eclipse
only - see Installing Visual COBOL into other instances of Eclipse for instructions.

These are the steps to install this product:

1. Run the vce_23.exe file and follow the wizard instructions to complete the installation.

By default, this installs Visual COBOL in the %ProgramFiles(x86)%\Micro Focus\Visual COBOL
folder and installs a full version of Eclipse 4.4.2, with the Micro Focus plugins already installed, in the C:
\Users\Public\Micro Focus\Product Name\eclipse directory. The setup file installs any missing
prerequisite software as listed in the topic Software Requirements.

Note: If you have Java 7 installed on your machine and you do not want the setup file to install Java 8,
you can install the product silently and use the skipjre=1 command line option to skip installing
Java 8. See Installing Silently for more details.

Installing Visual COBOL into other instances of Eclipse
Visual COBOL ships with Eclipse 4.4.2. After installing Visual COBOL, you can then also install it in other
instances of Eclipse available on the same machine. The supported versions of Eclipse are 4.2, 4.3 and
4.4, only for the 32-bit Eclipse.

Note: Though Visual COBOL does not support the 64-bit Eclipse, you can use the 32-bit Eclipse to
create both 32-bit and 64-bit applications.

To assist you with automatically installing the Micro Focus plug-ins into other instances of Eclipse, Visual
COBOL provides an installation utility, installeclipseplugins.bat available in the
%ProgramFiles(x86)%\Micro Focus\Visual COBOL\installer folder.

To install Visual COBOL into another instance of Eclipse:

1. Start a Visual COBOL command prompt.
2. At the command prompt, navigate to the location of the install utility: %ProgramFiles(x86)%\Micro

Focus\Visual COBOL\installer.
3. Run the install utility from the command prompt using the following syntax:

installeclipseplugins -eclipse <EclipseInstallDir> -version <version> [-
cobdir <InstallDir>] [-nosplash]

Where:

• EclipseInstallDir - full path to the installation directory of the instance of Eclipse you are installing
into.

• version - version number of the instance of Eclipse that you are installing into. The valid version
numbers are 4.2, 4.3 and 4.4 and these also cover minor version numbers such as 4.3.1, 4.3.2 and
4.4.1.

• InstallDir - optional. The full path to the installation directory of Visual COBOL. If this is not specified,
the COBDIR environment variable is used.
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• -nosplash - optional. If set, the installation will not replace the existing splash screen. A non-default
Eclipse splash screen will not be replaced, regardless of this setting.

Note: The default COBDIR location, in Windows environments, C:\Users\Public\Micro
Focus\ProductName\eclipse. Alternatively, the COBDIR can be specified on the command
line.

Running the utility installs the Visual COBOL plug-ins into the specified version of Eclipse and copies
the Visual COBOL UpdateSite folders into EclipseInstallDir\eclipse\dropins.

For example, to install Visual COBOL into an instance of Eclipse 4.3 available in the c:\eclipse
folder, run the install utility with the following parameters:

installeclipseplugins -eclipse c:\eclipse -version 4.3 -nosplash

After Installing
If you have used Eclipse from the same workspace before, the Eclipse perspective settings are not reset
after installing any Micro Focus product. To pick up any new features, you must reset the COBOL
perspective after installation:

1. Open the existing workspace with this product.

You may receive some warnings or errors which you can ignore.
2. Make sure you are in the COBOL perspective by clicking Window > Open Perspective > COBOL.
3. Click Window > Reset Perspective.
4. Click OK.
5. Reapply any customizations.

Note:

For applications created with earlier Micro Focus products or earlier versions of Visual COBOL, note
the following:

Building
Applications

If, after upgrading to this version of Visual COBOL, you start receiving unexpected
build errors when compiling an existing multi-project solution, this may be a result of
enabling parallel project builds in this release. These are a couple of examples of
issues that might be causing these errors:

• Using file references to project outputs in the same solution. You need to use
project-to-project references instead.

Use Project > Project Dependencies to manage the project dependencies and
build order within your solution.

• A customized build process such as one that is using pre- or post- build events.

If resolving any of these issues does not help resolve the build errors, consider
disabling the parallel build support - click Tools > Options > Projects and
Solutions > Build and Run and set maximum number of parallel project builds
to 1.

Note: Parallel builds are not supported with Personal Edition licensing.

Database Access Managed applications using SQL(DBMAN=ODBC) that were compiled in
Visual COBOL 2.1 Update 1 must be recompiled in Visual COBOL 2.3.

Existing
Applications

Application executables that were compiled using earlier Micro Focus products
must be recompiled from the sources using Visual COBOL.
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Product Help

Check the Product Documentation section of the Micro Focus SupportLine Web site and the Micro Focus
Infocenter for any updates to the documentation which might have been uploaded.

Installing X Windows on Windows
Some features of Visual COBOL for Eclipse on Windows require an X Windows installation, hence Micro
Focus ViewNowX is provided with the product. To install, run the file ViewNow_X_Server.exe in your
Visual COBOL installation. By default this will be in the %ProgramFiles(x86)%\Micro Focus\Visual
COBOL\ViewNowX folder.

ViewNowX requires that your client machine has Microsoft Visual C++ 2008 SP1 Redistributable Package
(x86) installed. If it is missing from your machine, the ViewNowX installation will offer a link to download the
package.

Repairing
If any product files, registry settings or shortcuts are accidentally removed at any point, you can perform a
repair on the installation to replace them.

To repair your installation on versions of Windows Vista or later:

1. From the Control Panel, click Uninstall a program under Programs.
2. Right-click your Micro Focus product and select Repair.

Uninstalling
Windows

To uninstall the product, you cannot simply delete its files from your hard disk. To uninstall the product:

1. Log in with the same user-ID as you used when you installed the product.
2. Click Uninstall a program under Programs in Control Panel.
3. Select the product and click Remove or Uninstall as appropriate.

When you uninstall, the only files deleted are those that the installation software installed. If the product
directory has not been removed, delete any unwanted files and subdirectories within it using Windows
Explorer.

Important: The installer creates separate installations for Micro Focus Visual COBOL and Micro
Focus License Administration. Uninstalling only Visual COBOL does not automatically uninstall the
Micro Focus License Administration or any of the prerequisite software.

To completely remove the product you must uninstall the Micro Focus License Administration as well.

You can optionally remove the prerequisite software. For instructions, check the documentation of the
respective software vendor.

To silently uninstall the product, you need the setup file and you need to execute the following at the
command line:

start /wait install-file.exe /quiet /uninstall

UNIX and Linux Installer Issues
Installing on Linux

On Linux, the 32-bit version of Java is required to install and use Visual COBOL for Eclipse. When you start
the installation, if the 64-bit version of Java is already installed on your Linux machine, you might not be
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able to install Visual COBOL. This is a known issue with the Oracle Java installers for Linux which prevent
you from installing both the 32-bit and the 64-bit versions of Java on the same machine. To work around
this problem:

• Download the 32-bit Java distribution in a compressed .tar format from the Oracle Web site.
• Untar the distribution into a location different from the one used for the 64-bit Java version. For example,

untar in /usr/local/java32 and not in /usr/local/java.
• Set JAVA_HOME and LD_LIBRARY_PATH to the 32-bit version of Java so that it is used to install and

run Visual COBOL.

License Infrastructure Installer

On some Solaris platforms, you can receive the following error message when SafeNet license server
needs to be installed or upgraded on your machine:

tar: /safenet.tar: No such file or directory

• To resolve this issue, wait for the installation to complete and then perform the following:

1. Navigate to the safenet directory in the COBDIR location.
2. With superuser permissions execute: ./MFLicenseServerInstall.sh

• Note: The following information applies when you are installing on Red Hat Enterprise Linux
(RHEL) 7.

Certain configuration changes in RHEL 7 (such as the /etc/inittab file no longer available) required
a change in the MF SafeNet license installer for this platform and the way you can manually manage the
licensing service.

By default, the MF SafeNet licensing service is still configured so that it starts automatically when
starting your machine. Only on RHEL 7, you must use the systemctl command available with the OS
if you need to override the default behaviour – for example, if you do not want run the MF SafeNet
licensing service at start-up or if you do not want the service to automatically start when you are
configuring trace levels.

1. Create a file, MFSafeNet.service, in /usr/lib/systemd/system/ with the following contents:

----------- start of /usr/lib/systemd/system/MFSafeNet.service -----------
    [Unit]
    Description=Micro Focus SafeNet licensing daemons. 
    Documentation=http://supportline.microfocus.com

    [Service]
    Type=forking
    ExecStart=/var/microfocuslicensing/bin/startboth.sh
    ExecStop=/var/microfocuslicensing/bin/stopboth.sh
    Restart=no

    [Install]
    WantedBy=multi-user.target
-----------  end of /usr/lib/systemd/system/MFSafeNet.service  -----------

2. Use the systemctl command to manage the SafeNet service:

[ asroot ] systemctl option MFSafeNet

Where some of the values that option can take are:

reenable Installs the SafeNet service.

is-enabled Checks the status of the SafeNet service. Does not require root privileges.

start Starts the SafeNet service.

stop Stops the SafeNet service.
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restart Restarts the SafeNet service.

disable Disables the SafeNet service so it does not start when the machine is booted.

enable Enables the SafeNet Service so it starts when the machine is booted.

For more information about systemctl, refer to the help available with the RHEL OS.

License Server

You need to configure the computer hostname to ensure the license server will start properly.

To avoid performance issues, "localhost" and the computer hostname must not both be mapped to IP
address 127.0.0.1. You should only map "localhost" to IP address 127.0.0.1.

The following is an example of how to specify these entries correctly in the etc/hosts file:

127.0.0.1 localhost.localdomain localhost
IP machinelonghostname machineshorthostname

where IP is the unique IP address of the computer in xx.xx.xx.xx format.

Installing Visual COBOL for Eclipse (UNIX)

Downloading the Product
1. Use the download links in your Electronic Product Delivery email.

For more information follow the links for the installation instructions and the End User License
Agreement.

Installing

Installing the software
Note: Micro Focus offers two types of installers on UNIX and Linux - a proprietary Micro Focus
installer for installing Visual COBOL on UNIX and Linux and a standard RPM (RPM Package
Manager) installer for installing Visual COBOL on Linux. See your product Help for instructions on
how to use the RPM installer.

These are the steps to install this product using the Micro Focus installer:

1. Give execute permissions to the setup file:

chmod +x setup_visualcobol_deveclipse_2.3_platform

2. Run the setup file with superuser permissions:

./setup_visualcobol_deveclipse_2.3_platform

If you don't run this as superuser, you are prompted to enter the superuser password during the install.

The COBOL environment is installed by default into /opt/microfocus/VisualCOBOL, (COBDIR). A
full version of Eclipse, with the Micro Focus plugins already installed, is present in the $COBDIR/
eclipse directory.

To install in a different location use the -installlocation="Location" parameter to specify an
alternative directory location. For example:

./setup_visualcobol_deveclipse_2.3_platform -installlocation="full path of 
new location"
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Note: You can use variables or the tilde syntax for the path for –installlocation. For example,
the following examples are equivalent:

-installlocation="/home/myid/installdir"

-installlocation="~myid/installdir"

-installlocation="~/installdir"

-installlocation="$HOME/installdir"

You can see details about which additional parameters can be passed to the install script if you enter
the -help option.

Note:

• The installation of this product could affect the SafeNet Sentinel licensed components running
on your machine. During installation licensing is shutdown to allow files to be updated. To
ensure the processes running on your machine are not affected, you need to use the -
skipsafenet option, which skips the installation of SafeNet:

. /setup_visualcobol_deveclipse_2.3_platform -skipsafenet

• To protect the SafeNet Sentinel installation from accidental updating you can create an empty
file named SKIP_SAFENET_INSTALL in /var/microfocuslicensing/ as follows:

touch /var/microfocuslicensing/SKIP_SAFENET_INSTALL

While the file is present, the SafeNet installer does not make changes to the installation or
shutdown the running license daemons. If licensing needs to be updated later, remove the file
and install Sentinel RMS server manually.

Setting up the environment
When you have installed the product, you need to set the environment as described below.

1. To set up your product, execute:

. /opt/microfocus/VisualCOBOL/bin/cobsetenv

2. To verify that your product is installed, execute:

cob -V

Important: These commands set the environment only for the current shell. You need to execute
them for each new shell that you start.

To avoid having to run cobsetenv for every shell, add these commands to the shell initialization files
(such as etc/profile, etc/bashrc).

Note that cobsetenv is only compatible with POSIX-like shells, such as bash, ksh, or XPG4 sh. It is
not compatible with C-shell or pre-XPG4 Bourne shell.

Starting the product
To start Eclipse:

• If you are using a GUI interface, double-click the product icon (automatically installed on your desktop).

Note: The installer automatically creates a shortcut icon for the product on the desktop for the user
for which you ran the install script. If you need to create desktop icons for other users' desktops on
the same machine, or if the icon was not created on the desktop for the root user, run the following
shell script as the user you need to login as: $COBDIR/bin/createdesktopicon.sh

• If you are using a non-GUI interface, such as a terminal emulator, type the following from a command
prompt:

eclipse
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Installing as an upgrade
This release works concurrently with the previous version of Visual COBOL, so you do not need to uninstall
it. There are two options for installing the latest version in this case:

• Move the existing installation to a different location and install the latest version to the default install
location specified by the COBDIR environment variable ( /opt/microfocus/VisualCOBOL/
eclipse, by default).

This ensures you do not need to change your environment. To move the existing older installation to a
different location:

1. Execute the following command as root:

mv /opt/microfocus/VisualCOBOL/eclipse /opt/microfocus/VisualCOBOL/
eclipseversion

2. Install the latest version as described in the section Installing.
• Install the latest version in a different location and set the environment to point to it. To do this, run the

Visual COBOL installer with the –installlocation option:

1. Execute the following command:

. /InstallFile -installlocation="/opt/microfocus/VisualCOBOL/eclipse"

Note: You can use variables or the tilde syntax for the path for –installlocation. For
example, the following examples are equivalent:

-installlocation="/home/myid/installdir"

-installlocation="~myid/installdir"

-installlocation="~/installdir"

-installlocation="$HOME/installdir"

2. Execute cobsetenv to set the environment and point to the new install location:

. /opt/microfocus/VisualCOBOL/bin/cobsetenv

Note that cobsetenv is only compatible with POSIX-like shells, such as bash, ksh, or XPG4 sh. It is
not compatible with C-shell or pre-XPG4 Bourne shell.

Installing Visual COBOL into other instances of Eclipse
Visual COBOL ships with Eclipse 4.4.2 but can be installed in other instances of Eclipse available on the
same machine. The supported versions of Eclipse are 4.2, 4.3 and 4.4 only for the 32-bit Eclipse.

Note: Though Visual COBOL does not support the 64-bit Eclipse, you can use the 32-bit Eclipse to
create both 32-bit and 64-bit applications.

To assist you with automatically installing the Micro Focus plug-ins in other instances of Eclipse, Visual
COBOL provides an installation utility, installeclipseplugins (UNIX) available in /opt/
microfocus/VisualCOBOL/eclipse.

To use the script to install Visual COBOL into another instance of Eclipse:

1. Start a terminal.
2. At the terminal, navigate to the location of the install utility.
3. Run the install utility from the command prompt using the following syntax:

installeclipseplugins -eclipse <EclipseInstallDir> -version <version> [-
cobdir <InstallDir>] [-nosplash]

Where:
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• EclipseInstallDir - full path to the installation directory of the instance of Eclipse you are installing
into.

• version - version number of the instance of Eclipse that you are installing into. The valid version
numbers are 4.2, 4.3 and 4.4 and these also cover for minor version numbers such as 4.3.1, 4.3.2 or
4.4.1.

• InstallDir - optional. The full path to the installation directory of Visual COBOL. If this is not specified,
the COBDIR environment variable is used.

• -nosplash - optional. If set, the installation will not replace the existing splash screen. A non-default
Eclipse splash screen will not be replaced, regardless of this setting.

Note: The default COBDIR location, in UNIX environments, /opt/microfocus/ProductName.
Alternatively, the COBDIR can be specified on the command line.

Running the utility installs the Visual COBOL plug-ins into the specified version of Eclipse and copies
the Visual COBOL UpdateSite folders into EclipseInstallDir/eclipse/dropins.

After Installing
If you have used Eclipse from the same workspace before, the Eclipse perspective settings are not reset
after installing any Micro Focus product. To pick up any new features, you must reset the COBOL
perspective after installation:

1. Open the existing workspace with this product.

You may receive some warnings or errors which you can ignore.
2. Make sure you are in the COBOL perspective by clicking Window > Open Perspective > COBOL.
3. Click Window > Reset Perspective.
4. Click OK.
5. Reapply any customizations.

Configuring the Environment for Developing RDBMS
Applications on UNIX

Note:

• If you are working with remote projects, you need to configure the environment before you start the
remote server process.

• On UNIX, if you are working with local projects, you need to configure the environment before you
start Eclipse.

1. Ensure the COBOL and the third-party software environments are set.
2. Set up the RDBMS environment.

Refer to your RDBMS vendor documentation for details.
3. Set COBCPY as required in order for the IDE to locate any copybooks that are external to your project.
4. If working with Pro*COBOL/Cobsql applications you need to set COBOPT. This sets the appropriate

linker options for the platform and the COBOL working mode:

To do this, execute the following at the command line:

$COBDIR/src/oracle/set_cobopt_oracle
COBOPT=$PWD/cobopt.ora
export COBOPT

Repairing
If a file in the installation of the product becomes corrupt, or is missing, we recommend that you reinstall
the product.
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Uninstalling
Note: Before you uninstall the product, ensure that the Enterprise Server instances and the Micro
Focus Directory Service (MFDS) are stopped.

To uninstall this product:

1. Execute as root the Uninstall_VisualCOBOLEclipse2.3.sh script in the $COBDIR/bin directory.

Note: The installer creates separate installations for the product and for Micro Focus License
Administration. Uninstalling the product does not automatically uninstall the Micro Focus License
Administration or the prerequisite software. To completely remove the product you must uninstall the
Micro Focus License Administration as well.

To uninstall Micro Focus License Administration:

1. Execute as root the UnInstallMFLicenseServer.sh script in the /var/
microfocuslicensing/bin directory.

The script does not remove some of the files as they contain certain system settings or licenses.

You can optionally remove the prerequisite software. For instructions, check the documentation of the
respective software vendor.

Installing Visual COBOL Development Hub

Downloading the Product
1. Use the download links in your Electronic Product Delivery email.

For more information follow the links for the installation instructions and the End User License
Agreement.

Installing
Note:

During the installation process, the installer configures the product's Enterprise Server System
Administrator Process User ID. The Process User ID will be the owner of all Enterprise Server
processes except the one for the Micro Focus Directory Server (MFDS). The Directory Server process
(Enterprise Server Administration) runs as root as this allows it to access the system files and ports.

All Enterprise Server processes you start from Enterprise Server Administration run under the
Process User ID which can affects the file access and creation.

By default, the installer uses the login id of the user that runs the installer for the Process User ID. To
change the user id after you complete the installation, execute $COBDIR/bin/casperm.sh.

These are the steps to install this product:

1. Give execute permissions to the setup file:

chmod +x setup_visualcobol_devhub_2.3_platform

2. Run the installer with superuser permissions:

./setup_visualcobol_devhub_2.3_platform

If you don't run this as superuser you will be prompted to enter the superuser password during the
installation.

The COBOL environment is installed by default into /opt/microfocus/VisualCOBOL, (COBDIR).
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To install in a different location use the -installlocation="Location" parameter to specify an
alternative directory location. For example:

./setup_visualcobol_devhub_2.3_platform -installlocation="full path of new 
location"

Note: You can use variables or the tilde syntax for the path for –installlocation. For example,
the following examples are equivalent:

-installlocation="/home/myid/installdir"

-installlocation="~myid/installdir"

-installlocation="~/installdir"

-installlocation="$HOME/installdir"

You can see details about which additional parameters can be passed to the install script if you enter
the -help option.

You can use the following options to configure the Enterprise Server installation: [ -
ESsysLog="location" ] [ -ESadminID="User ID" ] [ -CASrtDir="location" ],
where:

-ESsysLog Specifies a location in which the build will create the Enterprise Server System log file -
for example, -ESsysLog="/home/esuser/logs". The default location is /var/
mfcobol/logs.

-ESadminID Sets the Enterprise Server System Administrator Process User ID from the command
line - for example, -ESadminID="esadm". The default user ID is the one that runs the
installer.

-CASrtDir Specifies the location were the Enterprise Server run-time system files are placed - for
example, -CASrtDir="/home/esuser/casrt/es". The default location is /var/
mfcobol/es.

Note:

• The installation of this product could affect the SafeNet Sentinel licensed components running
on your machine. During installation licensing is shutdown to allow files to be updated. To
ensure the processes running on your machine are not affected, you need to use the -
skipsafenet option, which skips the installation of SafeNet:

./setup_visualcobol_devhub_2.3_platform -skipsafenet

• To protect the SafeNet Sentinel installation from accidental updating you can create an empty
file named SKIP_SAFENET_INSTALL in /var/microfocuslicensing/ as follows:

touch /var/microfocuslicensing/SKIP_SAFENET_INSTALL

While the file is present, the SafeNet installer does not make changes to the installation or
shutdown the running license daemons. If licensing needs to be updated later, remove the file
and install Sentinel RMS server manually.

1. To set up your product, execute:

. /opt/microfocus/VisualCOBOL/bin/cobsetenv

2. To verify that your product is installed, execute:

cob -V

Important: These commands set the environment only for the current shell. You need to execute
them for each new shell that you start.

To avoid having to run cobsetenv for every shell, add these commands to the shell initialization files
(such as etc/profile, etc/bashrc).
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Note that cobsetenv is only compatible with POSIX-like shells, such as bash, ksh, or XPG4 sh. It is
not compatible with C-shell or pre-XPG4 Bourne shell.

Note: For information about the Micro Focus Visual COBOL Development Hub, check the help for
Visual COBOL for Eclipse that is available online on the Micro Focus Infocenter.

Installing as an Upgrade
This release works concurrently with the previous version of Micro Focus Visual COBOL Development
Hub, so you do not need to uninstall it. There are two options for installing the latest version in this case:

• Move the existing installation to a different location and install the latest version to the default install
location specified by the COBDIR environment variable (/opt/microfocus/VisualCOBOL, by
default).

This ensures you do not need to change your environment. To move the existing older installation to a
different location:

1. Execute the following command as root:

mv /opt/microfocus/VisualCOBOL /opt/microfocus/VisualCOBOLversion

2. Install the latest version as described in the section Installing.
• Install the latest version in a different location and set the environment to point to it. To do this, run the

Micro Focus Visual COBOL Development Hub installer with the –installlocation option:

1. Execute the following command:

. /InstallFile -installlocation="/opt/microfocus/VisualCOBOL"

Note: You can use variables or the tilde syntax for the path for –installlocation. For
example, the following examples are equivalent:

-installlocation="/home/myid/installdir"

-installlocation="~myid/installdir"

-installlocation="~/installdir"

-installlocation="$HOME/installdir"

2. Execute cobsetenv to set the environment and point to the new install location:

. /opt/microfocus/VisualCOBOL/cobsetenv

Note that cobsetenv is only compatible with POSIX-like shells, such as bash, ksh, or XPG4 sh. It is
not compatible with C-shell or pre-XPG4 Bourne shell.

Configuring the Environment for Developing RDBMS
Applications on UNIX

Note:

• If you are working with remote projects, you need to configure the environment before you start the
remote server process.

• On UNIX, if you are working with local projects, you need to configure the environment before you
start Eclipse.

1. Ensure the COBOL and the third-party software environments are set.
2. Set up the RDBMS environment.

Refer to your RDBMS vendor documentation for details.
3. Set COBCPY as required in order for the IDE to locate any copybooks that are external to your project.
4. If working with Pro*COBOL/Cobsql applications you need to set COBOPT. This sets the appropriate

linker options for the platform and the COBOL working mode:
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To do this, execute the following at the command line:

$COBDIR/src/oracle/set_cobopt_oracle
COBOPT=$PWD/cobopt.ora
export COBOPT

Configuring the Remote System Explorer Support
The remote development support from the Eclipse IDE relies upon Visual COBOL Development Hub
running on the UNIX machine and handling all requests from the IDE for building and debugging programs.
Visual COBOL Development Hub provides a UNIX daemon, the Remote Development Option (RDO)
daemon, which initiates the RDO as Eclipse clients connect to it. Whichever environment is used to start
the RDO daemon will be inherited for all servers and hence all build and debug sessions.

Configuring the Environment

You may need to configure some aspects of the environment before you start the daemon. This is because
when a build or debug session is initiated on the Development Hub from one of the Eclipse clients, the
environment used will be inherited from whatever was used to start the daemon. A typical example of the
kind of environment that might need to be set up would include database locations and settings for SQL
access at build/run time.

Starting the Daemon

Important: Before starting the daemon you must have the following on your UNIX machine:

• a version of Perl
• a version of Java
• the as (assembler) and ld (linking) programs on the path, as specified by the PATH environment

variable

To start the daemon on the default port (4075) as a background process, perform this command with
superuser authority:

$COBDIR/remotedev/startrdodaemon

The daemon will now listen for any Eclipse client processes connecting to that machine on port 4075. If
you want to use another port, specify another port number on the startrdodaemon command.

The daemon can also be configured to instantiate the servers on a specified port or range of ports. This is
particularly relevant when you want to only open certain ports through a firewall. To do this, perform this
command with superuser authority:

$COBDIR/remotedev/startrdodaemon [<port> | <low port>-<high port>] 

where:

• <port> is the port number the daemon should use to listen for connections from Eclipse on the client
machine. If no value is given, it will be assigned a default value of 4075. This value matches the value
assigned within the Eclipse installation.

For example,

$COBDIR/remotedev/startrdodaemon 4999

This command will start a daemon listening on port 4999 and will use random server ports.
• <low port>-<high port> is the range of ports on which the servers (launched by the daemon) should use

to communicate with Eclipse on the client machine.

For example,

$COBDIR/remotedev/startrdodaemon 4080 4090-4999

This command will start a daemon listening on port 4080 and server ports will be in the range 4090 to
4999.
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Stopping the Daemon

To stop the daemon, type the following command with superuser authority:

$COBDIR/remotedev/stoprdodaemon <port>

Repairing on UNIX
If a file in the installation of the product becomes corrupt, or is missing, we recommend that you reinstall
the product.

Uninstalling
Note: Before you uninstall the product, ensure that the Enterprise Server instances and the Micro
Focus Directory Service (MFDS) are stopped.

To uninstall this product:

1. Execute as root the Uninstall_VisualCOBOLDevelopmentHub2.3.sh script in the $COBDIR/bin
directory.

Note: The installer creates separate installations for the product and for Micro Focus License
Administration. Uninstalling the product does not automatically uninstall the Micro Focus License
Administration or the prerequisite software. To completely remove the product you must uninstall the
Micro Focus License Administration as well.

To uninstall Micro Focus License Administration:

1. Execute as root the UnInstallMFLicenseServer.sh script in the /var/
microfocuslicensing/bin directory.

The script does not remove some of the files as they contain certain system settings or licenses.

You can optionally remove the prerequisite software. For instructions, check the documentation of the
respective software vendor.
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Licensing Information
Note:

• This package provides eight licenses for using Micro Focus Development Hub on all platforms.
• If you have purchased licenses for a previous release of this product, those licenses will also

enable you to use this release.
• Personal Edition licensing is only available with Visual COBOL for Visual Studio 2015 and Visual

COBOL for Eclipse
• The latest version of the SafeNet licensing software is required. See the Software Requirements

section in this document for more details.
• Your entitlement for using this product is governed by the Micro Focus End User License

Agreement and by your product order. If you are unsure of what your license entitlement is or if you
wish to purchase additional licenses, contact your sales representative or Micro Focus
SupportLine.

To activate Visual COBOL Personal Edition
Having activated Visual COBOL Personal Edition, you can use it for a limited period of 365 days. After this
period, you can either register a new Personal Edition license for 365 days or enter an authorization code
in order to continue using it, either for a 30-day trial or full license of Visual COBOL. To do this:

1. Start Visual COBOL.

If you have not installed a license for Visual COBOL, starting the IDE for the first time after you install
the product opens the Micro Focus Visual COBOL Product Licensing dialog box. If you cancel this
dialog box, you can invoke it again from Help > Micro Focus > Product Licensing.

If you have not installed a license for Visual COBOL, starting the IDE and trying to create a COBOL
project opens the Micro Focus Visual COBOL Product Licensing dialog box. If you cancel this dialog
box, you can invoke it again from Help > Micro Focus Product Help > Product Licensing.

2. Click I want to activate the free product.
3. Ensure that the email address used to register the product is in the Email address text entry field. If

you haven't registered your email address yet, click registration page and follow the instructions on
that page.

4. Select one of the following options:

Automatic Use this if you have Internet access.

1. Click Activate License (in Visual Studio) or Finish (in Eclipse) to activate your copy of
Visual COBOL Personal Edition.

Manual Use this if you are not connected to the Internet.

In Visual Studio:

1. Click Send email.

This opens your default email client and creates a new email filled in with the details to
send to Micro Focus about activating your copy of the free Personal Edition of the
product.

Note: If there is no mail client installed on your machine, click  next to Send
email, and click Display fields. You will be presented with a template that
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includes the email address, the subject and the contents of an email to send to
Micro Focus using a mail client of your choice. Do not modify the details.

You will receive a response email with details about your authorization request.
2. Paste the contents of the response email in the designated field in the Micro Focus

Visual COBOL Product Licensing dialog box.
3. Click Activate License.

This displays a message confirming your request for authorization has been
successful.

4. Click Close.

In Eclipse:

1. Click Next and then click Send email.

This opens your default email client and creates a new email filled in with the details to
email to Micro Focus about activating your copy of the free Personal Edition product.

2. Send the email.
3. If there is no mail client installed on your machine, copy the email address, the subject

and the exact contents from the Email details fields and paste them into an email to
sent to Micro Focus using a mail client of your choice. Do not modify or add to the text.

You will receive a response email with information with details about your authorization
request.

4. Paste the body text of the response email into the text entry field of the Manual
Activation dialog box.

5. Click Finish.

You should receive a message that the activation has been successful.
6. Restart Eclipse to complete the activation process.

To request and activate a 30-day trial license for Visual
COBOL

1. In the IDE, click Help > Micro Focus > Product LicensingHelp > Micro Focus Product Help >
Product Licensing.

This opens the Micro Focus Visual COBOL Product Licensing dialog box.
2. Type your email address in the Email address text entry field.

You need to use the same email address you used for the registration.
3. Select one of the following options:

Automatic Use this if you have Internet access.

1. Click Activate License (in Visual Studio) or Finish (in Eclipse) to activate the trial
license for Visual COBOL.

Important: After clicking Finish, if you click the Cancel button in the progress
dialog box to stop the activation process, the trial license might have registered on
Micro Focus servers but not yet be registered on your machine. If you request a trial
again then you can get a message saying that a trial license has already been
used. If this happens, you should contact a Micro Focus Sales representative to
obtain a new license.
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You can do this by sending an email to VCBuyNow@microfocus.com, or selecting
Help > Micro Focus > Buy Now and using the contact options in the dialog box.

Manual Use this if you are not connected to the Internet.

In Visual Studio:

1. Click Send email.

This opens your default email client and creates a new email filled in with the details to
send to Micro Focus about activating the trial license for Visual COBOL.

Note: If there is no mail client installed on your machine, click  next to Send
email, and click Display fields. You will be presented with a template that
includes the email address, the subject and the contents of an email to send to
Micro Focus using a mail client of your choice. Do not modify the details.

2. Send the email.

You will receive a response email with details about your authorization request.
3. Paste the contents of the response email in the designated field in the Micro Focus

Enterprise Developer Product Licensing dialog box.
4. Click Activate License.

This displays a message confirming your request for authorization has been
successful.

5. Click Close.

In Eclipse:

1. Click Next and then click Send email.

This opens your default email client and creates a new email filled in with the details to
email to Micro Focus about activating your trial of Visual COBOL.

2. Send the email.
3. If there is no email client installed on your machine, copy the email address, the

subject and the exact contents from the Email details fields and paste them into an
email to send to Micro Focus using a mail client of your choice. Do not modify or add
the text.

You will receive a response email with information with details about your authorization
request.

4. Paste the contents of the response email into the text entry field of the Manual
Activation dialog box.

5. Click Finish.

You receive a message that the activation has been successful.
6. Restart Eclipse to complete the activation process.

After activation, you can see how many days your trial license has remaining by selecting Help > Micro
Focus > Product Licensing, or by using Micro Focus License Administration.

To buy and activate a full unlimited license
To buy a license for Visual COBOL, contact your sales representative or Micro Focus SupportLine.

For instructions on using the Micro Focus Licensing Administration Tool, see Licensing in the Visual
COBOL help.
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To start Micro Focus License Administration

Windows

From the Windows Taskbar click Start > All Programs >Micro Focus License Manager > License
Administration.

Note: On Windows 8 and Windows Server 2012, you use the Start screen to invoke programs.

UNIX

Log on as root, and from a command prompt type:

/var/microfocuslicensing/bin/cesadmintool.sh

Installing licenses

If you have a license file

Windows

1. Start Micro Focus License Administration.
2. Click the Install tab.
3. Do one of the following:

• Click Browse next to the License file field and select the license file (which has an extension
of .mflic).

• Drag and drop the license file from Windows Explorer to the License file field.
• Open the license file in a text editor, such as Notepad, then copy and paste the contents of the file

into the box below the License file field.
4. Click Install Licenses.

Alternatively, you can install the license file from within the IDE as follows:

1. Start Visual COBOL.
2. Click Help > Micro Focus Product Help > Product LicensingHelp > Micro Focus > Product

Licensing to open the Product Licensing dialog box.
3. Ensure I have a full Visual COBOL license is checked.
4. Click Browse next to the License file field.
5. Select the license file (which has an extension of .mflic), and then click Open.
6. Click AuthorizeFinish to install the license.

You should see a dialog box with a confirmation that the licenses have been installed successfully.

UNIX

1. Start the Micro Focus License Administration tool and select the Manual License Installation option by
entering 4.

2. Enter the name and location of the license file.

If you have an authorization code
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Authorizing your product when you have an Internet connection
Note: This topic only applies if you have an authorization code.

The following procedure describes how to authorize your product using a local or network license server.
The license server is set up automatically when you first install the product.

Windows

1. Start Micro Focus License Administration.
2. Click the Install tab.
3. Type the authorization code in the Enter authorization code field.
4. Click Authorize.

If you change the name of the machine running your license server after it has granted licenses, the
licenses stop working.

UNIX

1. Start Micro Focus License Administration.
2. Select the Online Authorization option by entering 1 and pressing Enter.
3. Enter your authorization code at the Authorization Code prompt and then press Enter.

Authorizing your product when you don't have an Internet connection
Note: This topic only applies if you have an authorization code.

This method of authorization is required if your machine does not have an Internet connection or if normal
(automatic) authorization fails.

Windows

1. Start Micro Focus License Administration.
2. Click Manual Authorization on the Install page.
3. Make a note of the contents of the Machine ID field. You will need this later.
4. Do one of the following:

• If your machine has an Internet connection, click the SupportLine Web link in the Manual
Authorization Information window.

• If your machine does not have an Internet connection, make a note of the Web address and type it
into a Web browser on a machine that has an Internet connection.

The Micro Focus SupportLine Manual product authorization Web page is displayed.
5. Type the authorization code in the Authorization Code field. The authorization code is a 16-character

alphanumeric string supplied when you purchased your product.
6. Type the Machine ID in the Machine ID field.
7. Type your email address in the Email Address field.
8. Click Generate.
9. Copy the generated license string (or copy it from the email) and paste it into the box under the License

file field on the Install page.
10.Click Install Licenses.

UNIX

In order to authorize your product you must have the following:
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• Your authorization code (a 16-character alphanumeric string).
• The machine ID. To get this, start the Micro Focus License Administration tool and select the Get

Machine Id option by inputting 6. Make a note of the "Old machine ID".

If you have previously received the licenses and put them in a text file, skip to step 6.

1. Open the Micro Focus license activation web page http://supportline.microfocus.com/activation in a
browser.

2. Enter your authorization code and old machine ID and, optionally, your email address in the Email
Address field.

3. Click Generate.
4. Copy the licenses strings from the web page or the email you receive into a file.
5. Put the license file onto your target machine.
6. Start the Micro Focus License Administration tool and select the Manual License Installation option by

inputting 4.
7. Enter the name and location of the license file.

To obtain more licenses
If you are unsure of what your license entitlement is or if you wish to purchase additional licenses for Visual
COBOL, contact your sales representative or Micro Focus SupportLine.
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New Features in Visual COBOL 2.3
Enhancements are available in the following areas:

Integration with Visual Studio 2015
This release provides a new Visual COBOL flavor that takes advantage of the new features of Visual Studio
2015, including:

Light Bulbs You can use the light bulb feature ( ) to quickly implement interfaces or add
the USING directive.

Compatibility (Project
Round-Tripping)

Visual COBOL supports the Visual Studio project round-tripping feature which
enables you to work with COBOL projects in Visual Studio 2012, Visual
Studio 2013 or in Visual Studio 2015 without the need to upgrade the project
file.

.NET Framework 4.6
Compatibility

Provides support for creating managed COBOL applications that target
version 4.6 of the .NET Framework.

Microsoft Help Viewer
2.2

Provides support for the Micro Focus Help in Microsoft Help Viewer 2.2.

Integration with the Eclipse IDE
This release ships with Eclipse version 4.4.2.

Support for Eclipse versions 3.7 and 3.8 has been deprecated. This affects any applications that were
created using an earlier version of Visual COBOL that have a JVM COBOL part. Such applications must be
rebuilt using Visual COBOL 2.3 to avoid receiving errors during compilation or execution.

In addition, when Visual COBOL is installed, you can optionally install the Visual COBOL plugin in other
instances of Eclipse installed on your machine (supported versions of Eclipse are 4.2, 4.3 and 4.4 for the
32-bit IDE).

General Enhancements and Updates
In Visual Studio:

• Menu items - the following Micro Focus utilities were previously available under the Tools > Micro
Focus menu and have been moved as follows:

• ADO.NET Connection Editor - now accessed from View > Micro Focus SQL Tools.
• OpenESQL Assistant - now accessed from View > Micro Focus SQL Tools.
• OpenESQL Configuration Utility - now accessed from View > Micro Focus SQL Tools.
• Web Service Client - now accessed by creating a new project of type "Web Service Client

Application from JSON/REST" - click File > New > Project > COBOL > Native > Web Service
Client Application from JSON/REST.

• Managed COBOL project properties - a new setting, Expose group linkage items to managed code,
is now available on the COBOL tab in the properties of managed COBOL projects. Checking this sets
the ILSMARTLINKAGE directive that specifies that group linkage items in your code are to be exposed
as properties of a class. A related button, Options, enables you to also specify whether to remove
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specific prefixes from the names of COBOL data items, whether to make the new classes serializable,
expose Linkage Section items as nested classes of the program class or to limit the property generation
to non-redefining elementary items.

• Resetting the file properties - a new button, Use Project Defaults, on the file property pages of COBOL
files in native projects now enables you to reset the file properties of COBOL files in native COBOL
projects.

In Eclipse:

• The Variables view now shows the file status of an internal file name.
• The Find All References and Go To Definition commands are now supported for JVM COBOL

applications.
• Support is provided for the SOCKS5 proxy server for debugger communication over SSL.

Building applications in Visual Studio
Visual COBOL now supports Visual Studio's parallel builds for COBOL projects. Parallel building enables
you to build multiple projects faster on multi-CPU machines. Following this change, in order for your multi-
project solutions to build in parallel successfully, ensure that the project dependencies and build order are
set correctly for your solution using Project > Project Dependencies. For more information about parallel
building, see Tips on Building COBOL in your product help and your product Release Notes.

Note: Parallel builds are not supported with Personal Edition licensing.

Building JVM COBOL Projects Incrementally
To minimize the number of modules to compile when building JVM COBOL projects, Visual COBOL now
enables you to configure your projects so that they are built incrementally - the IDE only rebuilds the files
that have changed.

To enable incremental builds for JVM COBOL applications that contain namespaces, check the Use
incremental build (Technical preview feature) option on the project build configuration tab in the
project's properties.

For JVM COBOL applications that do not contain namespaces, you can use the Use dynamic calls option
available on the build configuration tab in the project's properties. When the project is built with this setting,
calls to modules are resolved at run time rather than during compilation. This has the effect of not requiring
every module to be compiled when rebuilding the application.

COBOL Editor in Visual Studio
The COBOL editor includes the following enhancements and new features:

• Improved Intellisense writing assistance for COBOL in both native and managed COBOL:

• Context sensitive suggestions - IntelliSense only shows suggestions that are relevant for the position
of the cursor in the code or for the type of project.

• Enhanced completion lists - lists include any relevant COBOL verbs, clauses and words, copybooks,
code templates, data items and section and paragraph names.

• Intelligent assistance with completing statements - when you have entered a COBOL verb,
IntelliSense shows suggestions for the relevant clauses and identifiers that you can use to complete
the statement.

• Automatic completion for single items - IntelliSense automatically inserts single suggestions in the
code.
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• Qualifying non-unique names - IntelliSense qualifies data items whose names are not unique.
• Configuration preferences for IntelliSense - enable you to configure what suggestions appear in the

completion lists, whether suggestions are added in insert or overwrite mode, and the case of the
inserted words.

• Snippets - code snippets are now included in the IntelliSense suggestions.
• $IF-$ELSE-$END statement colorization - parts of a $IF Compiler-control statement that are not

executed are now colored in grey.
• $REGION statement - support is provided for the $REGION Compiler-control statement. You can use

$REGION - $END-REGION to surround blocks of code that you want to folded or expand in the editor.
• Copybook glyphs ( ) in the left-hand margin on a copy line - indicate that a copybook can be expanded

inline.
• Creating copybooks from selection of code - a new context menu command, Extract to Copybook in

the editor enables you to move a selection of COBOL code into a new copybook file. The file is added to
the project and the code in the original program is replaced with a COPY statement that refers the new
copybook.

• Expanded copybook view - provides indicators for read-only copybooks
• Outlining - outlining is now available on comment blocks, paragraphs and on $REGION and $IF

statements.
• Task List comments - the COBOL editor now provides support for Visual Studio-style Task List

comments in COBOL. Typing TODO, HACK or UNDONE in the code immediately after the declaration
of the COBOL comment (*>, *>> or * in column 7) creates a task that appears in the Task List window.

COBOL Editor in Eclipse
Content Assist support for COBOL includes various enhancements and is now also available in JVM
COBOL:

• Context sensitive proposal - Content Assist only shows proposal that are relevant for the position of the
cursor in the code or for the type of project

• Enhanced proposal lists - lists include any relevant COBOL verbs, clauses and words, copybooks, code
templates, data items and section and paragraph names

• Intelligent assistance with completing statements - when you have entered a COBOL verb, Content
Assist shows proposals for the relevant clauses and identifiers that you can use to complete the
statement.

• Automatic completion for items - Content Assist automatically inserts single suggestions in the code.
• Qualifying non-unique names - Content Assist qualifies data items whose names are not unique.
• Configuration preferences for Content Assist - enable you to configure what suggestions appear in the

completion lists, whether suggestions are added in insert or overwrite mode, and the case of the
inserted words.

• Code templates - code templates are now included in the Content Assist proposals.

Code Analysis
Visual COBOL now offers more advanced code analysis features and enables you to run various analysis
queries (rules and groups of rules called rule sets) against your code to ensure adherence to standards
such as standards for coding or performance.

You can run analysis rules against programs in a project in the IDE at user request or you can run analysis
rules at the end of a project's build.
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Code Coverage
Visual COBOL now provides support for code coverage of native COBOL applications directly from within
the IDE where code coverage uses the Test Coverage functionality. You can produce code coverage
reports for applications running in the COBOL run-time and for applications that run in Enterprise Server.

To produce reports, you need to enable code coverage in a project's, a build configuration's, or a file's
properties, compile your application and then run your application with code coverage to produce the
relevant reports. For applications that require an Enterprise Server instance, you start the enterprise server
with code coverage.

Command Line Compilation and Linkage
When using the cbllink command to compile and link, there is a new -y option. Use this option to create
an executable that includes support to be able to run on Windows XP and Windows Server 2003.

Compiler Directives
The following Compiler directives are new in this release:

EOF-1A Treats a 0x1a character in the source file as the end of file.

JVMDECIMAL Determines the type in which certain items are exposed. This directive affects
COBOL data items of type 'decimal' and non-integral numeric items exposed as a
result of either ILSMARTLINKAGE usage or the PROPERTY keyword.

NLS-CURRENCY-
LENGTH

Specifies the number of bytes to allocate for the currency symbol in a PIC field.

NULL-ESCAPE Treats a 0x00 character in the source file as an escape character for other non-
printable characters in the source code.

The following Compiler directives contain new parameters in this release:

DBSPACE The new parameter 'MIXED' extends the DBSPACE directive to be able to evaluate data
items in programs that contain a mix of single-byte and double-byte strings.

Converting Additional Directives to Project's Properties
The Update Project Properties utility allows you to convert additional directives in your project to project
properties. This option is presented on opening a project. You can select to not show this dialog again by
unchecking Check Additional Directives for project properties in Tools > Options > Micro Focus >
General.

Data File Structure Command Line Utility
The Data File Structure Command Line (DFSTRCL) utility is a DOS-based command line utility that
enables you to create record layout (.str) files from COBOL debug information (.idy) files. You can use
the utility to process a single .idy file or batch process up to 100 .idy files.
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Data File Tools (Technology Preview)
Note: This is a technology preview feature only. It is being made available to allow you to test and
provide feedback on this new capability; however, this feature is not intended for production use and it
is not supported as such. Furthermore, Micro Focus does not guarantee that this feature will be
delivered at a GA level and if it is, then the functionality provided might differ considerably from this
technology preview.

The Data File Tools (Technology Preview) is a new standalone text editor in which you can create and edit
data files. By nature of it being a 'technology preview' product, it does not currently include all the
functionality that was available in the previous version of Data File Tools - now referred to as Classic Data
File Tools. If you require any of the functionality not provided in this version, you can still use the classic
version by accessing it in the usual way.

To run Data File Tools (Technology Preview), type mfdatatools2 from Visual COBOL's command prompt
(Windows) or a terminal (UNIX).

To use the new editor directly from the Visual Studio IDE, clear the Use classic data file tools check box,
available from Tools > Options > Micro Focus > Data File Tools. When cleared, the Data File Tools
(Technology Preview) version is used, when possible. When this editor does not support the action you are
attempting to complete, Classic Data File Tools is used instead. This check box is selected by default.

To use the new editor directly from the Eclipse IDE, use the Open with option on the shortcut menu when
selecting a data file or structure file, and select Data File Tools. Eclipse remembers the last tool used for a
particular file type, and so will use Data File Tools (Technology Preview) until you select a different editor.

Database Access
The following new features have been added as part of database access support:

COBSQL This release provides:

• Selection and configuration of the Oracle Pro*COBOL preprocessor for compiling
COBSQL applications in a project's properties on the SQL Preprocessor pageSQL tab
and in the build configuration settings.

• Support for COBOL directives SOURCEFORMAT(TERMINAL) and
SOURCEFORMAT(VARIABLE) for Pro*COBOL applications.

DB2 ECM This release provides:

• Support for the MFHCO environment variable across all platforms by default. See the
HCO DB2 compiler directive option topic for details.

• A new DB2 compiler directive option, OPTPER (NOOPTPER), that enhances
performance for CHARSET EBCDIC processing. See the OPTPER DB2 compiler
directive option topic for details.

• A new DB2 directive option, BINDDIR, which specifies an alternative directory in which
to write the DBRM file created during compilation. You can set BINDDIR from the
command line or specify it in your project's properties. See the BINDDIR DB2 compiler
directive option topic, and the Binding topic for details.

OpenESQL This version of Visual COBOL supports the following new OpenESQL features:

ADO.NET
Connection
Editor

• The ADO.NET Connection Editor has been redesigned using a
series of Wizards that guide you through the processes of adding,
copying, and removing connections.
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• Context help is now provided for the main window, and each Wizard
page and dialog box.

Date/Time
Processing

This release provides streamlined datetime processing for ODBC and
ADO.NET and JDBC.

OpenESQL
Assistant

OpenESQL Assistant Options are now set via the Eclipse IDE from
Window > Preferences > Micro Focus > Database > OpenESQL
Assistant (applies to Windows environments only).

Performance This release includes a new SQL compiler directive option, OPTPER
(NOOPTPER), that enhances performance for CHARSET EBCDIC
processing. See the OPTPER SQL compiler directive option topic for
details.

PostgreSQL In this release, PostgreSQL 9.4 has been tested with OpenESQL and
OpenESQL Assistant using the following PostgreSQL software:

Server software PostgreSQL EnterpriseDB version 9.4.4

Client software • psqlODBC driver version 09.03.04.00
• JDBC41 PostgreSQL driver version 9.4-1201
• Npgsql ADO.NET 4.0 driver version 2.2.5

In this release, PostgreSQL 9.4 has been tested with OpenESQL and
OpenESQL Assistant on the following platforms:

• Windows 32-bit
• Windows 64-bit
• X86-64 running Red Hat Linux, 32- and 64-bit
• X86-64 running SuSE Linux, 32- and 64-bit

In this release, PostgreSQL 9.4 has been tested with OpenESQL on
the following platforms:

• X86-64 running Red Hat Linux, 32- and 64-bit
• X86-64 running SuSE Linux, 32- and 64-bit

Note: Micro Focus provides compatibility for PostgreSQL but
does not directly contribute to or support the PostgreSQL open
source project. Any issues relating to PostgreSQL functionality
should be addressed through an open source support vendor.

SQL Server This release provides support for the SQL Server OUTPUT clause.

XA Switch
Modules

Restriction: This feature applies only when the Enterprise Server feature is
enabled.

In this release, the XA interface has been redesigned to provide:

• Consistent look and feel for SQL Server, DB2, and Oracle user personalization
• Consistent look and feel for both RM dynamic and static registration (SQL Server, DB2,

Oracle, generic one-phase commit)
• Additional support for two instances of the same switch module using Web Services

applications via the new XAID compiler directive
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File Handling
This release contains the following new configuration options:

ACUFH Enables or disables the use of the ACU file handler (ACUFH), which is required to handle
Vision and RM/COBOL indexed files.

ESACUFH Enables or disables the use of the ACU file handler (ACUFH) for file handling operations
running under Enterprise Server. ACUFH must also be enabled for this option to take effect.

File Locking
In versions prior to Visual COBOL 2.3, the semantics of the sharing phrase specified in an OPEN
statement or used within a call to CBL_OPEN_FILE were not correctly applied in some cases on UNIX and
Linux platforms. From version 2.3 onwards, the sharing phrase is correctly honored when the tunable
strict_file_locking=true is set, which is the default setting.

Example of potential changes in behavior:

• Process-A opens a file with read-only access and a sharing mode that denies other processes write
access (SHARING WITH READ ONLY).

• Process-B then attempts to open the file with read-only access and a sharing mode that denies other
processes read access (SHARING WITH NO OTHER).

With strict_file_locking=true, Process-B is unable to open the file, because Process-A has
successfully opened the file allowing only read access.

With strict_file_locking=false, Process-B successfully opens the file.

If your application encounters unexpected OPEN conditions or fails to open files, it might be as a result of
the new file locking behavior. In such circumstances, we recommend that you review the file locking and
sharing requirements of your application and refactor your source code to work with the default setting. The
original file locking and sharing behavior can be restored by setting strict_file_locking=false.

Library Routines
The following library routines are new in this release:

CBL_MANAGED_SESSION_GET_USERDATA Retrieves user data saved in the current RunUnit.

CBL_MANAGED_SESSION_SET_USERDATA Sets user data in the current RunUnit.

The following library routines contain new parameters in this release:

CBL_LOCATE_FILE You can now specify a file name that is a null-terminating string, which has resulted
in three new values available for the user-mode parameter.

Managed COBOL Syntax
The following enhancements have been made to the managed COBOL syntax:

• The TYPE OF type-name[ANY...] syntax enables you to obtain the System.Type (.NET) or
java.lang.Class (JVM) object for a generic class, interface, or delegate.

• The self:: or super:: syntax is no longer required to access inherited data within a subclass.
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• The ATTRIBUTE-ID syntax enables you to define new attribute types, which can be used in various
contexts.

Micro Focus Infocenter
The Micro Focus Infocenter Web site (http://documentation.microfocus.com) has been upgraded and now
includes the following improvements:

• Scope being persisted when you select a product documentation in the Product Documentation section
on the Micro Focus SupportLine Web site and choose to view the documentation in the Micro Focus
Infocenter.

• Updated Scope settings - provides the ability to nest four levels deep when setting a scope.
• Scope being persisted between browser sessions once it has been set.
• Creating automatic scopes using the Search Topics icon, .
• A link to change the scope from the search results when there are too many results.
• Improved Boolean search expressions.
• Details included with the search results.
• Help on how to use the Infocenter and how to construct search expressions - available using the

Infocenter Help button, .

Micro Focus Unit Testing Framework
Note: This is a technology preview feature only. It is being made available to allow you to test and
provide feedback on this new capability, but it is not intended for production use and is not supported
as such. Furthermore, Micro Focus does not guarantee that this feature will be delivered at a GA level
and if it is, then the functionality provided might differ considerably from this technology preview.
During the preview, you are encouraged to share your feedback and experiences via the Micro Focus
community forum - http://community.microfocus.com/microfocus/).

The Micro Focus Unit Testing Framework is an xUnit style testing framework, available from the command
line, for procedural COBOL applications.

It includes much of the architecture you would expect in an xUnit framework. The test runner is a 32- or 64-
bit executable that you run from aVisual COBOL command or shell prompt. A test fixture or suite is a
COBOL program compiled to .dll (Windows) or .so (UNIX) that can include the setup, the test case
code, and the teardown associated with the test case.

Test results are available in a number of formats. By default, results are displayed to screen and to a .txt
file, but you can use additional parameters on the command line to produce reports in JUnit format.

Microsoft Azure Support
Visual COBOL support for Microsoft Azure has been updated to version 2.6 of the Microsoft Azure SDK.

Support has been added to the product for making any future versions of the Microsoft Azure SDK
available before the next major release of Visual COBOL. Micro Focus will deliver support for these only
upon customers' requests.

Personal Edition Licensing
This release includes a Personal Edition licensing option for Visual COBOL for Visual Studio 2015 and for
Visual COBOL for Eclipse.
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Preprocessors
Support has been added in the IDE for enabling and using multiple preprocessors with your projects.

A new page, Additional Preprocessors Preprocessors, has been added to the project's and the files'
properties of native COBOL applications to enable you to choose one or more preprocessors to use when
building your application and to specify their order of execution.

New reporting capability is now available for user preprocessors: resp-main code 18 indicates that a buffer
contains a data name to be marked as modified by the immediately preceding preprocessed line. The data
name may be qualified and resp-more contains the column information for the reference.

Profiler
Visual COBOL now provides support for Profiler for native COBOL applications directly from within the IDE.
To produce reports, you need to:

1. Enable Profiler in the COBOL property page for a project, a build configuration, or a file.
2. Compile your application to apply the changes.
3. Create a run configuration that has Profiler enabled.
4. Run your application with Profiler to produce the relevant reports.

Remote Connections
This release provides the following enhancements:

• An improved diagnostic tooling to help determine connection problems - enhancements are available for
both the client and the server installations.

• It is now possible to specify the Remote System Explorer (RSE) type of connections to create remote
mainframe COBOL and PL/I projects. This is to cater for scenarios when it is not possible to use
SAMBA or NFS connections within your environment.

Note: The following features and utilities are not supported when remote projects use the RSE
connection type:

• The file layout editor and the file editor in the Classic Data File Tools and Data File Tools
(Technology Preview) utilities.

• Changing the type of a remote connection - it is now possible to change the type of the remote
connection from RSE to NFS and vice versa using the Remote Settings for remote projects.

REST service interfaces
RESTful service interfaces utilizing JSON as the media type in request and response messages are now
supported using the Interface Mapping Toolkit. This enables you to extend COBOL applications using
modern transport payloads and protocols.

RM/COBOL Compatibility
This release includes improved support for RM dialect applications. Please consult with Micro Focus before
considering a transition from RM/COBOL to Visual COBOL.
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Single File Support
The recommended way to work with files within Visual COBOL is to include them in a project. For
situations where you might want to quickly open edit a single file, Visual COBOL now provides support for
native COBOL files in the IDE when the file is not opened as part of a project. There is limited support for
the IDE editing, compiling and debugging features as full support requires a project file.

To enable full IDE support for single files, Visual COBOL provides a path for creating projects from them -
right-click such files in the editor, and click Create COBOL Project.

Tunables
This release of Visual COBOL contains the following new tunables:

putenv_interface Provides backward compatibility for UNIX systems in which the operating system's
putenv() function is required when setting environment variables.

strict_file_locking Enables a new, more reliable method of file locking for UNIX systems. See File
Locking for more information.

This release of Visual COBOL contains the following updates to tunables:

default_cancel_mode A new parameter, and default, has been introduced for this tunable; see
default_cancel_mode for more information.

subsystem_cancel_mode A new parameter has been introduced for this tunable; see
subsystem_cancel_mode for more information.

Updated Run-time System
COBOL Server has been updated to provide an execution environment capable of running applications that
were each built using different development products. A consequence of this is that If your application has
a main COBOL executable (.exe) that was built with a previous version of Visual COBOL, you should
ensure that the executable is rebuilt and packaged with the new run-time system. You can rebuild from the
IDE or the command line.

Other COBOL subprograms built with previous versions of Visual COBOL are not required to be rebuilt.
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Known Issues
Refer to the Known Errors and Restrictions topic in the Product Information section of your product Help.

In addition, note the following:

Debugging

Remote debugging does not work for programs running on AIX or HP machines, if you are trying to debug
using Visual COBOL installed on a Linux machine.

Documentation

• In Visual Studio 2012, clicking Help > Micro Focus Product Help > Product Documentation results in
the message "Cannot find requested topic on your computer". If you see this message, click Micro
Focus Visual COBOL x. x for Visual Studio 2012 in the Contents tab to display the documentation as
expected.

• If you install Visual COBOL for Visual Studio 2012 and its documentation is not available in the
Microsoft Help Viewer, perform the following steps:

1. In Visual Studio 2012, click Help > Add and Remove Help Content.
2. Choose the Manage Content tab.
3. Check the Disk radio button, then navigate to the folder containing the Visual COBOL for Visual

Studio 2012 documentation. By default, this is C:\Program Files (x86)\Micro Focus
\<product name>\help.

4. Select helpcontentsetup.msha and click Open.
5. In the content list, click Add next to the Visual COBOL entry.
6. Click Update.
7. Click Yes on the User Account Control and Microsoft Help Viewer 2.0 dialog boxes to enable the

update to continue.

The documentation for Visual COBOL for Visual Studio 2012 is added to the Microsoft Help Viewer.

Note:

This problem only occurs if you install Visual COBOL for Visual Studio 2012 while documentation
for Visual Studio 2012 is being downloaded or updated, which typically happens when you install
Visual Studio 2012 or run it for the first time.

• The tutorial "Calling JVM COBOL programs as part of an Axis Web service" in the product help for
Visual COBOL 2.3 for Eclipse cannot be completed. This is due to unresolved configuration issues with
some third-party components. The tutorial is not available in the documentation available on the Micro
Focus Infocenter.

• A known issue in JRE 1.7.0_45 (issue JDK-8028111) causes problems with searching and indexing the
help in the Eclipse help viewer if you are running Eclipse on a machine that has this version of JRE
installed.

Database Access

If you have a remote COBOL project under Eclipse that uses DB2 ECM in Visual COBOL or HCO for DB2
LUW in Enterprise Developer and the DB2 software is not installed on the client machine where you are
using the Eclipse IDE, you receive background parsing errors in your application. To resolve the issue, you
can do either one of the following:

• Disable background parsing Window > Preferences > Micro Focus > COBOL > Editor and disabling
the checkbox for Background parsing.
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• Install the IBM DB2 client-side software on the machine on which you are running Eclipse. Go to the
IBM Support Home and locate the page entitled "IBM Download Fix Packs for IBM Data Server Client
Packages" .

Enterprise Server

• The Historical Statistics Facility may generate incorrect records for SSTM-enabled enterprise servers.
• On Windows 10, if you are using Microsoft's EDGE browser to access the Enterprise Server

Administration GUI, issues with EDGE can cause the automatic refresh feature to display a dialog
asking whether you want to resubmit a form. To work around this issue, cancel the resubmit request and
then refresh the server list page or the Home page of Enterprise Server Administration. You can also
turn off the automatic refresh by setting the Auto-refresh interval setting on the Home page of
Enterprise Server Administration to 0.

• Enterprise Server instances will fail to start if they have been configured with the MLDAP ESM module
to use external security and are started using Enterprise Server credentials that are not configured with
"user administration" privileges (that is they do not have an allow update ACE in the "User
Administration" security resource in the Enterprise Server Administration). A fix for this is available if you
install HotFix 1 of version 2.3. of this product.

IDE

• When searching in Visual Studio using the Find in Files command, if Look in scope is set to COBOL
Project Copybook Paths, you might get a message that no files can be found and the search might
erroneously return no results.

To work around this issue, add the copybook folders you want to search to the solution and then, in the
Find and Replace dialog box, specify Entire Solution in the Look in field.

-2835506 (1101288)

• When you add a COPY statement in a COBOL program and then show it in Expanded Copybook View,
the line for the copybook statement is read-only. If you then perform an Undo in the COBOL program,
the COPY statement is removed while the contents of the copybook is still shown in the program.

• Replace All does not work inside the Expanded Copybook View
• For copybooks with file extensions that are not traditionally associated with COBOL you must first add

the file extension to the list of known copybooks extensions in Tools > Options > Text Editor > File
Extensions before you can show them in Expanded Copybook View.

ICETOOL Emulation

ICETOOL emulation for managed code is not available in this release.

Linking

Changes in the C compiler in Visual Studio 2015 affect the way you link COBOL object code and C object
code built with that version of Visual Studio in the same executable. In this scenario, you must use the
Microsoft link utility and the C runtime libraries directly from Visual Studio, rather than the Micro Focus
cbllink utility, the Microsoft link utility and the libraries supplied with Visual COBOL. You might also need to
specify some additional C runtime libraries - see the Microsoft documentation for more details.

Note that when using COBOL and C object code together, Micro Focus recommends you build and keep
the COBOL and C executables separate, and use import libraries and the Micro Focus C functions for
calling COBOL (see "C functions for calling COBOL" in the product help) to resolve calls between them.

Resource Adapters

Trying to deploy the local resource adaptor mfcobol-localtx.rar to WebLogic may fail with a
ClassCastException. To work around this issue, you need to deploy mfcobol-xa.rar first, then need to
undeploy this file and deploy the local one, mfcobol-localtx.rar. If there are issues deploying using
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the WebLogic GUI, you can use the command line. If there are issues with this as well, try reducing the
length of the command (for example, by moving the file to a location with a shorter path).

REST/JSON IMTK implementation and the same-origin policy (SOP)

HTTP requests sent from scripts within a web browser to REST services deployed on an enterprise server
might fail due to the same-origin policy (SOP). Some browsers might implement (or support plugins that
implement) techniques for relaxing SOP such as cross-origin resource sharing (CORS) that enable
sending cross-origin requests successfully. For REST services, Enterprise Server does not implement a
method for relaxing SOP. This means that browsers that implement CORS (or any other SOP relaxation
technique) might still forbid requests made from scripts due to Enterprise Server not implementing the
equivalent technique on the server side.

Setup

• A problem with Microsoft's Windows 10 prevents installing the Visual Studio 2013 Shell on that version
of the OS. You must install an advanced edition of Visual Studio 2013 on Windows 10 before you start
the installation of Visual COBOL for Visual Studio 2013.

• Visual COBOL for Visual Studio 2015 does not support Visual Studio 2015 Shell as the Shell has a
number of restrictions to COBOL development. The Visual Studio 2015 Shell is not included in the
setup for Visual COBOL for Visual Studio 2015 and before you start the installation, ensure that there is
an advanced edition of Visual Studio 2015 installed on your machine.

• On UNIX, check UNIX Installer Issues before you start the installation.
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Significant Changes in Behavior or Usage
This section describes significant changes in behavior or usage. These changes could potentially affect the
behavior of existing applications or impact the way the tools are used.

Where present, the numbers that follow each issue are the Support Incident Numbers followed by the
Reported Problem Incident (RPI) number (in parentheses).

• Building
• Converting Additional Directives to Projects' Properties
• CAS Security
• CAS XA Switch modules
• Compiler
• Data Tools
• File Handling - External File Handler
• File Locking
• IDE
• J2EE Connector
• MF Server Administrator (GUI)
• Updated Run-Time System

Building

Back to the list

• Visual COBOL now supports Visual Studio parallel builds for COBOL projects. Parallel builds enable
you to build multiple projects faster on multi-CPU machines.

If, after upgrading to this version of Visual COBOL, you start receiving unexpected build errors when
compiling an existing multi-project solution, this may be a result of enabling support for parallel project
builds. These are a couple of examples of issues that might be causing these errors:

• Using file references to project outputs in the same solution. You need to use project-to-project
references instead.

Use Project > Project Dependencies to manage the project dependencies and build order within
your solution.

• A customized build process such as one that is using pre- or post- build events.

If resolving any of these issues does not help resolve the build errors, consider disabling the parallel
build support - click Tools > Options > Projects and Solutions > Build and Run and set maximum
number of parallel project builds to 1.

Note: Parallel builds are not supported with Personal Edition licensing.

Converting Additional Directives to projects' properties

Back to the list

Starting with this release, an Update Project Properties dialog box might start to appear when you are
opening existing COBOL solutions. The dialog box recommends converting some of the directives
specified in Additional directives to project's properties. This is to address an issue where you might try
to set file properties that differ from the project directives and the directives specified in Additional
directives that have a property equivalent take precedence over the file properties. As a result of this you
might receive unexpected build issues when building your applications.
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This dialog box helps eliminate the issue by converting the directives specified in Additional directives to
project properties.

If you do not want the IDE to perform this check, click Tools > Options > Micro Focus > General and
uncheck Check Additional Directives for project properties.

CAS Security

Back to the list

• The Enterprise Server External Security Facility now includes MLDAP ESM Module 2.0, with a new
algorithm for identifying the best-matching resource-access rule and ACE for resource-access security
checks. This algorithm is faster and matches most customers' expectations. The new algorithm also
provides an optional "username substitution" feature. It can be enabled by setting "rule substitutions" to
"yes" in the [Operation] section in the Security Manager configuration text area. When this is enabled,
the string "${user}" in a resource-rule name will be replaced with the name of the user that makes the
request. For example, a DATASET rule named "USERS.${user}.**" would apply to datasets with the
requesting user's name as the second qualifier. In rare cases, customers with complex, ambiguous
resource-access security rules might see experience changes in behavior as a result of the new
algorithm. The old algorithm is still supported and can be enabled by setting "version 1 authentication"
to "yes" in the [Operation] section of the Security Manager configuration.

2807531 (1097783)

CAS XA Switch modules

Back to the list

• The XA switch modules now support dynamic registration.

2682101 (1092325)
• The XA switch modules now support batch-only operations when multiple XA Resource Managers have

been defined.

2664675 (1091082)
• In Visual COBOL 2.2 update 2, Micro Focus identified undefined run-time behavior when the following

combination of directives was specified: SIGN"EBCDIC", CHARSET"ASCII", and one of the following:
HOST-NUMMOVE, HOST-NUMCOMPARE or SIGN-FIXUP. Previously (Visual COBOL 2.2 update 1 and
earlier), if this combination was specified, the SIGN”EBCDIC” directive should have been ignored, to
avoid a mixture of ASCII and EBCDIC characters; however, SIGN”EBCDIC” was still being honored,
resulting in undefined run-time behavior. Therefore, this combination of directives is now invalid for
Visual COBOL 2.2 update 2 or later, and if specified, will be rejected at compile time.

2786397 (1095265)

Compiler

Back to the list

• For native COBOL, the size limit of the Data Division now stands at 2GB -1.

2796076 (1096384)
• COBDATA has no effect on compilation. The output of the Compiler is the same location regardless of

whether COBDATA is set.

Previously, it was not possible to specify sign(EBCDIC) with sign-fixup, host-num-move or with host-
num-compare. This combination is now supported in native COBOL but remains invalid for managed
COBOL code. This is applicable to version 2.2 U2 HotFix 10 onwards.

2824577 (1100823)
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Data Tools

Back to the list

• DFCONV now returns the correct return-code; previously, it would always return 0.

File Handling - External File Handler

Back to the list

• Custom file handlers (using DYNREDIR) are now called for each part of a concatenated file.

2795077 (1096322)

File Locking

Back to the list

• In versions prior to Visual COBOL 2.3, the semantics of the sharing phrase specified in an OPEN
statement or used within a call to CBL_OPEN_FILE were not correctly applied in some cases on UNIX
and Linux platforms. From version 2.3 onwards, the sharing phrase is correctly honored when the
tunable strict_file_locking=true is set, which is the default setting.

Example of potential changes in behavior:

• Process-A opens a file with read-only access and a sharing mode that denies other processes write
access (SHARING WITH READ ONLY).

• Process-B then attempts to open the file with read-only access and a sharing mode that denies
other processes read access (SHARING WITH NO OTHER).

With strict_file_locking=true, Process-B is unable to open the file, because Process-A has
successfully opened the file allowing only read access.

With strict_file_locking=false, Process-B successfully opens the file.

If your application encounters unexpected OPEN conditions or fails to open files, it might be as a result
of the new file locking behavior. In such circumstances, we recommend that you review the file locking
and sharing requirements of your application and refactor your source code to work with the default
setting. The original file locking and sharing behavior can be restored by setting
strict_file_locking=false.

IDE

Back to the list

• Changes in the C compiler in Visual Studio 2015 affect the way you link COBOL object code and C
object code built with that version of Visual Studio in the same executable. In this scenario, you must
use the Microsoft link utility and the C runtime libraries directly from Visual Studio, rather than the Micro
Focus cbllink utility, the Microsoft link utility and the libraries supplied with Visual COBOL. You might
also need to specify some additional C runtime libraries - see the Microsoft documentation for more
details.

Note that when using COBOL and C object code together, Micro Focus recommends you build and
maintain the COBOL and C executables as separate projects, and use import libraries and the Micro
Focus C functions for calling COBOL (see "C functions for calling COBOL" in the product help) to
resolve calls between them.

• The default warning level for new COBOL projects in Visual COBOL for Visual Studio is now "Include
recoverable errors (Level E)". This also includes "Severe errors only (Level S)" and unrecoverable (Level
U) errors. Micro Focus recommends you set the warning level on the COBOL page in a project's
properties to "Include warnings (Level W)" where appropriate to help avoid potential coding problems.
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• Visual COBOL for Eclipse now ships with Eclipse 4.4.2 (Luna). If your applications contain JVM COBOL
code that was built with a previous version of the product, those parts of your application must be
rebuilt; otherwise you will experience errors at either compilation or run time.

(609469)
• A project can have one of two connection modes: NFS/Samba, where the target location is mounted as

a local drive, and RSE, which is a purely remote connection to the target location. For project types
such as Mainframe COBOL, NFS/Samba is required to use some tools which do not support RSE. For
most other projects, it is possible to switch between connection modes using the Remote Settings
context menu option. In the dialog box, there are radio buttons allowing for selection of connection
modes. On changing mode, you must select an existing connection of the appropriate type, or create a
new one. If switching to NFS/Samba mode, you must specify the local path to the project.

2792882 (1096196)
• By setting "-Denable.projectrepair=true" in the eclipse.ini file, .cobolProj and .pliProj files will be repaired

to reflect the workspace on project refresh.

2696707 (1095994)

J2EE Connector

Back to the list

• This release provides a new command-line argument to Java, mf.ssl.algorithm, which can be set to an
appropriate algorithm.

2799213 (1096684)

MF Server Administrator (GUI)

Back to the list

• Passwords that entered through either the MFDS or the ESMAC interface now use the same encoding.

2792382 (1096011)

Updated Run-Time System

Back to the list

• COBOL Server now provides an execution environment capable of running applications that were each
built using different development products. A consequence of this is that if your application has a main
COBOL executable (.exe) that was built with a version of Visual COBOL prior to version 2.3, you should
ensure that the executable is rebuilt and packaged with the new run-time system. You can rebuild from
the IDE or the command line.

Other COBOL subprograms built with previous versions of Visual COBOL are not required to be rebuilt.
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Resolved Issues
The numbers that follow each issue are the Support Incident Numbers followed by the Reported Problem
Incident (RPI) number (in parentheses).

• Adis
• CASRDO
• Character Animator
• Code Analysis
• Compiler
• Data Tools
• Debugging
• Designer
• Documentation
• ecijava
• Enterprise Server
• File Handling
• IBM Language Environment for OS/390 and VM Support
• IDE
• Library
• Micro Focus Common Client
• Micro Focus Communications Server
• Micro Focus Directory Server
• Micro Focus Server Administrator (GUI)
• MLDAP API Interface
• RM COBOL
• Run-Time System
• Setup
• SQL: COBSQL
• SQL: DB2 ECM
• SQL: OpenESQL
• XML Extensions
• XML Support

Adis

Back to the list

• Paste now works as expected when pasting into numeric items under MS(2) with ACCEPT statements.

2800091 (1096820)
• When the MS Compiler directive is set, ACCEPT with EMPTY-CHECK now supports manually entering

of a zero for numeric items and a space for alphanumeric items.

2795831 (1096324)
• When using ACCEPT WITH UPDATE with the MS Compiler directive, the pre- and post- display

behavior is now the same as that of the MS compiler.

2795709 (1096311)
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CASRDO

Back to the list

• When trying to access the Catalog page from casrdo45, the JESSPOOL class was checked instead of
DATASET.

2819633 (1099350)
• The ESMAC Spool view is now sorted correctly when using a filter criteria.

2798643 (1096681)

Code Analysis

Back to the list

• An issue that was causing a slow down in opening source files in the editor has been resolved.

2804209 (1097351)
• Sequential line calculation has been fixed to provide correct position of POI (Point Of Interest) within file.
• The analysis component no longer hangs when running on programs containing DBCS (double-byte

character sets).
• 'error starting the query' and other similar non-descriptive error messages have been expanded to

include additional information as to what caused the error.
• The generic "Violations detected" string, preceding the actual description for the rule, has been

removed from the rule description. Users of Visual COBOL for Visual Studio will no longer see this
string as part of the description.

Character Animator

Back to the list

• Monitoring large fields no longer causes the Animator to abort.

2828703 (1100628)

Compiler

Back to the list

• A program compiled with the INIT-BY-TYPE directive that contains 'PROGRAM-ID IS INITIAL' syntax
and declarations of index names or data items now produces correct intermediate code.

2831469 (1100741)
• Programs compiled with DIALECT"RM" and containing 'PROGRAM-ID .. AS' syntax now execute as

expected.

2830956 (1100700)
• The CP preprocessor used in conjunction with the COBSQL preprocessor now correctly replaces any

text affected by the COPY... REPLACING statement.

2826558 (1100370)
• When using the WINDOW1 preprocessor, specification of the AUTOCLOSE option no longer prevents

subsequent preprocessor options from being actioned.

2822206 (1099687)
• The output from the SETTINGS compiler directive now also appears for programs specified via the

ILSOURCE option.

2822102 (1099604)
• The XML GENERATE statement now functions as expected in programs containing the DECIMAL

POINT IS COMMA clause.

2821786 (1099599)
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• The XML GENERATE statement now executes correctly when the specified FROM operand is a group
containing nested ODO tables (which is only possible with the ODOSLIDE directive).

2821779 (1099600)
• The INITBYTYPE compiler directive no longer causes spurious flag messages with DIALECT(OSVS).

2820920 (1099488)
• Typing "DEADDATA" in the Quick Browse window no longer causes Eclipse to crash.

2818822 (1099230)
• The LINE-COUNT Compiler directive now operates as expected.

2817442 (1098979)
• The maximum size of data items in a program compiled with the DIALECT(ENTCOBOL) directive now

correctly reflects the respective mainframe values in the latest version of Enterprise COBOL.

2816030 (1098926)
• The Compiler now rejects the use of special register names as arguments for reserved word altering

directives. You can only specify standard reserved words with these directives.

2813931 (1098542)
• Data names that start with a numeric digit and contain DBCS characters are now accepted by the

Compiler, as expected.

2813223 (1098456)
• A MOVE operation of an alphanumeric literal to an unsigned numeric DISPLAY field under RM/COBOL

emulation now executes as expected.

2812561 (1098446)
• Data names longer than 30 characters are now flagged when specifying the FLAG option with a

mainframe argument and not just when using the equivalent full DIALECT.

2810924 (1098133)
• Compiling a program with the COBSQL preprocessor, which contains a COPY REPLACING statement

with trailing spaces in the replacement pseudo text, now works as expected.

2807470 (1097737)
• Compilation of a program containing a GO TO statement that references an undeclared procedure

name, and has the RESTRICT-GOTO directive set no longer results in a run-time exception.

2807280 (1097616)
• A user function that specifies a PIC 1 item as a RETURNING field now receives an appropriate compile-

time error.

2806037 (1097470)
• The addressability of a linkage data item is now checked correctly.

2805523 (1097453)
• Compilation with a mainframe dialect, of a program containing a CALL statement with a mixture of

non-01 level group items and literals, now proceeds as expected with no internal error produced.

2803613 (1097190)
• A debugger query of a condition name with a negative literal VALUE now returns the expected result.

2801993 (1097607)
• The combination of a mainframe dialect and SOURCEFORMAT(FREE) no longer produces unexpected

compiler errors referring to tokens being in the wrong area of source.

2800332 (1096911)
• The specification of an alphanumeric literal in the VALUE clause of a DBCS data item (i.e. the G\N

prefix is missing) is now accepted as an MF extension. This still generates an error under mainframe
dialects, but can be hidden/suppressed like any other flag message.

2798426 (1096574)
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• Under DIALECT"MF", the Report Group description entry now permits the NEXT GROUP NEXT PAGE
clause without a LINE clause.

2798367 (1097201)
• It is now possible to specify fixed-point numeric literals without a trailing separator space before the next

token or operator. This provides a better mainframe emulation.

2797274 (1096469)
• A new CP option, ANYCOPYCASE, now provides more flexibility in matching the case of copybook

names.

2797035 (1096494)
• Previously, numeric items that used a decimal point and the OR sign were truncated when using the MS

display syntax under MS(2).

2795709 (1096308)
• DBSPACE(MIXED) directive has been implemented to allow comparison of mixed single and double-

byte spaces to the SPACE figurative constant.

2679222 (1092427)
• When importing aVisual COBOL source file, the generation of a CBLast (COBOL Abstract Symbol

Table) file no longer hangs when instructed to process a COBOL.DIR file.
• Mixing alphanumeric and national items in intrinsic functions which only allow one type now produces a

syntax error.
• A source line longer than the maximum supported by the compiler no longer receives an error about

truncation if the line is simply a comment.
• An error during compilation, when creating .int files when the COBDATA directive is set, has been fixed.
• An error reading the default directive file $COBDIR/etc/cobol.dir when COBDATA is set during

compilation has been fixed.

• A bug in accepting a field containing double-byte and single-byte characters has been fixed.

2829369 (1100513)
• A bug during compilation has been fixed, which caused a Run-Time System error 114 when generating

32-bit programs using the OPT directive, containing decimal operations.

2819838 (1099305)
• An error has been fixed in COMPUTE statements of the following form: COMPUTE a = b / constant

where a and b are COMP-3 or DISPLAY; a has greater than 19 digits and b has less than or equal to 19
digits, and constant is a literal which is a power of 10 (such as 10, 100, 1000, etc.)

2808008 (1097715)

• An error in managed COBOL that resulted in EXIT PROGRAM or GOBACK statements not being
executed has been fixed. The error could occur when perform ranges overlapped.

2825425 (1100162)
• When compiling for JVM COBOL with the ILSMARTLINKAGE directive, pic 9v9 items used as VALUE

parameters are now generated correctly.

2815477 (1098847)
• An illegal instruction 'invokespecial' is no longer generated. Previously, in some circumstances, this

could be generated, leading to a verification error on class load.

2811246 (1098205)
• When compiling a large program for JVM COBOL, the use of performtype(osvs) or performtype(rm) with

declaratives no longer leads to bad code generation and invalid jump errors when loading the resulting
class.

2695030 (1093952)

• Very large screen section records no longer produce unpredictable errors when generating managed
COBOL code.
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2830002 (1100580)
• Programs that contain report-writer syntax, and are compiled with either PERFORMTYPE(RM) or

PERFORMTYPE(OSVS), now behave as expected.

2824931 (1099963)
• When forming externalised names for ILSMARTLINKAGE, any double-byte hyphen (or similar)

characters are now removed from the name.

2822491 (1099668)
• For class programs containing COBOL files declared in the OBJECT section, it is now possible to

explicitly add the program to a run unit. Previously, this would cause a run-time exception.

2819597 (1099273)
• The use of the SCREEN SECTION CONTROL phrase in .NET unverifiable code no longer causes the

generation of illegal code.

2818736 (1099170)
• An INITIALIZE statement applied to a file record, which is not otherwise referenced, now correctly

initializes the whole record area.

2817756 (1099017)
• Verification or run time errors are no longer produced when NUMPROC(ACOS) is specified, and a level

88 item is declared for a numeric item in the Linkage section of your program.

2815137 (1098693)
• Opening a XAML file in a WCF client project no longer causes an unhandled exception to be generated.

2813004 (1098525)
• You can now use an external member reference as a target operand for the INITIALIZE statement. In

previous versions of the product, you could not.

2812151 (1098318)
• In previous versions of the product, compilation errors resulted when the NOILNATIVE directive was

specified when compiling programs that used the OCCURS ANY syntax for defining tables. This is no
longer the case, and the NOILNATIVE directive has no effect on such tables.

2809432 (1097893)
• The INITIALIZE statement is now working as expected when applied to a group item where an

OCCURS subgroup follows a FILLER data item. Previously, this could produce bad code, initializing
incorrect areas of the group.

2805149 (1097372)
• For class programs containing COBOL files declared in the OBJECT section, it is now possible to

explicitly add the program to a run unit. Previously, this would cause a run-time exception.

2802641 (1099053)
• When compiling for managed code (.NET or JVM), a zero length literal used as a value for a PIC N data

item no longer crashes compilation with run-time error 181.

2799176 (1096677)
• If a method has an optional parameter with a default value of System.Reflection.Missing.Value, and that

parameter was omitted in a method invocation expression, that parameter was being passed as null,
instead of the correct default value. This affected a number of methods - for example,
Microsoft.Office.Interop.Excel.

2796911 (1096408)
• Comparisons between PIC N or PIC G items and ALL hex-literals are now working correctly.

2795393 (1096266)
• Managed code that includes operands of the form 'typedef-name AT pointer' now generates correctly.

(607855)

Resolved Issues | 61



Data Tools

Back to the list

• It is now possible to associate data files with specific .STR files. This information is stored in the .pro file
for the respective data file.

2792214 (1095979)
• Creating a record or a segment layout file no longer fails when the COBOL names contain double-byte

characters.

(606488)

Debugging

Back to the list

• Pointer values no longer get incorrectly byte-swapped when their value is accepted.

2824427 (1100287)
• Trying to view the values of data-items that contain UTF-8 data no longer corrupts the values.

2810079 (1097992)

• You can now enable debugging of CGI programs when invoking them multiple times. To do this, check
"Return to waiting state when debugging" on the Debug tab of your project's properties.

2794496 (1096442)

• Stepping through programs with large data items could occasionally cause Eclipse to crashes.

2823848 (1099954)
• When using the Expressions view in Eclipse, you no longer receive an error related to variables

declared in nested programs.

2809946 (1098036)
• Sources are now located successfully when debugging COBOL JVM JUnit tests when the COBOL JVM

project is added to the debug configuration source lookup path.

2808860 (1097879)

Designer

Back to the list

• When importing using the Designer, you now receive an "Source Code Import Wizard Detected Errors
Page" if there are parsing errors. See your product help for more details. Previously, the import process
proceeded even when there were parsing errors. If errors or warnings were reported but the FD and 01
extraction process ran to completion, the errors will be reported but the "Next" button is enabled to allow
the partially extracted data items to be imported. The "Back" button is also enabled allowing the process
to be repeated once the errors are fixed. If a severe parsing error occurred, the errors are reported and,
since they must be fixed, the "Next" button is not enabled.

Documentation

Back to the list

• The product help now includes the optional attributes for the ‘container’ objectclass definition used by
Enterprise Server external security.

2801420 (1096977)
• The product help now includes information about how to retrieve the Run-Time System error code from

a file status code returned as a decimal value. For example, if you receive 14657 as a value for the file
status, this is a decimal value. This converts to 3941 HEX. The second byte of this value, 41, must be
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converted to Decimal before looking at the RTS error code - thus this HEX value then represents an
extended file status code of 9/065 which means the error code is COBRT065, a locked file status.

2822853 (1099769)
• The MFJSTATS topic has been updated to clarify that this refers to a COBOL SORT operation.

2828881 (1100446)
• The Micro Focus Infocenter documentation for Visual COBOL for Visual Studio has been updated with

the correct instructions to launch the Net Express Project Import wizard.

2802047 (1097052)
• The product documentation about the START statement and Relation Conditions now states that THEN

may be used instead of THAN.

2799291 (1096903)
• The topic "Using the CP Preprocessor to Expand Copybooks" in the product documentation has been

updated to include the following text: If the MODE=ANSI option is specified to the Oracle precompiler,
Pro*COBOL, then you should additionally use CP's SY directive to ensure that the SQLCA gets
populated correctly.

2792368 (1096084)
• The documentation for debugging in the IDE now includes instructions about how to create and

configure a COBOL Wait for Attachment configuration in order to debug a Windows Service, when you
do not have the original Eclipse project that builds the Service.

2781118 (1095738)
• The default setting for the ES_ESM_PLTPISEC variable is NONE.

2821810 (1099672)
• Additional information has been added to the description of the CASSI1400 error message.

2821806 (1099711)
• The AdminAPI resource class has been documented for ESF features.

2815870 (1098815)
• The Enterprise Server documentation for Retain Periods has been updated to include additional

information specific to spool output.

2790146 (1095777)
• The LISTCAT topic in the documentation has been updated to reflect accurate column headings and

descriptions for output format.

2789939 (1095765)
• The explanation of error message CASCF0052S has been updated with UNIX-specific information.

2821745 (1099737)
• Topic amended to refer to entry_point_mapper rather than entry_name_mapper.

2807744 (1097673)
• Details on MF_MVSJOB environment variable added.

2797526 (1096488)
• The documentation for Visual COBOL and Enterprise Developer 2.2 Update 2 for Visual Studio 2010 on

the Micro Focus Infocenter now correctly lists Microsoft's Visual Studio Service Pack 1 as a prerequisite.
The installation instructions also provide instructions about how to install the product if your machine is
not connected to the Internet.

2803705 (1097455)
• The Micro Focus Communications Server now supports rotational log files. To enable this feature, you

need to edit the mf-server.dat file, which resides in the product's bin directory (Windows), or the
$COBDIR/etc directory (UNIX). The mf-server.dat file contains details of this feature under the [logging]
paragraph, and full documentation is provided in the online help under "Server Instance Diagnostics:
CS Console".
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2675327 (1092083)
• NONCONNECTED has been added to the list of attributes of DECLARE.

ecijava

Back to the list

• Stateless Java ECI requests no longer cause memory leaks in MFCS as a result of abandoned
sessions.

2822108 (1099645)

Enterprise Server

Back to the list

• When using an EXCI link and a PPT defined with commarea 32767, the modified commarea was not
reflected back to the caller.

2830739 (1100654)
• It is possible to configure a Visual Studio or an Eclipse project to perform emergency debugging of an

application running in an enterprise server even when the server is operating in production mode (with
dynamic debugging disabled). To prevent this, starting with this HotFix, you can use the environment
variable ES_PRODUCTION in the server’s [ES-Environment]. When set to Y, this variable prevents the
IDE from initiating a debug session.

2825848 (1100160)
• When using a secure region and when the environment variable

ES_ESM_DISABLE_DFLTUSER_ESMAC is set to Y, clicking on the Home button in the signon page
now correctly opens the MFDS page.

2824772 (1099949)
• When the casspool.dat file is shared across multiple servers (excluding cluster scenarios), ESMAC

displays all jobs, including those that are not running in the current server. However, it is only possible to
cancel jobs that are running in the current server. For other jobs the CANCEL button is disabled.

2824230 (1099917)
• It is now possible to start a BATCH printer in ESMAC if its name consists of space characters only but

an exit name is provided.

2819122 (1099216)
• When using ESMAC, Enterprise Server now correctly loads the MFESMAC resource class, when

necessary. Previously, it was loading the ESMAC class.

2814789 (1098652)
• You can now use the environment variable ES_ESM_DISABLE_DFLTUSER_ESMAC in order to disable

the ESMAC default user. When this variable is set, the "DEFAULT" button on the logon screen is
disabled and a valid userid and password must always be entered.

2813092 (1098438)
• DBCS fields are now processed correctly when the PS attribute is set in the DSECT rather that defined

in the MAP in single field, groups and OCCURs.

2811683 (1098233)
• Web service timeout values are no longer truncated to two digits.

2792860 (1096024)
• An issue with dynamic debugging has been fixed where, previously, the ports that were freed were not

being reallocated.

2785911 (1095510)
• An artificial restriction on the size of cookies passed when invoking ESMAC requests has been

removed. Previously, this was causing Run-Time exceptions.
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2692460 (1094557)
• The characteristics of an FCT that references a cataloged file are now refreshed on each file open.
• If a file was already present, the date for an open request was not sent to the file handler.
• Open and close operations are no longer recorded in the transaction logs and replicated by extension

when they are associated with open input requests.
• A secondary node in a group no longer attempts to take over the role of a primary node. The entire

group now initializes correctly and all roles are assigned as expected.
• Microsoft's Internet Explorer versions 10 and 11, by default, does not use the current form name. As a

result, when invoking the javascript functions, the form name was not correct and the product behavior
was wrong. This has now been fixed.

• This release provides a number of enhancements to the CAS administration console:

• Improvements have been made to the log-in mechanism for situations where you are using an
External Security Manager to secure the MFDS and Enterprise Server, and you are logged on to
MFDS and ESMAC using different user accounts – for example, "user1" and "user2", respectively. If
you navigate from ESMAC to MFDS and you log off "user1" from the MFDS, this will now
automatically log off "user2" from ESMAC as well.

• When using an external security manager, if you sign off from ESMAC, the sign on screen no longer
preserves and displays the userID of the last user that was logged on.

• An issue with the "Home" link in the ESMAC sign on page when the environment variable
ES_ESM_DISABLE_DFLTUSER_ESMAC is set has been resolved.

2814494 (1098607)

• A memory leak occurred in the External Security Facility's MLDAP ESM Module in some HotFix
releases of COBOL Server 2.2 Update 2.

2833758 (1101024)
• When using the Enterprise Server External Security Facility with the audit feature, some audit events

generated by ESF Admin requests (such as ADDGROUP or ALTGROUP commands specifying many
group members) may include too much information to fit in a single audit event. These parameters are
now split across multiple audit events of category 5, type 3. Each split parameter has a unique number
(per process), and each piece of a split parameter has a sequence number. The original event will
contain a string with the split parameter identifier.

2827010 (1100238)
• The new resource access authorization processing in Enterprise Server's MLDAP ESM Module (LDAP-

based security), introduced in HotFix releases of COBOL Server 2.2 Update 2, now correctly handles
cases where multiple access control entries have the same rank. For example, this may apply when all
group mode is enabled and an Access Control List (ACL) contains Access Control Entries (ACE) for
different groups the user belongs to.

2826650 (1100313)
• In COBOL Server 2.2 Update 2 HotFix 06 only, when Enterprise Server External Security is used with

the "Version 2 Authentication" mode enabled, some ACEs might not be processed or applied. This has
been fixed.

2826650 (1100195)
• When using the Enterprise Server External Security Facility (ESF) with auditing enabled, and using the

ESF Admin API (programmatically or with the Enterprise Server Administration web interface or the
esfadmin command-line tool) to make certain changes to security data, very large audit events could be
generated. In some circumstances these could cause the Audit Manager process to crash or hang the
program making the request. This has been corrected by truncating parameter information for very large
security administration requests.

2825505 (1100158)
• When using Enterprise Server External Security Facility (ESF) with the optional Referential Integrity

User Exit, integrity constraints are now ignored for Access Control List (ACL) actors containing wildcard
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characters. This enables ESF Admin actions that include resource access control ACLs containing
wildcard actors.

2824117 (1099908)
• The optional ESF Referential Integrity user exit module no longer fails with an LDAP "filter error"

message when processing certain resource-rule commands, such as ALTRESOURCE, for resource
rules with names that include an asterisk, "*".

2824049 (1099884)
• The "referential integrity" sample user exit module for Enterprise Server External Security no longer

causes the MFDS process (Enterprise Server Administration) to terminate when external security with
the exit is configured for MFDS, and MFDS is used to add a user or to perform some other security
administration tasks.

2823947 (1099880)
• A new MFDS command line startup option (-b) is now available. Specifying -b disables the

establishment of anonymous MLDAP API sessions.

2818587 (1099264)
• This release enables you to prevent an Enterprise Server Monitor and Control (ESMAC) user from

displaying an enterprise server's environment variable settings using the "Env. Vars." button or the direct
URL. To enable this feature, you need to create a new element (ENV*) in the LDAP schema in the
CN=MFESMAC group below CN=Enterprise Server Resources.

This release includes an updated copy of the supplied LDIF import files that contain this change. Once
this element is installed in the security manager, you can control the visibility of the environment
variables page by configuring the group/user access rights using the microfocus-MFDS-Resource-ACE
attribute.

2811696 (1098264)
• The number of security manager user group members displayed by the Enterprise Server

Administration and the esfadmin tool is no longer limited to a maximum of 1024.

2807579 (1097703)
• Trying to use the SNMP audit emitter with Enterprise Server no longer fails with a run-time system error

114.

2800729 (1096951)
• The MLDAP ESM Module, part of the Enterprise Server External Security Facility, now supports

"nested" user groups where one user group can contain another user group. Members of the contained
group belong to both groups. This enables administrators to define very large user groups as well as
hierarchies of user groups.

2510993 (1078988)
• A new option, "LITERAL=YES" has been provided in the Enterprise Server External Security Facility's

Administration API, and in the esfadmin command-line utility. When this is set, "*" is not interpreted as a
wildcard when using any of the administrator's LIST commands. This is particularly useful for listing
resource access rules that include "*" in their name. Search the product documentation for esfadmin for
more information.

• Oracle and OCI XA switch modules leaked memory when using user personalization.

2830922 (1100676)

• When issuing an ENQ change request in a cluster environment, the request to change the lock type
was being sent to the GLM but not processed locally. It is now also being processed locally.

2826218 (1100148)
• During a cluster RECONNECT request, each cluster client sends a list of active locks and the GLM re-

populates the Global ENQ. Since the introduction of the VSAM shared options, the lock may also
contain a tca ptr which is used to store the client's casmgr information. This is required for lock with
persistence server. A pointer set to low-value was sent as part of a GIVELOCK request, but on the GLM
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that value was not used. This causes a run-time system error 114 in casgreqt on the RECONNECT/
GIVELOCKS function. This fix allocates the required tca for client casmgr for a RECONNECT request,
sets up the pointer depending on the lock persistence type as well as the clients casmgr PID.

File Handling

Back to the list

• You now receive an RC16 error message, if a PDSM file is missing from a list of concatenated DD's.

2821187 (1099770)
• Indexed files are no longer corrupted when their file size limit is reached.

2817599 (1099359)
• When lock mode is set to 'automatic', with single record locking, the lock from the previous operation is

released at the start of the next file operation; this is to avoid an ABBA deadlock situation occurring.

2816981 (1099052)
• A new file handler configuration file option (STRICTLSEQ) has been added. Only use this option if

instructed to by Support.

2814458 (1099019)
• RM and ACU files accessed from Visual COBOL no longer crash with a 114 error for I/O operations on

a non-existent optional file opened for input. An appropriate error code is now returned.

2809718 (1098141)
• MFSORT now takes the record length from a previous output file, if its record length is specified, rather

than defaulting to the value in the SORTIN statement.

2808188 (1098243)
• The rollback recovery process is now working as expected.

2802180 (1097066)
• This release provides a new format of the dataset allocation override rules file that supports multiple

conditions.

2783138 (1095007)
• The ACUFH interface between the MF File Handler and the RM File Manager will no longer report an

05 status (optional file created) to more than one COBOL run unit for creation of the same file. The 05
status will be reported to the COBOL run unit that actually created the file. The RM File Manager that
runs under ACUFH and the Micro Focus File Handler for Visual COBOL now includes optimizations that
enable it to use pread and pwrite system calls and to report status 99 (record locked) quicker. These
optimizations match the optimizations added to the RM File Manager within RM/COBOL.

• The file handler configuration file (extfh.cfg) now supports the following options:

• ACUFH=ON/OFF - enables or disables any calls to ACUFH. ON by default.
• ESACUFH=ON/OFF - enables or disables calls to ACUFH while running under Enterprise Server.

OFF by default.

Note: As a result of this change, calls to ACUFH are now disabled by default when running under
Enterprise Server.

• Copying an ESDS file no longer causes an RTS114 error.

2811583 (1098244)
• When a file is closed under Enterprise Server, the file's details are correctly removed from Fileshare.

Previously, some details were not removed.

2810549 (1098111)
• When handling indexed files, the correct .IDX file is now being processed.

2803247 (1097279)
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IBM Language Environment for OS/390 and VM Support

Back to the list

• The Language Environment utilities are now available as Java managed code.

2826067 (1100134)
• Mainframe Language Environment support (LE Services) is now available in Micro Focus Visual

COBOL and COBOL Server.

2799388 (1097806)
• The Language Environment functions CEEGMT, CEEUTC and CEELOCT now return the number of

seconds to millisecond precision.

2796098 (1098276)
• The I-S-Info field of the Language Environment (LE) Feed-Back group has been changed from a pointer

to a PIC S9(9) BINARY item.

IDE

Back to the list

Visual Studio IDE:

• Adding a new "Web Form using Master Page" item to a Web project now works correctly in Visual
Studio versions 2012 or later.

2815524 (1098743)
• When converting a Net Express project that does not contain any executable targets (exe, lib or dll), the

Net Express Project Import wizard now creates a project that holds the application-level dependencies
so they get copied into the main output directory.

2815290 (1098720)
• If, after using the Compile command from the file context menu in Solution Explorer to compile a

COBOL file in your project, you use Compile to compile an IMS file, the IDE no longer recompiles the
COBOL file.

2809825 (1098153)
• It is now possible to debug a 64-bit core dump from a 64-bit native Mainframe Subsystem Application

project.

2804416 (1097366)
• When using a COBOL Web Site project that references a COBOL assembly, the editor may have

incorrectly shown syntax errors even though a build would have succeeded.

2804043 (1097341)
• When adding a new WPF item that contained both XAML and COBOL partial classes to a project, the

code editor used the wrong source format for the COBOL part of the code.

2800293 (1096909)
• In a Micro Focus INT/GNT project that is configured to package the output as an .lbr, the .lbr file will

now include any files in the projects that have their Build Action property set to Content.

2799868 (1096821)
• Setting an SQL compiler directive on a project that contains a Windows Form prevented the IDE from

opening the form in Design view.

2612622 (1094509)
• The Light Bulbs feature in Visual Studio 2015 replaces Smart Tags. Light Bulbs provide functionality

similar to the one Smart Tags provided in previous versions of Visual Studio. The COBOL Smart Tags
(in Visual Studio 2012 and 2013) and the Light Bulbs feature (in Visual Studio 2015) now provide limited
support for managed COBOL language features including interfaces, attributes and generic types.
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Other improvements include support of these features within inline copybooks as well as various
performance and stability improvements.

• Saving temporary COBOL projects in Visual Studio now works as expected.
• It is now possible to publish SQL Database projects that target a version of the .NET Framework later

than version 4.0 and when your machine is configured to use the Japanese locale.
• Under certain circumstances, Show All Copybooks failed to expand inline copybooks.
• When debugging, if you attempt to query the value of an unassigned linkage item you are now

prompted to allow memory to be allocated for that item.
• An issue with the colorization of some string literals has been resolved.
• The Namespace Smart Tag now supports managed COBOL language features including interfaces,

attributes and generic types, can be used within inline copybooks, and has had a number of other
performance and stability improvements.

• When debugging COBSQL programs in applications that compile to .int or .gnt files, the caret position is
now set correctly.

• Adding a new "Web Form using Master Page" item to a Web project now works correctly in Visual
Studio versions 2012 or later.

• Under some conditions when editing a COBOL source file, the editor ignored the source format set in
the project's properties and treated the file as fixed format.

• An issue where new files added to a managed project were not included in the build has been fixed.
• The Namespace Smart Tag now supports managed COBOL language features including interfaces,

attributes and generic types, can be used within copybooks shown inline in the editor, and has a
number of performance and stability improvements.

• When editing .NET managed COBOL in the editor, if referencing a class member that matches a
COBOL reserved word (for example, my-str::Length), the member is now correctly identified and has
the correct color and IntelliSense functionality.

• While debugging, clicking on a line containing a COPY statement or stepping into a copybook which
was part of a program which had not been previously opened could result in an unpredicted behavior.

• If you set the warning level in a project to include recoverable errors (Level E), this setting is now
enforced when building the project and you no longer receive warnings and informational messages in
the build output or in the Error List window.

• The 'Set explicitly no SQL' setting in the properties of COBOL files now works correctly for the Oracle
Pro*COBOL and XDB preprocessors.

• The file extension filters included in the Save File As dialog for COBOL programs now work correctly.
• IntelliSense suggestions now correctly include MS Office Interop types.

Eclipse IDE:

• The system set COBPATH value is respected when running or debugging a COBOL program.

2826740 (1100255)
• Debugging a program located in a remote linked folder of an NFS remote project, previously could result

in errors being displayed and the program not being debugged.

2819526 (1099290)
• New functionality added, for COBOL only, that enables building of dependent programs from any

copybook i.e. it builds the programs that use the selected copybook.

2817675 (1099004)
• Linking of programs that are configured to compile as "Single Executable File" or "Single Native Library

File" no longer fails when there were build warnings but the build succeeded.

2816593 (1098972)
• When debugging a program in a project which had dependent projects calls to other programs in the

same project would give RTS 173 errors but calls to programs in the dependent projects would
succeed.

2814906 (1098671)
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• Source lookup now works correctly during JIT debugging when there are duplicate source file names in
the workspace.

2814382 (1098669)
• If you associated a new file extension with COBOL programs from Window > Preferences > General >

Content Types, the IDE would not recognize files with that extension as COBOL programs if the case of
the extension did not exactly match. On case insensitive file systems, the case of the file extension is
now ignored.

2814262 (610304)
• Duplicate COBOL Programs in the project whose names only differed in case or file extension were all

compiled during a project build. Only the first program in the build precedence order is now compiled.

2813787 (1098602)
• Creating a COBOL project from a project held in AccuRev could result in errors preventing the project

from being built.

2812951 (1098678)
• If the IBM Remote Debug Tool is installed, you could sometimes receive an "Unexpected Exception"

message when toggling a breakpoint.

2811173 (1098165)
• New debug option on the Enterprise Server debug configuration that controls whether the debugger

suspends on entry to the transaction or continues until a breakpoint is hit.

2810123 (1098582)
• Importing an existing NFS style remote project containing a linked folder could cause a

NullPointerException error.

2809790 (1098249)
• A new Debug Source Lookup container type called "Paths from debugger information files" causes the

debugger to search for source files using the paths specified when programs were compiled.

2802214 (1097212)
• Programs that use copybooks using a COPY... REPLACING statement that in effect replaces a line with

nothing will now open correctly in the Copy view.

2799982 (1096796)
• The error "Unable to read workbench state" could sometimes occur when opening Eclipse if a remote

file had been opened in the editor the last time Eclipse was closed.

2799151 (1096711)
• A remote build was sometimes not recognized as being complete even when the Console view showed

that it was, leaving a running progress monitor which could not be cancelled.

2798493 (1097187)
• Remote connections are now resolved correctly and do not depend on their order in the Remote

Systems view.

2797878 (1097183)
• You could sometimes receive an internal error when restarting Eclipse, if a remote project that was

using an NFS connection type contained a linked folder.

2791099 (1095976)
• A known issue has been documented that describes how Kerberos security settings can lead to a

failure to validate and create remote projects from the Eclipse IDE. It provides steps to diagnose and
implement a workaround by disabling the gssapi-with-mic authentication method.

Library

Back to the list
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• Using a dd_ environment variable to specify the path used in CBL_LOCTE_FILE now works as
expected.

2822153 (1099632)

Micro Focus Common Client

Back to the list

• The Micro Focus Common Client, used by COBOL Web Service proxies and other components, now
allows HTTP URLs with certain characters such as ":". It also no longer rejects correct URLs with "%xx"
escape sequences.

2828629 (1100520)

Micro Focus Communications Server

Back to the list

• Certain Enterprise Server administration actions such as notifying a running enterprise server of a
security update could cause MFCS to hang.

2784219 (1095045)

Micro Focus Directory Server

Back to the list

• The generated HTML fragment displayed for an individual resource entity element when using the
Enterprise Server Administration HTML GUI to administer an external Security Manager was
overflowing a fixed size buffer. This is now allocated based on the actual length required.

2828732 (1100545)
• Corrected the resource entity that the Enterprise Server Administration GUI checks to determine

whether the external Security Manager administration pages are accessible to a logged on user. The
correct resource entity is "User Administration" under the "Enterprise Server Administration" resource
class.

2828553 (1100539)
• Require read permission before returning repository data for authenticated users if MFDS is started with

the -b option.

2828228 (1100364)
• Access to password data is prevented on the security manager edit page in the Enterprise Server

Administration HTML GUI.

2827942 (1100333)
• When MFDS is secured using an external Security Manager, it does not display internal security

configuration pages which no longer have an effect.

2827786 (1100314)
• Correct display of user session data in the Enterprise Server Administration HTML GUI.

2826210 (1100161)
• An issue with the persistency of the audit output option in the MF Directory Server security configuration

has been resolved.

2824201 (1099902)
• Honor the trace flags values set in an Enterprise Server XML configuration file when importing it into

MFDS via the -g command line option.

2823855 (1099846)
• An issue with storing certificate passphrase in the Enterprise Server Administration HTML GUI form

data has been resolved.
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2820846 (1099448)
• The resistance of the Enterprise Server Administration HTML GUI log-on page to cross-site scripting

attacks has been increased.

2819223 (1099212)
• Improve browser caching control to increase security of the Enterprise Server Administration HTML

GUI.

2819218 (1099209)
• An issue with storing certificate passphrase in the Enterprise Server Administration GUI has been

resolved.

2819212 (1099207)
• The Enterprise Server Administration web page makes additional authorization checks before

displaying screens.

2819069 (1099192)
• The Enterprise Server Administration web page no longer displays sensitive session data.

2818974 (1099178)
• Password length restriction has been fixed in the Enterprise Server Administration login page.

2818973 (1099179)
• Enterprise Server Historical Statistics Facility (HSF) configuration can now be exported and imported

via the mfds -x and -g command-line options.

2815030 (1098695)
• Previously, the Enterprise Server Administration journal export to text truncated the exported file.

2802793 (1097108)
• It is now possible to expand and collapse items within the tree view of the external security manager

security resources in Enterprise Server Administration.

2801421 (1096979)
• The MFDS GUI now correctly displays external Security Manager resource ACL strings that are greater

than 3K byte length.

2800727 (1096978)
• The MFDS -x XML export option was not exporting Windows Monitoring and Management configuration

values for enterprise server instances.

2794382 (1096428)

Micro Focus Server Administrator (GUI)

Back to the list

• If access to Enterprise Server Administration is restricted by use of an MLDAP ESM-based external
Security Manager, you can now configure a user to have access to the "Security" menu item but not to
the "Options" menu item.

2804728 (1097916)
• Previously, when expanding or collapsing items in the tree view for external Security Manager within

Enterprise Server Administration, items associated with a user or a group no longer would always move
to the top of the resource list.

2803399 (1097848)
• If MFDS is configured to use an external Security Manager with the Windows "user" class, it is not

possible to edit the users from the MFDS GUI and you receive a warning.

MLDAP API Interface

Back to the list

72 | Resolved Issues



• The MLDAP ESM module now recognizes a wider range of errors that indicate that the specified LDAP
server is unavailable and, if configured, the server will retry to establish a connection.

2799921 (1098128)
• The MFDS GUI and the ESFADMIN utility now display the pages with LDAP query results.

2681539 (1092705)

RM/COBOL

Back to the list

• The RM File Manager for Visual COBOL now provides a mechanism for avoiding RM indexed file
corruption while debugging in managed code.

In Visual COBOL for Eclipse, to avoid file corruption, you need to manually set the environment variable
RMFM_PRETEND_FORCE_CLOSED to YES in the Debug Configuration.

Visual COBOL for Visual Studio is preconfigured to avoid file corruption. If necessary, you can also
specify the RMFM_PRETEND_FORCE_CLOSED variable in a project's Application Configuration File
(App.config).

See your product help for more details.

2796890 (1096699)

Run-Time System

Back to the list

• A run unit created with the RuntimeServices RunUnit class no longer causes an exception to occur if no
COBOL code has been executed inside it before the RunUnit is terminated with a StopRun() method.

2826239 (1100198)
• You now receive a correct error code when the product does not find a file located on a network drive.

2822161 (1099619)

• The RM/COBOL version of the “SYSTEM” library routine nows supports the return of an exit-code, for
native COBOL applications.

2830238 (1100599)
• When using ADIS DISPLAY statements and the RELDECDELIM=0D0A file handler configuration option

on UNIX, you could receive a Run-Time System error during process termination.

2829860 (1100601)
• On UNIX platforms, if the Audit Manager process is recycled, dependent processes will continue to

pass events to it after it's recycled; previously, these processes would hang.

2810770 (1098085)
• On a 32-bit Enterprise Server running on Windows, tasks that are blocked in the operating system can

now be canceled without terminating the SEP process.

2807997 (1097918)
• An error in generated code when initializing comp-2 data items from fractional literal values has been

fixed.

2800938 (1096960)
• The tunables default_cancel_mode and subsystem_cancel_mode both have a new setting, which

enables programs to remain in memory after they are canceled; this is opposed to the default behavior,
which physically removes .dll files and shared objects from memory when they are canceled.

2690881 (1096628)
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Setup

Back to the list

• A problem with the product setup file handling install locations has been fixed.

2802386 (1097065)

SQL: COBSQL

Back to the list

• The COBSQL preprocessor generated an error when it encountered a host variable declared as "01 HV
PICTURE S9(9) VALUE ZERO COMP."

2826093 (1100163)
• COBSQL now honors the position of the $SET statements in copybooks that are expanded inline in the

editor by the CP preprocessor.

2825364 (1100308)
• COBSQL examined hostvars in commented lines, causing compilation errors.

2824211 (1099928)
• CCOBSQL now processes COPY... REPLACING COBOL data items' level correctly.

2813839 (1098531)
• The COBSQL preprocessor inserted a NULL character in front of each non-printable character, causing

errors when processing Pro*COBOL (i.e., when COBSQLTYPE=ORACLE8).

2809551 (1097939)
• COBSQL did not always correctly handle COPY... REPLACING with text exceeding the 72 column.

2809404 (1097890)
• COBSQL incorrectly handled COPY... REPLACING when the level numbers of data items in the

copybook were being replaced.

2807898 (1097765)
• COBSQL was not recognizing the DECLARATIVES statement in some scenarios.

2804183 (1097346)
• COBSQL now processes COPY...REPLACING statements correctly.

2779818 (1094538)

SQL: DB2 ECM

Back to the list

• The DB2 ECM incorrectly generated code to process SET CURRENT PACKAGE PATH, resulting in
SQLCODE -4952 when executed.

2817342 (1098963)
• HCO incorrectly handled .bnd files. The new DB2(BINDDIR) directive resolves this issue.

2815734 (1098893)
• The DB2 ECM preprocessor incorrectly generated COBDB0103S errors when a fixed CHAR host

variable was defined as greater than 254 characters.

2803193 (1097169)
• When FILLER was used in group host variable structure, the DB2 ECM raised an SQL4914 error.

2802547 (1097091)
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SQL: OpenESQL

Back to the list

• When compiling for ODBC, the OpenESQL preprocessor failed to generate correct SQL code for some
large SQL statements.

2832617 (1100892)
• When compiling a WCF Service application with the SQL(DBMAN=ADO) directive, the OpenESQL

preprocessor attempted to generate SQL interface code, resulting in a COBCH002 error.

2827979 (1100367)
• The GetHire stored procedure sample showed that a COBOL CLR stored procedure could cause an

exception to be thrown when using stored procedure definition files, and when compiled without
SQL(DIALECT=MAINFRAME).

2827854 (1100318)
• Run-time exceptions sometimes resulted from dynamic COBOL calls in stored procedures.

2819325 (1099263)
• The OpenESQL runtime sometimes generated an index out of range error on SQL statements in

managed applications when the PID generated by the OpenESQL preprocessor for each method was
not unique.

2815075 (1098749)
• A problem where a stored procedure that uses DIALECT=MAINFRAME could throw an exception if the

HCOSS stored procedure remapping table had not been deployed to the database has been fixed.

2809927 (1097972)
• The OpenESQL preprocessor did not support SELECT statements coded with a colon (:) on host

variables after the INTO clause for ORACLE PROCOB migration applications.

2596427 (1086198)
• The OpenESQL preprocessor has been enhanced to allow the use of PIC S9(5) COMP-5 host variables

for INTEGER data on programs migrated from Pro*COBOL.

2596426 (1086197)
• When using SQL(DATE=EXTERNAL) with Oracle, timestamp values were formatted incorrectly. This

has been change to correctly format timestamp values according to the setting of
NLS_TIMESTAMP_FORMAT.

2596425 (1086196)
• When SQL(PROCOB) is set, Oracle date and timestamp result types fetched into PIC X(n) host

variables are truncated without warning.

2596424 (1086195)
• An SQLCODE incompatibility existed between Pro*COBOL and OpenESQL ADO.NET. This has been

corrected. Setting SQL(PROCOB) now also sets SQL(CHECKSINGLETON). When SQL(PROCOB) is
set, OpenESQL error codes in the SQLCA are converted to Pro*COBOL-compatible error codes, which
are controlled by a new file, mfpcocds.txt. This file is delivered in %ProgramData%\Micro Focus
\SQLCODES by default.

2595728 (1087599)
• The OpenESQL runtime for ADO.NET returned times using a 12-hour clock. It now returns times using

a 24-hour clock.

• For managed-code projects, PF_RO_CURSOR and other BEHAVIOR primitive directives were not
available from the User Interface.

2833926 (1101049)
• Some problems related to using ASSOCIATE with the Host Compatibility Option for SQL Server where

the stored procedure name was supplied in a host variable have been fixed.
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2831480 (1100747)
• HCO with SQL Server (HCOSS) using the ADO.NET run-time system exhibited a problem retrieving

result set locators on the second call and subsequent calls to a stored procedure.

2830688 (1100659)
• The SQL CLR wrapper program generated by the Generate SPD File tool caused errors during

deployment when it contained one or more data types exceeding 8000 bytes in size. To eliminate these
errors, the Generate SPD File tool now generates the SQL CLR wrapper program with MAX SIZE = -1.

2830545 (1100650)
• PIC X host variables passed to the server as variable-length data with trailing blank suppression

sometimes caused OpenESQL to return different query results than some earlier versions of this
COBOL development product.

2829810 (1100685)
• When generating a COBOL wrapper program, the Generate SPD File tool did not support the passing

of all parameters for a SQL CLR Stored Procedure definition routine as fixed length. To resolve this, a
new option, GENFIXEDLENGTH, has been added.

2829499 (1100629)
• A number of issues with PostgreSQL record logic and error handling have been fixed in OpenESQL's

run-time systems for ODBC and ADO.NET.

2828058 (1100338)
• When the SQL(PROCOB) directive is set, OpenESQL for ADO.NET now supports anonymous PL/SQL

blocks and the following host variable types: SQL-CURSOR SQL-ROWID SQL-BFILE SQL-BLOB SQL-
CLOB SQL-NCLOB

2825199 (1100003)
• When compiling with the SQL(PROCOB) directive, the OpenESQL preprocessor sometimes generated

incorrect SQL code when a host variable reference in COBOL was split over multiple lines.

2825194 (1099997)
• When using the SQL(CHECK) directives with SQL TYPE CLOB host variables, compilation sometimes

failed.

2819480 (1099342)
• Windows GUI projects compiled with the SQL compiler directive might throw a

MicroFocus.COBOL.Program.COBOLStopRunException on GOBACK.

2816463 (1098907)
• The insertion of more that 8000 characters into a SQL Server VARCHAR(MAX) column from a PIC X(n)

host variable caused a data truncation error.

2814679 (1098675)
• When SQL(TARGETDB=ORACLE) was set and the FOR UPDATE clause was used to enable row

locking, this combination could sometimes trigger a runtime failure. SQL(TARGETDB=ORACLE) is no
longer required to enable row locking via FOR UPDATE clauses on queries.

2814613 (1098624)
• A 114 error on DISCONNECT sometimes occured due to a long-standing bug in Oracle ODBC drivers.

This release provides a workaround. The ODBC specification states that the ODBC row status array is
an array of 2-byte integers, but some Oracle ODBC drivers from Oracle 11 onwards have been
observed to use either 4-byte or 8-byte integers. The OpenESQL runtime for ODBC now automatically
detects the element size used by the driver when an Oracle connection is opened, and adapts its
behavior accordingly.

2813428 (1098480)
• OpenESQL now supports OUTPUT clauses in SQL Server INSERT, UPDATE, and DELETE

statements. HCO for SQL Server now supports the DATA-CHANGE-TABLE-REFERENCE clause.

2812940 (1098424)
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• An SQLCA error message occurred when inserting a record into a table using a SQL CLR stored
procedure with a VARCHAR (max) column where the host variable was more than 8000 bytes.

2812261 (1098390)
• The OpenESQL preprocessor incorrectly generated a COBES0100 error when compiling code that

contained GEN-GV-FROM-GROUP and the same host variable used multiple times in same SQL
statement.

2811682 (1098231)
• The OpenESQL preprocessor reported an error for LOCK TABLE statements encountered when using

an Oracle database with the SQL(CHECK) compiler directive option.

2808579 (1097797)
• When using the SQL compiler directive option to compile a program that contained no SQL statements,

a 153 trap occurred when the OpenESQL preprocessor encountered SQLCODE defined as COMP.

2808076 (1097758)
• The OpenESQL preprocessor sometimes generated a "COBCH0302 IF....ELSE or scope-delimiter

mismatch" error if a program defined SQLCODE separately as COMP.

2807937 (1097702)
• The OpenESQL preprocessor sometimes generated a STOP RUN rather than a GOBACK at the

program end, which sometime caused improper termination for subroutines not coded with one or more
GOBACK statements.

2807272 (1097624)
• The OpenESQL preprocessor produced a COBES0125 or COBES0112 error message when it

encountered indicator variable arrays used with non-host array variables.

2805207 (1097457)
• COBOL SQL CLR stored procedures can now open connections to other databases using EXEC SQL

CONNECT statements. For type 6 CONNECT statements, this requires using a post-deployment script
to alter the connection string for the OpenESQL runtime such that it runs with EXTERNAL_ACCESS
privilege. For other CONNECT statement formats, INSAFE privilege is required. Use SQL Server
authentication rather than Windows authentication for external connections.

2804010 (1097230)
• In some situations, the OpenESQL pre-compiler incorrectly generated a COBES0125 error, "<variable>

should be defined with an OCCURS clause".

2802029 (1097036)
• The ODBC ECM incorrectly generated swap logic for COMP fields on singleton SELECTs in managed

applications which could result in field corruption if the variable was used in a WHERE clause.

2801806 (1097049)
• The OpenESQL Assistant generated copybooks using the same size for DATETIME2 columns

regardless of their definitions. The OpenESQL Assistant now generates PIC X(26) for DATETIME2(6),
and PIC X(29) for all other DATETIME2 definitions.

2799778 (1096776)
• A problem that affected the use of 'select *' in OpenESQL subqueries has been fixed.

2799720 (1096751)
• A problem with array fetches into PIC N NATIONAL host variables has been fixed in the ODBC run-time

system for OpenESQL.

2799002 (1096790)
• The OCI run-time now handles the NULL indicator correctly when running in 64-bit mode.

2792566 (1096149)
• OpenESQL for JDBC now supports positioned updates with PosgreSQL.
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• The THREAD SQL compiler directive option mishandled threads in certain scenarios.
• In certain scenarios, OpenESQL incorrectly handled host variables defined as SQL TYPE DBCLOB

when inserting or fetching DBCS data.
• OpenESQL for JVM now supports spaces between the start of an ODBC, JDBC, date, time or

timestamp escape marker and its associated date, time or timestamp literal string when the
SQL(DETECTDATE) directive is set.

• Use of the tinyint (pic s99 comp-5) host variable sometimes resulted in bad code generation for some
OpenESQL runtime systems. Tinyint is now fully supported on all OpenESQL runtime systems.

• The OpenESQL run-time now truncates DBCS character strings cleanly at a whole character boundary.
• Using CHARSET(EBCDIC) in a DBCS locale caused problems with the OpenESQL runtime systems for

ADO and JDBC. This has been corrected by changing the behavior to be consistent with the ODBC
runtime. In particular, SO/SI characters are now correctly inserted and removed for EBCDIC and ASCII
data respectively.

• The one-phase ODBC switch module now handles commit and rollback API calls from applications and
uses DSNRLI correctly, together with handling of global temporary tables by HCOSS applications.

XML Extensions

Back to the list

• The XML model file must be accessible to the XML extensions run-time environment. To make the file
accessible, either add it to the system path, or move it to the directory from which the program is run.

2822399 (1099702)

XML Support

Back to the list

• XMLPARSE no longer reports an error if a prefix is not properly declared and no validation is specified.

2823420 (1099786)
• The Compiler no longer errors preprocessed lines containing non-ASCII characters in the indicator

area. Previously, this could cause user programs using the htmlpp preprocessor to fail to compile.

2805067 (1097977)
• The XML I/O run-time used to read the whole document into memory which caused an out-of-memory

error.

2801337 (1096999)
• The namespace prefix in the namespace declaration is now handled correctly when the element itself

does not contain a prefix.

2799691 (1098150)
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Updates and SupportLine
Our Web site gives up-to-date details of contact numbers and addresses.

Further Information and Product Support
Additional technical information or advice is available from several sources.

The product support pages contain a considerable amount of additional information, such as:

• The Product Updates section of the Micro Focus SupportLine Web site, where you can download fixes
and documentation updates.

• The Examples and Utilities section of the Micro Focus SupportLine Web site, including demos and
additional product documentation.

• The Support Resources section of the Micro Focus SupportLine Web site, that includes troubleshooting
guides and information about how to raise an incident.

To connect, enter http://www.microfocus.com in your browser to go to the Micro Focus home page, then
click Support.

Note: Some information may be available only to customers who have maintenance agreements.

If you obtained this product directly from Micro Focus, contact us as described on the Micro Focus Web
site, www.microfocus.com. If you obtained the product from another source, such as an authorized
distributor, contact them for help first. If they are unable to help, contact us.

Also, visit:

• The Micro Focus Community Web site, where you can browse the Knowledge Base, read articles and
blogs, find demonstration programs and examples, and discuss this product with other users and Micro
Focus specialists. See http://community.microfocus.com.

• The Micro Focus YouTube channel for videos related to your product - see https://www.youtube.com/
user/MicroFocusIntl.

Information We Need
However you contact us, please try to include the information below, if you have it. The more information
you can give, the better Micro Focus SupportLine can help you. But if you don't know all the answers, or
you think some are irrelevant to your problem, please give whatever information you have.

• The name and version number of all products that you think might be causing a problem.
• Your computer make and model.
• Your operating system version number and details of any networking software you are using.
• The amount of memory in your computer.
• The relevant page reference or section in the documentation.
• Your serial number. To find out these numbers, look in the subject line and body of your Electronic

Product Delivery Notice email that you received from Micro Focus.

On Windows, if you are reporting a protection violation you might be asked to provide a dump ( .dmp) file.
To produce a dump file you use the Unexpected Error dialog box that is displayed when a protection
violation occurs. Unless requested by Micro Focus SupportLine, leave the dump setting as Normal
(recommended), click Dump, then specify a location and name for the dump file. Once the dump file has
been written you can email it to Micro Focus SupportLine.
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On Windows, you can use the Micro Focus SupportLine Support Scan Utility, mfsupportinfoII, to create
either:

• a .log file that contains the details about your environment, Micro Focus SupportLine products, and
settings.

• a .zip archive that includes the same information as the .log file plus some product configuration
files from c:\ProgramData and the product installation log files.

MFSupportInfoII.exe is stored in <install-dir>\bin.

To run mfsupportinfoII:

1. Start a 32-bit Enterprise Developer command prompt.
2. Enter MFSupportinfoII at the command prompt to start the utility.
3. Create a .log file or a .zip archive as follows:

a. To create a .log file, click File > Save.

This prompts to save the .log file, MFSupportInfo_Log_MachineName_YYYY-MM-DD_HH-MM-
SS.log, in the %temp% directory.

b. To create a .zip archive, click Tools > Create Zip Package.

This creates a .zip archive, MFSupportInfo_Log_MachineName_YYYY-MM-DD_HH-MM-
SS.zip, in the %temp% directory.

4. Send the diagnostic information to your Micro Focus SupportLine representative:

The following requires an Internet connection and an Email client:

a. Click Tools > Email Log to SupportLine to open the Email Log dialog box.
b. Fill in the required fields and click Send.

If the machine is not connected to the Internet or if there are no Email clients installed, copy either
the .log file or the .zip archive to a machine that is connected to the Internet. Use your Email client
to email the files to Micro Focus SupportLine at supportline@microfocus.com together with the Support
Incident (SI) number, if available, and any additional details that might be useful to diagnose the issues
that you are experiencing.

On UNIX, you can use the Micro Focus UNIX Support Scan Utility, mfsupport, to create a log file that
contains the details about your environment, product, and settings. The mfsupport script is stored in
$COBDIR/bin.

To run mfsupport:

1. Start a UNIX shell.
2. Set COBDIR to the product with issues.
3. Execute mfsupport from a directory where you have write permissions.

This creates a log file, mfpoll.txt, in that directory.
4. When the script finishes, send the mfpoll.txt file to your Micro Focus SupportLine representative.

Note:

If COBDIR is set to a location that does not contain etc/cobver, the script outputs the contents
of /opt/microfocus/logs/MicroFocusProductRegistry.dat which keeps a list of the
installed Micro Focus products.
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Creating Debug Files
If you encounter an error when compiling a program that requires you to contact Micro Focus SupportLine,
your support representative might request that you provide additional debug files (as well as source and
data files) to help us determine the cause of the problem. If so, they will advise you how to create them.
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Disclaimer
This software is provided "as is" without warranty of any kind. Micro Focus disclaims all warranties, either
express or implied, including the warranties of merchantability and fitness for a particular purpose. In no
event shall Micro Focus or its suppliers be liable for any damages whatsoever including direct, indirect,
incidental, consequential, loss of business profits or special damages, even if Micro Focus or its suppliers
have been advised of the possibility of such damages. Some states do not allow the exclusion or limitation
of liability for consequential or incidental damages so the foregoing limitation may not apply.

Micro Focus is a registered trademark.

Copyright © Micro Focus 1984-2015. All rights reserved.
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